Subject: RE: [Megaco] interpretation of H.248.23 andisp package and thedwa/data signals

From: "Jan Lindquist \(AL/EAB\)" <[email-masked]>
Date: Thu, 28 Apr 2005 09:02:34 +0200

Hello Kevin,
 
Can the description in the dwa signal be updated?  The text is
misleading specially when comparing to the ETSI specification, during
alerting and during ringing almost have the same meaning.  Can "during
alerting" be changed to "associated to alerting"?  This will help
clarify the usage of dwa.
 
Thanks,
JanL
 
-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]] 
Sent: den 27 april 2005 18:53
To: Wayne Cutler; Jan Lindquist (AL/EAB)
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Megaco] interpretation of H.248.23 andisp package and
thedwa/data signals

Your interpretation is incorrect.  The dwa signal is designed to perform
data delivery associated with ANY alerting, whether prior to or during
ringing.  This is clearly stated in the procedures section of the
document.

Kevin 

-----Original Message----- 
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Wayne Cutler 
Sent: Tuesday, April 26, 2005 5:45 AM 
To: [email-masked] 
Cc: [email-masked]; [email-masked]; [email-masked] 
Subject: Re: [Megaco] interpretation of H.248.23 andisp package and
thedwa/data signals 

>Question 1: 

>The description of the display with alerting signal in H.248.23 has the

following text: 

>"Sends the display information to the CPE. This signal indicates that 
>the 
data must be applied during alerting ? either power ringing, or call
waiting. >Therefore, this signal implies alerting, which will be
appropriately applied to the CPE by the gateway, based upon the on
hook/off-hook status of the >line."

>The ETSI specification, EN 300 659-1, On-Hook Data Transmission, 
>defines 
the following data transmission methods: 
>1. prior to ringing (including TAS equal to Ringing Pulse-Alert 
>Singal), 2. during ringing (ie between the first and second ringing 
>pattern) 

>Which signals defined in the andisp package should be used to support 
>the 
two methods because it is not clear from the andisp package descrition
for dwa >signal can be applied for method 1? 

>Question 2: 

>Additionally it would be useful to find out what MG and MGC vendors 
>have 
implemented for methods 1 and 2. 

Hi Jan, 

For question 1, we'd read h248.23 as meaning that andisp/dwa should be
used for option 2 (during ringing) and andisp/data for option 1 (prior
to ringing).

In terms of question 2, this is what the Marconi CA & MSAN has
implemented. 

Regards, 
Wayne 

_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Jan Lindquist \(AL/EAB\)" <[email-masked]>
Date: Thu, 28 Apr 2005 17:02:18 +0200

Thank you Kevin.  The change is appreciated.  Do you need any liaison
statement from TISPAN to motivate the change in SG16?
Regards,
JanL
 
-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]] 
Sent: den 28 april 2005 16:38
To: Jan Lindquist (AL/EAB); Wayne Cutler
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Megaco] interpretation of H.248.23 andisp package and
thedwa/data signals

If the text is confusing, then we can certainly update it.  I will be
more than happy to propose a Corrigendum to H.248.23 to clear this up.
 
Kevin

________________________________

	From: Jan Lindquist (AL/EAB) [mailto:[email-masked]]

	Sent: Thursday, April 28, 2005 3:03 AM
	To: Boyle, Kevin [NCRTP:3Z40:EXCH]; Wayne Cutler
	Cc: [email-masked]; [email-masked];
[email-masked]
	Subject: RE: [Megaco] interpretation of H.248.23 andisp package
and thedwa/data signals

	Hello Kevin,

	Thanks,
	JanL
	 
	-----Original Message-----
	From: Kevin Boyle [mailto:[email-masked]] 
	Sent: den 27 april 2005 18:53
	To: Wayne Cutler; Jan Lindquist (AL/EAB)
	Cc: [email-masked]; [email-masked];
[email-masked]
	Subject: RE: [Megaco] interpretation of H.248.23 andisp package
and thedwa/data signals

	Your interpretation is incorrect.  The dwa signal is designed to
perform data delivery associated with ANY alerting, whether prior to or
during ringing.  This is clearly stated in the procedures section of the
document.

	Kevin 

	-----Original Message----- 
	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Wayne Cutler 
	Sent: Tuesday, April 26, 2005 5:45 AM 
	To: [email-masked] 
	Cc: [email-masked]; [email-masked];
[email-masked] 
	Subject: Re: [Megaco] interpretation of H.248.23 andisp package
and thedwa/data signals 

	>"Sends the display information to the CPE. This signal
indicates that 
	data must be applied during alerting ? either power ringing, or
call waiting. >Therefore, this signal implies alerting, which will be
appropriately applied to the CPE by the gateway, based upon the on
hook/off-hook status of the >line."

	>Which signals defined in the andisp package should be used to
support 
	two methods because it is not clear from the andisp package
descrition for dwa >signal can be applied for method 1? 

	Hi Jan, 

	For question 1, we'd read h248.23 as meaning that andisp/dwa
should be used for option 2 (during ringing) and andisp/data for option
1 (prior to ringing).

	Regards, 
	Wayne