Subject: [Megaco] Individual audit: differences in text & binary

From: Frank Reno <[email-masked]>
Date: Wed, 6 Apr 2005 13:17:27 -0700 (PDT)

I've noticed some differences between what can be
specified in an individual audit between the text and
binary encodings. Was this an oversight or
intentional?

1. StreamID can be specified for events and signals in
binary mode only.
2. Event buffer's event parameters can be specified in
text mode only.
3. RequestID is optional in binary and required in
text.

There were a couple of earlier threads discussing item
3, but I didn't understand the responses. What is the
correct way to handle the requestID when received in
an audit descriptor? Is it:

a. the specified requestID is ignored and the event is
always audited
b. the event is only audited if the specified
requestID is the requestID of the termination's
current event descriptor. (Can '*' be used for the
requestID in this case?)
c. something else

Many thanks,
Frank

__________________________________ 
Do you Yahoo!? 
Yahoo! Personals - Better first dates. More second dates. 
http://personals.yahoo.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Mon, 11 Apr 2005 18:32:08 +1000

Hello Frank,

The Invidual audits for text and binary should have the equivalent functionality 
  (apart from Local and Remote). Please see my comments below.

Regards, Christian

> 1. StreamID can be specified for events and signals in

[CHG] This does appear to be case. It seems that something like below is needed:

; StreamID only in sigParameter or EventParameter
indAudsignalRequest	= signalName [LBRKT sigParameter *(COMMA sigParameter) RBRKT]
indAudrequestedEvent	= pkgdName [LBRKT eventParameter *(COMMA eventParameter) RBRKT]

> 2. Event buffer's event parameters can be specified in

[CHG] The text does allow this to happen. However I think that the only 
parameter that should be able to be given is the "streamID". This would be the 
same in (1) above. By references the "eventParameter" construct you 
automatically get the ability to audit signal and event parameters.

> current event descriptor. (Can '*' be used for the

[CHG] I would say b. Rather than use '*' just perform a descriptor audit.