Subject: [Megaco] Notation used in example callflow in RFC 3525

From: Raghupathi Adiga <[email-masked]>
Date: Mon, 5 Dec 2005 18:28:04 -0800 (PST)

HI,
   
  I  have difficulty in understanding notation/represention used in Call flows in the end of the RFC ( Appendix I ).
   
  Which notation it follows ? Is the representation in ABNF ?
  Services Token value is not used in ASN format .
   
  In MGCP it was bit easy to understand. 

  Say for example :
  ===========
   
  MEGACO/1 [124.124.124.222] Transaction = 9998 {
       Context = - {

           ServiceChange = ROOT {Services {
               Method=Restart,
               ServiceChangeAddress=55555, Profile=ResGW/1}
           }
       } }

  Thanks,
  Amitha

   
  Thanks
  Amitha

---------------------------------
 Yahoo! Personals
 Single? There's someone we'd like you to meet.
 Lots of someones, actually. Try Yahoo! Personals

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 6 Dec 2005 08:37:54 -0500

Yes it is in ABNF.  See Annex B.
 
MGCP is a different protocol, and therefore has a different syntax.
Being easy or hard to understand is a subjective measure.  Case in
point: I know people who can look at the ASN.1 encoding of H.248 and
read it without using a decoder tool.  I, on the other hand, need a tool
to decode the fields.  It's just a matter of experience.
 
Kevin

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Raghupathi Adiga
	Sent: Monday, December 05, 2005 9:28 PM
	To: [email-masked]
	Subject: [Megaco] Notation used in example callflow in RFC 3525

	HI,
	 
	I  have difficulty in understanding notation/represention used
in Call flows in the end of the RFC ( Appendix I ).

	 
	Say for example :
	===========

	Thanks,
	Amitha

	 
	Thanks
	Amitha

________________________________

	Yahoo! Personals
	Single? There's someone we'd like you to meet.
	Lots of someones, actually. Try Yahoo! Personals
<http://us.rd.yahoo.com/evt=36108/*http://personals.yahoo.com>