Subject: RE: [Megaco] Fax and Modem detection

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 20 Dec 2005 12:13:59 -0500

Most faxes do start with CNG.  Modems start with one of several
possible, of which you have described some.  I suggest having a look at
the relevant modem specs, which are found in the ITU-T V-series
Recommendations.
 
Kevin

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Tamar Nemet
	Sent: Tuesday, December 20, 2005 5:15 AM
	To: [email-masked]
	Cc: Shai Antebi; Michal Yachimovitz; Victoria Mendelevich; Moiz
Terem; Rima Mazorov
	Subject: [Megaco] Fax and Modem detection

	Hello,
	 
	The ftmd (FAX/Textphone/Modem Tones Detection) package defines
many events to detect the presence of data traffic (fax, modem) on a
line.
	Which event should be used in order to notify the SoftSwitch
that a fax or modem has been detected ?
	 
	It looks that CNG should be used in case of fax. But for modem
there are a lot of events. Does the Media Gateway must detect all kinds
of modem signals and send the exact modem event to the SoftSwitch ?
(V21flag,CIV18, XCI,CIdata,V21Tone,V23tone ....)
	Or there is a generic event for modem detection ?
	 
	Thanks,
	Tamar Nemet

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 20 Dec 2005 15:35:47 -0500

I'll add that the most common modems are described in 
draft-ietf-avt-rfc2833bisdata-05.txt.  Most of the startup sequences 
seem to have ANS or ANSam in common at the called end, but you can't 
count on the calling end to emit any specific tone to start with.

---

From: "Gunnar Hellstrom" <[email-masked]>
Date: Tue, 20 Dec 2005 23:05:37 +0100

You need to consider both calling and called devices.
Modems, textphones and faxes.
In order to detect most types you need to listen for all these tones. But
You can add a lot more logic to the discrimination than is described in ftmd
in order to reduce risk of false detection.

Read V.25, V.18, T.30, V.8, V.8bis, V.34, V.90 etc. to get more exact info
on how they are signaling.

And, please include textphones in your logic. They are too often left out of
the implementations, causing severe communication problems for the users.

Regards

Gunnar

----------------------------------------------------------------------------
-
Gunnar Hellström, Omnitor
[email-masked] <mailto:[email-masked]>

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf
Of Kevin Boyle
Sent: Tuesday, December 20, 2005 6:14 PM
To: Tamar Nemet; [email-masked]
Cc: Michal Yachimovitz; Rima Mazorov; Shai Antebi; Victoria Mendelevich;
Moiz Terem
Subject: RE: [Megaco] Fax and Modem detection

Kevin

	Hello,

	Thanks,
	Tamar Nemet