Subject: RE: [Megaco] A question about DTMF erasion

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 1 Dec 2005 04:23:01 -0500

I have thought about this some, and my thoughts are that the MG would
NOT remove the digits from the stream.  Think about what happens when
the keypad is pressed while in an active call: The digit tones are
carried all the way to the far end, even if there is something in the
middle detecting the digits.  Therefore, I believe that the MG would not
alter the media stream.  It would be incumbent upon the MGC to ensure
that the digit collection is done at an appropriate place in the
network, and to discard a repeated digit that is caused by dual
collection.
 
Kevin

________________________________

	From: [email-masked]
[mailto:[email-masked]] 
	Sent: Monday, November 28, 2005 11:50 PM
	To: [email-masked]; Boyle, Kevin [NCRTP:3Z40:EXCH]
	Subject: RE: [Megaco] A question about DTMF erasion

	Hi Kevin: 
	   I think You may have misunderstood my question. May be I have
not clearified the 
	situation. 
	
	   What I mean is : One MG has been requested to collect digits,
and The MG detects 
	a digit from the user's sending media stream. Then MG report the
digit to MGC by 
	signaling or hold the digit . But what confused me is whether
the MG should 
	automatically erase the DTMF signal from the sending media
stream or Not. 
	    
	   If the MG do not erase the DTMF signal from the sending media
stream, The called 
	may receive repeated numbers: One from signaling, the other
comes from The caller's 
	Media stream. 
	    
	   I wonder if there are some rules defining how to handle this
kind of situation. 
	  
	   Looking forward to your reply! 
	        
	   BEST REGARD! 
	
	   ShiCao 
	Message: 3
	Date: Sat, 26 Nov 2005 12:21:52 -0500
	From: "Kevin Boyle" <[email-masked]>
	Subject: RE: [Megaco] A question about DTMF erasion
	To: <[email-masked]>, <[email-masked]>
	Message-ID: <34B3EAA5B3066A42914D28C5ECF5FEA4055D11DB@zrtphxm2>
	
	Once a digit is reported to the MGC, I cannot think of a case
where the
	MG should transmit that digit again.  There are explicit
statements in
	the digit collection rules about when to hold digits and when to
discard
	them.
	
	Kevin

	________________________________
	
	                From: [email-masked]
[mailto:[email-masked]]
	On Behalf Of [email-masked]
	                Sent: Thursday, November 24, 2005 7:16 AM
	                To: [email-masked]
	                Subject: [Megaco] A question about DTMF erasion

	                Hi: 
	                
	                  These days we encoute with such a problem: the
caller recevied
	repeated numbers due to the missunderstanding of DTMF erasion. 
	                  
	                  If Softswitch has requested MG to collect
numbers , should MG
	automatically enable DTMF erasion? 
	                    
	                  Is any packets defining enbable/disable MG's
DTMF erasion? 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Mon, 5 Dec 2005 20:19:44 +0800

Hi Kevin:

   If the the called is an PBX(connected to the called MG's analog 
line),and caller&called used G.723 to communication. Then caller may need 
to dail external phone number. The called PBX may can not detect the digit 
signal even though the digit signal is transmitted within the voice 
stream, because the signal is distorted when coded into G.723. But the 
called PBX still has the chance to detect the digit because sometimes the 
signal is not so distorted.
   So there are risks in transmite digit within the media stream.
   The responsibility of digit transmition falls on the MGC (forget 
RFC2833,suppose both MGs don't support RFC2833). The MGC may use packet 
'dd' to request MG to detect digits and used packet 'tonegen' to request 
the called MG to play digit signal to the called PBX.
   From my view,  Once the MGC decide to collect numbers from MG, the MG 
SHOULD automatically erase the digit signal from the sending media stream 
to avoid repeated digits(one from media stream, another from signal).

Message: 2
Date: Thu, 1 Dec 2005 04:23:01 -0500
From: "Kevin Boyle" <[email-masked]>
Subject: RE: [Megaco] A question about DTMF erasion
To: <[email-masked]>, <[email-masked]>
Message-ID: <34B3EAA5B3066A42914D28C5ECF5FEA40573F813@zrtphxm2>

Kevin

                 Hi Kevin: 
                    I think You may have misunderstood my question. May be 
I have
not clearified the 
                 situation. 
 
                    What I mean is : One MG has been requested to collect 
digits,
and The MG detects 
                 a digit from the user's sending media stream. Then MG 
report the
digit to MGC by 
                 signaling or hold the digit . But what confused me is 
whether
the MG should 
                 automatically erase the DTMF signal from the sending 
media
stream or Not. 
 
                    If the MG do not erase the DTMF signal from the 
sending media
stream, The called 
                 may receive repeated numbers: One from signaling, the 
other
comes from The caller's 
                 Media stream. 
 
                    I wonder if there are some rules defining how to 
handle this
kind of situation. 

                    BEST REGARD! 
 
                    ShiCao 
                 Message: 3
                 Message-ID: 
<34B3EAA5B3066A42914D28C5ECF5FEA4055D11DB@zrtphxm2>
 
                 Once a digit is reported to the MGC, I cannot think of a 
case
where the
                 MG should transmit that digit again.  There are explicit
statements in
                 the digit collection rules about when to hold digits and 
when to
discard
                 them.
 
                 Kevin

                                 Subject: [Megaco] A question about DTMF 
erasion

                                 Hi: 
 
                                   These days we encoute with such a 
problem: the
caller recevied
                 repeated numbers due to the missunderstanding of DTMF 
erasion. 
 
                                   If Softswitch has requested MG to 
collect
numbers , should MG
                 automatically enable DTMF erasion? 
 
                                   Is any packets defining enbable/disable 
MG's
DTMF erasion?

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 07 Dec 2005 10:04:02 -0500

If you don't have RFC2833, your alternative is for the sending gateway
to upspeed to G.711 when it detects tones.

[email-masked] wrote:
> RFC2833 is truely the best way to transmite digits between gateways right 
> now. But what should we do when both gateway don't support RFC2833 .One 
> solution is  MGC relay the digits from one gateway to another by 
> signaling. In this case, to avoid repeated digits(one from media stream, 
> the other from signaling),I think MG should automatically ERASE the digit 
> signal from the sending media stream. 
> examples of application:
> (1)   PHONE-PSTN-MG-----MGC------MG-PSTN-PHONE
>       PHONE-MG-----MGC------MG-PSTN-PHONE
> (2)   PHONE-MG-----MGC------MG-PBX-PHONE
> (3)   PHONE-MG-----MGC------MG-Service_Server
> 
> I Can NOT agree with Kevin on the opinion that MG SHOULD NOT alter the 
> media stream in anyway, because RFC2833 requests erase DTMF tones when 
> sending RFC2833 Events.
> 
> Bypass I find a similar question has been dicussed in SIP forum two years 
> ago. Is there any one who knows the final result?
>  
> 
> 
> 
> 
> "Tom-PT Taylor" <[email-masked]>
> 2005-12-07 00:31
> 
>  
>         收件人：        "Kamitses, Jerry" <[email-masked]>
>         抄送：  "Kevin Boyle" <[email-masked]>, [email-masked], 
> [email-masked]
>         主题：  Re: [Megaco] A question about DTMF erasion
> 
> 
> Gateway to gateway, the technical answer is RFC 2833, period.  RFC 2833, 
> particularly as rewritten (draft-ietf-avt-rfc2833bis-12.txt, just passed 
> WGLC) has advice on what to do with the audio signal.
> 
> In other applications you should view the SIP application framework:
> 
> draft-ietf-sipping-app-interaction-framework-05.txt
> 
> 
> 
...