Subject: [Megaco] digit match question

From: "Karthikeyan Sankaran" <[email-masked]>
Date: Tue, 13 Dec 2005 04:30:25 -0800

HI,

Following is the dial plan extract:

                0[12]XXXXXXXX.S |

                0[12]XXXXXXXXX

Digits dialed:012132118000

Can somebody clarify which of the following option is correct?

1.	Notify:012132118000S with FM
2.	Notify:012132118000 with FM
3.	Notify:01213211800S with PM

Or do you think this is an ambiguous dial plan for a MG to handle and
leave it to implementation?

Thanks in advance.

Regards

Karthik

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 13 Dec 2005 12:01:54 -0500

Speaking from the assumption that you are using the enhanced matching
rules in H.248.16, it would return 01213211800 as a Full Match.  The
trailing 0 would be buffered per the rules outlined therein.
 
If this was using the regular matching rules, this would be returned as
012132118000 as a Full Match.
 
Kevin

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Karthikeyan Sankaran
	Sent: Tuesday, December 13, 2005 7:30 AM
	To: [email-masked]
	Subject: [Megaco] digit match question

	HI,

	                0[12]XXXXXXXX.S |

	                0[12]XXXXXXXXX

	Or do you think this is an ambiguous dial plan for a MG to
handle and leave it to implementation?

	Thanks in advance.

	Regards

	Karthik