Subject: [Megaco] Question about handling an error scenario

From: "Karthikeyan Sankaran" <[email-masked]>
Date: Mon, 5 Dec 2005 09:15:00 -0800

HI,
 
I have a doubt. In a scenario where a RTP termination associated with an analog termination; the analog termination was given ringing signal which passed without problem in Media gateway. In the next transaction the associated RTP termination was given some command which failed to execute and the MG has replied back with an error. What should be the behaviour of Media gateway?
 
i) Should it stop the ringing signal on the associated analog termination or
ii) Wait for MGC to take appropriate action

Thanks in advance...

Regards
karthik

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Jon Rowland" <[email-masked]>
Date: Mon, 5 Dec 2005 17:21:53 -0000

Karthik,
 
Answer ii) is correct - the MG should wait for the MGC to deal with the
situation. In Megaco, unlike MGCP, there is no implicit association
between the analog and RTP terminations just because they are in the
same context - they behave independently from a signalling point of
view, so a failed command on one has no effect on the other.
 
Hope this helps.
 
Cheers,
Jon.

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Karthikeyan Sankaran
	Sent: 05 December 2005 17:15
	To: [email-masked]
	Subject: [Megaco] Question about handling an error scenario

	HI,
	 
	I have a doubt. In a scenario where a RTP termination associated
with an analog termination; the analog termination was given ringing
signal which passed without problem in Media gateway. In the next
transaction the associated RTP termination was given some command which
failed to execute and the MG has replied back with an error. What should
be the behaviour of Media gateway?
	 
	i) Should it stop the ringing signal on the associated analog
termination or
	ii) Wait for MGC to take appropriate action

	Thanks in advance...

	Regards
	karthik

---

From: "Karthikeyan Sankaran" <[email-masked]>
Date: Mon, 5 Dec 2005 11:00:38 -0800

THanks very much Jon. And the answer is as I expected. I have one more doublt.
 
The following happens in sequence for a termination

1.	
	MGC activates reporting of off hook with Embed{dial tone, xdd/xce with some dial plan, on hook}   
2.	
	Term goes off hook
3.	
	MG plays dial tone and starts a START timer
4.	
	Term goes on hook without pressing any digit
5.	
	MG reports on hook, stops the dial tone and now should it stop the START Timer? or it should wait till MGC gives any further commands to stop before it expires?

I still expect MGC to act appropriately rather wait till the START timer expires since the megaco v2 draft says on detection any event MG shall stop any signal [if no keepactive flag enabled] and any  .

Thanks in advance

Karthik

From: Jon Rowland [mailto:[email-masked]]
Sent: Mon 12/5/2005 10:51 PM
To: Karthikeyan Sankaran
Cc: [email-masked]
Subject: RE: [Megaco] Question about handling an error scenario

Karthik,
 
Answer ii) is correct - the MG should wait for the MGC to deal with the situation. In Megaco, unlike MGCP, there is no implicit association between the analog and RTP terminations just because they are in the same context - they behave independently from a signalling point of view, so a failed command on one has no effect on the other.
 
Hope this helps.
 
Cheers,
Jon.

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Karthikeyan Sankaran
	Sent: 05 December 2005 17:15
	To: [email-masked]
	Subject: [Megaco] Question about handling an error scenario

	HI,

	Thanks in advance...

	Regards
	karthik

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 5 Dec 2005 14:24:31 -0500

Terminations are not related to each other except by being in a context
together.  Any other linkage is a violation of the protocol.  The only
exception to this is via the use of the Multiplex Descriptor, but that
clearly does not apply here.
 
This makes the answer to your question quite obvious: the physical
termination continues to play the signal until interrupted through one
of the means described in the protocol.
 
Kevin

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Karthikeyan Sankaran
	Sent: Monday, December 05, 2005 12:15 PM
	To: [email-masked]
	Subject: [Megaco] Question about handling an error scenario

	HI,

	Thanks in advance...

	Regards
	karthik

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 5 Dec 2005 14:27:35 -0500

Yes.  Detection of an event does not disable the Events Descriptor.
Other events in the active descriptor continue to be detected as
specified until the Events Descriptor is replaced.  This behavior can be
altered via the use of the EventBuffer Descriptor and LockStep.
 
Kevin

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Karthikeyan Sankaran
	Sent: Monday, December 05, 2005 2:01 PM
	To: Jon Rowland
	Cc: [email-masked]
	Subject: RE: [Megaco] Question about handling an error scenario

	THanks very much Jon. And the answer is as I expected. I have
one more doublt.

	1.	
		MGC activates reporting of off hook with Embed{dial
tone, xdd/xce with some dial plan, on hook}   
	2.	
		Term goes off hook
	3.	
		MG plays dial tone and starts a START timer
	4.	
		Term goes on hook without pressing any digit
	5.	
		MG reports on hook, stops the dial tone and now should
it stop the START Timer? or it should wait till MGC gives any further
commands to stop before it expires?

	I still expect MGC to act appropriately rather wait till the
START timer expires since the megaco v2 draft says on detection any
event MG shall stop any signal [if no keepactive flag enabled] and any
.

	Thanks in advance

	Karthik

	Karthik,
	 
	Answer ii) is correct - the MG should wait for the MGC to deal
with the situation. In Megaco, unlike MGCP, there is no implicit
association between the analog and RTP terminations just because they
are in the same context - they behave independently from a signalling
point of view, so a failed command on one has no effect on the other.
	 
	Hope this helps.
	 
	Cheers,
	Jon.

		From: [email-masked]
[mailto:[email-masked]] On Behalf Of Karthikeyan Sankaran
		Sent: 05 December 2005 17:15
		To: [email-masked]
		Subject: [Megaco] Question about handling an error
scenario

		HI,
		 
		I have a doubt. In a scenario where a RTP termination
associated with an analog termination; the analog termination was given
ringing signal which passed without problem in Media gateway. In the
next transaction the associated RTP termination was given some command
which failed to execute and the MG has replied back with an error. What
should be the behaviour of Media gateway?
		 
		i) Should it stop the ringing signal on the associated
analog termination or
		ii) Wait for MGC to take appropriate action

		Thanks in advance...

		Regards
		karthik