Subject: RE: [Megaco] Fax and Modem detection

From: "Wainwright, John \(Com US\)" <[email-masked]>
Date: Fri, 13 Jan 2006 13:44:16 -0800

Can anyone provide me with more insight into the CTYP and FTMD packages
in relationship to support of fax pass-thru via G.711 only and not using
T.38 ?
Is support of both packages and all events/signals required for this
feature ?

Thanks 
John

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Gunnar Hellstrom" <[email-masked]>
Date: Sat, 14 Jan 2006 06:58:49 +0100

If you want to discriminate all kinds of faxes from all other
communications: Voice, modem, text telephony, then you would need a large
part of CTYP.

If you can accept to catch also modem and text telephony calls, so that you
give all data related calls more reliable transfer, then you might be able
to reduce the detail of some events.

I would guess that you would also select something more reliable than plain
G.711 for the transport.

Gunnar
----------------------------------------------------------------------------
-
Gunnar Hellstrom, Omnitor
[email-masked] <mailto:[email-masked]>

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf
Of Wainwright, John (Com US)
Sent: Friday, January 13, 2006 10:44 PM
To: [email-masked]
Subject: RE: [Megaco] Fax and Modem detection

Thanks
John

---

From: [email-masked]
Date: Sat, 14 Jan 2006 15:52:40 +0100

John,
like to complement Gunnar.

You are looking for VBD mode (VBDoIP; e.g., according ITU-T V.152).
There is NO H.248 Package required for the CONTROL of VBD (see also V.152),
but if you want to NOTIFY the MGC about the detection of a VBD stimuli then
you may use H.248.2 ctyp.
The Event ctyp/dtone is typically sufficient ("the observed event parameter
dtt may be used in addition for discriminating tone types, but I never saw
so far this requirement and application in the context of VBDoIP").

- Albrecht

                      "Gunnar Hellstrom"                                                                                                
                      <gunnar.hellstrom@         To:      "Wainwright, John \(Com US\)" <[email-masked]>,                  
                      omnitor.se>                <[email-masked]>                                                                      
                      Sent by:                   cc:                                                                                    
                      megaco-bounces@iet         Subject: RE: [Megaco] Fax and Modem detection                                          
                      f.org                                                                                                             

                      14.01.2006 06:58                                                                                                  

Gunnar

-

-----Original Message-----

Thanks
John