Subject: [Megaco] Correlating Contexts in Replies and Requests

From: "Alon Tal" <[email-masked]>
Date: Mon, 16 Jan 2006 16:41:24 +0200

When monitoring an exchange between an MG and an MGC, given the
following request:

  -----------------------
  TransactionRequest 42 {
    ContextID = $ {
      ADD = $ {
        Media = XYZ
      }
    }
 
    ContextID = $ {
      ADD = $ { 
        Media = ABC
      }
    }
  }
  ----------------------- 

And the reply:
  -----------------------
  TransactionReply 42 {
    ContextID = 10 {
      ADD = T1000
    }
    ContextID = 20 {
      ADD = T2000
    }
  }
  -----------------------

How can you tell which newly created ContextID in the reply (10 or 20)
is associated with which "$" in the request? By their order?

Thanks,
Alon

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 16 Jan 2006 14:04:50 -0500

Yes.  H.248 requires replies to occur in the same order as the request.

Kevin 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Alon Tal
Sent: Monday, January 16, 2006 9:41 AM
To: [email-masked]
Subject: [Megaco] Correlating Contexts in Replies and Requests

  -----------------------
  TransactionRequest 42 {
    ContextID = $ {
      ADD = $ {
        Media = XYZ
      }
    }
 
    ContextID = $ {
      ADD = $ { 
        Media = ABC
      }
    }
  }
  ----------------------- 

And the reply:
  -----------------------
  TransactionReply 42 {
    ContextID = 10 {
      ADD = T1000
    }
    ContextID = 20 {
      ADD = T2000
    }
  }
  -----------------------

Thanks,
Alon