Subject: [Megaco] Segmentation Package Questions

From: "Michael Dell" <[email-masked]>
Date: Thu, 6 Apr 2006 11:25:57 +0100

Hi there

I have a couple of questions on the Segmentation package defined in
H.248.1 v3.

Firstly, would it be legitimate to use this package over H.248.1 v2, or
could it only be used on a v3 association, since it relies on new tokens
only defined in v3?

Secondly, the definition states that each segment of the response must
be a syntactically valid construct.  I think that means that the
following segmentation would be valid, but wanted to confirm that:

MGC: 		!/2 [12.34.56.78]:2944 T=1 { C=10 { S=ip/12 { AT { SA,
M}}, S=ip/34 { AT {SA, M}}}}
MG:		!/2 [12.34.56.79]:2944 P=1/1 { C=10 { S=ip/12 {M{..},
SA{..}}}}
MGC:    	!/2 [12.34.56.78]:2944 SM=1/1
MG:		!/2 [12.34.56.79]:2944 P=1/2/# { C=10 { S=ip/34 {M{..},
SA{..}}}}
MGC:    	!/2 [12.34.56.78]:2944 SM=1/2/#
MGC:    	!/2 [12.34.56.78]:2944 K=1

Lastly, in the version of the specification I have, the segmentation
example uses # for the SegmentationCompleteToken, but the ABNF suggests
it should be & - which is correct?

Thanks

Mike Dell
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 6 Apr 2006 08:33:20 -0400

Comments inline. [KJBII]
 
Kevin

________________________________

	From: Michael Dell [mailto:[email-masked]] 
	Sent: Thursday, April 06, 2006 6:26 AM
	To: [email-masked]
	Subject: [Megaco] Segmentation Package Questions

	Hi there 

	I have a couple of questions on the Segmentation package defined
in H.248.1 v3. 

	Firstly, would it be legitimate to use this package over H.248.1
v2, or could it only be used on a v3 association, since it relies on new
tokens only defined in v3?

	[KJBII] Unfortunately, the syntax of V2 does not allow the use
of the segmentation package. 

	Secondly, the definition states that each segment of the
response must be a syntactically valid construct.  I think that means
that the following segmentation would be valid, but wanted to confirm
that:

	MGC:            !/2 [12.34.56.78]:2944 T=1 { C=10 { S=ip/12 { AT
{ SA, M}}, S=ip/34 { AT {SA, M}}}} 
	MG:             !/2 [12.34.56.79]:2944 P=1/1 { C=10 { S=ip/12
{M{..}, SA{..}}}} 
	MGC:            !/2 [12.34.56.78]:2944 SM=1/1 
	MG:             !/2 [12.34.56.79]:2944 P=1/2/# { C=10 { S=ip/34
{M{..}, SA{..}}}} 
	MGC:            !/2 [12.34.56.78]:2944 SM=1/2/# 
	MGC:            !/2 [12.34.56.78]:2944 K=1 

	[KJBII] This is correct. 

	Lastly, in the version of the specification I have, the
segmentation example uses # for the SegmentationCompleteToken, but the
ABNF suggests it should be & - which is correct?
	 
	[KJBII] The syntax definition takes precedence over the
examples.  I believe this has been corrected in the H.248 Subseries
Implementors' Guide, which will be approved on April 13. 

	Thanks 

	Mike Dell