Subject: [Megaco] andisp/dwa with notifyCompletion

From: Tonny Kung <[email-masked]>
Date: Fri, 7 Apr 2006 16:46:00 +0800 (CST)

Hi,
   
  I'm just wondering if the MGC requests CLIP sending with alerting (andisp/dwa) and also wants to be notify when the sending is completed with notifyCompletion. Then will the Notify be sent when the CLIP data is sent, or when the alerting stopped?
I'm assuming the notify will be sent only after both the CLIP delivery and alerting has stopped, which basically mean when the subscriber off-hook, is that right?

Theoretical Question: Is there anyway to get the notifyCompletion for CLIP delivery only? other than separating the CLIP and alerting request?

Best Regards,
Tonny

_______________________________________
 YM - 離線訊息
 就算你沒有上網，你的朋友仍可以留下訊息給你，當你上網時就能立即看到，任何說話都冇走失。
 http://messenger.yahoo.com.hk

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 25 Apr 2006 13:07:50 -0400

The Notify would be sent when the alerting component halted.  The
subscriber could already be off-hook, in the case of a Caller ID on Call
Waiting function.  In this case, NotifyCompletion could occur due to the
completion of the call waiting tone, the occurrence of a flash prior to
the completion of call wait tone, etc.  There are many possibilities for
the halt of an alerting signal in both the on-hook and off-hook cases.
 
There is currently no way to detect the end of the data transfer with
the dwa signal.  Given that the alerting portion is supposed to continue
even if the transfer fails, I am not sure how useful knowing when the
data transfer completes is useful.
 
Kevin  

________________________________

	From: Tonny Kung [mailto:[email-masked]] 
	Sent: Friday, April 07, 2006 4:46 AM
	To: [email-masked]
	Subject: [Megaco] andisp/dwa with notifyCompletion

	Hi,
	 
	I'm just wondering if the MGC requests CLIP sending with
alerting (andisp/dwa) and also wants to be notify when the sending is
completed with notifyCompletion. Then will the Notify be sent when the
CLIP data is sent, or when the alerting stopped?
	I'm assuming the notify will be sent only after both the CLIP
delivery and alerting has stopped, which basically mean when the
subscriber off-hook, is that right?
	
	Theoretical Question: Is there anyway to get the
notifyCompletion for CLIP delivery only? other than separating the CLIP
and alerting request?
	
	Best Regards,
	Tonny

	_______________________________________
	YM - �x��ӍϢ
	������]���ϾW����������Կ�������ӍϢ�o�㣬�����ϾW�r����������
�����κ��fԒ������ʧ��
	http://messenger.yahoo.com.hk