Subject: [Megaco] working with MGC sampleof Erlang/OTP

From: Yotam Roch <[email-masked]>
Date: Tue, 4 Apr 2006 23:18:11 -0700 (PDT)

H,
  Does anyone know what do I get the "Error = 501 { "Only handled for root" }" response from Erlang's MGC?
  *************************************
(To: [127.0.0.1]:2944)
MEGACO/1 <MG1>
Transaction=30296{
 Context=-{
  ServiceChange=root{Services{Method=Restart, Reason="901 Cold Boot", Version=1, 20060404T13283637}}
 }
}
*************************************
(From: [127.0.0.1]:2944)
MEGACO/1 controller
Reply = 30296 {
 Context = - {
  ServiceChange = root {
   Services {
    MgcIdToTry = controller
   }
  }
 }
}
*************************************
(To: [127.0.0.1]:2944)
MEGACO/1 <MG1>
Transaction=30297{
 Context=-{
  ServiceChange=aaln/1{Services{Method=Restart, Reason="901 Cold Boot"}}
 }
}
TransactionResponseAck{30296}
*************************************
(From: [127.0.0.1]:2944)
MEGACO/1 controller
Reply = 30297 {
 Context = - {
  ServiceChange = aaln/1 {
   Error = 501 { "Only handled for root" } 
  }
 }
}
   
  Regards,
  Yotam

---------------------------------
Talk is cheap. Use Yahoo! Messenger to make PC-to-Phone calls.  Great rates starting at 1&cent;/min.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Mudit Gupta" <[email-masked]>
Date: Wed, 5 Apr 2006 12:33:49 +0530

Hi Yotam,
 
It means ServiceChange is only implemented for ROOT termination, not for individual termination. 
 
Regards,
Mudit

________________________________

From: Yotam Roch [mailto:[email-masked]]
Sent: Wed 4/5/2006 11:48 AM
To: [email-masked]
Subject: [Megaco] working with MGC sampleof Erlang/OTP 

H,
 
Regards,
Yotam

________________________________

Talk is cheap. Use Yahoo! Messenger to make PC-to-Phone calls. Great rates starting at 1¢/min. <http://us.rd.yahoo.com/mail_us/taglines/postman7/*http://us.rd.yahoo.com/evt=39666/*http://beta.messenger.yahoo.com> 
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 5 Apr 2006 04:02:14 -0400

I don't believe this to be true.  I believe the problem is that SCReason
901 is only used with Root.  A different SCReason will have to be used
for other terminations.
 
Kevin

	From: Mudit Gupta [mailto:[email-masked]] 
	Sent: Wednesday, April 05, 2006 3:04 AM
	To: Yotam Roch; [email-masked]
	Subject: RE: [Megaco] working with MGC sampleof Erlang/OTP

	Hi Yotam,
	 
	It means ServiceChange is only implemented for ROOT termination,
not for individual termination. 
	 
	Regards,
	Mudit

	H,
	Does anyone know what do I get the "Error = 501 { "Only handled
for root" }" response from Erlang's MGC?
	*************************************
	(To: [127.0.0.1]:2944)
	MEGACO/1 <MG1>
	Transaction=30296{
	 Context=-{
	  ServiceChange=root{Services{Method=Restart, Reason="901 Cold
Boot", Version=1, 20060404T13283637}}
	 }
	}
	*************************************
	(From: [127.0.0.1]:2944)
	MEGACO/1 controller
	Reply = 30296 {
	 Context = - {
	  ServiceChange = root {
	   Services {
	    MgcIdToTry = controller
	   }
	  }
	 }
	}
	*************************************
	(To: [127.0.0.1]:2944)
	MEGACO/1 <MG1>
	Transaction=30297{
	 Context=-{
	  ServiceChange=aaln/1{Services{Method=Restart, Reason="901 Cold
Boot"}}
	 }
	}
	TransactionResponseAck{30296}
	*************************************
	(From: [127.0.0.1]:2944)
	MEGACO/1 controller
	Reply = 30297 {
	 Context = - {
	  ServiceChange = aaln/1 {
	   Error = 501 { "Only handled for root" } 
	  }
	 }
	}
	 
	Regards,
	Yotam

	Talk is cheap. Use Yahoo! Messenger to make PC-to-Phone calls.
Great rates starting at 1¢/min.
<http://us.rd.yahoo.com/mail_us/taglines/postman7/*http://us.rd.yahoo.co
m/evt=39666/*http://beta.messenger.yahoo.com>