Subject: [Megaco] Response should resend?

From: Tony Zhang <[email-masked]>
Date: Thu, 24 Aug 2006 10:21:56 +0800

HI All:

    I have a question about  Three-way handshake. If a response have been send, but the response entity do not received the response acknowledgement. Then, Is it necessary or possible or unnecessary that the response should be initiative resent by respond entity in Three-way handshake mode? Thanks.

Best regards!

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Raphael Tryster" <[email-masked]>
Date: Thu, 24 Aug 2006 09:48:01 +0200

The responder should not retransmit the response as a result of not receiving ack.  If the initiator of the request does not receive the response, it will retransmit the request, and the responder should then retransmit the response.  Ack just tells the responder that it can delete the response because it knows it was received.  If no ack is received, the responder needs to keep a copy of it for a while (see the standard for precise definition) in case it receives a retransmitted request.
 
Raphael Tryster
 
"Things should be made as simple as possible, but not any simpler."  - Albert Einstein
 
-----Original Message-----
From: Tony Zhang [mailto:[email-masked]]
Sent: Thursday, August 24, 2006 4:22 AM
To: [email-masked]
Subject: [Megaco] Response should resend?
 
HI All:
 
Best regards!
 
**********************************************************************************************
This e-mail contains confidential, privileged or proprietary information to VocalTec Communications.
If you received this messege by mistake, please inform us and then delete the original and all copies.
*** eSafe scanned this email for viruses, vandals, and malicious content. ***
**********************************************************************************************
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Sudhanshu Garg <[email-masked]>
Date: Thu, 24 Aug 2006 11:25:28 +0530

Hi,

There is no need to retransmit the response by itself as
it is responsibility of requesting entity to provide
suitable timeouts for all outstanding transactions.
Reference: Section D.1.3 of H.248.1

Similar query was discussed earlier in the mailing list.
May 2006: Baseroot v2 Use case query

Regards,
Sudhanshu.
Technical Leader
Flextronics Software Systems
Phone:  +91-124-4176301 extn 5109
Fax: +91-124-4300247
web: www.flextronicssoftware.com

Tony Zhang <[email-masked]> 
08/24/2006 07:51 AM

To
[email-masked]
cc

Subject
[Megaco] Response should resend?

HI All:
    I have a question about  Three-way handshake. If a response have been 
send, but the response entity do not received the response 
acknowledgement. Then, Is it necessary or possible or unnecessary that the 
response should be initiative resent by respond entity in Three-way 
handshake mode? Thanks.
 
Best regards!

***********************  FSS-Restricted   ***********************