Subject: [Megaco] ServiceChange indicating multiple terminations

From: "Oikonomou, Ioannis" <[email-masked]>
Date: Thu, 10 Aug 2006 23:34:49 +0300

Hello,

I have 2 questions concerning the ServiceChange command:

1) ServiceChange(Handoff) is the only ServiceChange command that an MGC
is allowed to send towards an MG. Is this correct?

2) Is the following syntax allowed?

MEGACO/1 [216.33.33.61]: 25000
Transaction = 4321 {
    Context = - {
        ServiceChange = TermA, TermB, TermC { Services {
            Method = Forced }
        }
    }
}

The syntax for ServiceChange is the following according to H.248.1:

ServiceChangeRequest ::= SEQUENCE

{

     terminationID              TerminationIDList,

     serviceChangeParms         ServiceChangeParm,

     ...

}

TerminationIDList ::= SEQUENCE OF TerminationID

TerminationID ::= SEQUENCE

{

     wildcard  SEQUENCE OF WildcardField, 

     id    OCTET STRING(SIZE(1..8)),

     ...

}

WildcardField ::= OCTET STRING(SIZE(1))

Ioannis Oikonomou

Senior Software Engineer

Siemens SA

Greece

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Sudhanshu Garg <[email-masked]>
Date: Fri, 11 Aug 2006 11:04:02 +0530

Hi,

The ABNF syntax of H.248.1 (version 3), provides termination ID list as:
        termIDList                      = (TerminationID / LSBRKT 
TerminationID 1*(COMMA
                                                TerminationID) RSBRKT)

The termination ID list was not allowed in ABNF syntax in earlier versions 
of H.248.1

Also the service change reason is mandatory in the service change command 
request.

So the correct syntax should have Megaco version 3, termination list 
enclosed in square brackets and service change reason present:

MEGACO/3 [216.33.33.61]: 25000
Transaction = 4321 {
    Context = - {
        ServiceChange = [TermA, TermB, TermC] { Services {
            Method = Forced, Reason = "905 Term Taken OOS" }
        }
    }
}

Regards,
Sudhanshu.
Technical Leader
Flextronics Software Systems
Phone:  +91-124-4176301 extn 5109
Fax: +91-124-4300247
web: www.flextronicssoftware.com

"Oikonomou, Ioannis" <[email-masked]> 
08/11/2006 02:04 AM

To
<[email-masked]>
cc

Subject
[Megaco] ServiceChange indicating multiple terminations

Hello,

1) ServiceChange(Handoff) is the only ServiceChange command that an MGC is 
allowed to send towards an MG. Is this correct?

 

 

Ioannis Oikonomou
Senior Software Engineer
Siemens SA
Greece

***********************  FSS-Private   ***********************

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 15 Aug 2006 12:22:33 -0400

In reference to your second question below, you are trying to construct
text encoding using the ASN.1 definition.  ASN.1 is for binary encoding,
and is not suitable for text construction.  You need to reference Annex
B, which contains the ABNF encoding rules.
 
Kevin

________________________________

From: Oikonomou, Ioannis [mailto:[email-masked]] 
Sent: Thursday, August 10, 2006 4:35 PM
To: [email-masked]
Subject: [Megaco] ServiceChange indicating multiple terminations

Hello,

{

     ...

}

{

     ...

}

Ioannis Oikonomou

Senior Software Engineer

Siemens SA

Greece