Subject: RE: [Megaco] Error format

From: "Wainwright, John \(Com US\)" <[email-masked]>
Date: Wed, 2 Aug 2006 14:03:26 -0700

As a follow on to this question, if the original ADD request involved a
CHOOSE ($) for the ephemeral then if for example there was an error in
the Local Descriptor, such as codec not supported, would the response
indicate a failure for ADD of a specific Ephemeral termination or would
the entire ADD for the ephemeral fail with the response indicating $ for
its terminationId ?

i.e. 
    ADD = eph/00337 { 
          ERROR = 515 {"Unsupported Media Type"} 

Or
    ADD = $ { 
          ERROR = 515 {"Unsupported Media Type"} 

Thanks
John

-----Original Message-----
From: Ashish Singh [mailto:[email-masked]] 
Sent: Wednesday, July 26, 2006 1:55 PM
To: Wainwright, John (Com US)
Cc: [email-masked]
Subject: Re: [Megaco] Error format

I guess it will be easier for MGC to parse, if we only include 
"streamID" and no other text. IMO, error descriptor should look like:

ERROR = 515 {"xxx"}

Thanks
Ashish

Wainwright, John (Com US) wrote:
> So would a more accurate response have something like the following
> 	ERROR = 515 {"Unsupported Media Type.  Stream = xxx"
>
> If "Stream = 1" can it be omitted and assumed by default ?
>
> Thanks
> John
>
>
> -----Original Message-----
> From: Ashish Singh [mailto:[email-masked]] 
> Sent: Wednesday, July 26, 2006 11:36 AM
> To: Wainwright, John (Com US)
> Cc: [email-masked]
> Subject: Re: [Megaco] Error format
>
> Hi John,
>
> The response is correct from syntax point of view. But H.248.8
mentions 
> to include "stream ID" as Error text for this particular error code.
>
> There are many other error codes, for which extra information is 
> required. Like with error codes 433 and 435, contextID is returned, so

> that MGC can synchronize its database.
>
> Thanks
> Ashish
>
>
> Wainwright, John (Com US) wrote:
>   
>> Is the following format 'valid' for a response to an ADD request 
>> containing an unsupported codec in the Local descriptor?  Would the 
>> same format apply, apart from the error code and text, for any other 
>> type of error in the SDP data within the Local descriptor ?
>>  
>> MEGACO/2 [20.0.4.32]:2084
>> REPLY = 269820167 {
>>   CONTEXT = 13 {
>>     ADD = port_1
>>   ,
>>     ADD = eph/00337 { 
>>           ERROR = 515 {"Unsupported Media Type"} 
>>     }
>>   }
>> } 
>>  
>> Thanks
>> John
>>  
>>
>>     
>
------------------------------------------------------------------------
>   
>> _______________________________________________
>> Megaco mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/megaco
>>   
>>     
>
>
>   

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Oikonomou, Ioannis" <[email-masked]>
Date: Thu, 3 Aug 2006 11:15:11 +0300

John,

I think that the second response is the correct one, i.e. with "$".
See also
http://www1.ietf.org/mail-archive/web/megaco/current/msg06129.html.

Ioannis Oikonomou

-----Original Message-----
From: Wainwright, John (Com US) 
Sent: Thursday, August 03, 2006 12:03 AM
To: [email-masked]
Subject: RE: [Megaco] Error format

i.e. 
    ADD = eph/00337 { 

Or
    ADD = $ { 

Thanks
John

-----Original Message-----
From: Ashish Singh [mailto:[email-masked]] 
Sent: Wednesday, July 26, 2006 1:55 PM
To: Wainwright, John (Com US)
Cc: [email-masked]
Subject: Re: [Megaco] Error format

ERROR = 515 {"xxx"}

Thanks
Ashish

mentions

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 15 Aug 2006 13:00:58 -0400

Remember that descriptors don't fail -- commands do.  If there is
something in a descriptor that causes a command to fail, then the entire
command fails.  So, for commands that result in the creation of
terminations or contexts (in the case of a single add or move into a
CHOOSE context), the termination and/or context in question do NOT come
into existence.  The command must succeed in order for the element to be
created.

I will also note that the Error Descriptor has no such restriction that
only the information suggested in the Error Code definitions be present.
As long as that information is present, the entity sending the Error
Descriptor is free to put other information in the Error Descriptor as
well.

Kevin

-----Original Message-----
From: Wainwright, John (Com US) [mailto:[email-masked]] 
Sent: Wednesday, August 02, 2006 5:03 PM
To: [email-masked]
Subject: RE: [Megaco] Error format

i.e. 
    ADD = eph/00337 { 

Or
    ADD = $ { 

Thanks
John

-----Original Message-----
From: Ashish Singh [mailto:[email-masked]]
Sent: Wednesday, July 26, 2006 1:55 PM
To: Wainwright, John (Com US)
Cc: [email-masked]
Subject: Re: [Megaco] Error format

ERROR = 515 {"xxx"}

Thanks
Ashish

mentions