Subject: [Megaco] Error during Add Command

From: [email-masked]
Date: Thu, 31 Aug 2006 17:20:24 +0300

Hi all

We see here the following :

MGC sends ADD request to the MG :

MEGACO/1 [xx.xx.xx.xx]:2944
T=369419463{C=${A=aaln/65{M{O{MO=IN,RV=OFF,RG=OFF}},E=370727168{tonedet/std{tl=*},al/*},SG{}},A=${M{O{MO=RC,RV=OFF,RG=OFF},L{v=0
    c=IN IP4 $
    m=audio $ RTP/AVP 8
    a=ptime:20
    }}}}}

The MG does not support the tonedet package :
What is the right behavior at this case :

a.  Send an error message without creating a context and not process the
ADD request.
b. Process the ADD request and add the termination to a context, with an
error notification regarding the Unsupported Package.

Thanks In Advance

Seraya

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 31 Aug 2006 11:42:47 -0400

The command failed, therefore the context did not come into existence
and the termination is still in NULL.

Kevin 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, August 31, 2006 10:20 AM
To: [email-masked]
Subject: [Megaco] Error during Add Command

Hi all

MEGACO/1 [xx.xx.xx.xx]:2944
T=369419463{C=${A=aaln/65{M{O{MO=IN,RV=OFF,RG=OFF}},E=370727168{tonedet/
std{tl=*},al/*},SG{}},A=${M{O{MO=RC,RV=OFF,RG=OFF},L{v=0
    c=IN IP4 $
    m=audio $ RTP/AVP 8
    a=ptime:20
    }}}}}

Thanks In Advance

Seraya

---

From: Wglastonio <[email-masked]>
Date: Thu, 31 Aug 2006 13:16:15 -0300

Hello,
Chapter 8 (Transactions) describes:
"At the first failing command in a transaction, processing of the remaining
commands in that transaction stops."

Reg,

Wg.