Subject: [Megaco] Who chooses circuit between TGW and SS7?

From: "Raphael Tryster" <[email-masked]>
Date: Thu, 31 Aug 2006 20:24:06 +0200

I refer to draft-ietf-megaco-callflows-02.txt.  In the section on a call between SS7 trunk in TGW and RGW, the MGC receives in the IAM message the identity of the circuit that the SS7 switch has chosen to be used for the call, translates this into a termination, and tells the TGW to use that termination.  I have no problem with this.
 
For a call in the opposite direction, the draft says that the MGC asks the TGW to choose a circuit.  I would understand if the MGC then used the chosen circuit in the messages it send to SS7 to set up the call.  However, the draft says that these SS7 messages are exchanged BEFORE adding the physical termination.  How can this work?  There doesn't seem to be anything ensuring that SS7 and TGW will use the same circuit.
 
Raphael Tryster
**********************************************************************************************
This e-mail contains confidential, privileged or proprietary information to VocalTec Communications.
If you received this messege by mistake, please inform us and then delete the original and all copies.
*** eSafe scanned this email for viruses, vandals, and malicious content. ***
**********************************************************************************************

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Terry L Howe <[email-masked]>
Date: Thu, 31 Aug 2006 11:43:20 -0600

The TGW is bearer only, SS7 should determine the CIC, it is signaling.

Quoting Raphael Tryster <[email-masked]>:

> I refer to draft-ietf-megaco-callflows-02.txt.  In the section on a   
> call between SS7 trunk in TGW and RGW, the MGC receives in the IAM   
> message the identity of the circuit that the SS7 switch has chosen   
> to be used for the call, translates this into a termination, and   
> tells the TGW to use that termination.  I have no problem with this.
>
> For a call in the opposite direction, the draft says that the MGC   
> asks the TGW to choose a circuit.  I would understand if the MGC   
> then used the chosen circuit in the messages it send to SS7 to set   
> up the call.  However, the draft says that these SS7 messages are   
> exchanged BEFORE adding the physical termination.  How can this   
> work?  There doesn't seem to be anything ensuring that SS7 and TGW   
> will use the same circuit.
>
> Raphael Tryster

-- 
Terry L Howe
[email-masked]

---

From: "Raphael Tryster" <[email-masked]>
Date: Thu, 31 Aug 2006 22:05:18 +0200

Does that mean the call flows document is wrong?
 
Raphael Tryster

-----Original Message-----
From: Terry L Howe [mailto:[email-masked]]
Sent: Thursday, August 31, 2006 7:43 PM
To: [email-masked]
Subject: Re: [Megaco] Who chooses circuit between TGW and SS7?

-- 
Terry L Howe
[email-masked]

---

From: Terry L Howe <[email-masked]>
Date: Thu, 31 Aug 2006 14:30:18 -0600

I guess it gets down to a design decision.  In theory, you could
have a TGW make routing decisions, but it doesn't seem like a
good place to make that decision to me.  I would think someone
else would make that decision and the TGW would just blindly set
up connections and keep some DSPs busy.  The implementations I've
worked on have used more centralized routing.

-- 
Terry L Howe
[email-masked]