Subject: [Megaco] FAILOVER

From: "Nicolas Emiliani" <[email-masked]>
Date: Wed, 2 Aug 2006 18:00:45 -0300

Hi...
Im using the H248.14 package to detect if the MGC is alive or not, and I
have a quetsion, if the MGC doesn't send a message the MG fails over to the
next MGC provided. The thing is that it sends to the next MGC a transmision
failure. The thing is that when the other MGC gets the transimission failure
and replies it, it doesn't know what is the state of the terminations. So I
supouse I should audit them to figure it out, but i don't want to right now,
so I was thinking, is there a way to restart the MG through a megaco
message?... I know it's pretty nasty... but it is just fot few days :P ....
Im sending a SC=ROOT with mnethod=restart but the MG replies and doesn't
restart... bastard!... jejeje.... well... any suggestions?
Thanks!
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Thu, 3 Aug 2006 09:42:00 +0200

Nicolas,
ServiceChange procedure should be principally possible.
See Annex F.3.9/H.248.1 "MGC Initiated Service Restoration".

=> ServiceChange 'object' = Root termination

=> ServiceChangeMethod = RESTART
=> ServiceChangeReason = 900 or 901

The reaction by the MG must be then the "attempt to establish a new control
association in accordance with F.3.2 ...".

Perhaps your Reason codepoint was different!?

- Albrecht

                      "Nicolas                                                                                                        
                      Emiliani"                To:      [email-masked]                                                               
                      <[email-masked]         cc:                                                                                    
                      om>                      Subject: [Megaco] FAILOVER                                                             
                                                                                                                                      
                      02.08.2006 18:00                                                                                                

Hi...
Im using the H248.14 package to detect if the MGC is alive or not, and I
have a quetsion, if the MGC doesn't send a message the MG fails over to the
next MGC provided. The thing is that it sends to the next MGC a transmision
failure. The thing is that when the other MGC gets the transimission
failure and replies it, it doesn't know what is the state of the
terminations. So I supouse I should audit them to figure it out, but i
don't want to right now, so I was thinking, is there a way to restart the
MG through a megaco message?... I know it's pretty nasty... but it is just
fot few days :P .... Im sending a SC=ROOT with mnethod=restart but the MG
replies and doesn't restart... bastard!... jejeje.... well... any
suggestions?
Thanks!_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco