Subject: [Megaco] h.248 control association

From: "Araz," <[email-masked]>
Date: Mon, 10 Mar 2008 18:15:42 +0330

hi all ,
In H.248 V3 stack Implementation , which document should I refer regarding
MG and MGC control association state machines ? and interpreting Service
Change commands for association deletion/creation/config etc. and their
states?
I've come up with 2 references one is the following :
MEGACO Control Association State Machine ,
http://tools.ietf.org/draft/draft-hss-megaco-control-association-state-machine/draft-hss-megaco-control-association-state-machine-00.txt

which is an expired draft and I can't find a similar reference on this
issue.
I cheked the H.248 V3 annex F on "ServiceChange Procedures" it refers to
H.248.1 on where there are descrepancies .
http://ftp3.itu.int/av-arch/avc-site/2001-2004/0202_Gen/pl-036r1_h248_1.zip

I would appreciate if one can guide me based on what reference and How
should I treat and implement control association state for MG/MGC ?
Best,
Araz.
_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 10 Mar 2008 12:42:48 -0400

The expired draft is considered obsolete and is not relevant.  Further,
it proposes ideas that are not generally accepted.
 
If you checked H.248.1 V3 Annex F, then you already have H.248.1 in your
possession.  The item you list here is a proposed Corrigendum to the
original H.248 document that was never approved. Instead, H.248 with
this Corrigendum included was reissued as H.248.1 Version 1.  It has
been supplanted by two newer versions of H.248.1 in the intervening 6
years.
 
Please see http://www.itu.int/rec/T-REC-H.248.1-200509-I/en for the most
recent version of H.248.1 (including Annex F).  Everything you need to
know about the H.248 control association is in H.248.1 and Annex F.
 
Kevin

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Araz,
Sent: Monday, March 10, 2008 10:46 AM
To: [email-masked]
Subject: [Megaco] h.248 control association

hi all ,
In H.248 V3 stack Implementation , which document should I refer
regarding MG and MGC control association state machines ? and
interpreting Service Change commands for association
deletion/creation/config etc. and their states?
I've come up with 2 references one is the following :
MEGACO Control Association State Machine , 
http://tools.ietf.org/draft/draft-hss-megaco-control-association-state-m
achine/draft-hss-megaco-control-association-state-machine-00.txt
 
which is an expired draft and I can't find a similar reference on this
issue.
I cheked the H.248 V3 annex F on "ServiceChange Procedures" it refers to
H.248.1 on where there are descrepancies .
http://ftp3.itu.int/av-arch/avc-site/2001-2004/0202_Gen/pl-036r1_h248_1.
zip

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Tue, 11 Mar 2008 10:49:22 +0100

Agree to Kevin.
 
The underyling question is whether the Control Association (CA) is stateless or stateful.
The last time of such a discussion was, as far as I remember, due to our contribution AVD-3003.
http://ftp3.itu.int/av-arch/avc-site/2005-2008/0703_She/AVD-3003.zip
 
This was a side question then, just raised, but not progressed (because low prio => "It was also agreed to add a living list item to investigate a control association state model.").
 
The conclusion is: there is not yet any explicit state model defined for the H.248 CA.
This didn't cause so far any problems in my understanding.
 
Thus, the CA is either "not existing" or "successfully established". Might be considered as an implicit, 2-state model for the CA. The basic state model may be extended by adding sub-states for the established phase (like IS, OoS) ... but then you may question it again, because you may got already such a state model for your L4 transport connection (for H.248 transport)...
 
-Albrecht
 
PS
The AVD-3003 discussion:

Item:

[Q1]         Do we need a state model for the H.248 Control Association?

Probably not. 

Note:      In case of a lacking state model, the "state" of the control association is often coupled (or confused?) with the ServiceState or/and the ServiceChange state of the H.248 entity terminating the control association in our experience.
E.g., when the H.248 MG or MGC is transitioning for IS to OoS, is when also the correspondent Control Association endpoint going to "OoS state", or may the endpoint still in "IS state"? If yes, then there might be a situation with state mismatch concerning both Control Association endpoints!?

But probably we should explicitly document whether 

Q2.1: the H.248 Control Association state model could be related with the ServiceState of the ROOT Termination (Yes/No?);

Q2.2: the H.248 Control Association state model could be related with the ServiceChange state (Yes/No?);

Q2.3: the H.248 Control Association state model could be related with the state model of the underlying transport connection (Yes/No?); or

Q2.4: the H.248 Control Association is fundamentally "stateless" (Yes/No?).

Approach (2.2) looks on the first glance advantageous due to the then "tight coupling with ServiceChange procedures" (but we may have to review & revisit the entire Annex F/H.248.1 ...). 

Approach (2.3) looks also advantageous, at least for stateful transport technologies like SCTP, TCP or ATM (but may raise questions in case of UDP ...). 

Proposal for "Q2" item: 

A clarification of "Q2" would be beneficial, but is not easy and has currently not the highest priority in our opinion. If the meeting agrees, then we'd like to propose to move the discussion about Q2 in our living list.

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Kevin Boyle
	Sent: Montag, 10. März 2008 17:43
	To: Araz,; [email-masked]
	Subject: Re: [Megaco] h.248 control association

	The expired draft is considered obsolete and is not relevant.  Further, it proposes ideas that are not generally accepted.
	 
	If you checked H.248.1 V3 Annex F, then you already have H.248.1 in your possession.  The item you list here is a proposed Corrigendum to the original H.248 document that was never approved. Instead, H.248 with this Corrigendum included was reissued as H.248.1 Version 1.  It has been supplanted by two newer versions of H.248.1 in the intervening 6 years.
	 
	Please see http://www.itu.int/rec/T-REC-H.248.1-200509-I/en for the most recent version of H.248.1 (including Annex F).  Everything you need to know about the H.248 control association is in H.248.1 and Annex F.
	 
	Kevin

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Araz,
	Sent: Monday, March 10, 2008 10:46 AM
	To: [email-masked]
	Subject: [Megaco] h.248 control association

	hi all ,
	In H.248 V3 stack Implementation , which document should I refer regarding MG and MGC control association state machines ? and interpreting Service Change commands for association deletion/creation/config etc. and their states?
	I've come up with 2 references one is the following :
	MEGACO Control Association State Machine , 
	http://tools.ietf.org/draft/draft-hss-megaco-control-association-state-machine/draft-hss-megaco-control-association-state-machine-00.txt
	 
	which is an expired draft and I can't find a similar reference on this issue.
	I cheked the H.248 V3 annex F on "ServiceChange Procedures" it refers to H.248.1 on where there are descrepancies .
	http://ftp3.itu.int/av-arch/avc-site/2001-2004/0202_Gen/pl-036r1_h248_1.zip
	 
	I would appreciate if one can guide me based on what reference and How should I treat and implement control association state for MG/MGC ?
	Best,
	Araz.