Subject: [Megaco] Play tone and signal on inactive terminations?

From: "Suchi Sahoo (suchis)" <[email-masked]>
Date: Fri, 28 Mar 2008 09:30:49 -0700

Hi,
  I want to know if we can play tone or signal on a termination which is
in INACTIVE mode. Let's say initially the physical terminations are in
NULL context. That time the default mode is INACTIVE. Can we play dial
tone when the mode of the physical termination is INACTIVE? 
 
If a termination is in SEND_RECV mode and we subtract that termination,
what will be the new mode of this termination in NULL context after it
is subtracted by gateway? Will it be INACTIVE or SEND_RECV? 
 
Thanks,
Suchi

_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 28 Mar 2008 13:05:02 -0400

Per H.248.1, the Mode Property does not affect Signals.  See clause
7.1.11.
 
Per H.248.1, Properties are returned to their default value upon
Subtract, unless overridden by provisioning.  If overridden, they return
to their provisioned value.  See clause 7.2.3.  For the Mode Property,
the default is "Inactive".  See clause 7.1.7.1.1.
 
Kevin

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Suchi Sahoo (suchis)
Sent: Friday, March 28, 2008 12:31 PM
To: [email-masked]
Subject: [Megaco] Play tone and signal on inactive terminations?

Hi,

Thanks,
Suchi

---

From: "Suchi Sahoo (suchis)" <[email-masked]>
Date: Fri, 28 Mar 2008 11:06:58 -0700

Is it applicable to ephemeral termination also?

From: Kevin Boyle [mailto:[email-masked]] 
Sent: Friday, March 28, 2008 12:05 PM
To: Suchi Sahoo (suchis); [email-masked]
Subject: RE: [Megaco] Play tone and signal on inactive terminations?

 
Kevin

Hi,

Thanks,
Suchi

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 28 Mar 2008 14:18:43 -0400

Terminations behave the same in terms of protocol constructs regardless
of their type, excepting their existence outside of a named Context.  In
terms of Subtract behavior, ephemerals cease to exist upon Subtract, so
the values of Properties are irrelevant after Subtract.  See clause 6.2.
 
Kevin

From: Suchi Sahoo (suchis) [mailto:[email-masked]] 
Sent: Friday, March 28, 2008 2:07 PM
To: Boyle, Kevin (NCRTP:0Q10); [email-masked]
Subject: RE: [Megaco] Play tone and signal on inactive terminations?

 
 
Kevin

Hi,

Thanks,
Suchi

---

From: "John Wainwright" <[email-masked]>
Date: Mon, 31 Mar 2008 09:00:37 -0500

Can I just clarify the expected response form the following command

{C=-{AV=ROOT{AT{PG}}}}

Should this response return a list of all the packages supported by this
particular MG, appropriately formatted of course ?

Would it be different if instead of ROOT it was a PHY or EPH termination
specified?

Regards

John

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 31 Mar 2008 12:03:18 -0400

Yes, this request elicits the union of packages realized across all
terminations (including Root) on the MG.
 
The reply would be different if a particular non-Root termination were
specified -- the reply would contain the list of packages realized by
that particular termination.
 
Kevin

From: [email-masked] [mailto:[email-masked]] On Behalf
Of John Wainwright
Sent: Monday, March 31, 2008 10:01 AM
To: [email-masked]
Subject: [Megaco] Auditvalue on ROOT

{C=-{AV=ROOT{AT{PG}}}}

Regards

John