Subject: [Megaco] <No Subject>

From: Ramesh Babu Kuppili <[email-masked]>
Date: Tue, 06 May 2008 16:17:43 +0530

H.248 Gurus,
Some Megaco switches sends AuditCapability request for all terms in NULL context and is not requesting for wildcarded response as part of the request. The question is how should the gateway respond if the response for such a request exceeds the MTU size (lets say the gateway is configured with a large number of subscribers).

- ramesh

_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco

---

From: "Raphael Tryster" <[email-masked]>
Date: Tue, 6 May 2008 14:00:14 +0300

The gateway should send as many command replies as it can for individual
terminations, and end the action reply with error 533.
 
If anyone else wishes to comment, please reply to this posting rather
than to the original question, so it will have a meaningful subject
line.
 
Raphael Tryster

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Ramesh Babu Kuppili
Sent: Tuesday, May 06, 2008 1:48 PM
To: [email-masked]
Cc: sramanathan
Subject: [Megaco] <No Subject>

H.248 Gurus,
Some Megaco switches sends AuditCapability request for all terms in NULL
context and is not requesting for wildcarded response as part of the
request. The question is how should the gateway respond if the response
for such a request exceeds the MTU size (lets say the gateway is
configured with a large number of subscribers).

- ramesh

**********************************************************************************************
IMPORTANT: The contents of this email and any attachments are confidential. They are intended for the 
named recipient(s) only.
If you have received this email in error, please notify the system manager or the sender immediately and do 
not disclose the contents to anyone or make copies thereof.
*** eSafe scanned this email for viruses, vandals, and malicious content. ***
**********************************************************************************************

---

From: Sachin <[email-masked]>
Date: Tue, 6 May 2008 17:51:12 +0530

Hi Raphael,

What is the maximum MTU size the gateway supports?. If the gateway is
sending the reply which exceeds the MTU size of the gateway controller and
it parses only a portion of the message and discards the rest. What should
be the handling at gateway controller for these scenario.

Thanks
Sachin

On 5/6/08, Raphael Tryster <[email-masked]> wrote:
> If anyone else wishes to comment, please reply to this posting rather than
> to the original question, so it will have a meaningful subject line.
>
> Raphael Tryster
>
>  ------------------------------
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Ramesh Babu Kuppili
> *Sent:* Tuesday, May 06, 2008 1:48 PM
> *To:* [email-masked]
> *Cc:* sramanathan
> *Subject:* [Megaco] <No Subject>
>
>
>  H.248 Gurus,
>
> for such a request exceeds the MTU size (lets say the gateway is configured
> with a large number of subscribers).
>
> - ramesh
> ------------------------------
> *IMPORTANT: The contents of this email and any attachments are
> confidential. They are intended for the named recipient(s) only.
> If you have received this email in error, please notify the system manager
> or the sender immediately and do not disclose the contents to anyone or make
> copies thereof.
> ***** eSafe scanned this email for viruses, vandals, and malicious
> content. ****
> ------------------------------
>

---

From: "Schwarz Albrecht" <[email-masked]>
Date: Tue, 6 May 2008 14:47:39 +0200

Sachin,
 
>What is the maximum MTU size the gateway supports?. 
 
this is the wrong way in trying to solve the underlying problem ("using
a non-segmenting transport technology for H.248 Message sizes above the
allowed L4 SDU size") IMO.
 
Parameter MTU is link layer technology specific, there might be multiple
different L2 technologies below the H.248 Control Association (CA).
Even worse: an H.248 entity may be realized as multihomed IP host (see
also H.Sup7) for a single H.248 application, different H.248-over-IP
packets (of the same CA) could then use different IP routes and thus IP
interfaces of the H.248 MG (or MGC). And each IP interface could use a
different L2 technology (e.g. Ethernet, 802.3, ATM) with a different
max. MTU size.
 
I do thus agree to Raphael in notifying such a situation just by an
error code.
 
The problem itself should be solved by e.g. either
a) using a segmenting transport technology (e.g. SCTP => H.248.4)
b) using the H.248 segmentation package in case of non-segmenting
transport technologies or
c) limiting wildcarding options for particular commands by H.248 profile
specifications.
 
BR, Albrecht

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Sachin
	Sent: Dienstag, 6. Mai 2008 14:21
	To: Raphael Tryster
	Cc: [email-masked]
	Subject: Re: [Megaco] AuditCapability reply exceeds MTU size

	Hi Raphael,
	 
	What is the maximum MTU size the gateway supports?. If the
gateway is sending the reply which exceeds the MTU size of the gateway
controller and it parses only a portion of the message and discards the
rest. What should be the handling at gateway controller for these
scenario.
	 
	Thanks
	Sachin

	On 5/6/08, Raphael Tryster
<[email-masked]> wrote: 

		The gateway should send as many command replies as it
can for individual terminations, and end the action reply with error
533.
		 
		If anyone else wishes to comment, please reply to this
posting rather than to the original question, so it will have a
meaningful subject line.
		 
		Raphael Tryster

		From: [email-masked]
[mailto:[email-masked]] On Behalf Of Ramesh Babu Kuppili
		Sent: Tuesday, May 06, 2008 1:48 PM
		To: [email-masked]
		Cc: sramanathan
		Subject: [Megaco] <No Subject>

		H.248 Gurus,
		Some Megaco switches sends AuditCapability request for
all terms in NULL context and is not requesting for wildcarded response
as part of the request. The question is how should the gateway respond
if the response for such a request exceeds the MTU size (lets say the
gateway is configured with a large number of subscribers).

		- ramesh

		IMPORTANT: The contents of this email and any
attachments are confidential. They are intended for the named
recipient(s) only.
		If you have received this email in error, please notify
the system manager or the sender immediately and do not disclose the
contents to anyone or make copies thereof.
		*** eSafe scanned this email for viruses, vandals, and
malicious content. *** 
________________________________

---

From: "Agonias, Richard L. (Digitel-GSM)" <[email-masked]>
Date: Thu, 8 May 2008 08:39:17 +0800

Hi Guys,

	We're on the process of evaluating now the difference between
MSC Pooling and Dual Homing technology. Does any one here already deploy
such technology in the network? 

	Do we have some standards for these techs already?

	Thanks!

	daywalker