Subject: [Megaco] KeepActive flag in signal

From: "Chen, Hao SNLB PEK" <[email-masked]>
Date: Thu, 8 May 2008 11:36:09 +0800

Hello all, 
 
In H.248.1 it is said  that
"A new Signals Descriptor replaces any existing Signals Descriptor. Any
signals applied to the termination not in the replacement descriptor
shall be stopped, and new signals are applied, except as follows.
Signals present in the replacement descriptor and containing the
KeepActive flag shall be continued if they are currently playing and
have not already completed. If a replacement Signals Descriptor contains
a signal that is not currently playing and contains the KeepActive flag,
that signal shall be ignored."
 
In my understanding to this statement , if a signal with keepactive flag
is not been played currently, it should be ignored. On the other hand
if it is been played now ,the play should not be interrupted ,which
means the new same signal is also not applied now. 
 
My question is  "Should the new signal be played after the old one is
finished ?"   If the answer is NO, then the signal with keepactive flag
will not make any sense because  it is always useless. 

Thank you very much !

Best regards,

Chen Hao

NSN R&D BBA

Tel: +86 10 58421052

Email: [email-masked] <mailto:[email-masked]> 

IMPORTANT NOTE: This e-mail and any attachment are confidential and may contain trade secrets and may also be legally privileged or otherwise protected from disclosure. If you have received it in error, you are herewith informed about its status. Please notify us immediately by reply e-mail and then delete this e-mail and any attachment from your system. You are prohibited from making use of or copying this e-mail or any attachment or disclosing the contents to any other person.

<Disclaimer in Chinese below, characters may not be displayed correctly.>

????:???????????,???????????????????????????,????????????,?????????????????????????????????????,???????????????????????????

_______________________________________________
Megaco mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/megaco

---

From: "Maridi R. Makaraju \(Raju\)" <[email-masked]>
Date: Thu, 8 May 2008 15:52:38 -0500

Chen,
 
The signals with KeepActive continue to play while the new signals are being applied (simultaneously).
Please note that multiple signals can be played simultaneously on a termination. This is rarely needed
(as opposed to sequential signal list) and protocol supports it.
One such case I can think of is, an analog line getting (constantly active, i.e. KeepActive) a normal/reverse Plarity 
Signal while ringing or ringback (or any call progress tone) signal is applied to that termination.
 
- Raju

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of Chen, Hao SNLB PEK
Sent: Wednesday, May 07, 2008 10:36 PM
To: [email-masked]
Cc: Li, Ling Juan SLC Com PEK
Subject: [Megaco] KeepActive flag in signal

Hello all, 
 
In H.248.1 it is said  that
"A new Signals Descriptor replaces any existing Signals Descriptor. Any signals applied to the termination not in the replacement
descriptor shall be stopped, and new signals are applied, except as follows. Signals present in the replacement descriptor and
containing the KeepActive flag shall be continued if they are currently playing and have not already completed. If a replacement
Signals Descriptor contains a signal that is not currently playing and contains the KeepActive flag, that signal shall be ignored."
 
In my understanding to this statement , if a signal with keepactive flag is not been played currently, it should be ignored. On the
other hand  if it is been played now ,the play should not be interrupted ,which means the new same signal is also not applied now. 
 
My question is  "Should the new signal be played after the old one is finished ?"   If the answer is NO, then the signal with
keepactive flag will not make any sense because  it is always useless. 

Thank you very much !

Best regards,

Chen Hao

NSN R&D BBA

Tel: +86 10 58421052

Email: chen.hc <mailto:[email-masked]> @siemens.com

IMPORTANT NOTE: This e-mail and any attachment are confidential and may contain trade secrets and may also be legally privileged or
otherwise protected from disclosure. If you have received it in error, you are herewith informed about its status. Please notify us
immediately by reply e-mail and then delete this e-mail and any attachment from your system. You are prohibited from making use of
or copying this e-mail or any attachment or disclosing the contents to any other person.

< Disclaimer in Chinese below, characters may not be displayed correctly.>