Subject: [Megaco] Local and Remote Descriptor IP type

From: Abhijit Dutta <[email-masked]>
Date: Thu, 23 Feb 2012 00:38:19 +0530

Hi,

Sorry for this naïve question -  I am posting it since there is no clear indication in the RFC.

Can local and remote descriptor contain differ IP address types -  one say IPv4 and another IPv6. If not, what should the MGC return (error code) in reply during such situations.

~Thanx
Abhijit

---

From: Deepak Bissa <[email-masked]>
Date: Fri, 24 Feb 2012 09:19:29 +0530

Hi,
Megaco protocol does not impose such restrictions on SDP internals and it is possible to have such situation.
MGCs "might not" look into these details and just tunnel it to respective MGs and then MG has to apply or reject such media connection.

H.248.8 provides list of error codes that can be exchanged between MG and MGC.  "Not Implemented" could be one of the candidate.

Regards,
Deepak Bissa

From: [email-masked] [mailto:[email-masked]] On Behalf Of Abhijit Dutta
Sent: Thursday, February 23, 2012 12:38 AM
To: [email-masked]
Subject: [Megaco] Local and Remote Descriptor IP type

Hi,

~Thanx
Abhijit

===============================================================================
Please refer to http://www.aricent.com/legal/email_disclaimer.html
for important disclosures regarding this electronic communication.
===============================================================================

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Fri, 24 Feb 2012 09:47:05 +0100

Abhijit,

1st: there isn't any RFC, you got to use the ITU-T H.248.x-series of Recommendations concerning MEGACO protocol.

2nd: the H.248 stream is fundamentally a bidirectional construct, i.e., covering two unidirectional media (or control) flows.
However, each traffic direction may be different than the reverse direction, sometimes called asymmetrical media (flows).

Thus, it's definetely not a failure situation per se your use case. You may use different IP protocol versions for each traffic direction!
You may also use different media formats (e.g. different video or audio codecs) for each traffic direction. Etc.

-Albrecht

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Deepak Bissa
Sent: Freitag, 24. Februar 2012 04:49
To: Abhijit Dutta; [email-masked]
Subject: Re: [Megaco] Local and Remote Descriptor IP type

Hi,

Regards,
Deepak Bissa

Hi,

~Thanx
Abhijit