Subject: [Megaco] Response to tonegen request

From: Abhijit Dutta <[email-masked]>
Date: Wed, 30 May 2012 07:36:15 +0000

Hi All,

As per specs: (H248v2) section E.3

"Tonegen package is designed to be extended ONLY.  Also it mentions that no tone ids are defined/specified in the package.
 It is the responsibility of the packages derived from it to add possible values...."

Please verify the understanding based on the above statement
------------------------------------------------------------------------------

1.       MGC cannot  send tongen/pt to MG since,  since it needs to define the tone(s) in the request ( which will contradict the spec).

2.       So if assumption (1) is correct, then in case MG receives such request it will return an error response back.

3.       If assumption (1) is incorrect in which cases MGC can send tonegen request and with what kind of tone ids in the list?

~Thanx
Abhijit

---

From: Tom Taylor <[email-masked]>
Date: Wed, 30 May 2012 13:07:54 -0400

I'd say your alternative 1 is correct. Assuming the tone you wanted was 
defined in package Xtonegen, extending tonegen, you would have to send 
Xtonegen/pt <tone>.

On 30/05/2012 3:36 AM, Abhijit Dutta wrote:
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/megaco