Subject: [Megaco] [H.248.39] Advanced SDP Wildcarding Package - Recursiveness vs multiplicity

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Thu, 6 Mar 2014 09:01:32 +0000

Hello Christian, Tommy,
thanks for the package proposal, a good solution for the related problem in our opinion.

One pre-meeting comment concerning terminology, because possibly caused by us. We were also struggling (when working on AVD-4504) with the editor's note concerning "recursion", but couldn't remember a real example.

If we consider a single SDP line, then recursion would be a structure like "X = Y ... X ...", right?
However, such SDP line grammar is not possible.

If we consider line interlinkage, then a circular definition could be e.g.
X = Y ...
Y = X ...
But again, such SDP line grammars are not possible.

Thus, perhaps we should term the "$R" wildcard as "multiplicity wildcard" or sth similar, but not "recursive wildcard".
Or "cardinality wildcard" ... hm?

What do you think?
Albrecht

Ref.:
AVD-4538 H.248.39 Updates: Additional wildcarding
AVD-4504 H.248.39 (Rev.): Wildcard "~" -  Continuation of discussion

---

From: Christian Groves <[email-masked]>
Date: Thu, 06 Mar 2014 23:59:31 +1100

Hello Albrecht,

OK I see your point, the usage of "recursion" doesn't meet 
mathematical/logic definition. I'm OK to rename it. Maybe the "multiple 
value response" wildcard?

With regards to AVD-4504 I think i'd be happier adding "~" if we also 
tied that capability to a package.

Regards, Christian

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Thu, 6 Mar 2014 13:04:29 +0000

Hello Christian,

> With regards to AVD-4504 I think i'd be happier adding "~" if we also tied that capability to a package.

We had the same idea. 
The "~" as advanced wildcarding capability would definetely match the scope of an "advanced SDP wildcarding package".

BR,
Albrecht

-----Original Message-----
From: Christian Groves [mailto:[email-masked]] 
Sent: Donnerstag, 6. März 2014 14:00
To: Schwarz, Albrecht (Albrecht); Tommy Young
Cc: [email-masked]
Subject: Re: [H.248.39] Advanced SDP Wildcarding Package - Recursiveness vs multiplicity

Hello Albrecht,

OK I see your point, the usage of "recursion" doesn't meet mathematical/logic definition. I'm OK to rename it. Maybe the "multiple value response" wildcard?

With regards to AVD-4504 I think i'd be happier adding "~" if we also tied that capability to a package.

Regards, Christian