Subject: Re: [Mentoring-coordinators] Mentoring Feedback IETF 94 and Plans for Buenos Aires

From: John C Klensin <[email-masked]>
Date: Sat, 05 Mar 2016 01:44:09 -0500

(IETF list note copied)

Nalini, 

A few very late observations and questions...

--On Friday, February 05, 2016 15:44 +0000
[email-masked] wrote:

> First, let me thank the wonderful mentors who kindly and
> generously gave of their time and effort to make the mentees
> feel welcome.  Without everyone's support, we would not have
> a mentoring program.
> 
> If you would like to sign up to mentor for IETF95 in Buenos
> Aires, please do so here!  We need you!  (In particular for
> Speed Mentoring.)   
>
> 
Sign up is here: https://www.surveymonkey.com/r/XPJ3LRK 

I'm assuming from your other comments that you are not
particularly interested in signups for remote mentors, but I've
available should a mentee show up for whom I'm relevant.

> What did not work
> ------------------------
>...
> Remote mentoring is where the mentee is not physically
> present.  The problem with this is that out of 8 potential
> remote mentees only 2 responded to an initial email asking
> them of their interests.  Those 2 we matched but we felt that
> if the individual could not even respond to an email asking
> them questions, then how interested and committed are they?

"Lurk first" or even "my boss or colleague told me that looking
in remotely would be educational or a good idea" are legitimate
reasons for remote participation (of a sort) and may not require
a mentor-style relationship.   I wish it were otherwise, but,
except for old IETF hands who are participating remotely rather
than traveling, actually participating (rather than just
watching and listening) is hard and requires a _lot_ of
determination.   I think you should be surprised and pleased
that you got two, rather than disappointed and that the
underlying problems are not ones the mentoring project can
solve.   On the other hand, if the IETF were to change the rules
so that pre-registration of remote people (or at least those
intending to do more than lurk) was expected, you would have
more of a platform to stand on... but the mentoring program is
probably not the right place to discuss that issue either.

> We understand that remote mentoring needs to happen and will
> think about how this can be done better.

Perhaps the above is helpful.

> 2. Crisis Mentors: some mentees wanted to have mentors
> available who would be available to go for a cup of coffee (or
> whatever) and support when their presentation was torn to
> shreds in a WG.  It happens.  It has happened to me.  It is
> nice to have someone to say "Hang in there.  Try again. 
> This is how you might do better next time."
> 
> Some have asked if this is not the job of the mentor to do
> this.  I think that is great for the mentor to do it but it
> is nice to have some other perspectives also.  The mentoring
> team will also provide support in these cases.

I'd suggest a different answer: Someone has to authorize any
such presentation.  We usually call them "WG Chairs" or "ADs".
If a presenter (experienced, new, of otherwise) gives a
presentation, gets beaten up, and is surprised by it, that is
the fault of whomever authorized the presentation without
providing adequate explanation and support for the presenter.
If it happens, the authorizer (WG Chair or otherwise) should be
the person the presenter goes to, both for support and as an
accountability mechanism.    More to the point --because
preparation is better than help with recovery post-beating -- it
would probably be useful to make mentoring arrangements
available to/for first-time presenters -- arrangements closely
tied to what to expect and how to be effective-- and to make
sure that authorizers are aware of such arrangements and either
suggest or require their use by first-time presenters.    A bit
more effort along those lines might not only result in fewer
nasty surprises but might lead to more efficient and productive
presentations (and hence better use of meeting time).

best,
    john

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 6 Mar 2016 06:24:10 +0000

Hi,

About crisis mentoring - I believe that John raises a good point here. Helping first-timers or first-time-presenters prepare for their premiere is very important. This starts with requesting the presentation slot, building expectations about what can be achieved, preparing for hard questions, managing the floor, processing the feedback. Yet, I find value in the idea of crisis mentors, things can go wrong for many reasons, and even when they apparently go reasonably well there is a need to translate results or silence. WG chairs should certainly be partners, but they may be very busy, they do not / cannot know all the new participants, so I would not rely exclusively in them, but rather try to help from the mentoring team the communication with them. 

Regards,

Dan

> -----Original Message-----
> From: mentoring-coordinators [mailto:mentoring-coordinators-
> [email-masked]] On Behalf Of John C Klensin
> 
> > 2. Crisis Mentors: some mentees wanted to have mentors available who
> > would be available to go for a cup of coffee (or
> > whatever) and support when their presentation was torn to shreds in a
> > WG.  It happens.  It has happened to me.  It is nice to have someone
> > to say "Hang in there.  Try again.
> > Some have asked if this is not the job of the mentor to do this.  I
> > think that is great for the mentor to do it but it is nice to have
> > some other perspectives also.  The mentoring team will also provide
> > support in these cases.
> 
> I'd suggest a different answer: Someone has to authorize any such
> presentation.  We usually call them "WG Chairs" or "ADs".
> If a presenter (experienced, new, of otherwise) gives a presentation, gets
> beaten up, and is surprised by it, that is the fault of whomever authorized
> the presentation without providing adequate explanation and support for
> the presenter.
> If it happens, the authorizer (WG Chair or otherwise) should be the person
> the presenter goes to, both for support and as an
> preparation is better than help with recovery post-beating -- it would
> probably be useful to make mentoring arrangements available to/for first-
> time presenters -- arrangements closely tied to what to expect and how to
> be effective-- and to make sure that authorizers are aware of such
> arrangements and either
> more effort along those lines might not only result in fewer nasty surprises
> but might lead to more efficient and productive presentations (and hence
> better use of meeting time).
>

---

From: <[email-masked]>
Date: Sun, 6 Mar 2016 14:10:07 +0000 (UTC)

Very good points, Dan.

John, we are asking the mentees if they have a draft underway.  If they do, then we can ask some mentors to see if they will do a dry-run with them.   I think this will be helpful.

Actually, assistance with the process of preparing and presenting a draft by a newcomer should start well before they arrive at the meeting.

I think will talk with ADs & chairs to see if they want to suggest to newcomers doing presentations that they work with the mentoring team to get help BEFORE they arrive at the meeting.
 Thanks,

Nalini Elkins
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

----- Original Message -----
From: "Romascanu, Dan (Dan)" <[email-masked]>
To: John C Klensin <[email-masked]>; "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Sent: Sunday, March 6, 2016 1:24 AM
Subject: RE: [Mentoring-coordinators] Mentoring Feedback IETF 94 and Plans for Buenos Aires

Hi,

Regards,

Dan

---

From: John C Klensin <[email-masked]>
Date: Sun, 06 Mar 2016 09:44:41 -0500

--On Sunday, March 06, 2016 14:10 +0000
[email-masked] wrote:

> Very good points, Dan.
> 
> John, we are asking the mentees if they have a draft underway.
> If they do, then we can ask some mentors to see if they will
> do a dry-run with them.   I think this will be helpful.
> 
> Actually, assistance with the process of preparing and
> presenting a draft by a newcomer should start well before they
> arrive at the meeting.

Indeed.  That probably starts with being sure the drafts are
coherent and comprehensible enough that the "presentation" can
be little more than a quick review and opportunity for
discussion rather than either trying to introduce new ideas,
reading or showing the draft or sections of it, etc., none of
which, as you know, work well in the IETF (and that can be one
of the sources of beating-up).

For obvious reasons, some of us may also be able to provide
extra help about the things that make presentations more
effective and understandable to people who are _not_ in the room.

> I think will talk with ADs & chairs to see if they want to
> suggest to newcomers doing presentations that they work with
> the mentoring team to get help BEFORE they arrive at the
> meeting.

Good.  Given that the EDU team has tried to give presentations
on presentation skills, I hope the two teams can be coordinated
and mutually supportive about this.

    john

---

From: John C Klensin <[email-masked]>
Date: Sun, 06 Mar 2016 10:13:49 -0500

--On Sunday, March 06, 2016 06:24 +0000 "Romascanu, Dan (Dan)"
<[email-masked]> wrote:

> Hi,
> 
> About crisis mentoring - I believe that John raises a good
> point here. Helping first-timers or first-time-presenters
> prepare for their premiere is very important. This starts with
> requesting the presentation slot, building expectations about
> what can be achieved, preparing for hard questions, managing
> the floor, processing the feedback. Yet, I find value in the
> idea of crisis mentors, things can go wrong for many reasons,
> and even when they apparently go reasonably well there is a
> need to translate results or silence. WG chairs should
> certainly be partners, but they may be very busy, they do not
> / cannot know all the new participants, so I would not rely
> exclusively in them, but rather try to help from the mentoring
> team the communication with them. 

Dan, I agree with you but, at the same time, there is an
important balance.  I think it is important --for the IETF as
well as the newcomer-- that those who authorize presentations
take significant responsibility ("busy" is not enough of an
excuse).  More important, I think that, if there is an issue
with something the WG authorized (by allowing the presentation
in the first place), the newcomer should feel able to approach
the WG Chair and that the WG Chair had better figure out how to
be available.  I have no problem at all with mentors backing
that process up, or even going to the WG Chair together with the
newcomer and providing introductions (and even cultural
translation if needed). Probably all of them are good ideas as
long as we are very careful that newcomers don't get the idea
that they need intermediaries.    One of the important lessons
about the IETF is that WG Chairs and ADs are supposed to be
approachable.  If we let a newcomer develop the impression that
WG Chairs or ADs are too high-level and lofty to be approached
by newcomers, we do far more damage than any amount of mentoring
can possibly undo.

To be clear, IMO, if any member of the "IETF Leadership"
(including WG Chairs) ever takes a position that a reasonable
person would construe as "I am too important to listen to you or
your concerns" he or she should be promptly removed, recalled,
or publicly flogged.  We just can't have that.  If a WG Chair is
too busy to respond, then it may be that an important function
for the mentor is to help the newcomer find the relevant AD and
help explain that the AD has a problem in the form of that WG
Chair and is expected to solve it.

Yeah, I feel strongly about this :-(

    john

---

From: <[email-masked]>
Date: Sun, 6 Mar 2016 15:38:10 +0000 (UTC)

John,

Speaking from personal experience, sometimes there can be communication problems with WG chairs, ADs, and even chairs!  

Also, the new person may not understand what WG they belong in.   In some ways, it takes a village!
 Thanks,

Nalini Elkins
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

----- Original Message -----
From: John C Klensin <[email-masked]>
To: "Romascanu, Dan (Dan)" <[email-masked]>; [email-masked]
Cc: [email-masked]
Sent: Sunday, March 6, 2016 10:13 AM
Subject: Re: [Mentoring-coordinators] Mentoring Feedback IETF 94 and Plans for Buenos Aires

    john

_______________________________________________
mentoring-coordinators mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mentoring-coordinators

---

From: John C Klensin <[email-masked]>
Date: Sun, 06 Mar 2016 12:24:34 -0500

--On Sunday, March 06, 2016 15:38 +0000
[email-masked] wrote:

> Speaking from personal experience, sometimes there can be
> communication problems with WG chairs, ADs, and even chairs! 

Yes, absolutely.  My only point was that I don't want the
mentoring process to hide those problems or encourage them by
providing "good enough" workarounds, much less encourage
newcomers to believe they don't have a right to such
communication.
 
> in.   In some ways, it takes a village!

True... but I was focusing on the specific issue of someone who
has been authorized to give a presentation and is either setting
it up, giving it, or having problems during or after it.
Someone who can't figure out what WG they belong in is either
not giving presentations there or there is a problem in which
the WG Chair(s) can't figure that out either.

    best,
    john

---

From: <[email-masked]>
Date: Sun, 6 Mar 2016 23:09:49 +0000 (UTC)

>the WG Chair(s) can't figure that out either.

John, a few things:

1.  Some WG chairs have more patience / nurturing / emotional skills than others.   WG chairs and ADs, as all others in the world, are only human.  Some are incredibly wonderful; others are arrogant and full of themselves.   This is life.

2.  There can also be personality differences between people.   Many of us have quite strong personalities.  Some of us are not to each other's taste.  When one is a bit more mature, you can work with others & respect their work but not necessarily want to go out to a bar with them.  This is fine.

Others who are less mature (or insecure), whatever their chronological age, may be less than helpful to others who are on a "different wave length".

3.  Quite a few mentees can be "high maintenance" and absorb a fair chunk of time.  Again, comes with the territory of the kind of person who is a potential high-value contributor to IETF.  I have 3 or 4 that I continue to correspond with from Yokohama.  One is trying to plan a BOF & is asking for time in a WG for 2 drafts.  Wonderful.  But, it takes time to answer their questions, guide them, etc.

If a number of us share the load of these people, it will make it easier for all.

4.  Mentoring is a Work-In-Progress.   We are feeling our way.  I really appreciate your thoughtful comments.   I want to fill the holes left in support for newcomers, probably unintentionally.  I would rather have them turn to us than have no one.  Then, we can figure out if there is a different system that needs to be worked out.  I think it is fine if new people see the mentoring team as a safety net.  In fact, I would be very happy & proud if they did.   
 Thanks,

Nalini Elkins
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

----- Original Message -----
From: John C Klensin <[email-masked]>
To: [email-masked]; "Romascanu, Dan (Dan)" <[email-masked]>
Cc: [email-masked]
Sent: Sunday, March 6, 2016 9:24 AM
Subject: Re: [Mentoring-coordinators] Mentoring Feedback IETF 94 and Plans for Buenos Aires

    best,

    john