Subject: [MEXT] Questions on draft-ietf-mext-binary-ts & draft-ietf-mext-flow-binding

From: <[email-masked]>
Date: Tue, 6 Apr 2010 17:36:05 +0100

Hi

1. If I get it right, a traffic selector is used by the MN to tell the
Home Agent or Correspondent Node (or mobility anchor in Hierarchical ),
"if you see a pkt that matches this traffic selector, then forward(*) it
to this one of the CoAs"

The traffic selector can include a list of (say) source addresses, which
(I think) means, "if a pkt matches *any* of these source addresses, then
forward it to this one of the CoAs"

However, the list of source addresses is of uncertain length (the
'start' and 'end' feature), similarly for the lists of destination
addresses, ports, protocol numbers, SPIs, Diffserv codepoints. So how
does the home agent know whether an address is the last of the source
addresses or the first of the destination addresses? Or whether it's a
source port or destination port? 

2. (*) draft-ietf-mext-flow-binding only allows forwarding (S4.2,
'Action'). This seems to rule out that case where the MN wants to tell
the HA to tunnel pkts to a mobility anchor [for HMIP]?

3. draft-ietf-mext-flow-binding doesn't mention Proxy mobile IP
[rfc5213] and implies /says that the flow binding comes from a MN or
mobile router. I guess this means it can't come from a MAG (=PMIP's node
that acts on behalf of the MN). Does this mean that flow bindings and
PMIP are mutually exclusive? In fact, are PMIP and rfc5648 (multiple CoA
registrations) mutually exclusive? If yes - why?

Thanks
Best wishes,
Philip Eardley.

---

From: "Laganier, Julien" <[email-masked]>
Date: Tue, 6 Apr 2010 11:29:25 -0700

Hi Phil,

Some answers below:

[email-masked] wrote:
>
> Hi
>  
> 1. If I get it right, a traffic selector is used by the MN to tell the Home Agent or Correspondent Node (or mobility anchor in Hierarchical ), "if you see a pkt that matches this traffic selector, then forward(*) it to this one of the CoAs"
>
> The traffic selector can include a list of (say) source addresses, which (I think) means, "if a pkt matches *any* of these source addresses, then forward it to this one of the CoAs"
>
> However, the list of source addresses is of uncertain length (the 'start' and 'end' feature), similarly for the lists of destination addresses, ports, protocol numbers, SPIs, Diffserv codepoints. So how does the home agent know whether an address is the last of the source addresses or the first of the destination addresses? Or whether it's a source port or destination port? 

It is not a list of addresses but a range of addresses. The ranges spans the interval between the start address and the end address, e.g., 192.168.1.50-192.168.1.99

Same goes with port numbers.

> 2. (*) draft-ietf-mext-flow-binding only allows forwarding (S4.2, 'Action'). This seems to rule out that case where the MN wants to tell the HA to tunnel pkts to a mobility anchor [for HMIP]?

>From the HA perspective, the HMIP RCoA appears as a CoA, thus the effect you're describing is achieved by putting a "forward" rule towards the RCoA, that will cause packets to be tunneled to the MAP.

> 3. draft-ietf-mext-flow-binding doesn't mention Proxy mobile IP [rfc5213] and implies /says that the flow binding comes from a MN or mobile router. I guess this means it can't come from a MAG (=PMIP's node that acts on behalf of the MN). Does this mean that flow bindings and PMIP are mutually exclusive? In fact, are PMIP and rfc5648 (multiple CoA registrations) mutually exclusive? If yes - why?

Proxy Mobile IP does not support (yet) simultaneous multi-access so this document does not apply to Proxy Mobile IP. The netext WG has just been re-chartered to work on that space.

--julien