Subject: [MEXT] draft-ietf-mext-rfc3775bis-05

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 19 May 2010 10:01:31 -0700 (PDT)

Hi Charlie,
  In Sec. 10.4.5, it says 
the home agent MUST verify that the Source
      Address in the tunnel IP header is the mobile node's primary
      care-of address.

I think the above text contradicts Sec. 11.3.1 which says home address must be used.

Can you shed some light into this?

Thx.

Behcet

---

From: [email-masked] (Arnaud Ebalard)
Date: Wed, 19 May 2010 21:09:38 +0200

Hi,

Behcet Sarikaya <[email-masked]> writes:

> Hi Charlie,
>  In Sec. 10.4.5, it says 
> the home agent MUST verify that the Source Address in the tunnel IP
>  header is the mobile node's primary care-of address.
>

In 10.4.5, the HA verifies that the source address in the outer IP
header of the tunnel is the CoA. The HoA is the source address of the
inner packets.

Cheers,

a+