Subject: [MEXT] I-D Action:draft-ietf-mext-rfc3775bis-07.txt

From: [email-masked]
Date: Mon, 4 Oct 2010 16:30:09 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Mobility EXTensions for IPv6 Working Group of the IETF.

	Title           : Mobility Support in IPv6
	Author(s)       : C. Perkins, et al.
	Filename        : draft-ietf-mext-rfc3775bis-07.txt
	Pages           : 175
	Date            : 2010-10-04

This document specifies Mobile IPv6, a protocol which allows nodes to
remain reachable while moving around in the IPv6 Internet.  Each
mobile node is always identified by its home address, regardless of
its current point of attachment to the Internet.  While situated away
from its home, a mobile node is also associated with a care-of
address, which provides information about the mobile node's current
location.  IPv6 packets addressed to a mobile node's home address are
transparently routed to its care-of address.  The protocol enables
IPv6 nodes to cache the binding of a mobile node's home address with
its care-of address, and to then send any packets destined for the
mobile node directly to it at this care-of address.  To support this
operation, Mobile IPv6 defines a new IPv6 protocol and a new
destination option.  All IPv6 nodes, whether mobile or stationary,
can communicate with mobile nodes.  This document obsoletes RFC 3775.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-mext-rfc3775bis-07.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 05 Oct 2010 17:25:20 +0200

Thanks for this new 3775bis.

At some point there was discussion and agreement to refer rfc3963 (aka 
nemov6) in 3775bis...

Alex

Le 05/10/2010 01:30, [email-masked] a écrit :
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 05 Oct 2010 16:01:01 -0700

Hello Alex,

I'm almost out of time before travel.  Could you suggest a
good place for the citation?

Regards,
Charlie P.

On 10/5/2010 8:25 AM, Alexandru Petrescu wrote:
> MEXT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mext
>

---

From: "Laganier, Julien" <[email-masked]>
Date: Tue, 5 Oct 2010 16:47:31 -0700

Alex: 

I do not recall that discussion and agreement, could you please provide us with a pointer to the relevant thread?

--julien

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 06 Oct 2010 14:49:45 +0200

Le 06/10/2010 01:47, Laganier, Julien a écrit :
> Alex:
>
> I do not recall that discussion and agreement, could you please
> provide us with a pointer to the relevant thread?

Right, discussion is at url below.  Now that I see it I realize I may
have appreciated agreement wrongly.  It is half-half agreement.

http://www.ietf.org/mail-archive/web/mext/current/msg03695.html

Alex

>> At some point there was discussion and agreement to refer rfc3963
>> (aka nemov6) in 3775bis...
>>
>> Alex
>>
>>> A New Internet-Draft is available from the on-line
>>> Internet-Drafts
>> directories.
>>> This draft is a work item of the Mobility EXTensions for IPv6
>>> Working
>> Group of the IETF.
>>>
>>>
>>> Title           : Mobility Support in IPv6 Author(s)       : C.
>>> Perkins, et al. Filename        :
>>> draft-ietf-mext-rfc3775bis-07.txt Pages           : 175 Date :
>>> 2010-10-04
>>>
>>> This document specifies Mobile IPv6, a protocol which allows
>>> nodes to remain reachable while moving around in the IPv6
>>> Internet.  Each mobile node is always identified by its home
>>> address, regardless of its current point of attachment to the
>>> Internet.  While situated away from its home, a mobile node is
>>> also associated with a care-of address, which provides
>>> information about the mobile node's current location.  IPv6
>>> packets addressed to a mobile node's home address are
>>> transparently routed to its care-of address.  The protocol
>>> enables IPv6 nodes to cache the binding of a mobile node's home
>>> address with its care-of address, and to then send any packets
>>> destined for the mobile node directly to it at this care-of
>>> address.  To support this operation, Mobile IPv6 defines a new
>>> IPv6 protocol and a new destination option.  All IPv6 nodes,
>>> whether mobile or stationary, can communicate with mobile nodes.
>>>  This document obsoletes RFC 3775.
>>>
Internet-Drafts are also available by anonymous FTP at:
>>> _______________________________________________ I-D-Announce
>>> mailing list [email-masked]
>>> https://www.ietf.org/mailman/listinfo/i-d-announce Internet-Draft
>>> directories: http://www.ietf.org/shadow.html or
>>> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>>
>>
>> _______________________________________________ MEXT mailing list
>> [email-masked] https://www.ietf.org/mailman/listinfo/mext
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 06 Oct 2010 14:53:42 +0200

> good place for the citation?

Hi Charles,

I believe your early suggestion to add it next to the first occurence of 
Mobile Router would be:

Old:
>    o  Mobile routers.

New:
o Mobile Routers: a related document describes extensions to
   Mobile IPv6 for Mobile Routers and Mobile Networks -
   RFC 3963 [RFC3963].

How would this sound?

Alex

---

From: "Laganier, Julien" <[email-masked]>
Date: Wed, 6 Oct 2010 10:11:39 -0700

> http://www.ietf.org/mail-archive/web/mext/current/msg03695.html

I have reviewed this thread and I do not see (rough) consensus to add a reference to NEMO. 

(That's orthogonal, but I also do not see a reasoning why we should have a reference to NEMO. On the other hand I see a valid point that we're not going to reference all extensions to Mobile IPv6, and thus nothing make NEMO special.)

--julien

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 06 Oct 2010 10:16:38 -0700

Hello folks,

I've taken the path of least resistance on this,
and submitted revision ...-08.txt without the
citation for NEMO.  I can very easily make another
revision including the citation if that is needed.

Regards,
Charlie P.

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 06 Oct 2010 20:27:41 +0200

Le 06/10/2010 19:11, Laganier, Julien a écrit :
>>>> At some point there was discussion and agreement to refer
>>>> rfc3963 (aka nemov6) in 3775bis...
>>>
>> Right, discussion is at url below.  Now that I see it I realize I
>> may have appreciated agreement wrongly.  It is half-half
>> agreement.
>>
> (That's orthogonal, but I also do not see a reasoning why we should
> have a reference to NEMO. On the other hand I see a valid point that
>  we're not going to reference all extensions to Mobile IPv6, and thus
>  nothing make NEMO special.)

Are you saying this as Chair?  If yes then the decision is simple, as
you suggest.

On another hand,

What is an MN and does 3775bis support MNs?

An MN by 3775bis-without-3963 is actually a Mobile Host. ("node" is a
"device that implements IP", and "host" is a "any node that is not a
router".  Hence, a Mobile Node which is not a Mobile Router (no 3963) is
actually a Mobile Host.

Should I suggest to change "MN" to "MH" throughout 3775bis (and not
refer to 3963)?

Alex

---

From: "Laganier, Julien" <[email-masked]>
Date: Wed, 6 Oct 2010 11:53:44 -0700

Alexandru Petrescu wrote:
> Sent: Wednesday, October 06, 2010 11:28 AM
> To: Laganier, Julien
> Cc: mext
> Subject: Re: [MEXT] I-D Action:draft-ietf-mext-rfc3775bis-07.txt
> 

Yes.

--julien

---

From: Hesham Soliman <[email-masked]>
Date: Thu, 07 Oct 2010 10:46:57 +1000

On 7/10/10 3:11 AM, "Laganier, Julien" <[email-masked]> wrote:

> (That's orthogonal, but I also do not see a reasoning why we should have a
> reference to NEMO. On the other hand I see a valid point that we're not going
> to reference all extensions to Mobile IPv6, and thus nothing make NEMO
> special.)

=> I agree with not referencing any extensions, including NEMO.

Hesham

---

From: Thierry Ernst <[email-masked]>
Date: Thu, 07 Oct 2010 09:27:33 +0200

Dear all,

I don't know what the discussion was but it would seem a bit logical to 
me that NEMO (RFC 3963) is given as a reference once Mobile Routers are 
mentioned. That is the very least we can do.

Regards,
Thierry.

---

From: <[email-masked]>
Date: Thu, 7 Oct 2010 16:46:36 +0200

> => I agree with not referencing any extensions, including NEMO.

+1 
-Raj

---

From: "Laganier, Julien" <[email-masked]>
Date: Thu, 7 Oct 2010 09:07:44 -0700

> mentioned. That is the very least we can do.

As I said, we are not adding new references to this document at this point. As to the discussion, there was never consensus to reference NEMO in this specification.

--julien

---

From: Thierry Ernst <[email-masked]>
Date: Fri, 08 Oct 2010 13:47:19 +0200

It is written somewhere:

In particular, this protocol does not attempt to solve:

* Mobile routers.

If would make sense to me to indicate to the reader that it is solved in 
RFC 3963. Or, I would provide a reference to the NEMO terminology.

Regards,
Thierry