Subject: [MEXT] Suggestion to 3775bis to add references to MIP6 extensions

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 06 Oct 2010 20:53:42 +0200

I think it makes sense to suggest adding references in 3775bis to
several extensions based on Mobile IPv6 messages:

FMIPv6
HMIPv6
NEMOv6
PMIPv6
other?

Current 3775bis-08 has 44 references.  5 more references is not much.

Why shouldn't these references be added?

(besides:
Normative reference [11] FIPS Secure Has is not used anywhere in 3775bis
- should be removed.
Informative reference [29] BU attacks is an individual draft expired
(updated?)
Informative reference [37] securing RH is also individual and expired
(updated?))

Alex

---

From: "Laganier, Julien" <[email-masked]>
Date: Wed, 6 Oct 2010 11:58:22 -0700

Alex:

> Current 3775bis-08 has 44 references.  5 more references is not much.

How about 10? That's irrelevant as a metric.

> Why shouldn't these references be added?

Because:
- It makes no sense.
- There's no consensus to do so.
- WGLC is finished. (the revisions of 3775bis that are currently made are only those necessary to resolve WGLC comments and pass IDnits checks.)
 
--julien

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 06 Oct 2010 21:28:08 +0200

Le 06/10/2010 20:58, Laganier, Julien a écrit :
>> FMIPv6 HMIPv6 NEMOv6 PMIPv6 other?
>>

If there are 10 such extensions to Mobile IPv6 then all should be
referred and cited.  I don't understand why not.

Maybe only RFCs StdsTrack which are old enough is a better criterion?

> Because: - It makes no sense. - There's no consensus to do so. - WGLC
> is finished. (the revisions of 3775bis that are currently made are
> only those necessary to resolve WGLC comments and pass IDnits
> checks.)

The reference suggestion was made during WGLC.  Now we are past the
WGLC, I agree.

The idnits couldn't capture this suggestion, but as a sidenote it could
capture reference [11] which is not cited.

There is reference [33] bu3way expired - if so then one thinks to
add draft-perkins-bake-01 which did secure RO too.  Idnits couldn't
capture this either.

Alex

---

From: "Laganier, Julien" <[email-masked]>
Date: Wed, 6 Oct 2010 12:30:57 -0700

Alexandru Petrescu wrote:
> referred and cited.  

You're the only one thinking so.

> I don't understand why not.

Because 3775bis is not a catalog of MIPv6 extensions, it is the MIPv6 specification.
 
> The reference suggestion was made during WGLC.  Now we are past the

The reference suggestion did not gather WG consensus.
 
--julien

---

From: Suresh Krishnan <[email-masked]>
Date: Wed, 6 Oct 2010 15:38:40 -0400

I am with Julien here. This is a slippery slope to follow. I am not for 
adding references to extensions in 3775bis.

Cheers
Suresh

On 10-10-06 03:30 PM, Laganier, Julien wrote:
> _______________________________________________
> MEXT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mext

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 06 Oct 2010 22:28:52 +0200

Le 06/10/2010 21:30, Laganier, Julien a écrit :
>>>> I think it makes sense to suggest adding references in 3775bis
>>>>  to several extensions based on Mobile IPv6 messages:
>>>>

Well the MIPv6 specification is wrong, at least with respect to Mobile
Nodes - it claims doing Mobile Nodes whereas what it does is Mobile
Hosts. (any node that is not a router is a host, and 3775 does not do
routers).  (sidenote: PMIPv6 spec clearly states 3775 is hosts only, and
DS-MIPv6 clearly states 3775 _and_ 3963 do "nodes").

The effects of the 3775 spec error (claim "nodes" whereas what it does
is "hosts") can be seen in documents mentioning Mobile IPv6.

Rfc4861 talks Mobile Nodes as MIPv6 only (no 3963).  4861 authors are
under the impression that 3775bis does mobile routers too, which it
actually doesn't.

draft-ietf-6man-node-req-bis-05 (which also claims to not be such a
catalog) cites 3775 as _the_ mobility specification, and says "a node".
  When suggested to add 3963 it was said fine but would 3775 be
sufficient (yes, it would, provided 3775 cites 3963).  Were 3775bis to
say a MR is 3963 then the 6man draft and 4861 would be less wrong with
respect to a "node".

Moreover,

3775-wo-3963 leaves the place to interpretation such that a Mobile
Router does not necessarily implement NEMOv6.

Because the NEMO terminology RFC itself does not state a Mobile Router
runs Mobile IPv6, but "possibly a dynamic routing protocol."  The
Mobility Terminology RFC doesn't say a Mobile Router runs Mobile IPv6
either.

Alex

>>> Because: - It makes no sense. - There's no consensus to do so. -
>>>  WGLC is finished. (the revisions of 3775bis that are currently
>>> made are only those necessary to resolve WGLC comments and pass
>>> IDnits checks.)
>>
>> The reference suggestion was made during WGLC.  Now we are past
>> the WGLC, I agree.
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 06 Oct 2010 22:29:37 +0200

> adding references to extensions in 3775bis.

How about the slippery slope of 4861 claiming 3775 does nodes?

Alex

---

From: "Laganier, Julien" <[email-masked]>
Date: Wed, 6 Oct 2010 14:21:19 -0700

Alex,

As I said, WGLC is finished, and the revisions to 3775bis that are currently made are only those necessary to resolve WGLC comments and pass IDnits checks. We are NOT making further changes.

--julien

> -----Original Message-----
> From: Alexandru Petrescu [mailto:[email-masked]]
> Sent: Wednesday, October 06, 2010 1:29 PM
> To: Laganier, Julien
> Cc: mext
> Subject: Re: [MEXT] Suggestion to 3775bis to add references to MIP6
> extensions
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 06 Oct 2010 23:34:11 +0200

Le 06/10/2010 23:21, Laganier, Julien a écrit :
> Alex,
>
> As I said, WGLC is finished, and the revisions to 3775bis that are
> currently made are only those necessary to resolve WGLC comments and
> pass IDnits checks. We are NOT making further changes.

So are the WGLC comments solved?

Alex

>
> --julien
>
>> -----Original Message----- From: Alexandru Petrescu
>> [mailto:[email-masked]] Sent: Wednesday, October 06,
>> 2010 1:29 PM To: Laganier, Julien Cc: mext Subject: Re: [MEXT]
>> Suggestion to 3775bis to add references to MIP6 extensions
>>
>>>>>> I think it makes sense to suggest adding references in
>>>>>> 3775bis to several extensions based on Mobile IPv6
>>>>>> messages:
>>>>>>
>>>> If there are 10 such extensions to Mobile IPv6 then all should
>>>> be referred and cited.
>>>
>> Well the MIPv6 specification is wrong, at least with respect to
>> Mobile Nodes - it claims doing Mobile Nodes whereas what it does is
>> Mobile Hosts. (any node that is not a router is a host, and 3775
>> does not do routers).  (sidenote: PMIPv6 spec clearly states 3775
>> is hosts only, and DS-MIPv6 clearly states 3775 _and_ 3963 do
>> "nodes").
>>
>> The effects of the 3775 spec error (claim "nodes" whereas what it
>> does is "hosts") can be seen in documents mentioning Mobile IPv6.
>>
>> Rfc4861 talks Mobile Nodes as MIPv6 only (no 3963).  4861 authors
>> are under the impression that 3775bis does mobile routers too,
>> which it actually doesn't.
>>
>> draft-ietf-6man-node-req-bis-05 (which also claims to not be such
>> a catalog) cites 3775 as _the_ mobility specification, and says "a
>> node". When suggested to add 3963 it was said fine but would 3775
>> be sufficient (yes, it would, provided 3775 cites 3963).  Were
>> 3775bis to say a MR is 3963 then the 6man draft and 4861 would be
>> less wrong with respect to a "node".
>>
>> Moreover,
>>
>> Because the NEMO terminology RFC itself does not state a Mobile
>> Router runs Mobile IPv6, but "possibly a dynamic routing protocol."
>> The Mobility Terminology RFC doesn't say a Mobile Router runs
>> Mobile IPv6 either.
>>
>> Alex
>>
>>>
>>>>> Because: - It makes no sense. - There's no consensus to do
>>>>> so. - WGLC is finished. (the revisions of 3775bis that are
>>>>> currently made are only those necessary to resolve WGLC
>>>>> comments and pass IDnits checks.)
>>>>
>>>> The reference suggestion was made during WGLC.  Now we are
>>>> past the WGLC, I agree.
>>>

---

From: "Laganier, Julien" <[email-masked]>
Date: Wed, 6 Oct 2010 14:36:19 -0700

> So are the WGLC comments solved?

All the WGLC comments for which we reached WG consensus on a proposed resolution were resolved as per this WG consensus. We are not making additional changes.

Thank you for the discussion.

--julien

---

From: Gaurav Goswami <[email-masked]>
Date: Wed, 6 Oct 2010 17:38:26 -0400

*ALL,*
**
*I am not the intended recipient for this email.Please DO NOT forward me the
email now on.*
**
*Thanks*
*--*
*Gaurav
*
On Wed, Oct 6, 2010 at 5:34 PM, Alexandru Petrescu <