Subject: [MEXT] draft-ietf-mext-flow-binding -09 vs -10

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 4 Oct 2010 09:31:15 -0700 (PDT)

Dear authors,
  There was an action field in Flow Identification Mobility Option in -09. This 
field has been removed in -10.

Any explanation why? Please indicate if there was a comment for removing it.

Regards,

Behcet

---

From: "Laganier, Julien" <[email-masked]>
Date: Mon, 4 Oct 2010 10:43:32 -0700

There were only two meaningful values for the Action field, forward and discard. Lars Eggert (TSV AD) had a DISCUSS on the basis that the discard action turns MIPv6 into a firewall control protocol, and thus we removed the discard action. With only one Action left, i.e., forward, the Action field lost its meaning and was removed.

--julien

From: [email-masked] [mailto:[email-masked]] On Behalf Of Behcet Sarikaya
Sent: Monday, October 04, 2010 9:31 AM
To: George Tsirtsis; Hesham Soliman; [email-masked]
Cc: Tsirtsis, George
Subject: [MEXT] draft-ietf-mext-flow-binding -09 vs -10

Dear authors,
  There was an action field in Flow Identification Mobility Option in -09. This field has been removed in -10.

Regards,

Behcet

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 4 Oct 2010 11:46:41 -0700 (PDT)

>
>From: "Laganier, Julien" <[email-masked]>
>To: Behcet Sarikaya <[email-masked]>; George Tsirtsis 
><[email-masked]>; Hesham Soliman <[email-masked]>; 
>"[email-masked]" <[email-masked]>
>Cc: "Tsirtsis, George" <[email-masked]>
>Sent: Mon, October 4, 2010 12:43:32 PM
>Subject: RE: [MEXT] draft-ietf-mext-flow-binding -09 vs -10
>
> 
>There were only two meaningful values for the Action field, forward and discard. 
>
>Lars Eggert (TSV AD) had a DISCUSS on the basis that the discard action turns 
>MIPv6 into a firewall control protocol, and thus we removed the discard action. 

>With only one Action left, i.e., forward, the Action field lost its meaning and 

>was removed.

I respectfully disagree.

This field has been there all over. It should be kept possibly with a statement 
other actions TBD.

Regards,

Behcet

> 
>--julien
> 
>From:[email-masked] [mailto:[email-masked]] On Behalf Of Behcet 
>Sarikaya

---

From: George Tsirtsis <[email-masked]>
Date: Mon, 4 Oct 2010 20:06:08 +0100

FWIW, the bits that used to make up the Action field are still there
and still available (i.e.,  reserved for future use).

The WG can at any time turn these back to a Action field, assuming
someone comes up with a valid action. The effort needed to do this is
not a lot more than having to define a new action value had we
retained the Action field in the specification, so in practice there
is no difference and no flexibility/extensibility has been lost.

Having said that, there aren't that many things one can do to a packet
(i.e., possible actions)  and we have considered a number of them, all
of which have been rejected.

George

---

From: "Laganier, Julien" <[email-masked]>
Date: Mon, 4 Oct 2010 12:10:55 -0700

Behcet Sarikaya wrote:
> Laganier, Julien wrote:
> > Lars Eggert (TSV AD) had a DISCUSS on the basis that the discard
> > action turns MIPv6 into a firewall control protocol, and thus we
> > removed the discard action.
> >
> > With only one Action left, i.e., forward, the Action field lost its
> > meaning and was removed.
> 
> I respectfully disagree.
> 
> This field has been there all over. It should be kept possibly with a
> statement other actions TBD.

Having a field which always encode a single value (i.e., forward) is useless. 

If you ever come up with an action that needs to be signaled in the FID option, there are still 8 bits reserved there so you're fine.

--julien