Subject: [MIB-DOCTORS] Unused textual conventions

From: "David Harrington" <[email-masked]>
Date: Wed, 24 Jan 2007 14:07:38 -0500

Hi,

While removing some disputed items from the syslog-mib, the editor
removed two objects with a syntax defined in enumeration textual
conventions syslogFacility and syslogSeverity.

Since the TCs were not otherwise used, the editor removed tham as
well.

draft-ietf-ipcdn-eventmess (already submitted to the IESG) imports
those TCs from the syslog-mib, and now we have removed the TCs.

I think the syslog mib is the right place to define these, even if the
syslog mib does not use them. I would expect mib developers looking
for the definitive syslog enumeration TCs would look in the syslog mib
module.

RFC4181 doesn't address this issue. Is it acceptable practice to
define relevant TCs in a mib module that does not use them?

David Harrington
[email-masked] 
[email-masked]
[email-masked]

_______________________________________________
MIB-DOCTORS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mib-doctors

---

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Wed, 24 Jan 2007 21:37:53 +0200

I believe that the answer is yes, and the case that you are mentioning
is a good justification why. 

We would help the community if we build on our OPS area wiki a list of
TCs with the MIB module where they can be imported and the relevant RFC.

Dan

> -----Original Message-----
> From: David Harrington [mailto:[email-masked]] 
> Sent: Wednesday, January 24, 2007 9:08 PM
> To: 'MIB Doctors (E-mail)'
> Subject: [MIB-DOCTORS] Unused textual conventions
> 
> Hi,
> 
> While removing some disputed items from the syslog-mib, the 
> editor removed two objects with a syntax defined in 
> enumeration textual conventions syslogFacility and syslogSeverity.
> 
> Since the TCs were not otherwise used, the editor removed 
> tham as well.
> 
> draft-ietf-ipcdn-eventmess (already submitted to the IESG) 
> imports those TCs from the syslog-mib, and now we have 
> removed the TCs.
> 
> I think the syslog mib is the right place to define these, 
> even if the syslog mib does not use them. I would expect mib 
> developers looking for the definitive syslog enumeration TCs 
> would look in the syslog mib module.
> 
> RFC4181 doesn't address this issue. Is it acceptable practice 
> to define relevant TCs in a mib module that does not use them?
> 
> David Harrington
> [email-masked]
> [email-masked]
> [email-masked]
> 
> 
>

---

From: "Wijnen, Bert \(Bert\)" <[email-masked]>
Date: Wed, 24 Jan 2007 21:03:46 +0100

I think it is OK if syslog MIB defines TCs that it does not 
use itself, but are intended for generic use in other MIB
modules. IT is OK to ask the question (during MIB review)
as to why they are not used here, but if the answer is that
one expects/forsees such TCs used elsewhere, then I think
that that is fine.

I do not yet see why we have to spell this out in 4181 though?

Bert 

> Sent: woensdag 24 januari 2007 11:08

---

From: "David B Harrington" <[email-masked]>
Date: Wed, 24 Jan 2007 15:08:58 -0500

Hi,

I wasn't suggesting that we need to spell it out in rfc4181. I just
mentioned that I looked there and didn't see any advice on the issue.

dbh 

> From: Wijnen, Bert (Bert) [mailto:[email-masked]] 
> Sent: Wednesday, January 24, 2007 3:04 PM
> To: David Harrington; MIB Doctors (E-mail)
> Subject: RE: [MIB-DOCTORS] Unused textual conventions
>