Subject: RE: [MIB-DOCTORS] FW: Last Call: draft-ietf-magma-mgmd-mib (MulticastGroup Membership Discovery MIB) to Proposed Standard

From: "Wijnen, Bert \(Bert\)" <[email-masked]>
Date: Sat, 1 Sep 2007 17:54:06 +0200

Based on the errors/warnings I get from both SMICNG and SMILINT, I
wonder
how this can have passed MIB-doctor review (sorry Dave) and I also
wonder
how an IETF Last Call can go out for a MIB module in this shape.

I did not look at any MIB details yet.

I get this from SMICng:

C:\bwijnen\smicng\work>smicng mgmd.inc
E: f(mgmd.mi2), (90,38) A SIZE or range clause may not be used with ENUM
E: f(mgmd.mi2), (246,38) A SIZE or range clause may not be used with
ENUM
E: f(mgmd.mi2), (487,38) A SIZE or range clause may not be used with
ENUM
E: f(mgmd.mi2), (590,38) A SIZE or range clause may not be used with
ENUM
E: f(mgmd.mi2), (644,27) A SIZE or range clause may not be used with
TimeTicks
E: f(mgmd.mi2), (751,38) A SIZE or range clause may not be used with
ENUM
E: f(mgmd.mi2), (835,38) A SIZE or range clause may not be used with
ENUM
E: f(mgmd.mi2), (797,5) Item "mgmdRouterInterfaceIfIndex" in sequence
"MgmdRouterInverseCacheEntry" is not a column for
row "mgmdRouterInverseCacheEntry"
E: f(mgmd.mi2), (798,5) Item "mgmdRouterCacheAddressType" in sequence
"MgmdRouterInverseCacheEntry" is not a column for
row "mgmdRouterInverseCacheEntry"
E: f(mgmd.mi2), (799,5) Item "mgmdRouterCacheAddress" in sequence
"MgmdRouterInverseCacheEntry" is not a column for row
"mgmdRouterInverseCacheEntry"
E: f(mgmd.mi2), (910,5) Item "mgmdRouterCacheAddressType" in sequence
"MgmdRouterSrcListEntry" is not a column for row "
mgmdRouterSrcListEntry"
E: f(mgmd.mi2), (911,5) Item "mgmdRouterCacheAddress" in sequence
"MgmdRouterSrcListEntry" is not a column for row "mgmd
RouterSrcListEntry"
E: f(mgmd.mi2), (912,5) Item "mgmdRouterCacheIfIndex" in sequence
"MgmdRouterSrcListEntry" is not a column for row "mgmd
RouterSrcListEntry"
E: f(mgmd.mi2), (784,1) Row "mgmdRouterInverseCacheEntry" must have leaf
objects defined under it
W: f(mgmd.mi2), (791,18) Row "mgmdRouterInverseCacheEntry" does not have
a consistent indexing scheme - cannot specify a
n index item from additional "base row" mgmdRouterInterfaceEntry, since
can have only one "base row" which is mgmdRouter
CacheEntry

*** 14 errors and 1 warning in parsing

And I get this from smilint:

C:\bwijnen\smicng\work>smilint -m -l 6 -s ./MGMD-STD-MIB
./MGMD-STD-MIB:39: [3] {revision-missing} revision for last update is
missing
./MGMD-STD-MIB:90: [2] {size-illegal} illegal size restriction for
non-octet-string parent type `InetAddressType'
./MGMD-STD-MIB:100: [2] {sequence-type-mismatch} type of
`mgmdHostInterfaceQuerierType' in sequence and object type defi
nition do not match
./MGMD-STD-MIB:246: [2] {size-illegal} illegal size restriction for
non-octet-string parent type `InetAddressType'
./MGMD-STD-MIB:256: [2] {sequence-type-mismatch} type of
`mgmdRouterInterfaceQuerierType' in sequence and object type de
finition do not match
./MGMD-STD-MIB:487: [2] {size-illegal} illegal size restriction for
non-octet-string parent type `InetAddressType'
./MGMD-STD-MIB:494: [2] {sequence-type-mismatch} type of
`mgmdHostCacheAddressType' in sequence and object type definiti
on do not match
./MGMD-STD-MIB:590: [2] {size-illegal} illegal size restriction for
non-octet-string parent type `InetAddressType'
./MGMD-STD-MIB:597: [2] {sequence-type-mismatch} type of
`mgmdRouterCacheAddressType' in sequence and object type defini
tion do not match
./MGMD-STD-MIB:644: [2] {subtype-illegal} subtyping not allowed
./MGMD-STD-MIB:751: [2] {size-illegal} illegal size restriction for
non-octet-string parent type `InetAddressType'
./MGMD-STD-MIB:756: [2] {sequence-type-mismatch} type of
`mgmdInverseHostCacheAddressType' in sequence and object type d
efinition do not match
./MGMD-STD-MIB:798: [2] {sequence-type-mismatch} type of
`mgmdRouterCacheAddressType' in sequence and object type defini
tion do not match
./MGMD-STD-MIB:835: [2] {size-illegal} illegal size restriction for
non-octet-string parent type `InetAddressType'
./MGMD-STD-MIB:842: [2] {sequence-type-mismatch} type of
`mgmdHostSrcListAddressType' in sequence and object type defini
tion do not match
./MGMD-STD-MIB:910: [2] {sequence-type-mismatch} type of
`mgmdRouterCacheAddressType' in sequence and object type defini
tion do not match
./MGMD-STD-MIB:796: [3] {sequence-no-column} SEQUENCE element #1
`mgmdRouterInterfaceIfIndex' is not a child node under
`mgmdRouterInverseCacheEntry'
./MGMD-STD-MIB:784: [5] {index-element-not-accessible} warning: exactly
one index element of row `mgmdRouterInverseCache
Entry' must be accessible
./MGMD-STD-MIB:909: [3] {sequence-no-column} SEQUENCE element #1
`mgmdRouterCacheAddressType' is not a child node under
`mgmdRouterSrcListEntry'
./MGMD-STD-MIB:909: [3] {sequence-no-column} SEQUENCE element #2
`mgmdRouterCacheAddress' is not a child node under `mgm
dRouterSrcListEntry'
./MGMD-STD-MIB:909: [3] {sequence-no-column} SEQUENCE element #3
`mgmdRouterCacheIfIndex' is not a child node under `mgm
dRouterSrcListEntry'
./MGMD-STD-MIB:102: [5] {inetaddress-inetaddresstype} warning:
`InetAddress' object should have an accompanied preceding
 `InetAdressType' object
./MGMD-STD-MIB:258: [5] {inetaddress-inetaddresstype} warning:
`InetAddress' object should have an accompanied preceding
 `InetAdressType' object
./MGMD-STD-MIB:496: [5] {inetaddress-inetaddresstype} warning:
`InetAddress' object should have an accompanied preceding
 `InetAdressType' object
./MGMD-STD-MIB:524: [5] {inetaddress-inetaddresstype} warning:
`InetAddress' object should have an accompanied preceding
 `InetAdressType' object
./MGMD-STD-MIB:599: [5] {inetaddress-inetaddresstype} warning:
`InetAddress' object should have an accompanied preceding
 `InetAdressType' object
./MGMD-STD-MIB:620: [5] {inetaddress-inetaddresstype} warning:
`InetAddress' object should have an accompanied preceding
 `InetAdressType' object
./MGMD-STD-MIB:758: [5] {inetaddress-inetaddresstype} warning:
`InetAddress' object should have an accompanied preceding
 `InetAdressType' object
./MGMD-STD-MIB:844: [5] {inetaddress-inetaddresstype} warning:
`InetAddress' object should have an accompanied preceding
 `InetAdressType' object
./MGMD-STD-MIB:862: [5] {inetaddress-inetaddresstype} warning:
`InetAddress' object should have an accompanied preceding
 `InetAdressType' object
./MGMD-STD-MIB:917: [5] {inetaddress-inetaddresstype} warning:
`InetAddress' object should have an accompanied preceding
 `InetAdressType' object	
Bert Wijnen  

> -----Original Message-----
> From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
> Sent: Thursday, August 30, 2007 4:46 PM
> To: [email-masked]
> Subject: [MIB-DOCTORS] FW: Last Call: 
> draft-ietf-magma-mgmd-mib (MulticastGroup Membership 
> Discovery MIB) to Proposed Standard 
> 
> Dave Thaler performed the MIB Doctor review of version 08 of 
> this document. A second look would be welcome.  
> 
> Dan
> 
>  
> 
> -----Original Message-----
> From: The IESG [mailto:[email-masked]]
> Sent: Thursday, August 30, 2007 5:24 PM
> To: IETF-Announce
> Cc: [email-masked]
> Subject: Last Call: draft-ietf-magma-mgmd-mib (Multicast 
> Group Membership Discovery MIB) to Proposed Standard 
> 
> The IESG has received a request from the Multicast & Anycast 
> Group Membership WG (magma) to consider the following document:
> 
> - 'Multicast Group Membership Discovery MIB '
>    <draft-ietf-magma-mgmd-mib-10.txt> as a Proposed Standard
> 
> The IESG plans to make a decision in the next few weeks, and 
> solicits final comments on this action.  Please send 
> substantive comments to the [email-masked] mailing lists by 
> 2007-09-13. Exceptionally, comments may be sent to 
> [email-masked] instead. In either case, please retain the 
> beginning of the Subject line to allow automated sorting.
> 
> The file can be obtained via
> http://www.ietf.org/internet-drafts/draft-ietf-magma-mgmd-mib-10.txt
> 
> 
> IESG discussion can be tracked via
> https://datatracker.ietf.org/public/pidtracker.cgi?command=vie
> w_id&dTag=
> 10603&rfc_flag=0
> 
> 
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf-announce
> 
> 
> _______________________________________________
> MIB-DOCTORS mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mib-doctors
> 

_______________________________________________
MIB-DOCTORS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mib-doctors

---

From: Dave Thaler <[email-masked]>
Date: Sat, 1 Sep 2007 09:21:35 -0700

Ok, I must be losing it, because I don't remember doing a MIB-doctor review on this document.

(Dan if you think I did, can you send my review because I can't find one.
I think I said I would do one and I still need to.  Will do so by next
Wednesday.)

-Dave

> From: Wijnen, Bert (Bert) [mailto:[email-masked]]
> Sent: Saturday, September 01, 2007 8:54 AM
> To: Romascanu, Dan (Dan); Dave Thaler
> Cc: [email-masked]
> Subject: RE: [MIB-DOCTORS] FW: Last Call: draft-ietf-magma-mgmd-mib
> (MulticastGroup Membership Discovery MIB) to Proposed Standard
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 2 Sep 2007 09:59:25 +0200

The version that got reviewed by Dave in April 2006 was version 08. I
sent separately to Dave the copy of the mail he sent then to the
authors. 

Answering to Bert, as you know the control of when a document goes to
IETF Last Call is at the discretion of the AD. Common practice is that a
MIB-doctor review is performed before the IETF LC, which seems to have
happened here and that the revised version is acknowledged by the
MIB-doctor which seems that did not happen here. In any case the Last
Call itself is a good opportunity for the responsible MIB-doctor (and
other MIB-doctors) to have another look. 

Dan

> From: Dave Thaler [mailto:[email-masked]] 
> Sent: Saturday, September 01, 2007 7:22 PM
> To: Wijnen, Bert (Bert); Romascanu, Dan (Dan)
> Cc: [email-masked]
> Subject: RE: [MIB-DOCTORS] FW: Last Call: 
> > wonder how this can have passed MIB-doctor review (sorry 
> Dave) and I 
> > also wonder how an IETF Last Call can go out for a MIB 
> module in this 
> > shape.
> >
> > E: f(mgmd.mi2), (784,1) Row "mgmdRouterInverseCacheEntry" must have 
> > leaf objects defined under it
> > W: f(mgmd.mi2), (791,18) Row "mgmdRouterInverseCacheEntry" does not 
> > have a consistent indexing scheme - cannot specify a n 
> index item from 
> > additional "base row" mgmdRouterInterfaceEntry, since can have only 
> > one "base row" which is mgmdRouter CacheEntry
> >
> > `mgmdHostInterfaceQuerierType' in sequence and object type 
> defi nition 
> > do not match
> > `mgmdHostCacheAddressType' in sequence and object type 
> definiti on do 
> > not match
> > `mgmdRouterCacheAddressType' in sequence and object type 
> defini tion 
> > do not match
> > `mgmdRouterCacheAddressType' in sequence and object type 
> defini tion 
> > do not match
> > `mgmdHostSrcListAddressType' in sequence and object type 
> defini tion 
> > do not match
> > `mgmdRouterCacheAddressType' in sequence and object type 
> defini tion 
> > do not match
> > ./MGMD-STD-MIB:784: [5] {index-element-not-accessible} warning: 
> > exactly one index element of row `mgmdRouterInverseCache 
> Entry' must 
> > be accessible
> > `InetAdressType' object Bert Wijnen
> >
> > > Dave Thaler performed the MIB Doctor review of version 08 of this 
> > > document. A second look would be welcome.
> > >
> > > Dan
> > >
> > >
> > >
> > > Subject: Last Call: draft-ietf-magma-mgmd-mib (Multicast Group 
> > > Membership Discovery MIB) to Proposed Standard
> > >
> > > The IESG has received a request from the Multicast & 
> Anycast Group 
> > > Membership WG (magma) to consider the following document:
> > >
> > > solicits final comments on this action.  Please send substantive 
> > > comments to the [email-masked] mailing lists by 2007-09-13. 
> > > Exceptionally, comments may be sent to [email-masked] instead. In 
> > > either case, please retain the beginning of the Subject line to 
> > > allow automated sorting.
> > >