Subject: Re: [MIB-DOCTORS] Help with conformance statements in draft-ietf-trill-rbridge-mib

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 13 Apr 2012 17:34:17 +0100

Anil,

The Ops ADs and your own ADs [added to this message] will probably have a view on this. My feeling is that a Trill implementation is somewhat dependent on an IS-IS implementation. Therefore the MIB module for an Rbridge is not complete without the ability to model/manage an IS-IS speaker. 

It is possible that you can cover this with suitable wording, however, it remains my opinion that the correct way to handle this is with a compliance statement. I have two reasons for saying this:
1. An Rbridge is not properly manageable without IS-IS management
2. The IS-IS module is not fully applicable to an Rbridge

Cheers,
Adrian

> -----Original Message-----
> From: Anil Rijhsinghani [mailto:[email-masked]]
> Sent: 10 April 2012 17:38
> To: Bert Wijnen (IETF)
> Cc: [email-masked]; [email-masked]; [email-masked]; draft-
> [email-masked]
> Subject: Re: [MIB-DOCTORS] Help with conformance statements
> 
> Agreed that the MUST etc language is unusual for a "Relationships to
> other MIBs" section. I haven't looked at this section in a while. There
> are references to several other MIBs as well in that part of the
> document, and the description in those is not at the level of 6.7, nor
> should it be.
> 
> Let me go back and edit that section to bring it more in line with
> other "Relationship" sections in the draft, and see if it becomes more
> acceptable.
> 
> I'd rather not add new Compliance clauses for other MIBs as that would
> be enforced in syntax and will have to go back to at least the RBridge
> WG (and perhaps even the IS-IS WG) for agreement - which will almost
> certainly take several months more. The intention was not to enforce
> this stuff, only to provide hints to implementors, and many of these
> hints are probably overkill.
> 
> I'll work on that section and submit another draft by end of week.
> 
> Regards,
> Anil
> 
> 
> On Tue, Apr 10, 2012 at 4:53 AM, Bert Wijnen (IETF) wrote:
> 
> > From a quick read that I did (section 6.7), then it
> > indeed seems to specify a set of requirements (even in
> > MUST) language for the ISIS-MIB module. So here (in
> > sect 6.7) they are described in English.
> >
> > It would indeed be useful to have that documented
> > in machine readable format, i.e. in (or as part of)
> > a MODULE-COMPLIANCE statement.
> >
> > Is it a reason to hold up the document?
> > Not sure about that. At the time when I was AD, I
> > tried to strongly encourage people to express such
> > requirements in the form of MODULE_COMPLIANCE
> > statements. But that was/is my view.
> >
> > Maybe other MIB doctors do have an opinion on that.
> >
> > Bert
> >
> > On 4/8/12 10:34 PM, Adrian Farrel wrote:
> >> Hi,
> >>
> >> Is there a MIB Doctor that can help us?
> >>
> >> I am holding a Discuss on draft-ietf-trill-rbridge-mib-07.txt
> >>
> >> It reads...
> >>
> >>> I would like help from the OPS ADs (and MIB Doctors) on this point:
> >>>
> >>> It seems to me that section 6.7 needs a new conformance statement to
> >>> be applied to ISIS-MIB. The text in the section appears to be in two
> >>> parts:
> >>>
> >>> - Implementation guidance (what value to return on a GET from a
> >>> Trill
> >>>   implementation)
> >>>
> >>> - Implementation requirements (which tables/objects to implement or
> >>> not  (conformance statement).
> >>
> >> Can anyone tell me if I am right or wrong.
> >>
> >> Thanks,
> >> Adrian
> >>
> >>
> >> _______________________________________________
> >> MIB-DOCTORS mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/mib-doctors
> >>

---

From: Andy Bierman <[email-masked]>
Date: Fri, 13 Apr 2012 09:50:13 -0700

> 2. The IS-IS module is not fully applicable to an Rbridge

I agree that a MODULE-COMPLIANCE macro is the correct solution.
Your WG needs to agree on the specific objects from the specific MIB modules
that need to be supported.

> Adrian

Andy

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 15 Apr 2012 16:03:59 +0200

I agree with Andy. If only part of the IS-IS MIB module applies to
Rbridges, than the MODULE-COMPLIANCE statement can specify which objects
or MIB groups need to be supported. 

Regards,

Dan

> From: [email-masked] [mailto:mib-doctors-
> [email-masked]] On Behalf Of Andy Bierman
> Sent: Friday, April 13, 2012 7:50 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked];
> 'Anil Rijhsinghani'; [email-masked]; [email-masked]
> Subject: Re: [MIB-DOCTORS] Help with conformance statements indraft-
> ietf-trill-rbridge-mib
> 
> > The Ops ADs and your own ADs [added to this message] will probably
> have a view on this. My feeling is that a Trill implementation is
> somewhat dependent on an IS-IS implementation. Therefore the MIB
module
> for an Rbridge is not complete without the ability to model/manage an
> IS-IS speaker.
> >
> > It is possible that you can cover this with suitable wording,
> however, it remains my opinion that the correct way to handle this is
> with a compliance statement. I have two reasons for saying this:
> >>>>> It seems to me that section 6.7 needs a new conformance
statement
> to