Subject: Re: [MIB-DOCTORS] Read-only MIB modules

From: Randy Presuhn <[email-masked]>
Date: Thu, 27 Feb 2014 20:26:09 -0500 (EST)

Hi -

>From: David Harrington <[email-masked]>
>Sent: Feb 27, 2014 2:14 PM
...
>"WG groups can then decide
>if they have enough participants who plan on implementing read-create.
>If not, then they can't have it.  The MIB gets rejected and sent back
>to the WG if it contains any MIN-ACCESS clauses.
>"
>
>So why should rw mibs be held to a higher standard than other IETF proposed
>standards?

I can think of three barely plausible policy motivations:

   - WGs are stupid and don't know what they're getting
     into when they decide to standardize configuration,
     so they should be discouraged in every way possible

   - by making rw mibs more difficult to standardize WGs
     will be encouraged to use Yang / Netconf instead,
     presumably because Yang modules are cheaper to develop
     or because there has been a policy decision to favor
     that technology.

   - standardized configuration of any kind is expensive
     (in terms of WG resources) to develop and consequently
     should be discouraged in favor of whatever vendor-
     specific solutions might arise.

I think all of these are lousy rationales, so I
would welcome a more plausible explanation.

Randy

---

From: Andy Bierman <[email-masked]>
Date: Thu, 27 Feb 2014 18:12:27 -0800

Hi,

If 20+ years of publishing RFCs for ANY technology has not produced
industry adoption, then it might just be time to reevaluate the practice
of publishing these RFCs.

It is not surprising that MIB Police would remain in denial that
the jury is still out on SNMP Set.

We have understood for at least 15 years now that adding standard config
on top of proprietary config is complicated.  NETCONF/YANG has its
best chance with new products that do not have lots of legacy code
to work around.

Given the new marketing push for programmatic interfaces, companies
are forced to address this problem, more than ever before.

I am usually in favor of letting others flail in their own sandbox, as
long as I don't have to waste my time on it.  So if the MPLS world
feels better producing r/w MIBs that nobody implements, then
let them keep flailing.

The NETMOD WG has a backlog of configuration models that
have come from vendors.  There is some evidence that vendors
are willing to implement data models for configuration, using YANG.
IMO, nothing in the "SNMP world" is remotely relevant to this trend.
The industry has already decided SNMP is for monitoring.  That memo
apparently never got delivered to MIB police.

Andy

On Thu, Feb 27, 2014 at 5:26 PM, Randy Presuhn <[email-masked]
> wrote:

> _______________________________________________
> MIB-DOCTORS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mib-doctors
>

---

From: Thomas D Nadeau <[email-masked]>
Date: Fri, 28 Feb 2014 08:20:49 +0000

well said; totally agree.

Tom 

> On Feb 28, 2014, at 2:12, Andy Bierman <[email-masked]> wrote:
> 
> Hi,
> 
>> On Thu, Feb 27, 2014 at 5:26 PM, Randy Presuhn <[email-masked]> wrote:
>> Hi -
>>