Subject: Re: [MIB-DOCTORS] YANG life-cycle issues - lessons from SNMP?

From: Randy Presuhn <[email-masked]>
Date: Fri, 4 Apr 2014 16:08:58 -0700 (GMT-07:00)

Hi -

>From: Andy Bierman <[email-masked]>
>Sent: Apr 4, 2014 3:43 PM
>To: YANG Doctors <[email-masked]>, "MIB Doctors (E-mail)" <[email-masked]>
>Subject: [MIB-DOCTORS] YANG life-cycle issues - lessons from SNMP?
...
>Is that just because of configuration vs. monitoring?

I don't think that's it.  I think it has more to do
with the (lack of an) underlying metamodel, rules
for type extensibility and a not completely-thought-
through approach to defining the limits of how inter-
version compatibility is supposed to work.

...
>Does SMIv2 allow a mandatory column to be added
>to a table in a module update? It appears yes.
>It would just be a change to the RowStatus description
>clause, e.g., "column A, B, and E must be present in order
>for this row to be in the active state".

Disagree.  Such a change to the semantics of a Rowstatus
object would violate the SMI revision rule that "Otherwise,
if the semantics of any previously defined object are
changed (i.e., if a non-editorial change is made to any
clause other than those specifically allowed above), then
the OBJECT IDENTIFIER value associated with that object
must also be changed."

Randy

---

From: Andy Bierman <[email-masked]>
Date: Fri, 4 Apr 2014 16:26:50 -0700

> version compatibility is supposed to work.

How many mandatory objects are there in SNMP? none?
How hard is it for a client to receive some monitoring info
it doesn't know or care about?  Monitoring is really easy
compared to configuration.

I agree NETCONF's framework is still evolving (to be kind).
We have never had any meaningful standard CM data models,
let alone updates to them 3 - 5 years later.

> the OBJECT IDENTIFIER value associated with that object
OK -- just checking.  I implemented a lot of MIB modules,
some (RMON suite) with Set support.  There was never
any update to a read-create table that I can remember.

I am not convinced that the strict rules for YANG are so smart.
Looks to be trading 1 set of problems for a different set
(e.g., obsolete and start over is intrusive and expensive)

> Randy
Andy