Subject: Re: [mif] draft-blanchet-mif-problem-statement-00.txt

From: "Kai Ju" <[email-masked]>
Date: Fri, 16 Jan 2009 21:50:14 +0800

Hi, all
>-----Original Message-----
>From: mif-bounces at ietf.org [mailto:mif-bounces at ietf.org] On
>Behalf Of ext Tony Finch
>Sent: 05 January, 2009 21:24
>To: mif at ietf.org
>Subject: [mif] draft-blanchet-mif-problem-statement-00.txt
>
>Can a host use multiple interfaces to get more bandwidth?
>Obviously yes now by binding the local end of each socket to
>each interface, but that introduces much more complexity to an
>area that was previously simple. Is that complexity avoidable?

This is probably not in mif scope. There's some interesting work ongoing
on having multipath support on transpor layer (multipath TCP):
http://www.ietf.org/proceedings/08jul/slides/tsvarea-2.pdf

Yes, We agree that it's not in mif scope, that one application can get more
bandwidth by using multiple interfaces.
But we believe that a host who has several applications on can optimize the
bandwidth
condition by using multiple interfaces, under the policy provided by the
ISP. For example,
one application is moved from one interface to another due to the network
congestion,
or the requirement for more bandwidth.
We think it's one direction which is worth to be discussed by MIF.
Best regards,

Kai
_______________________________________________
mif mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mif

---

From: "Hong Yong-Geun" <[email-masked]>
Date: Sat, 17 Jan 2009 01:33:35 +0900

Hi, all.

I think that a host can use multiple interfaces to get more bandwidth without
increasing complexity. Even though multiple interfaces exist, if it is possible to hide
the existing of multiple interfaces to the upper layer (network layer), multiple interfaces
can be used to get more bandwidth. One of solutions for this is a virtual network interface concept.

http://tools.ietf.org/draft/draft-hong-virtualif-mn-mipv6/draft-hong-virtualif-mn-mipv6-00.txt

As Kai says, I agreed that using multiple interfaces and changing interfaces during communication
for the avoidance of network congestion or the requirement for more bandwidth can be one of study
items in mif.

Thanks..

Yong-Geun.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Kai Ju
Sent: Friday, January 16, 2009 10:50 PM
To: [email-masked]
Subject: Re: [mif] draft-blanchet-mif-problem-statement-00.txt

Hi, all

But we believe that a host who has several applications on can optimize the bandwidth

condition by using multiple interfaces, under the policy provided by the ISP. For example,

one application is moved from one interface to another due to the network congestion,

Best regards,

Kai

---

From: <[email-masked]>
Date: Mon, 19 Jan 2009 09:36:38 +0200

Hi,
 
But for this approach you need deployment of MIP Home Agent, right? My
impression of mif work is that the solution must be usable without
P(MIP) being deployed (though of course if it helps (P)MIP, the better).
 
With (DS)MIPv6 in place, certainly a host can have a virtual interface
and multiple CoAs (simultaneously in use). However, that is not a
solution for the scenario where a host is having multiple interfaces to
different management domains (intranets, walled gardens), which
interfaces cannot be bound together as a single virtual network
interface.
 
Best regards,
 
    Teemu

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext Hong Yong-Geun
	Sent: 16 January, 2009 18:34
	To: Kai Ju; [email-masked]
	Subject: Re: [mif] draft-blanchet-mif-problem-statement-00.txt

	Hi, all.

	I think that a host can use multiple interfaces to get more
bandwidth without
	increasing complexity. Even though multiple interfaces exist, if
it is possible to hide
	the existing of multiple interfaces to the upper layer (network
layer), multiple interfaces
	can be used to get more bandwidth. One of solutions for this is
a virtual network interface concept.

http://tools.ietf.org/draft/draft-hong-virtualif-mn-mipv6/draft-hong-vir
tualif-mn-mipv6-00.txt

	As Kai says, I agreed that using multiple interfaces and
changing interfaces during communication
	for the avoidance of network congestion or the requirement for
more bandwidth can be one of study
	items in mif.

	Thanks..

	Yong-Geun. 

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Kai Ju
	Sent: Friday, January 16, 2009 10:50 PM
	To: [email-masked]
	Subject: Re: [mif] draft-blanchet-mif-problem-statement-00.txt

	Hi, all

	>From: mif-bounces at ietf.org <http://ietf.org/>
[mailto:mif-bounces at ietf.org <http://ietf.org/> ] On 
	>To: mif at ietf.org <http://ietf.org/> 

	This is probably not in mif scope. There's some interesting work
ongoing
	on having multipath support on transpor layer (multipath TCP):
	http://www.ietf.org/proceedings/08jul/slides/tsvarea-2.pdf

	Yes, We agree that it's not in mif scope, that one application
can get more 

	But we believe that a host who has several applications on can
optimize the bandwidth 

	condition by using multiple interfaces, under the policy
provided by the ISP. For example, 

	one application is moved from one interface to another due to
the network congestion, 

	We think it's one direction which is worth to be discussed by
MIF.

	Best regards,
	
	Kai

<http://umail.etri.re.kr/External_ReadCheck.aspx?email=[email-masked]&name
=mif%40ietf.org&fromemail=[email-masked]&messageid=%3C617bc284-c26d-4
[email-masked]%3E>