Subject: [mif] mobility issues and general issues on mif

From: "Hong Yong-Geun" <[email-masked]>
Date: Thu, 8 Jan 2009 14:44:04 +0900

Hi. mif..

Let me join this discussion.

It is very interesting to see mif.

As Hui Deng says, I understand that mif has different approach
from other WG such as MEXT and monami6 WG, etc.

In MEXT, multiple interfaces issues are related to Mobile IP, NEMO,..
In mif, multiple interfaces issues are different from those of MEXT.
So, in mif, it is better to find more general issues which are not related to Mobile IP.

I think that M.Blanchet's "Multiple Interfaces Problem Statement" draft is
a good starting point to discuss general issues on mif.

I would like to introduce another related drafts which I presented at monami6 WG at 64th IETF meeting.

- Analysis of multiple interfaces in a Mobile Node(draft-hong-multipleif-mn-pb-statement-00)
http://tools.ietf.org/draft/draft-hong-multipleif-mn-pb-statement/draft-hong-multipleif-mn-pb-statement-00.txt

- Virtual network interface for multiple interfaces in a Mobile node using Mobile IPv6
(draft-hong-virtualif-mn-mipv6-00)
http://tools.ietf.org/draft/draft-hong-virtualif-mn-mipv6/draft-hong-virtualif-mn-mipv6-00.txt

In the section 2.2 (General Network Issues) in the first draft,
there are general network issues due to multiple interfaces.

Including these drafts, I hope to encourage this discussion

Yong-Geun.

_______________________________________________
mif mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mif

---

From: "Hui Deng" <[email-masked]>
Date: Tue, 13 Jan 2009 15:20:29 -0700

Hi, Hong Yong,

I read through your two drafts, understand you are talking the issue without
Monami
it seems Mobile Ipv6 internal also has similar issue with us if I understand
it correctly,
In this case I would like to encourage you to propose this issue to our
work, if allowed,
it mightbe doable within our scope,

many thanks

-Hui
2009/1/7 Hong Yong-Geun <[email-masked]>

>  - Analysis of multiple interfaces in a Mobile
> Node(draft-hong-multipleif-mn-pb-statement-00)
>

---

From: "Hong Yong-Geun" <[email-masked]>
Date: Wed, 14 Jan 2009 20:37:40 +0900

Hi..Hui..

Thank you for comments. See below inline reply.

Best regards.

Yong-Geun..

From: Hui Deng [mailto:[email-masked]]
Sent: Wednesday, January 14, 2009 7:20 AM
To: 홍용근
Cc: [email-masked]
Subject: Re: [mif] mobility issues and general issues on mif

Hi, Hong Yong,

I read through your two drafts, understand you are talking the issue without Monami

?  Yes, you are correct.
I want to solve the multiple interface problems without modifying Mobile IPv6/NEMO code.
(In Monami6, multiple interface problems (which are related to mobility issues, such as multiple CoA,
multiple HoA, etc., ) are resolving by modifying Mobile IPv6/NEMO protocol)

it seems Mobile Ipv6 internal also has similar issue with us if I understand it correctly,

?  Yes, because Mobile IPv6 is based on the basic operation of IPv6, Mobile IPv6 internal
has similar issues of mif. So, I think that it is valuable to separate more general issues from
multiple interface issues which are directly related to Mobile IPv6/NEMO.

In this case I would like to encourage you to propose this issue to our work, if allowed,

?  Thanks. It is my pleasure..

many thanks

-Hui

Hi. mif..

Yong-Geun.

---

From: "Hui Deng" <[email-masked]>
Date: Wed, 14 Jan 2009 23:47:09 -0700

you already had a discussion with mext wg, they are not adopting this work?

-Hui

2009/1/14 Hong Yong-Geun <[email-masked]>

> *From:* Hui Deng [mailto:[email-masked]]
> *Sent:* Wednesday, January 14, 2009 7:20 AM
> *To:* 홍용근
> *Cc:* [email-masked]
> *Subject:* Re: [mif] mobility issues and general issues on mif
>
>
>
> Hi, Hong Yong,
>
>
>

---

From: "Hong Yong-Geun" <[email-masked]>
Date: Thu, 15 Jan 2009 20:11:53 +0900

Hi..Hui..

No, I didn’t discuss with mext wg. I presented and discussed with monami6 wg at 64th IETF meeting.

And it was not adopted in monami6 wg because it was not in the scope of monami6 wg.

Best regards.

Yong-Geun..

From: Hui Deng [mailto:[email-masked]]
Sent: Thursday, January 15, 2009 3:47 PM
To: 홍용근
Cc: [email-masked]
Subject: Re: [mif] mobility issues and general issues on mif

-Hui

Hi..Hui..

Best regards.

Yong-Geun..

Hi, Hong Yong,

?  Yes, you are correct.

many thanks

-Hui

Hi. mif..

Yong-Geun.

오류! 파일 이름이 지정되어 있지 않습니다.

---

From: "Hui Deng" <[email-masked]>
Date: Mon, 19 Jan 2009 15:37:44 +0800

Hi, Hong,

Could you make a short summary , cross-post to the mext/mif, and cc to
chairs, and
see their comments?
Many thanks

-Hui
2009/1/15 Hong Yong-Geun <[email-masked]>

>
>
> Hi..Hui..
>
>
>
> No, I didn't discuss with mext wg. I presented and discussed with monami6
> wg at 64th IETF meeting.
>
> *Sent:* Thursday, January 15, 2009 3:47 PM
> *To:* 홍용근
>
> *Cc:* [email-masked]
> *오류! 파일 이름이 지정되어 있지 않습니다.*
>
>
>

---

From: "Hong Yong-Geun" <[email-masked]>
Date: Mon, 19 Jan 2009 23:52:04 +0900

Hi..Hui..

Thank you for your interest.

I think that the discussion of multiple interfaces issues which is not related to Mobile IPv6/NEMO in MEXT WG
is not useful because MEXT WG is focusing on the extension of Mobile IPv6/NEMO.
The intension of my previous two drafts is not extending Mobile IPv6/NEMO.

Instead, if you wonder the response of Monami6 WG for my previous two drafts, you can refer the 64th monami6 WG
meeting report when I presented.

http://www.ietf.org/proceedings/05nov/monami6.html   (6th presentation)

Thanks..

Yong-Geun..

From: Hui Deng [mailto:[email-masked]]
Sent: Monday, January 19, 2009 4:38 PM
To: 홍용근
Cc: [email-masked]
Subject: Re: [mif] mobility issues and general issues on mif

Hi, Hong,

Could you make a short summary , cross-post to the mext/mif, and cc to chairs, and

see their comments?

Many thanks

-Hui

Hi..Hui..

No, I didn't discuss with mext wg. I presented and discussed with monami6 wg at 64th IETF meeting.

Best regards.

Yong-Geun..

Cc: [email-masked]

-Hui

Hi..Hui..

Best regards.

Yong-Geun..

Hi, Hong Yong,

?  Yes, you are correct.

many thanks

-Hui

Hi. mif..

Yong-Geun.

오류! 파일 이름이 지정되어 있지 않습니다.

오류! 파일 이름이 지정되어 있지 않습니다.

---

From: Hui Deng <[email-masked]>
Date: Thu, 22 Jan 2009 22:39:41 +0800

---

From: "Hong Yong-Geun" <[email-masked]>
Date: Sat, 24 Jan 2009 12:16:36 +0900

Hi, Hui.

Thanks for your comments.

I agree to your suggested approach to clarify the difference between my proposal and
Jari’s comments 6 (Tunnel multihoming).

I will make a summary and cross-post to the mext/mif both.

Although it seems that my draft name was quite related to mext wg, I think that the purpose of my drafts

are different to the scope of mext. I understand that mext wg is targeting on the extending of Mobile IPv6/NEMO
and my purpose is to support multiple interfaces without extending of Mobile IPv6/NEMO.

Thanks for your encouragement.

Best regards.

Yong-Geun..

From: Hui Deng [mailto:[email-masked]]
Sent: Thursday, January 22, 2009 11:40 PM
To: 홍용근
Cc: [email-masked]
Subject: Re: [mif] mobility issues and general issues on mif

Hi, Hong,

I encourage to clarify the difference between your proposal and Jari's comments 6, or which todo work is the same as your proposal.

since your draft name is quite related to mext wg, that's the reason asking you to do consult work with mext, to avoid future interconnection work.

thanks again.

-Hui

2009/1/19 Hong Yong-Geun <[email-masked]>

Hi..Hui..

Thanks..

Yong-Geun..

Cc: [email-masked]

Hi, Hong,

see their comments?

Many thanks

-Hui

Hi..Hui..

Best regards.

Yong-Geun..

Cc: [email-masked]

-Hui

Hi..Hui..

Best regards.

Yong-Geun..

Hi, Hong Yong,

?  Yes, you are correct.

many thanks

-Hui

Hi. mif..

Yong-Geun.

오류! 파일 이름이 지정되어 있지 않습니다.

오류! 파일 이름이 지정되어 있지 않습니다.

오류! 파일 이름이 지정되어 있지 않습니다.