Subject: [mif] One general issue on MIF

From: Kai Ju <[email-masked]>
Date: Wed, 28 Jan 2009 11:22:24 +0800

Hi, All

Firstly, allow me wish everyone in MIF Discussion a magnificent Chinese
Spring Festival, and good luck for whole new year.

I got one issue which maybe would raise a fundamental question on MIF, and
it has confused me for days.

If host has WLan connection, and user wanna start one application on it,
because Wlan provided by ISP is free. But the policy which host has got from
network forbid it on Wlan. When they're conflict between the policy and
user's willing, how should MIF do? Ignor user's willing, choose another
interface according the policy? Or change the
policy, do what the user wanna do?

So, the question is policy and user's willing, who get the higher priority?

BRG

Kai
_______________________________________________
mif mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mif

---

From: <[email-masked]>
Date: Wed, 28 Jan 2009 09:17:33 +0100

Hi Kai,
 
Please see my opinion inline.
 
Regards,
Pierrick
 
________________________________

De : [email-masked] [mailto:[email-masked]] De la part de Kai Ju
Envoyé : mercredi 28 janvier 2009 04:22
À : mif
Objet : [mif] One general issue on MIF
 
Hi, All
 
Firstly, allow me wish everyone in MIF Discussion a magnificent Chinese Spring Festival, and good luck for whole new year.
 
I got one issue which maybe would raise a fundamental question on MIF, and it has confused me for days.
 
If host has WLan connection, and user wanna start one application on it, because Wlan provided by ISP is free. But the policy which host has got from network forbid it on Wlan. When they're conflict between the policy and user's willing, how should MIF do? Ignor user's willing, choose another interface according the policy? Or change the
policy, do what the user wanna do? 

[PS] IMO, it is an implementation issue. Some operators are thinking that the final decision is made on the user preferences except if cannot apply (e.g. preferred access overloaded making it impossible to use); but it's not the only way to do.
 
BRG
 
Kai

---

From: Hui Deng <[email-masked]>
Date: Thu, 29 Jan 2009 00:56:48 +0800

I agree Pierrick's opinion here, it is more local policy implementaion
issue,
MIF is only working on transfer some network policy to the local policy
repository.
this repository may be used between application and socket api interface.

thanks

-Hui

2009/1/28 <[email-masked]>

>   ------------------------------
>
> *De :* [email-masked] [mailto:[email-masked]] *De la part de*Kai Ju
> *Envoyé :* mercredi 28 janvier 2009 04:22
> *À :* mif
> *Objet :* [mif] One general issue on MIF
>
>
>
> Hi, All
>
>
>
> [PS] IMO, it is an implementation issue. Some operators are thinking that
> the final decision is made on the user preferences except if cannot apply
> (e.g. preferred access overloaded making it impossible to use); but it's not
> the only way to do.
>
>
>
> BRG
>
>
>
> Kai
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 28 Jan 2009 12:43:43 -0800 (PST)

Hi Hui,
  See my question below.

Regards,

Behcet

________________________________
From: Hui Deng <[email-masked]>
To: [email-masked]
Cc: [email-masked]
Sent: Wednesday, January 28, 2009 10:56:48 AM
Subject: Re: [mif] One general issue on MIF

I agree Pierrick's opinion here, it is more local policy implementaion issue,
MIF is only working on transfer some network policy to the local policy repository.
this repository may be used between application and socket api interface.
 
[behcet] What type of protocol will be used for this purpose?

thanks

-Hui

Hi Kai,

Regards,
Pierrick

De :[email-masked] [mailto:[email-masked]] De la part de Kai Ju
Envoyé : mercredi 28 janvier 2009 04:22
À : mif
Objet : [mif] One general issue on MIF
 
Hi, All

 

 
BRG
 
Kai

---

From: <[email-masked]>
Date: Thu, 29 Jan 2009 10:00:34 +0100

Hi,

All existing devices do solve the complex multi-interface problem by some means, but probably not perfectly.

I think managing to standardize tools that help those current implementation-specific solutions work better, e.g. with less user-interaction, with better default behaviour, with better and faster fall-backs or having better selection between "otherwise-equal" interfaces etc. would be a good achievement for mif. I mean to work on standardizing tools and issues that can and should be standardized here, and leave the rest out.

In the policy conflict case mentioned below I think it depends, e.g.:
- if the device is ISP subsidized (e.g. "rented"), ISP's policy could force the device to behave exactly as ISP policy says, even if user would prefer free WLAN available nearby. The ISP likely is able to configure the device to behave this way by non-IETF means.
- similarly, if device is corporation managed & owned, corporation would probably want to be able to force device to do exactly as corporation policy says, even if user would prefer faster WLAN (the cost might not matter so much in this case). The corporation is likely able to configure device this way by non-IETF means.
- however, if the device is user owned and user managed, user probably would like to have full control on which interface is used, and e.g. have ways to prioritize expensive (for user) connetions to low (and rather have lower QoS, longer transport paths, than higher prize) . And the user should have this possibly available - even if by default device would follow e.g. received ISP's policies in order to provide easy user experience for those people who don't want to hear about any configuration issues

Best regards,

    Teemu

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext [email-masked]
Sent: 28 January, 2009 10:18
To: [email-masked]; [email-masked]
Subject: Re: [mif] One general issue on MIF

Hi Kai,

Regards,
Pierrick

Hi, All

BRG

Kai

---

From: Hui Deng <[email-masked]>
Date: Thu, 29 Jan 2009 18:13:41 +0800

Hi, Behcet,

Thanks for your question,
there are several proposals at the moment:
http://tools.ietf.org/id/draft-savolainen-6man-fqdn-based-if-selection-00.txt
http://tools.ietf.org/id/draft-hui-ip-multiple-connections-01.txt

Regards,

-Hui

2009/1/29 Behcet Sarikaya <[email-masked]>

> *From:* Hui Deng <[email-masked]>
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Sent:* Wednesday, January 28, 2009 10:56:48 AM
> *Subject:* Re: [mif] One general issue on MIF
>

---

From: Hui Deng <[email-masked]>
Date: Thu, 29 Jan 2009 18:34:53 +0800

Hi, Teemu,

I would like to append more based on your three categorization.
1) for  ISP subsidized , policy works
2) for corporation owned, policy together with ISP should also work.
3) for user owned, policy recommend better way to do, and user can change,
anyhow, policy should be first position to consider, so policy works again
if user is not able to change it.
summary all these 3 cases, configured policy will all works.

For your first part, wondering whether MIF is suitable for tools? Since ietf
more focus on the protocol, anyhow protocol will influence those tools
finally.

thanks

-Hui

2009/1/29 <[email-masked]>

> I think managing to standardize tools that help those current
> implementation-specific solutions work better, e.g. with less
> user-interaction, with better default behaviour, with better and faster
> fall-backs or having better selection between "otherwise-equal" interfaces
> etc. would be a good achievement for mif. I mean to work on standardizing
> tools and issues that can and should be standardized here, and leave the
> rest out.
>
> - if the device is ISP subsidized (e.g. "rented"), ISP's policy could force
> the device to behave exactly as ISP policy says, even if user would prefer
> free WLAN available nearby. The ISP likely is able to configure the device
> to behave this way by non-IETF means.
> - similarly, if device is corporation managed & owned, corporation would
> probably want to be able to force device to do exactly as corporation policy
> says, even if user would prefer faster WLAN (the cost might not matter so
> much in this case). The corporation is likely able to configure device this
> way by non-IETF means.
> - however, if the device is user owned and user managed, user probably
> would like to have full control on which interface is used, and e.g. have
> ways to prioritize expensive (for user) connetions to low (and rather have
> lower QoS, longer transport paths, than higher prize) . And the user should
> have this possibly available - even if by default device would follow e.g.
> received ISP's policies in order to provide easy user experience for those
> people who don't want to hear about any configuration issues
>
> Best regards,
>
>     Teemu
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *ext
> [email-masked]
> *Sent:* 28 January, 2009 10:18
> *To:* [email-masked]; [email-masked]

---

From: <[email-masked]>
Date: Thu, 29 Jan 2009 11:41:54 +0100

Hi Hui,

I agree on those. I ment MIF is a part, a tool, of the greater system.

Best regards,

    Teemu

________________________________
From: ext Hui Deng [mailto:[email-masked]]
Sent: 29 January, 2009 12:35
To: Savolainen Teemu (Nokia-D-MSW/Tampere)
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [mif] One general issue on MIF

Hi, Teemu,

3) for user owned, policy recommend better way to do, and user can change, anyhow, policy should be first position to consider, so policy works again if user is not able to change it.

For your first part, wondering whether MIF is suitable for tools? Since ietf more focus on the protocol, anyhow protocol will influence those tools finally.

thanks

-Hui

2009/1/29 <[email-masked]<mailto:[email-masked]>>
Hi,

Best regards,

    Teemu

________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of ext [email-masked]<mailto:[email-masked]>
Sent: 28 January, 2009 10:18
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [mif] One general issue on MIF

Hi Kai,

Regards,

Pierrick

De : [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] De la part de Kai Ju
Envoyé : mercredi 28 janvier 2009 04:22
À : mif
Objet : [mif] One general issue on MIF

Hi, All

BRG

Kai

_______________________________________________
mif mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mif