Subject: [mif] IP model for multiple mode mobile terminal

From: "Hui Deng" <[email-masked]>
Date: Tue, 13 Jan 2009 15:35:15 -0700

Hi, Qin,

Thanks for your comments. see below inline reply.
2009/1/8 Qin Wu <[email-masked]>

>  Interesting topic, As we discussed before, you thought Internet IP
> model was invented by 1 PC, 1 Default Gateway, 1 default route. But today it
> is a little different, mobile terminal has multiple modes, it would like to
> use all of them simulatenously which orginal IP model doesn't work any more
> on it.
>
Thanks for your agreement on this issue.

>   I can understand IETF more concentrates on single-point technology, not
> end to end solution.
> As regarding Internet IP model, dual radio model has already been
> developing to support inter-technology handover. Dual mode teminal is not
> fanciful.
>
Could you help to write down how you implement on this?

>   In the future, with the development of femto technolgy, single mode
> teminal can access mobile network via a femto basestation at home. I can not
>  judge whether single radio technology or dual radio technology will
> dominate the future market. Any way, from the technical perspective, I think
> the traditional internet IP model will be gradually evolving. multiple
> interface requirements will become one big issue to be considered, e.g.,
> dynamic provision and routing , coordination and synchronization mechanisms
> are needed to be further study.
>
>
it seems that dynamical provision and routing, coordination and
synchronization will become more complicated, simple way make deployment
easy, it is the way of Internet exist

thanks

-Hui

>   -Qin
>
>   ----- Original Message -----
> *From:* Hui Deng <[email-masked]>
> *To:* [email-masked]
> *Sent:* Thursday, January 08, 2009 11:13 PM
> *Subject:* [mif] Mailing list Issue
>
> Hello, all
>
> I saw lots of email with  [email-masked].
>
> It seems some people has issue with this mailing list.
> If that is the case, please don't hestitate to let me know that,
>
> many thanks
>
> -Hui
>
> ------------------------------
>
> _______________________________________________
> mif mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mif
>
>
_______________________________________________
mif mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mif

---

From: w53375 <[email-masked]>
Date: Sat, 17 Jan 2009 19:03:22 +0800

Thanks for your reply, Please see the follow up comments below.
-Qin
  ----- Original Message ----- 
  From: Hui Deng 
  To: Qin Wu 
  Cc: [email-masked] 
  Sent: Wednesday, January 14, 2009 6:35 AM
  Subject: IP model for multiple mode mobile terminal

  Hi, Qin, 

    Interesting topic, As we discussed before, you thought Internet IP model was invented by 1 PC, 1 Default Gateway, 1 default route. But today it is a little different, mobile terminal has multiple modes, it would like to use all of them simulatenously which orginal IP model doesn't work any more on it.
  Thanks for your agreement on this issue.

    I can understand IETF more concentrates on single-point technology, not end to end solution.
    As regarding Internet IP model, dual radio model has already been developing to support inter-technology handover. Dual mode teminal is not fanciful.
  Could you help to write down how you implement on this?
  [Qin]What I understand in order to achieve seamless handover during the inter-technology handover, the UE is required to support dual mode,e.g.,WiMAX mode and CDMA mode.Before UE moves from WiMAX access network to the CDMA access network, the UE can attach to WIMAX and CDMA link simuteneusly,in this situation, the traffic can be bicasted to the UE through two links, the packet loss can be avoided wholly, however, the difficulty is when the UE frequently moves between hetergeneous network at high speed, there are great chanllenge for the UE to maintain the WiMAX link and CDMA link simuteneously.
    In the future, with the development of femto technolgy, single mode teminal can access mobile network via a femto basestation at home. I can not  judge whether single radio technology or dual radio technology will dominate the future market. Any way, from the technical perspective, I think the traditional internet IP model will be gradually evolving. multiple interface requirements will become one big issue to be considered, e.g., dynamic provision and routing , coordination and synchronization mechanisms are needed to be further study.

  it seems that dynamical provision and routing, coordination and synchronization will become more complicated, simple way make deployment easy, it is the way of Internet exist
  [Qin} I agree more optimized approach can be used to faciliate utilizing the network resource and better user experience.
  thanks

  -Hui

    -Qin
      ----- Original Message ----- 
      From: Hui Deng 
      To: [email-masked] 
      Sent: Thursday, January 08, 2009 11:13 PM
      Subject: [mif] Mailing list Issue

      Hello, all

      many thanks

      -Hui

--------------------------------------------------------------------------

---

From: Peny Yang <[email-masked]>
Date: Mon, 19 Jan 2009 10:24:07 +0800

Hi, Qin:

It's a interesting point. Check the lines below:

On Sat, Jan 17, 2009 at 7:03 PM, w53375 <[email-masked]> wrote:
> [Qin]What I understand in order to achieve seamless handover during the
> inter-technology handover, the UE is required to support dual
> mode,e.g.,WiMAX mode and CDMA mode.Before UE moves from WiMAX access network
> to the CDMA access network, the UE can attach to WIMAX and CDMA link
> simuteneusly,in this situation, the traffic can be bicasted to the UE
> through two links, the packet loss can be avoided wholly, however, the
> difficulty is when the UE frequently moves between hetergeneous network at
> high speed, there are great chanllenge for the UE to maintain the WiMAX link
> and CDMA link simuteneously.
[Peny] Are you talking about MIP case or non-MIP case?
In case of MIP, I agree with you.
In case of non-MIP, it seems in IETF there is no way to bi-cast the
streams to two different interfaces with two addresses of MN.
I just review the discussion in this list. Personally, I think MIF is
to solve the issue of GENERIC  IP model. As hui said previously, IP
model should no longer have the original assumption of "one link" as
many terminals have multiple links so far.
MIP has the way to support the multiple links in MN. I once did some
work on this as well. Basically, Generic MIP solution is not adequate
to make the seamless handover. It needs some low layer modifications
(such as one address for multiple link, prevent the high layers to
detecting the link transfer event, etc). All the problems originated
from the "one default link" design of current OS. Maybe it's the time
to do something to improve the generic IP model for multiple link
support in MN.

> [Qin} I agree more optimized approach can be used to faciliate utilizing the
> network resource and better user experience.
> thanks
[Peny] I agree with you two as well.

BRG
Peny

---

From: "Hui Deng" <[email-masked]>
Date: Mon, 19 Jan 2009 14:55:40 +0800

What Peng pointed out here is really what we would like to work on,
Many thanks

-Hui

2009/1/19 Peny Yang <[email-masked]>