Subject: Re: [mif] mif Digest, Vol 5, Issue 18

From: ma yc <[email-masked]>
Date: Tue, 17 Mar 2009 13:41:13 +0800

Hi, Min Hui,

I an also confused on the requirement 5.

As for the the flow directed to the multiple
interface node, why does the network side need
to decide which interface to forward the data?

The dst address of the packet should be used for routing.
The network just forwards the data according to the routing table.
I do not see the needs for interface selection to route the flow.

Also if you have the use case, i have the same concern
as macelo, which elememt will be in chcarge of
distributing the traffic?

Thank you.
Regards
Yuanchen

> Date: Mon, 16 Mar 2009 18:13:29 +0100
> From: marcelo bagnulo braun <[email-masked]>
> Subject: Re: [mif] about draft-hui-ip-multiple-connections-ps-02
> To: Min Hui <[email-masked]>
> Cc: mif <[email-masked]>
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
>

> >  5 Network side should be capable of distributing the IP flow
> >  according to some parameters, such as IP address prefix, network type
> >  and so on.
> >
> > i don't understnad what you mean by this one, could you expand?
> >
> > A: That is the policy in the network side. Corresponding to the policy
> > of sending data mentioned in the fourth bullet, the policy of
> > receiving data is also needed, which can be apply in the network side.
> > The network can determine forward a specific IP flow to which
> > interface of the destination host according to the policy.
> >
> >
>
> right, i see what you mean. I am not sure which element of the network
> would do that... i mean, are you assuming that all interfaces are being
> connected to the same ISP? If not, i am not sure how would you do this...
> > Regards, marcelo
> >

---

From: <[email-masked]>
Date: Tue, 17 Mar 2009 09:55:08 +0100

Hi,

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part de ma
> yc
> Envoyé : mardi 17 mars 2009 06:41
> À : [email-masked]
> Objet : Re: [mif] mif Digest, Vol 5, Issue 18
> 
> Hi, Min Hui,
> 

For instance, an aggregation router can be in charge of distributing the traffic.
But, as Marcelo pointed out, there is an issue when the user is connected to different ISPs; "which entity for distributing the traffic" and "how to harmonize network policies" in that case...

Regards,
Pierrick

> _______________________________________________
> mif mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mif

---

From: Min Hui <[email-masked]>
Date: Tue, 17 Mar 2009 17:25:25 +0800

Hi, Yuanchen

For the first question, there are two situations.

1. the host sends data using one of its interfaces, and the correspond
node reply to the address of this interface. it's has no problem, the
host will receive the reply by the same interface.
2. the network side initiate the communication, the host name will be
used in the DNS query to get a list of addresses, which one should be
choosed depends on the network side policy.

For the second question, the element would be the gateway which in
charge of all the interfaces, e.g. PDN GW in 3GPP architecture, LMA in
PMIP domain.

Thanks for your comments.

- Hui Min

---

From: ma yc <[email-masked]>
Date: Tue, 17 Mar 2009 19:02:00 +0800

Hi Min

Thank you for your reply. Please check inline.

Yuanchen

> choosed depends on the network side policy.
yuanchen> i agree with this scenario that the DNS query may result
in a list of addresses. But i still don't understand what "network
side initiated"
means. IP flow is end-to-end and the other end node should
make the DNS query and make the decision. Do you mean that the other end
node should get some information from somewhere in the network to help the
decision making? I think the requirement should be clarified.

> charge of all the interfaces, e.g. PDN GW in 3GPP architecture, LMA in
yuanchen> I do not think LMA is a good example for MIF, since the LMA is for
mobility management. PND GW in 3GPP also has the function of LMA.
Such scenario sounds more like extension to PMIP for multiple interface node
support. Netlmm may be better place for such topic.

---

From: ma yc <[email-masked]>
Date: Tue, 17 Mar 2009 19:07:15 +0800

Hi, Pierrick

The question  is whether such aggregation router applies
in all the scenarios. As marcelo and you pointed out, in
different ISPs case there will be big issue.

I think it may be better for the other end node which will send the packet,
not some mid-way gateways, to do interface selection. The selection
may be aimed by getting some additional information (policy) from the network.

Regards
Yuanchen

---

From: Min Hui <[email-masked]>
Date: Wed, 18 Mar 2009 16:56:59 +0800

Hi,  Yuanchen

pls see my reply in line. thx.

> decision making? I think the requirement should be clarified.
Sorry for misleading the "network side", the meaning is when the other
end node initiates the communication, it will not directly target one
of the addresses, the network element will make this decision and
return one address to this node.

> support. Netlmm may be better place for such topic.

I'll avoid to discuss mobility management in mif, but I'm not very
sure whether PDN GW example isn't suitable to be discussed in mif,
because it's a network element which is responsible for all the
interfaces in the 3GPP architecture, and doesn't only appear as a LMA.

---

From: ma yc <[email-masked]>
Date: Wed, 18 Mar 2009 18:36:17 +0800

hi Min

Thank you for your reply, please check inline.

Yuanchen

> return one address to this node.
yuanchen> This seems reasonable. I think the description for
item 5 can be improve to reflect that.

> interfaces in the 3GPP architecture, and doesn't only appear as a LMA.
yuanchen> If you are talking about GTP based S5/S8 interface etc. , i agree
PDN GW is not only mobility related. But in 3GPP the mutiple access PDNs topic
is still based on MIP solutions, multiple coa, flow binding, etc. Let's see
what will happen in 3GPP...

---

From: marcelo bagnulo braun <[email-masked]>
Date: Thu, 19 Mar 2009 10:33:13 +0100

> return one address to this node.

I don't understand this
Usually, the DNS is the one that returns the addresses, Are you 
considering that the network influences the DNS responses or are you 
thinking in something else?

Regards, marcelo

---

From: Min Hui <[email-masked]>
Date: Fri, 20 Mar 2009 17:06:16 +0800

Hi, marcelo

2009/3/19 marcelo bagnulo braun <[email-masked]>:
> Usually, the DNS is the one that returns the addresses, Are you considering
> that the network influences the DNS responses or are you thinking in
> something else?

I mean the network influences the DNS responses. DNS need to pick one
address among multiple addresses and return it to the node, the
network could have some selection policy to influence the DNS
responses.

---

From: marcelo bagnulo braun <[email-masked]>
Date: Fri, 20 Mar 2009 16:21:07 +0100

> network could have some selection policy to influence the DNS

we need to look into this a bit more in detail...i am not sure it is the 
best idea to have the network tweaking the dns responses.

regards, marcelo

---

From: Scott Brim <[email-masked]>
Date: Mon, 23 Mar 2009 07:26:51 -0700

marcelo bagnulo braun allegedly wrote on 03 20 2009 8:21 AM:
>>> considering

I believe you are saying the same thing.  DNS is the one that responds
but the DNS takes locality into consideration.  We have this with split
DNS.  No?

---

From: ma yc <[email-masked]>
Date: Tue, 24 Mar 2009 01:08:14 +0800

> but the DNS takes locality into consideration.  We have this with split
This is different from split DNS. Split DNS is about how a node with multiple
interfaces selects DNS server. This thread is about when other node does DNS
query for a node with multiple interfaces, the DNS server has the possiblity to
response a series of  IP addresses. Whether the DNS response in this scenario
is infulenced by the network should be considered.

---

From: Scott Brim <[email-masked]>
Date: Mon, 23 Mar 2009 13:43:51 -0700

Excerpts from ma yc on Tue, Mar 24, 2009 01:08:14AM +0800:
> > >>>> Sorry for misleading the "network side", the meaning is when
> > >>>> the other end node initiates the communication, it will not
> > >>>> directly target one of the addresses, the network element
> > >>>> will make this decision and return one address to this node.
> > >>>>
> > >>>>
> > >>> I don't understand this Usually, the DNS is the one that
> > >>> returns the addresses, Are you considering that the network
> > >>> influences the DNS responses or are you thinking in something
> > >>> else?
> > >>>
> > >>
> > >> I mean the network influences the DNS responses. DNS need to
> > >> pick one address among multiple addresses and return it to the
> > >> node, the network could have some selection policy to influence
> > >> the DNS responses.
> > >>
> > >
> > > we need to look into this a bit more in detail...i am not sure
> > > it is the best idea to have the network tweaking the dns
> > > responses.
> > >
> > > regards, marcelo
> >
> > I believe you are saying the same thing.  DNS is the one that
> > responds but the DNS takes locality into consideration.  We have
> > this with split DNS.  No?
> >
> This is different from split DNS. Split DNS is about how a node with
> multiple interfaces selects DNS server. This thread is about when
> other node does DNS query for a node with multiple interfaces, the
> DNS server has the possiblity to response a series of  IP addresses.
> Whether the DNS response in this scenario is infulenced by the
> network should be considered.

I was referring to, for example,
<http://en.wikipedia.org/wiki/Split-horizon_DNS>.  "... split-horizon
DNS, split-view DNS, or split-brain DNS is the facility of a Domain
Name System (DNS) implementation to provide different sets of DNS
information, selected by, usually, the source address of the DNS
request."

---

From: ma yc <[email-masked]>
Date: Tue, 24 Mar 2009 13:35:13 +0800

> information, selected by, usually, the source address of the DNS
well, seems we have different references
as for split DNS i was referring to the mif drafts.
draft-blanchet-mif-problem-statement-00
draft-savolainen-mif-dns-server-selection-00

In Min Hui's comment the network could have some
selection policy to influence the DNS responses.
I think the intention for the selection policy is to
select interface based on the mif node status.
The split horizon DNS in your reference does not
seem to take this into consideration.