Subject: [mif] question about draft-montenegro-mif-multihoming-00.txt

From: marcelo bagnulo braun <[email-masked]>
Date: Mon, 16 Mar 2009 21:59:19 +0100

Hi,

Read the draft, very clear and useful, thanks for writing it.

I only have one clarifying question at this point:

In section 6. DNS Query Behavior it reads:

   The DNS Client service queries the DNS servers in the following
   order:

   1. The DNS Client service sends the name query to the first DNS
     server on the preferred interface's list of DNS servers and waits
     one second for a response.

I understand then that Windows vista still uses the preferred interface 
concept, not for routing but yes for the DNS queries, right?

And the preferred interface is the first one bound to the TCP ip stack 
while booting, right?

So, how this works with dual faced DNS?
I understand that if the dual faced DNS only provides answer for a given 
query over one of the faces, then this works more or less fine cause 
windows retries (i say more or less cause it may result in latency, i guess)

But if the dual faced does provide replies in both faces, but different 
addresses, then how does this works? I mean, i guess it should work 
cause if the answer of the dns query returns for instance a private 
address, then rfc3484 longest prefix match rule will prefer the source 
address with the same scope and will use the interface with the private 
address, is that correct? Is it then accurate to say that the source 
address selection mechanism is used to select the right outgoing 
interface in case the routing table doesn't provide a unique putgoing 
interface? (i mean, the interface selection for outgoing packet would be 
first determined by routing and if the routing doesn't select a single 
interface, then selected based on the source address?)

Regards, marcelo

---

From: gabriel montenegro <[email-masked]>
Date: Wed, 18 Mar 2009 00:28:41 -0700 (PDT)

Please see inline.

----- Original Message ----
> Read the draft, very clear and useful, thanks for writing it.

Thanks, Marcelo.

> I understand then that Windows vista still uses the preferred interface concept, 
> not for routing but yes for the DNS queries, right?

Right, as stated in the terminology section.

> And the preferred interface is the first one bound to the TCP ip stack while 
> booting, right?

That's the initial setting, but this can be modified programmatically or via UI.

> I understand that if the dual faced DNS only provides answer for a given query 
> over one of the faces, then this works more or less fine cause windows retries 
> (i say more or less cause it may result in latency, i guess)

You guess right, but see below.

> addresses, then how does this works? I mean, i guess it should work cause if the 
> answer of the dns query returns for instance a private address, then rfc3484 
> longest prefix match rule will prefer the source address with the same scope and 
> will use the interface with the private address, is that correct? Is it then 
> accurate to say that the source address selection mechanism is used to select 
> the right outgoing interface in case the routing table doesn't provide a unique 
> putgoing interface? (i mean, the interface selection for outgoing packet would 
> be first determined by routing and if the routing doesn't select a single 

Up to Vista, RFC3484 does not apply to
determine which interface is used to send out a DNS query. The
"preferred" interface is used. Because of retries, eventually the
right interface will hopefully get used (not perfect, though). 

Windows 7 introduces a new feature called Direct Access: 

http://www.microsoft.com/directaccess

As part of that, the new Name Resolution Policy Table (NRPT) introduces the capability 
to define DNS servers per name space (per interface already exists, as the draft mentions).

If you want more info on this, please download the "DirectAccess Early Adopter's Guide" from
the above web site.

Gabriel