Subject: [mif] Two Drafts: DHCPv6 extensions for address selection and route information

From: Tao Sun <[email-masked]>
Date: Thu, 5 Mar 2009 12:55:25 +0800

Dear all,

Here are two drafts. Both are extensions of DHCPv6 options.
One is extended for convey RFC3484 default address selection policy.
The other extension is for sending route information to update routing
table.
Details are as follows. Comments are welcome.

Tao

http://www.ietf.org/internet-drafts/draft-sun-mif-address-policy-dhcp6-00.txt

Title:   Address Selection Policy Configuration by DHCPv6 Option
Abstract:
For hosts with multiple interfaces, the problem is how to make it run
several applications simultaneously on variant interfaces such as
GPRS, Wifi etc. To achieve this, one way is to select appropriate IP
address so that the packets can be sent to the corresponding
interface for forwarding. RFC 3484 defines a ''policy table'' for
default IP address selection. This document extends the DHCPv6 option
message so that the policy table can be dynamically updated.

http://www.ietf.org/internet-drafts/draft-sun-mif-route-config-dhcp6-00.txt
Title:   Route Configuration by DHCPv6 Option for Hosts with Multiple
Interfaces
Abstract:
For hosts with multiple interfaces, the problem is how to make it run
several applications simultaneously on variant interfaces such as
GPRS, Wifi etc. To achieve this, one key issue here is to select
appropriate route according to RFC 1122. The approach presented in
this document is extending DHCPv6 option to configure route tables of
the hosts.

---

From: Arifumi Matsumoto <[email-masked]>
Date: Mon, 9 Mar 2009 14:03:03 +0900

Hi,

I found draft-sun-mif-address-policy-dhcp6-00.txt largely overlaps
our ongoing draft.
http://tools.ietf.org/html/draft-fujisaki-dhc-addr-select-opt-06

Updated version 07 will be posted soon.

I hope this helps.

On 2009/03/05, at 13:55, Tao Sun wrote:

> The other extension is for sending route information to update  
> routing table.
> Title:   Route Configuration by DHCPv6 Option for Hosts with  
> Multiple Interfaces
> Abstract:
> _______________________________________________
> mif mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mif

--
Arifumi Matsumoto
   Secure Communication Project
   NTT Information Sharing Platform Laboratories
   E-mail: [email-masked]

---

From: Tao Sun <[email-masked]>
Date: Mon, 9 Mar 2009 14:29:39 +0800

Thank you for pointing out this reference.  The draft will not be updated
any more unless I find some major new on this.

Tao

---

From: Tao Sun <[email-masked]>
Date: Tue, 10 Mar 2009 04:58:07 +0800

Dear Arifumi and all,

Two drafts are updated that are intended to fulfill policy merging in the
scenarios met by MIF.
For DHCPv6 conveying routing information, a "Preference" value is added to
indicate the priority of one route.
http://www.ietf.org/internet-drafts/draft-sun-mif-route-config-dhcp6-01.txt

For DHCPv6 conveying address selection policy, a "IF-Based" boolean value is
added to indicate whether the policy is applied for one interface or for all
the interfaces of the host.

http://www.ietf.org/internet-drafts/draft-sun-mif-address-policy-dhcp6-01.txt

Dear Arifumi, following your reference, I have seen that your group has done
fruiteful work beyond the second draft. Could you kindly to comment on the
updated draft?  This will help me to evaluate whether the updated one makes
sense and worth further investigation. Thanks a lot.

Tao

On Mon, Mar 9, 2009 at 2:29 PM, Tao Sun <[email-masked]> wrote:

>   On Mon, Mar 9, 2009 at 1:03 PM, Arifumi Matsumoto <[email-masked]>wrote:
>
>> Hi,
>>

---

From: Arifumi Matsumoto <[email-masked]>
Date: Wed, 11 Mar 2009 18:30:02 +0900

Hi,

> Dear Arifumi and all,

I believe I'm in this mif list, so you do not need to CC me.

>
> Two drafts are updated that are intended to fulfill policy merging  
> in the scenarios met by MIF.
> For DHCPv6 conveying routing information, a "Preference" value is  
> added to indicate the priority of one route.
> For DHCPv6 conveying address selection policy, a "IF-Based" boolean  
> value is added to indicate whether the policy is applied for one  
> interface or for all the interfaces of the host.
> Dear Arifumi, following your reference, I have seen that your group  
> has done fruiteful work beyond the second draft. Could you kindly to  
> comment on the updated draft?  This will help me to evaluate whether  
> the updated one makes sense and worth further investigation. Thanks  
> a lot.

At a glance, I could not get how to process this "IF-Based" flag at  
DHCPv6 client.
This is because the policy table is defined to be host global  
information.

Regards,

> Thank you for pointing out this reference.  The draft will not be  
> updated any more unless I find some major new on this.
>
> Tao
>

---

From: Tao Sun <[email-masked]>
Date: Thu, 12 Mar 2009 15:33:22 +0800

Hi Arifumi,

I got your point here especially for source address selection. Thanks

Tao

On Wed, Mar 11, 2009 at 5:30 PM, Arifumi Matsumoto <[email-masked]>wrote:

>> For DHCPv6 conveying address selection policy, a "IF-Based" boolean value
>> is added to indicate whether the policy is applied for one interface or for
>> all the interfaces of the host.
>>
>> Dear Arifumi, following your reference, I have seen that your group has
>> done fruiteful work beyond the second draft. Could you kindly to comment on
>> the updated draft?  This will help me to evaluate whether the updated one
>> makes sense and worth further investigation. Thanks a lot.
>>
>
> At a glance, I could not get how to process this "IF-Based" flag at DHCPv6
> client.
> This is because the policy table is defined to be host global information.
>
> Regards,
>
>
>
>
>
>> Tao
>>

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 12 Mar 2009 07:48:33 -0700 (PDT)

Folks,
  There is another draft 
http://ietfreport.isoc.org/all-ids/draft-sarikaya-mif-dhcpv6solution-01.txt

I think this draft is the best 

Regards,

Behcet

________________________________
From: Tao Sun <[email-masked]>
To: [email-masked]
Sent: Thursday, March 12, 2009 2:33:22 AM
Subject: Re: [mif] Two Drafts: DHCPv6 extensions for address selection and route information

Hi Arifumi, 

Tao

On Wed, Mar 11, 2009 at 5:30 PM, Arifumi Matsumoto <[email-masked]> wrote:

Hi,

Dear Arifumi and all,

Two drafts are updated that are intended to fulfill policy merging in the scenarios met by MIF.
For DHCPv6 conveying routing information, a "Preference" value is added to indicate the priority of one route.
http://www.ietf.org/internet-drafts/draft-sun-mif-route-config-dhcp6-01.txt

For DHCPv6 conveying address selection policy, a "IF-Based" boolean value is added to indicate whether the policy is applied for one interface or for all the interfaces of the host.
 http://www.ietf.org/internet-drafts/draft-sun-mif-address-policy-dhcp6-01.txt

Dear Arifumi, following your reference, I have seen that your group has done fruiteful work beyond the second draft. Could you kindly to comment on the updated draft?  This will help me to evaluate whether the updated one makes sense and worth further investigation. Thanks a lot.

At a glance, I could not get how to process this "IF-Based" flag at DHCPv6 client.
This is because the policy table is defined to be host global information.

Regards, 

Tao

On Mon, Mar 9, 2009 at 2:29 PM, Tao Sun <[email-masked]> wrote:
Thank you for pointing out this reference.  The draft will not be updated any more unless I find some major new on this.

Tao

I hope this helps.

Dear all,

Here are two drafts. Both are extensions of DHCPv6 options.
One is extended for convey RFC3484 default address selection policy.
The other extension is for sending route information to update routing table.
Details are as follows. Comments are welcome.

Tao

Title:   Route Configuration by DHCPv6 Option for Hosts with Multiple Interfaces