Subject: [mif] questions for clarification in MPVD arch

From: GangChen <[email-masked]>
Date: Thu, 12 Jun 2014 09:56:32 +0800

WG,

We intend to update the draft-ietf-mif-happy-eyeballs-extension to
align with MPVD arch.
Questions have to be clarified in order to proceed the progress.

Is there any conclusion if PVD rules conflict with RFC6731 and RFC4191?

Two particular cases are:

1)  Name resolution

Let's say, host A receives RDNSS Selection DHCPv6 Option with domain
name of example.com on interface 1.
It also receives PVD-ID of example.com on interface 2.

If the host A makes query for a.example.com, which interface should be selected

2) next hop

draft-ietf-mif-mpvd-arch-01 states:

   For each obtained destination
   address, the node shall perform a next-hop lookup among routers,
   associated with that PVD.

Does it means the host likely excludes Route Information Option on the
routers which can't associate with the PVD?

Many thanks

Gang

---

From: "Hui Deng" <[email-masked]>
Date: Mon, 16 Jun 2014 10:08:01 +0800

这是DAN的意思，还是你的想法？

-----Original Message-----
From: mif [mailto:[email-masked]] On Behalf Of GangChen
Sent: Thursday, June 12, 2014 9:57 AM
To: mif
Cc: draft-ietf-mif-happy-eyeballs-extension
Subject: [mif] questions for clarification in MPVD arch

WG,

We intend to update the draft-ietf-mif-happy-eyeballs-extension to align with MPVD arch.
Questions have to be clarified in order to proceed the progress.

1)  Name resolution

Let's say, host A receives RDNSS Selection DHCPv6 Option with domain name of example.com on interface 1.
It also receives PVD-ID of example.com on interface 2.

2) next hop

Does it means the host likely excludes Route Information Option on the routers which can't associate with the PVD?

Many thanks

Gang

_______________________________________________
mif mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mif

---

From: "Hui Deng" <[email-masked]>
Date: Mon, 16 Jun 2014 10:12:51 +0800

Excuse me, I have sent to the wrong email address, sorry for mistake.

Best regards,

-Hui

-----Original Message-----
From: mif [mailto:[email-masked]] On Behalf Of Hui Deng
Sent: Monday, June 16, 2014 10:08 AM
To: 'GangChen'; 'mif'
Cc: 'draft-ietf-mif-happy-eyeballs-extension'
Subject: Re: [mif] questions for clarification in MPVD arch

这是DAN的意思，还是你的想法？

-----Original Message-----
From: mif [mailto:[email-masked]] On Behalf Of GangChen
Sent: Thursday, June 12, 2014 9:57 AM
To: mif
Cc: draft-ietf-mif-happy-eyeballs-extension
Subject: [mif] questions for clarification in MPVD arch

WG,

1)  Name resolution

2) next hop

Many thanks

Gang