Subject: [mif] WGLC for draft-ietf-mif-mpvd-dhcp-support

From: Hui Deng <[email-masked]>
Date: Tue, 14 Jul 2015 23:16:05 +0800

Hello all
 
This email initiates 3 weeks WGLC for below document:
http://datatracker.ietf.org/doc/draft-ietf-mif-mpvd-dhcp-support/
 
According to our working group discussion, we need 4-5 substantive reviews for this document before we move it to the IESG
 
This WGLC will end on Aug. 5th.
 
Thanks for your review.
 
DENG Hui

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Sat, 18 Jul 2015 13:24:01 +0000

Hi:

A few items regarding this draft:

1. There is still "[TODO: Should we add any other exclusions?]" in section 6. Shouldn't this be resolved before sending this draft on?

2. RFC 7227 and general DHCPv6 options handling has avoided explicit ordering of options (or encapsulated options). So, why specify: "The OPTION_PVD_AUTH option MUST be the last option inside the OPTION_PVD option" in section 5?

I presume (though it is not explicitly stated) that this is because this option contains the signature and obviously one can't generate the signature of the signature. But given how the signature is calculated, why is this even an issue?

Can we avoid enforcing the order here? I cannot see how this matters and what the benefit is?

If there is a reason for this ordering, please explain.

Perhaps this comes from SEND document, but even then there is the question as to why this is needed.

Anyway, these are some initial comments. 

- Bernie

-----Original Message-----
From: dhcwg [mailto:[email-masked]] On Behalf Of Tomek Mrugalski
Sent: Wednesday, July 15, 2015 6:00 AM
To: dhcwg
Cc: [email-masked]
Subject: [dhcwg] WGLC in MIF WG for draft-ietf-mif-mpvd-dhcp-support

Gentlepeople,

There's working group last call going in the mif working group for the multiple provisioning domains proposal. One of those drafts
(draft-ietf-mif-mpvd-dhcp-support) defines DHCPv6 options. I'd appreciate any comments you may have on this. Make sure you post your comments in a way that will reach the draft authors - either cc them directly or perhaps send to both dhc and mif. They may not be subscribed to the dhc list.

Tomek

-------- Forwarded Message --------
Subject: 	[mif] WGLC for draft-ietf-mif-mpvd-dhcp-support
Date: 	Tue, 14 Jul 2015 23:16:05 +0800
From: 	Hui Deng <[email-masked]>
To: 	[email-masked] <[email-masked]>, Margaret <[email-masked]>

Hello all

Thanks for your review.

DENG Hui

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Erik Kline <[email-masked]>
Date: Mon, 20 Jul 2015 13:39:04 +0200

I think the encapsulation matters so that you can have data for PVD1
and data for PVD2 clearly and correctly associated in one logical
response.

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 20 Jul 2015 11:47:23 +0000

I don't think that applies as each PVD is a separate option with encapsulations, including the OPTION_PVD_AUTH option. This PVD_AUTH option covers each PVD.

- Bernie (from iPad)

> On Jul 20, 2015, at 7:39 AM, Erik Kline <[email-masked]> wrote:
>

---

From: Erik Kline <[email-masked]>
Date: Mon, 20 Jul 2015 14:06:39 +0200

I misunderstood your comment: you referred to avoiding ordering but I
misread as "avoiding encapsulated options".  Apologies.