Subject: [mile] Including enumeration values for external registries in IODEF documents

From: <[email-masked]>
Date: Wed, 28 Mar 2012 09:22:31 -0400

Hello,

As part of yesterday's WG meeting, we decided that it was a good idea to break out the use case of including enumeration value information in a specified format directly in IODEF (via the reference class) from Take's draft (structured cybersecurity information) that enables the inclusion of XML documents within IODEF.

Could we have volunteers to work on this draft?  The draft will specify a format to include relevant enumeration values in an IODEF document so that they can be parsed.  The value would be placed in the Reference class that also includes a URL and description.  Examples may include CVE numbers or other enumerated values associated with relevant registries to incident response.  The solution should consider international representation of values.  This should be a pretty straightforward draft.

Thank you in advance!
Kathleen

---

From: Adam Montville <[email-masked]>
Date: Wed, 28 Mar 2012 15:22:51 +0000

Hi Kathleen,

I'll take a swing at working on this issue.

Adam

On 3/28/12 3:22 PM, "[email-masked]"
<[email-masked]> wrote:

>Hello,
>
>As part of yesterday's WG meeting, we decided that it was a good idea to
>break out the use case of including enumeration value information in a
>specified format directly in IODEF (via the reference class) from Take's
>draft (structured cybersecurity information) that enables the inclusion
>of XML documents within IODEF.
>
>Could we have volunteers to work on this draft?  The draft will specify a
>format to include relevant enumeration values in an IODEF document so
>that they can be parsed.  The value would be placed in the Reference
>class that also includes a URL and description.  Examples may include CVE
>numbers or other enumerated values associated with relevant registries to
>incident response.  The solution should consider international
>representation of values.  This should be a pretty straightforward draft.
>
>Thank you in advance!
>Kathleen
>_______________________________________________
>mile mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/mile
>

---

From: <[email-masked]>
Date: Wed, 28 Mar 2012 11:29:27 -0400

Thank you, Adam!
________________________________________
From: Adam Montville [[email-masked]]
Sent: Wednesday, March 28, 2012 11:22 AM
To: Moriarty, Kathleen; [email-masked]
Subject: Re: [mile] Including enumeration values for external registries in IODEF documents

Hi Kathleen,

Adam