Subject: [mile] Adoption of draft-trammell-mile-iodef-xmlreg-01 as a MILE WG item

From: <[email-masked]>
Date: Wed, 28 Mar 2012 08:25:09 -0400

Hello,

At the MILE WG meeting yesterday, there was consensus in the room to adopt draft-trammell-mile-iodef-xmlreg-01 as a working group item. I would like to confirm this consensus call on the list; if anyone has additional objections or comments about the adoption of this draft, please let them be known on the list by next Tuesday.

http://tools.ietf.org/html/draft-trammell-mile-iodef-xmlreg-01

Thank you!
Kathleen

---

From: "Martin, Robert A." <[email-masked]>
Date: Wed, 28 Mar 2012 08:41:58 -0400

I agree that this topic should be adopted as a work item.

One thought I would offer is to consider whether we should be 
restricting it to just registries of XML Namespaces and Schemas or 
should we consider adding other formats/structures of relavent security 
information within this work like simple id-based registries?

Regards,

Bob

On 3/28/12 8:25 AM, [email-masked] wrote:
> _______________________________________________
> mile mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mile
>

---

From: <[email-masked]>
Date: Wed, 28 Mar 2012 07:50:26 -0500

I would like to express my support for this document to be a working group draft.

Kent Landfield
Director Content Strategy, Architecture and Standards

McAfee | An Intel Company
5000 Headquarters Dr.
Plano, Texas 75024

Direct: +1.972.963.7096
Mobile: +1.817.637.8026
Web: www.mcafee.com<http://www.mcafee.com/>

From: Kathleen Moriarty <[email-masked]<mailto:[email-masked]>>
Date: Wed, 28 Mar 2012 07:25:09 -0500
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [mile] Adoption of draft-trammell-mile-iodef-xmlreg-01 as a MILE WG item

Hello,

Thank you!
Kathleen
_______________________________________________
mile mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mile

---

From: "Waltermire, David A." <[email-masked]>
Date: Thu, 29 Mar 2012 02:48:17 -0400

I am also in favor of this draft.

I like the idea of addressing simple id formats in addition to XML formats.  I see three data points that are relevant to references using simple ids.

1) The type of the id - A name that indicates the format of the identifier as a pointer into the registry for simple id formats.  This could be a simple label (e.g. CVE, CVE-1) similar to the schema name in the RID IANA registery for XML schemas.

http://www.iana.org/assignments/rid/rid.xml#xml-schemas

In addition to the "id name", the registry could contain a reference to a RFC that describes the format(s) of each simple identifier type.

2) The id instance in the population - For example: CVE-2012-1907.

3) References to resources that present information about the issue related to the identifier. In the case of a CVE this could be a reference to a vulnerability database or other sources of information (e.g. content repositories, etc.)

An IODEF reference using this format could look like:

<reference>
 <referenceName>cve-1#CVE-2012-1907</referenceName>
 <url>http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2012-1907</url>
 <url>https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1907</url>
 <description>A pointer to CVE-2012-1907.</description>
</reference>

Thoughts?
Dave
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Martin, Robert A. [[email-masked]]
Sent: Wednesday, March 28, 2012 2:41 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [mile] Adoption of draft-trammell-mile-iodef-xmlreg-01 as a MILE WG        item

Regards,

Bob