Subject: [mile] [IANA #910912] Evaluation: <draft-ietf-mile-rfc5070-bis-22.txt> to Proposed Standard

From: "Amanda Baber via RT" <[email-masked]>
Date: Thu, 02 Jun 2016 06:21:34 +0000

IESG:

IANA NOT OK.  Comments in tracker
IANA Actions - NOT OK

How to populate these 33 registries is unclear. 

For example, Section 3.9 says, “These values are maintained in the ‘Contact-role’ IANA registry per Section 10.2” and then presents a list of 19 items. Is the “Contact-role” registry made up of the single entry in the IANA Considerations table, as the IANA Considerations section seems to indicate, or does it consist of the 19 items in Section 3.9? If the latter, where should the entries in 10.2 table's "IV (Value)" column be placed?

Thank you,

Amanda Baber
IANA Senior Specialist
ICANN

---

From: "Roman D. Danyliw" <[email-masked]>
Date: Thu, 2 Jun 2016 13:09:30 +0000

Hello Amanda!

Sorry for the confusion.  Let me clarify below ...

> -----Original Message-----
> From: Amanda Baber via RT [mailto:[email-masked]]
> Sent: Thursday, June 02, 2016 2:22 AM
> Cc: [email-masked]; [email-masked]
> Subject: [IANA #910912] Evaluation: <draft-ietf-mile-rfc5070-bis-22.txt> to
> Proposed Standard
> 
> IESG:
> 
> For example, Section 3.9 says, “These values are maintained in the ‘Contact-
> role’ IANA registry per Section 10.2” and then presents a list of 19 items. Is
> the “Contact-role” registry made up of the single entry in the IANA
> Considerations table, as the IANA Considerations section seems to indicate,
> or does it consist of the 19 items in Section 3.9? If the latter, where should
> the entries in 10.2 table's "IV (Value)" column be placed?

Taking "Contact-role" as an example, the desired outcome is the following:

--[ snip ]--
Registry name: Contact-role

Value, Description, Reference
"creator", "The entity that generate the document.", RFC-num-of-this-document
"reporter, "The entity that reported the information.", RFC-num-of-this-document
"admin", "An administrative contact or business owner for an asset or organization.", RFC-num-of-this-document
... [ entry #4 - 18] ...
"ext-value", "A value used to indicate that this attribute is extended and the actual value is provided using the corresponding ext-* attribute." , RFC-num-of-this-document
--[ snip ]--

Yes, each enumerate value will be a distinct entry in a given registry.  Contact-role would have 19 entries.

I realized that there is no text saying that a reference to this document should be added to each registry entries in the Reference column.

Roman

---

From: "Roman D. Danyliw" <[email-masked]>
Date: Thu, 2 Jun 2016 13:09:30 +0000

Hello Amanda!

--[ snip ]--

Roman

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Thu, 02 Jun 2016 18:43:09 +0000

Hi Roman,

One more question: should the contents of Section 10.2's "IV (Value)" column appear anywhere in the registry? Should it be the label for that registry's value column?

thanks,
Amanda

On Thu Jun 02 13:24:34 2016, [email-masked] wrote:
> "ext-value", "A value used to indicate that this attribute is extended
> and the actual value is provided using the corresponding ext-*
> attribute." , RFC-num-of-this-document
> --[ snip ]--
> 
> Yes, each enumerate value will be a distinct entry in a given
> registry.  Contact-role would have 19 entries.
> 
> I realized that there is no text saying that a reference to this
> document should be added to each registry entries in the Reference
> column.
> 
> Roman

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Thu, 09 Jun 2016 18:56:34 +0000

Hi Roman,

One more question: should the contents of Section 10.2's "IV (Value)" column appear anywhere in the registry? For example, should it be the label for that registry's value column? For example, in the CDNI Payload Types registry at http://www.iana.org/assignments/cdni-parameters, the label for the value column is "Payload Type." 

thanks,
Amanda

---

From: "Roman D. Danyliw" <[email-masked]>
Date: Fri, 10 Jun 2016 20:13:21 +0000

Good afternoon Amanda!

Thanks for the example.  Could you please make the column names:

** "Attribute Value"
** "Description"
** "Reference"

Back to my earlier example:

Sub-Registry name: Contact-role
Attribute Value = creator
Description = The entity that generate the document.
Reference = RFC-num-of-this-document

Roman

> From: Amanda Baber via RT [mailto:[email-masked]]
> Sent: Thursday, June 09, 2016 2:57 PM
> Cc: [email-masked]
> Subject: [IANA #911630] RE: Evaluation: <draft-ietf-mile-rfc5070-bis-22.txt>
> to Proposed Standard
> 
> Hi Roman,
> 
> One more question: should the contents of Section 10.2's "IV (Value)"
> column appear anywhere in the registry? For example, should it be the label
> for that registry's value column? For example, in the CDNI Payload Types
> registry at http://www.iana.org/assignments/cdni-parameters, the label for
> the value column is "Payload Type."
> 
> thanks,
> Amanda
> 
> > > Subject: [IANA #910912] Evaluation: <draft-ietf-mile-rfc5070-bis-
> > > 22.txt> to Proposed Standard
> > >
> > > IESG:
> > >
> > > role’ IANA registry per Section 10.2” and then presents a list of 19
> > > items. Is the “Contact-role” registry made up of the single entry in
> > > the IANA Considerations table, as the IANA Considerations section
> > > seems to indicate, or does it consist of the 19 items in Section
> > > 3.9? If the latter, where should the entries in 10.2 table's "IV
> > > (Value)" column be placed?
> >
> > "creator", "The entity that generate the document.", RFC-num-of-this-
> > document "reporter, "The entity that reported the information.",
> > RFC-num-of- this-document "admin", "An administrative contact or
> > business owner for an asset or organization.",
> > RFC-num-of-this-document ... [ entry #4 - 18] ...
> > attribute." , RFC-num-of-this-document --[ snip ]--
> >