Subject: [mile] Benoit Claise's No Objection on draft-ietf-mile-iodef-guidance-10: (with COMMENT)

From: Benoit Claise <[email-masked]>
Date: Wed, 30 Aug 2017 03:19:10 -0700

Benoit Claise has entered the following ballot position for
draft-ietf-mile-iodef-guidance-10: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-mile-iodef-guidance/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I noted the exact same point as Ben regarding the intended status.
This is really a BCP, right? https://tools.ietf.org/html/rfc2026#section-5
However, I believe the combination of BCP and RFC2119 language is fine.
If I take a single sentence, as an example:

   An IODEF document MUST include
   at least an Incident class, an xml:lang attribute that defines the
   supported language an the IODEF version attribute.

Is this a specification coming from RFC 7970 (which I could not find, by
browsing for a few minutes)? Or is this is a new specification of this "BCP"?

See also Qin's OPS DIR feedback.

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Wed, 30 Aug 2017 14:03:56 +0000

Thank you Benoit.

Good catch on xml:lang. The "MUST" for xml:lang is not normative language we are introducing. It comes from RFC7970 where the XML schema for the Incident class defines the xml:lang attribute as non-optional/mandatory. The truth is that the text in RFC7970 does not reflect that, as the text mentions in as optional. The authors did intend to have xml:lang as mandatory as it is in the XML schema, so we are trying to get the discrepancy in the text fixed in RFC7970 with an errata. 

In summary, the "MUST" for xml:lang is not something new we are introducing in this draft.

Panos

-----Original Message-----
From: mile [mailto:[email-masked]] On Behalf Of Benoit Claise (bclaise)
Sent: Wednesday, August 30, 2017 6:19 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; Qin Wu <[email-masked]>; [email-masked]
Subject: [mile] Benoit Claise's No Objection on draft-ietf-mile-iodef-guidance-10: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Is this a specification coming from RFC 7970 (which I could not find, by browsing for a few minutes)? Or is this is a new specification of this "BCP"?

_______________________________________________
mile mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mile