Subject: [Mip4] Last Call: 'Mobile IPv4 Dynamic Home Agent Assignment' to Proposed Standard

From: The IESG <[email-masked]>
Date: Wed, 12 Jan 2005 10:53:26 -0500

The IESG has received a request from the Mobility for IPv4 WG to consider the 
following document:

- 'Mobile IPv4 Dynamic Home Agent Assignment '
   <draft-ietf-mip4-dynamic-assignment-03.txt> as a Proposed Standard

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action.  Please send any comments to the
[email-masked] or [email-masked] mailing lists by 2005-01-26.

The file can be obtained via
http://www.ietf.org/internet-drafts/draft-ietf-mip4-dynamic-assignment-03.txt

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: [email-masked]
Date: Mon, 24 Jan 2005 14:56:21 +0200

Figures 2 and 3 and bullet 5 for the figures give the impression that
the second registraiton request bypasses the foreign agent. Surly
all requests must traverse the FA (if one is present), mustn't they?

Just as a note, a simpler and perhaps more backward compatible way to address 
one of the issues addressed in the draft is to use subnet directed
broadcast method described in RFC3344 but with a unicast address:
1. The MN sends a RRQ to a unicast HA address
2. If the HA that receives the RRQ wants to redirect the MN to another HA
   it replies with the "unknown HA" failure code and sets the redirected HA
   in the HA field of the RRP as specified in RFC3344.
3. The MN registrers with the new HA.

The unicast address used in step 1 may either be an address owned
by a single specific HA, or it may be a virtual HA cluster address
which is directed to an appropriate HA address in the home network
(with whatever means, e.g. ARP or routing tables). This way
one can achieve lightweight load balancing and high-availability while
providing backward compatiblity. We have a couple of years of good
real-world experiences using this method in our product.

This method is of course not as flexible as the one described in the
draft and does not address all issues. But it may perhaps be worthwhile
to consider the method I described in scenarios where it is sufficient
as it is (nearly) backwards compatible from the MN point-of-view
(provided it does not differient between broadcast addresses and unicast
addresses) and does not introduce new registration message extensions.

  Bjorn Andersson

-- 
Björn Andersson <[email-masked]>
PGP id 5AFC144B
Mobile +358 40 7723074

---

From: "Alpesh" <[email-masked]>
Date: Sun, 30 Jan 2005 22:33:55 -0800

Bjorn -

Thanks for the comments. Please see inline:

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Monday, January 24, 2005 4:56 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Mip4] Last Call: 'Mobile IPv4 Dynamic Home 
> Agent Assignment' toProposed Standard
> 

Agree on the above two points - it was an oversight. Definitely the RRQ
traverses the FA. We will update the diagrams and the associated text to
clarify this. Thanks for pointing it out.

> 3. The MN registrers with the new HA.

I understand your suggestion here. Unfortunately, we will like to use the
all zero/one
address as an explicit indication for dynamic HA assignment. This is the
explicit mechanism defined in the base spec and we are enhancing on it.

Per RFC3344, I believe that the HA can reject the RRQ as you mention even
today with code 139 (not sure with the code value).

Regards
Alpesh
> >      Charter page: 
> http://www.ietf.org/html.charters/mip4-charter.html

---

From: keshav <[email-masked]>
Date: Mon, 31 Jan 2005 12:49:25 +0530

Hi,
 This drafts has mentioned that 
"The mechanism by which the network selects an HA for assignment to the MN
is outside the scope of this document".

Unless a standard mechanism is proposed, can this be implemented across
different vendors?

Regards,
keshava

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of The
IESG
Sent: Wednesday, January 12, 2005 9:23 PM
To: IETF-Announce
Cc: [email-masked]
Subject: [Mip4] Last Call: 'Mobile IPv4 Dynamic Home Agent Assignment' to
Proposed Standard

The IESG has received a request from the Mobility for IPv4 WG to consider
the 
following document:

The file can be obtained via
http://www.ietf.org/internet-drafts/draft-ietf-mip4-dynamic-assignment-03.tx
t

---

From: Kent Leung <[email-masked]>
Date: Sun, 30 Jan 2005 23:45:31 -0800

Hi Keshava.  The MN, FA, and HA that operates in accordance
to the draft will be interoperable regardless of how the HA is
assigned.  The signaling between the mobility entities is
specified in the draft, thus allowing HA to be dynamically
assigned.

Kent

--
      |           |                   Kent Leung
     :|:         :|:                  IP Mobility Development
    :|||:       :|||:                 IOS Technologies Division
   :|||||||:   :|||||||:              Voice: 408.526.5030
.:|||||||||:.:|||||||||:.             Fax:   408.525.1653
  c i s c o S y s t e m s             Email: [email-masked]

---

From: keshav <[email-masked]>
Date: Mon, 31 Jan 2005 15:56:18 +0530

Hi Kent,
	If we want to achieve the Load balancing across different HA 
	How to achieve this? Is there any dynamic mechanism where 	HA

	can learn other HA's   capability  before redirecting.

	Unless such capability negotiation across HA is standardized
achieving
	True load balancing   may not be practicable?
	
	(Of course administrator can configure this based on policy which is
very cumbersome)

Keshava	

-----Original Message-----
From: Kent Leung [mailto:[email-masked]] 
Sent: Monday, January 31, 2005 1:16 PM
To: [email-masked]
Cc: 'IETF-Announce'; [email-masked]; [email-masked]; Keshav; [email-masked]
Subject: RE: [Mip4] Last Call: 'Mobile IPv4 Dynamic Home Agent Assignment'
to Proposed Standard

Kent

---

From: Kent Leung <[email-masked]>
Date: Mon, 31 Jan 2005 07:51:24 -0800

There are numerous methods to support load balancing.  Some of
them are transparent to the assigned HA.  That's why it's up to
the implementers to come up with what works best for them.  The
draft ensures that dynamic HA assignment can be achieved,
regardless what is used specifically for load balancing.

Kent

---

From: [email-masked]
Date: Mon, 31 Jan 2005 12:53:10 -0500

Just as an aside, it is possible to collapse the HA and FA (i.e. in Fig 2,
potentially the FA and HA can be the same entity). That would
imply a certain amount of load balancing and also avoid the
triangular routing for the first subnet. When the MN moves to another
subnet then ofcourse the FA(HA)-old becomes the HA.

Subrata Goswami, Ph.D.

> >http://www.ietf.org/internet-drafts/draft-ietf-mip4-dynamic-assignment-03.t

Subrata Goswami, Ph.D.