Subject: [Mip4] FA&HA on the same machine

From: dav s <[email-masked]>
Date: Thu, 3 Mar 2005 12:04:31 +0100 (CET)

Hello everybody,
i hope it's the right place for my questions...
can i put on the same machine a Foreign Agent and an
Home Agent or could I have some problems? 
thanks in advance!
davide.

___________________________________ 
Nuovo Yahoo! Messenger: E' molto più divertente: Audibles, Avatar, Webcam, Giochi, Rubrica… Scaricalo ora! 
http://it.messenger.yahoo.it

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: [email-masked]
Date: Thu, 3 Mar 2005 13:25:00 +0200

> Home Agent or could I have some problems? 

There is nothing in the RFCs that prohibits this setup, you shouldn't
have any problems protocolwise. There are also several implementation
that allows this setup, but there are also implementations where this
is not possible. 

Regards,
Bjorn Andersson

-- 
Bjorn Andersson <[email-masked]>
PGP id 5AFC144B

---

From: davide <[email-masked]>
Date: Thu, 3 Mar 2005 13:14:04 +0100 (CET)

Thanks Bjorn,
I've seen in RFC 3344 that Home Agent and Foreign
Agent listen to Registration Requests on the same port
(434).
I think that this could cause problems if I put the HA
and FA on the same machine.
What do you think?
Thanks!

 --- [email-masked] ha scritto: 
> On Thu, Mar 03 2005, at 12:04:31 +0100, davide

---

From: [email-masked]
Date: Thu, 3 Mar 2005 16:17:09 +0200

> and FA on the same machine.

This is not a problem. You can deterimine if the packet is destined to
the home agent or foreign agent based on the home agent address in the
registration request message. As I said, there is empirical evidence in
several Mobile IP implementations that it is possible to run the foreign
and home agent on the same host. It is an implementation specific issue
if it possible to run both services on the same host.

Regards,
Bjorn