Subject: RE: [Mip4] Request to consider FMIPv4 as a working group document

From: Narayanan Vidya-CVN065 <[email-masked]>
Date: Fri, 18 Mar 2005 13:41:56 -0600

Hi Kent, 
What you are implying here seems to be that in order to have a fast handoff solution, the MN must be using an FA CoA - did I get that right? 

If so, that seems a little restrictive to me. There are scenarios where the MN may be using a CCoA and registering through an FA. Also, in general, it seems that a solution that will work with or without FAs will be a preferable one. 

Vidya

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Kent Leung
Sent: Friday, March 18, 2005 12:45 PM
To: Charles E.Perkins
Cc: Mobile IPv4 Mailing List; Rajeev Koodli
Subject: Re: [Mip4] Request to consider FMIPv4 as a working group document

Hi Charlie.

Generally, I support having a WG solution for fast handover using MIPv4.

Some of the areas that is debatable in the draft:

  - Key difference between MIPv4 and MIPv6 is FA existence.
  - FMIPv4 enabled ARs not being FAs is unlikely, IMHO.  So
    we can simplify by specifying only FA mode operation, no CCoA
    support needed since ARs would have to be MIPv4 enabled.
    This would fit the deployment model and clean up most of
    draft dealing with IP address management.
  - Support for fast handover in WiFi already exists today w/o
    MIPv4 involvement.  Therefore, realizing deployments using
    this type of scheme will be difficult.

Haven't read the draft in detail for specifics to MIPv4.  Will comment on them later.

Kent

At 01:53 PM 3/17/2005 -0800, Charles E.Perkins wrote:

>Hello folks,
>
>We made a presentation at IETF 61 about a way to do
>fast handovers with Mobile IPv4.  Our method is adapted
>from the protocol for Mobile IPv6,
>      draft-ietf-mipshop-fast-mipv6-03.txt
>
>The Mobile IPv6 protocol has been approved for
>publication and is currently in the RFC editor's
>queue.
>
>The discussion at IETF 61 can be reviewed from the
>minutes, located at: 
>http://www1.ietf.org/proceedings_new/04nov/toc.html#int
>
>As part of this discussion, I showed some results which indicate very 
>good performance for FMIPv4, suitable for handling interactive voice 
>applications.  I probably have the PowerPoint presentation around 
>somewhere if needed.
>
>The protocol specification for the Mobile IPv4 fast
>handovers is documented in the Internet Draft:
>      draft-koodli-fmipv4-00.txt
>which is available in the standard IETF draft
>directories.
>
>Thanks in advance for your consideration of our
>request.
>
>Regards,
>Charlie P.
>
>--
>Mip4 mailing list: [email-masked]
>     Web interface: https://www1.ietf.org/mailman/listinfo/mip4
>      Charter page: http://www.ietf.org/html.charters/mip4-charter.html
>Supplemental site: http://www.mip4.org/

--
      |           |                   Kent Leung
     :|:         :|:                  IP Mobility Development
    :|||:       :|||:                 Internet Technologies Division
   :|||||||:   :|||||||:              Voice: 408.526.5030
.:|||||||||:.:|||||||||:.             Fax:   408.525.1653
  c i s c o S y s t e m s             Email: [email-masked]

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Kent Leung <[email-masked]>
Date: Fri, 18 Mar 2005 12:29:12 -0800

Hi Vidya.  I wouldn't put it that way.

My logic is that a Mobile IP based fast handover solution will involve 
Mobile IP
operation and messaging on the access router.  If the access router is to
be enabled with Mobile IP to support fast handover, then it might as well
be a Foreign Agent.  I don't see a practical rationale to upgrade the AR part
way in a sense.

Kent

At 01:41 PM 3/18/2005 -0600, Narayanan Vidya-CVN065 wrote:
>Hi Kent,
>What you are implying here seems to be that in order to have a fast 
>handoff solution, the MN must be using an FA CoA - did I get that right?
>
>If so, that seems a little restrictive to me. There are scenarios where 
>the MN may be using a CCoA and registering through an FA. Also, in 
>general, it seems that a solution that will work with or without FAs will 
>be a preferable one.
>
>Vidya
>

---

From: Kent Leung <[email-masked]>
Date: Fri, 18 Mar 2005 12:38:51 -0800

Oops, I missed one of your comments.

At 01:41 PM 3/18/2005 -0600, Narayanan Vidya-CVN065 wrote:
>the MN may be using a CCoA and registering through an FA.

Hmm, I haven't seen a deployment case for this scenario.  My main point is to
focus activities around deployments, which is a charter item.  As such 
needs arise,
we can address them then.  Just trying to simplify document.

Kent