Subject: RE: [Mip4] Query For error code from HA ..

From: Arun H S <[email-masked]>
Date: Tue, 01 Mar 2005 11:18:12 +0530

Hi,
 
Sorry, I guess the problem was not understood properly.

    The problem in question is as follows:
 
    __________                         ____________
    |                | HA1                  |                    |
    |    HA        | ============|        FA        |
    |                |                 FA1  |                    |
    -----------------                         ----------------------
                                                        ||   COA
                                                        ||
                                                        ||
                                                ___________
                                                |                  |
                                                |        MN     |
                                                |                  |
                                                --------------------
 
Now when MN sends an RRQ with Care-of-Address as COA, to Home-Agent Address,
HA1, the Registration is successful because the IP addresses HA1 and FA1 are
routable. However, since the tunnel that is created is between the IP
addresses HA1 and COA, at the Home Agent, there may not be any route in HA
for the IP Address COA. 
In such a scenario, what type of error-code should the Home Agent send back
to the Mobile Node. 
 
PS: In such a scenario, the Registration will be successful, however the
packet forwarding to the Mobile Node will fail since there is no route to
the COA at the Home Agent.
 
Regards,
Arun

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Radhakrishnan Suryanarayanan
Sent: Friday, February 25, 2005 05:52 PM
To: [email-masked]; [email-masked]
Subject: Re: [Mip4] Query For error code from HA ..

Hi Mr.Keshav,
If you are talking about Registration reply, HA will recv ICMP Destination
unreachable (from intermediate routers) for CoA of MN.
Where is the question of HA sending any error msg to MN if MN's CoA in
unreachable?????
 
Regards
Radhakrishnan

----- Original Message ----- 
From: keshav <mailto:[email-masked]>  
To: [email-masked] 
Cc: [email-masked] 
Sent: Friday, February 25, 2005 5:32 PM
Subject: [Mip4] Query For error code from HA ..

Hi,

            I would like to know is there any error code that HA has to send
to MN if the 

            Care of address of the MN is not reachable during registration?

 

Thanks & regards,

Keshava

  _____  

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Radhakrishnan Suryanarayanan <[email-masked]>
Date: Tue, 01 Mar 2005 12:41:53 +0530

MessageHi arun,
  For further understanding your problem can you please clarify the following:
  Is the CoA address of the FA (in case registration is being done via FA) or that MN (co-located CoA)?

Regards
Radhakrishnan
  ----- Original Message ----- 
  From: Arun H S 
  To: [email-masked] 
  Sent: Tuesday, March 01, 2005 11:18 AM
  Subject: RE: [Mip4] Query For error code from HA ..

  Hi,

      __________                         ____________
      |                | HA1                  |                    |

  Now when MN sends an RRQ with Care-of-Address as COA, to Home-Agent Address, HA1, the Registration is successful because the IP addresses HA1 and FA1 are routable. However, since the tunnel that is created is between the IP addresses HA1 and COA, at the Home Agent, there may not be any route in HA for the IP Address COA. 
  In such a scenario, what type of error-code should the Home Agent send back to the Mobile Node. 

  PS: In such a scenario, the Registration will be successful, however the packet forwarding to the Mobile Node will fail since there is no route to the COA at the Home Agent.

  Regards,
  Arun

    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]] On Behalf Of Radhakrishnan Suryanarayanan
    Sent: Friday, February 25, 2005 05:52 PM
    To: [email-masked]; [email-masked]
    Subject: Re: [Mip4] Query For error code from HA ..

    Hi Mr.Keshav,
    If you are talking about Registration reply, HA will recv ICMP Destination unreachable (from intermediate routers) for CoA of MN.
    Where is the question of HA sending any error msg to MN if MN's CoA in unreachable?????

    Regards
    Radhakrishnan
      ----- Original Message ----- 
      From: keshav 
      To: [email-masked] 
      Cc: [email-masked] 
      Sent: Friday, February 25, 2005 5:32 PM
      Subject: [Mip4] Query For error code from HA ..

      Hi,

                  I would like to know is there any error code that HA has to send to MN if the 

                  

      Thanks & regards,

      Keshava

--------------------------------------------------------------------------

------------------------------------------------------------------------------

---

From: Arun H S <[email-masked]>
Date: Tue, 01 Mar 2005 13:00:50 +0530

For the Home Agent, I think it dows not matter whether the "COA" is a CLCOA
or a COA

-----Original Message-----
From: Radhakrishnan Suryanarayanan [mailto:[email-masked]] 
Sent: Tuesday, March 01, 2005 12:42 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Mip4] Query For error code from HA ..

Hi arun,
  For further understanding your problem can you please clarify the
following:
  Is the CoA address of the FA (in case registration is being done via FA)
or that MN (co-located CoA)?
 
Regards
Radhakrishnan

----- Original Message ----- 
From: Arun H S <mailto:[email-masked]>  
To: [email-masked] 
Sent: Tuesday, March 01, 2005 11:18 AM
Subject: RE: [Mip4] Query For error code from HA ..

Hi,

 
    __________                         ____________
    |                | HA1                  |                    |

 
Regards,
Arun

-----Original Message-----

Hi Mr.Keshav,
 
Regards
Radhakrishnan

----- Original Message ----- 
From: keshav <mailto:[email-masked]>  
To: [email-masked] 
Cc: [email-masked] 
Sent: Friday, February 25, 2005 5:32 PM
Subject: [Mip4] Query For error code from HA ..

Hi,

            

Thanks & regards,

Keshava

  _____  

  _____