Subject: RE: [Mip4] Request to consider FMIPv4 as a working group document

From: "Soliman, Hesham" <[email-masked]>
Date: Fri, 18 Mar 2005 15:25:31 -0500

Hi Charlie, 

I think this work can be adopted by the WG if there are
concrete benefits over the existing WG doc. It would be really
useful if you could highlight the advantages. 
>From reading through, it seems to me that it is mainly about
doing the same thing differently to make it similar to FMIPv6.
I.e. packetizing information differently. 
I understand that you have simulations that show good performance, 
but it's not clear that this is due to the different packet
format or simply because the handover improvement is good. The 
latter is done by both drafts and, at least intuitively, it doesn't
look like packetizing things differently is having any significant
impact. 

Some of the work we have discussed recently (i.e. dual stack MIP)
was about literally using the same packet for both v4 and
v6. I can see an advantage in doing that, but this is not what
your draft proposes. 

thanks,
Hesham

 > -----Original Message-----
 > From: [email-masked] [mailto:[email-masked]]On 
 > Behalf Of
 > Charles E.Perkins
 > Sent: Thursday, March 17, 2005 4:53 PM
 > To: Mobile IPv4 Mailing List
 > Cc: Rajeev Koodli
 > Subject: [Mip4] Request to consider FMIPv4 as a working 
 > group document
 > 
 > 
 > 
 > 
 > Hello folks,
 > 
 > We made a presentation at IETF 61 about a way to do
 > fast handovers with Mobile IPv4.  Our method is adapted
 > from the protocol for Mobile IPv6,
 >      draft-ietf-mipshop-fast-mipv6-03.txt
 > 
 > The Mobile IPv6 protocol has been approved for
 > publication and is currently in the RFC editor's
 > queue.
 > 
 > The discussion at IETF 61 can be reviewed from the
 > minutes, located at:
 > http://www1.ietf.org/proceedings_new/04nov/toc.html#int
 > 
 > As part of this discussion, I showed some results which
 > indicate very good performance for FMIPv4, suitable for
 > handling interactive voice applications.  I probably have
 > the PowerPoint presentation around somewhere if needed.
 > 
 > The protocol specification for the Mobile IPv4 fast
 > handovers is documented in the Internet Draft:
 >      draft-koodli-fmipv4-00.txt
 > which is available in the standard IETF draft
 > directories.
 > 
 > Thanks in advance for your consideration of our
 > request.
 > 
 > Regards,
 > Charlie P.
 > 
 > -- 
 > Mip4 mailing list: [email-masked]
 >     Web interface: https://www1.ietf.org/mailman/listinfo/mip4
 >      Charter page: 
 > http://www.ietf.org/html.charters/mip4-charter.html
 > Supplemental site: http://www.mip4.org/
 > 

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Narayanan Vidya-CVN065 <[email-masked]>
Date: Fri, 18 Mar 2005 17:08:48 -0600

All,
Does anyone know what happened to the draft on post-MIT? A few years ago, I thought it was being considered to be part of the low latency handoff spec - but, obviously it has not made it. 

James' draft on Post-MIT was trying to solve the issue of L2 dependency. Essentially, I see this as a major deployment issue to have a fast handoff solution exclusively dependent on receiving an L2 trigger (e.g. the L2 Target Trigger at the nFA). 

I think an approach like FMIPv4 is essential in light of this. Ideally, I think post-MIT should have been a part of LLH - that way, we won't have the need to have 2 specifications that are somewhat close with only minor differences. 

Vidya

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Espen Klovning
Sent: Friday, March 18, 2005 4:30 PM
To: 'Charles E.Perkins'; 'Mobile IPv4 Mailing List'
Cc: 'Rajeev Koodli'
Subject: RE: [Mip4] Request to consider FMIPv4 as a working group document

Hi Charlie

I support making this draft a WG item.

I do have some concerns that more or less reflect what Kent Leung has voiced in previous mails on the list. 
- AR == FA 
- IP address management

An additional issue is how the MN-PAR auth extension is handled. I take it this will reuse MN-FA auth extension. It will require key distribution of some kind that could jeopardize the performance benefits. What am I missing?

regards
espen
Espen Klovning
Birdstep Technology

In addition, 

> From: [email-masked] [mailto:[email-masked]] On Behalf 
> Of Charles E.Perkins
> Sent: Thursday, March 17, 2005 10:53 PM
> Subject: [Mip4] Request to consider FMIPv4 as a working group document
> 
> 
> 
> Hello folks,
> 
> As part of this discussion, I showed some results which indicate very 
> good performance for FMIPv4, suitable for handling interactive voice 
> applications.  I probably have the PowerPoint presentation around 
> somewhere if needed.
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 22 Mar 2005 20:22:53 +0100

Forwarding a mail to the list, minus the attached slideset which was
too big to be accepted by Mailman.  I've instead made the slides for
Charlie's FMIPv4 presentation from IETF-61 available here:

    http://mip4.org/ietf61/FMIPv4.pdf

Regards,

	Henrik

---- Forwarded Mail: ----

> Subject: Re: [Mip4] Request to consider FMIPv4 as a working group document
> From: "Charles E. Perkins" <[email-masked]>
> Date: Tue, 22 Mar 2005 07:43:01 -0800
> To: Alexandru Petrescu <[email-masked]>
> CC: Mobile IPv4 Mailing List <[email-masked]>, Rajeev Koodli <[email-masked]>
> 
> Hello Alexandru,
> 
> Attached, please find my very small set of slides.
> The presentation was pretty lightweight, and in fact
> I only got to make it because there ended up being
> time on the schedule after other more urgent
> presentations were finished.
> 
> Regards,
> Charlie P.
> 
> 
> 
> Alexandru Petrescu wrote:
> 
>> Hi Charlie,
>>
>> Charles E.Perkins wrote:
>>
>> Yes, I need these slides, please send in if easily available for you,
>> thank you.
>>
>> I am interested to find out about "hard" limits on the interruption
>> times that a human user of a interactive voice IP application is ready
>> to tolerate.  During some IP and non-IP discussions, very often the
>> numbers 100ms or 200ms come up.  But for some reason I'm unable to
>> identify a written report/paper, eventually with some "hands-on"
>> non-simulated experience to determine this "tolerable delay".  Anything
>> like a I-D report or ppt slides or journal/conference paper applies, 
>> thanks,
>>
>> Alex
> 
>