Subject: RE: [Mip4] review: draft-ietf-mip4-rfc3012bis-04.txt

From: "Jayshree Bharatia" <[email-masked]>
Date: Tue, 8 Nov 2005 10:55:53 -0600

I am also ok with this suggestion. If it is agreed by all, I can change
section 3.1 to reflect this change.

Regards,
Jayshree

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Kent Leung (kleung)
Sent: Monday, November 07, 2005 8:40 PM
To: Nakhjiri Madjid-MNAKHJI1; Vijay Devarapallli; Pete McCann
Cc: [email-masked]; [email-masked]
Subject: RE: [Mip4] review: draft-ietf-mip4-rfc3012bis-04.txt

I agree with this sentiment.  Unless there's an issue with using zero
for Challenge value in the calculation for CCoA mode, this problem will
be addressed in the draft.  The challenge is not needed for CCoA mode
since there's already Timestamp/Nonce replay protection.

Kent 

> -----Original Message-----
> From: Nakhjiri Madjid-MNAKHJI1 [mailto:[email-masked]]
> Sent: Monday, November 07, 2005 4:46 PM
> To: Kent Leung (kleung); Vijay Devarapallli; Pete McCann
> Cc: [email-masked]; [email-masked]
> Subject: RE: [Mip4] review: draft-ietf-mip4-rfc3012bis-04.txt
> 
> The fix to deal with CCoA is a very small one as I mentioned
> my previous email. I really don't think it warrants a huge 
> discussion or a doc split. The fix that we suggested was 
> agreed by Charlie as well.
> 
> Madjid
>  
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Kent Leung (kleung)
> Sent: Monday, November 07, 2005 11:42 AM
> To: Vijay Devarapallli; Pete McCann
> Cc: [email-masked]; [email-masked]
> Subject: RE: [Mip4] review: draft-ietf-mip4-rfc3012bis-04.txt
> 
> On this particular topic, I don't understand what is missing
> in the details to support the CCoA mode?  Since the draft 
> covers MN-AAA authentication with NAS in between, I would 
> like to see both FA (CoA) and HA (CCoA) modes supported.  
> Where else would we be able to cover just the CCoA for MN-AAA 
> authentication if not in this draft?
> 
> Kent
> 
> 
> > 
> > not at this late stage. its fine as it is. however, I have
> one comment
> 
> > on the support for co-located CoA mode. the draft claims it
> supports
> > it but there really isnt enough detail.
> > IMO, it should be clarified that only FA mode is described in the
> > draft.
> > 
> 
> --
> Mip4 mailing list: [email-masked]
>     Web interface: https://www1.ietf.org/mailman/listinfo/mip4
>      Charter page: http://www.ietf.org/html.charters/mip4-charter.html
> Supplemental site: http://www.mip4.org/
> 

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 22 Nov 2005 19:59:13 +0100

Hi Jayshree,

I believe we've reached consensus on this.  The AD is waiting for an
updated document, so please make the change and submit a new version.

Regards,

	Henrik

---

From: Vijay Devarapallli <[email-masked]>
Date: Tue, 22 Nov 2005 18:41:33 -0800

> updated document, so please make the change and submit a new version.

just to make sure I understand what the consensus is.

when Kent and I discussed this, we agreed that the MN leaves
out the challenge extension in the registration request when
using co-located CoA mode rather than include a null challenge.

is this the consensus?

I think we also need some text which explains that replay
protection is provided by the use of timestamp in the registration
request instead of a challenge when the mobile node is using
co-located CoA mode.

Vijay