Subject: RE: [Mip4] review: draft-ietf-mip4-rfc3012bis-04.txt

From: "Kent Leung \(kleung\)" <[email-masked]>
Date: Mon, 7 Nov 2005 11:35:56 -0800

OK.  Since this registration exchange is between MN and HA, I expect
that MN would generate some random number in Challenge value.  All
implementations that I'm aware of do this.

   "The mechanism used by the mobile node to
   obtain the Challenge value in this case is outside the scope of this
   document."

But the point is mute since there won't be any Challenge value if the
new scheme of zero in place of Challenge for authentication is adopted.

Kent

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]] 
> Sent: Monday, November 07, 2005 11:28 AM
> To: Kent Leung (kleung)
> Cc: Vijay Devarapallli; Pete McCann; [email-masked]; 
> [email-masked]
> Subject: Re: [Mip4] review: draft-ietf-mip4-rfc3012bis-04.txt
> 
> Kent Leung (kleung) wrote:
> > On this particular topic, I don't understand what is missing in the 
> > details to support the CCoA mode?  Since the draft covers MN-AAA 
> > authentication with NAS in between, I would like to see 
> both FA (CoA) 
> > and HA (CCoA) modes supported.  Where else would we be able 
> to cover 
> > just the CCoA for MN-AAA authentication if not in this draft?
> 
> for e.g. who generates the challenge in co-located mode?
> 
> Vijay
> 
> > 
> > Kent
> > 
> > 
> > 
> >>not at this late stage. its fine as it is. however, I have 
> one comment 
> >>on the support for co-located CoA mode. the draft claims it 
> supports 
> >>it but there really isnt enough detail.
> >>IMO, it should be clarified that only FA mode is described in the 
> >>draft.
> >>
> > 
> > 
> 

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 07 Nov 2005 14:04:21 -0800

> implementations that I'm aware of do this.

the MN itself generates the challenge? shouldnt the
network be challenging the mobile node?

>    obtain the Challenge value in this case is outside the scope of this

and this is not enough for interoperability.

> new scheme of zero in place of Challenge for authentication is adopted.

if you set the challenge to 0, then the whole point of
challenge/response mechanism is lost, right? or am I
missing something?

Vijay