Subject: RE: [Mip4] review: draft-ietf-mip4-rfc3012bis-04.txt

From: "Yoshi Tsuda \(yotsuda\)" <[email-masked]>
Date: Tue, 8 Nov 2005 04:17:17 +0800

Hi Vijay,

 Even in co-located mode, you know, an FA can push
 challenge to an MN by setting R-bit and challenge in
 agent advertisements.

 Do you need pushing challenge from an HA to an MN,
 instead ?  If so, Kent has already mentioned one option.
 If you want to push challenge from an HA to an MN really,
 say MS CHAPv2, we want you describe such a scenario
 in order to review it.
 At the time when we defined and did interoperability tests
 about rfc3012, we assumed visiting subnets need some
 guard by challenge.  Pushing challenge really from an HA 
 to an MN is beyond our assumptions at that time.  I prefer
 a new rfc rather than updating rfc3012, because in such a
 case we would probably need more functions, such as some
 guard against losing challenge on an MN.

Thanks.
-Yoshi

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Vijay Devarapalli
> Sent: Monday, November 07, 2005 11:28 AM
> To: Kent Leung (kleung)
> Cc: Pete McCann; [email-masked]; Vijay Devarapallli; 
> [email-masked]
> Subject: Re: [Mip4] review: draft-ietf-mip4-rfc3012bis-04.txt
> 
> Kent Leung (kleung) wrote:
> > On this particular topic, I don't understand what is missing in the 
> > details to support the CCoA mode?  Since the draft covers MN-AAA 
> > authentication with NAS in between, I would like to see 
> both FA (CoA) 
> > and HA (CCoA) modes supported.  Where else would we be able 
> to cover 
> > just the CCoA for MN-AAA authentication if not in this draft?
> 
> for e.g. who generates the challenge in co-located mode?
> 
> Vijay
> 
> > 
> > Kent
> > 
> > 
> > 
> >>not at this late stage. its fine as it is. however, I have 
> one comment 
> >>on the support for co-located CoA mode. the draft claims it 
> supports 
> >>it but there really isnt enough detail.
> >>IMO, it should be clarified that only FA mode is described in the 
> >>draft.
> >>
> > 
> > 
> 
> 
> 
> --
> Mip4 mailing list: [email-masked]
>     Web interface: https://www1.ietf.org/mailman/listinfo/mip4
>      Charter page: http://www.ietf.org/html.charters/mip4-charter.html
> Supplemental site: http://www.mip4.org/
> 

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 07 Nov 2005 14:07:25 -0800

>  challenge to an MN by setting R-bit and challenge in

in co-located mode, I am assuming there are networks
with no FA.

>  instead ?  

nope.

If so, Kent has already mentioned one option.

I dont think the MN itself generating the challenge
is a solution.

>  say MS CHAPv2, we want you describe such a scenario

I wanted the draft actually to say that the
challenge/response mechanism is specified only for
FA mode. for co-located mode, it could be out of
scope for this draft. the draft currently claims
that it supports co-located mode too. I am objecting
to that.

>  guard against losing challenge on an MN.

ok.

Vijay