Subject: RE: [Mip4] review: draft-ietf-mip4-rfc3012bis-04.txt

From: "Jayshree Bharatia" <[email-masked]>
Date: Mon, 7 Nov 2005 16:45:11 -0600

Vijay,

I agree that having co-located CoA support information in this draft is
confusing. We added co-located CoA support at the later time as a result
of comments (rather long debate!) we had on the mailing list. At that
time, it was decided not to limit the use of this mechanism (use of the
MN-AAA extension) given that challenges are generated by some other
means and make them available at the MN.

I am open to any suggestions which may clarify the scope better.

Regards,
Jayshree

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Vijay Devarapalli
Sent: Monday, November 07, 2005 4:07 PM
To: Yoshi Tsuda (yotsuda)
Cc: Kent Leung (kleung); [email-masked]; Pete McCann;
[email-masked]
Subject: Re: [Mip4] review: draft-ietf-mip4-rfc3012bis-04.txt

Yoshi Tsuda (yotsuda) wrote:
> Hi Vijay,
> 
>  Even in co-located mode, you know, an FA can push
>  challenge to an MN by setting R-bit and challenge in
>  agent advertisements.

in co-located mode, I am assuming there are networks
with no FA.

>  Do you need pushing challenge from an HA to an MN,
>  instead ?

nope.

If so, Kent has already mentioned one option.

I dont think the MN itself generating the challenge
is a solution.

>  If you want to push challenge from an HA to an MN really,  say MS 
> CHAPv2, we want you describe such a scenario  in order to review it.

I wanted the draft actually to say that the
challenge/response mechanism is specified only for
FA mode. for co-located mode, it could be out of
scope for this draft. the draft currently claims
that it supports co-located mode too. I am objecting
to that.

>  At the time when we defined and did interoperability tests  about 
> rfc3012, we assumed visiting subnets need some  guard by challenge.  
> Pushing challenge really from an HA  to an MN is beyond our 
> assumptions at that time.  I prefer  a new rfc rather than updating 
> rfc3012, because in such a  case we would probably need more 
> functions, such as some  guard against losing challenge on an MN.

ok.

Vijay

> 
> Thanks.
> -Yoshi
> 
> 
>>-----Original Message-----
>>From: [email-masked] [mailto:[email-masked]] On
>>Behalf Of Vijay Devarapalli
>>Sent: Monday, November 07, 2005 11:28 AM
>>To: Kent Leung (kleung)
>>Cc: Pete McCann; [email-masked]; Vijay Devarapallli; 
>>[email-masked]
>>Subject: Re: [Mip4] review: draft-ietf-mip4-rfc3012bis-04.txt
>>
>>Kent Leung (kleung) wrote:
>>
>>>On this particular topic, I don't understand what is missing in the
>>>details to support the CCoA mode?  Since the draft covers MN-AAA 
>>>authentication with NAS in between, I would like to see 
>>
>>both FA (CoA)
>>
>>>and HA (CCoA) modes supported.  Where else would we be able
>>
>>to cover
>>
>>>just the CCoA for MN-AAA authentication if not in this draft?
>>
>>for e.g. who generates the challenge in co-located mode?
>>
>>Vijay
>>
>>
>>>Kent
>>>
>>>
>>>
>>>
>>>>not at this late stage. its fine as it is. however, I have
>>
>>one comment
>>
>>>>on the support for co-located CoA mode. the draft claims it
>>
>>supports
>>
>>>>it but there really isnt enough detail.
>>>>IMO, it should be clarified that only FA mode is described in the
>>>>draft.
>>>>
>>>
>>>
>>
>>
>>--
>>Mip4 mailing list: [email-masked]
>>    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
>>     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
>>Supplemental site: http://www.mip4.org/
>>

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 07 Nov 2005 16:11:45 -0800

> I am open to any suggestions which may clarify the scope better.

IMHO, this what we should do

- clarify that 3012bis only addresses using the FA
   challenge/response extension in FA CoA mode.
   co-located CoA mode is not supported.

- mention that the MN-AAA extension can be used in
   co-located CoA mode, but the actual details are
   out of scope for 3012bis.

RFC 3957 also does a poor job of describing the
co-located CoA mode.

the RADIUS MIPv4 extensions draft,
draft-nakhjiri-radius-mip4-02.txt, does a better job
of describing how the MN-AAA extension can be used
between the MN and the HA along with RFC 3957. IMO,
thats the best reference today.

I think draft-nakhjiri is also the wrong place for
this. it should be in a separate draft.

my 2 cents.

Vijay