Subject: FW: [Mip4] FW: I-D ACTION:draft-tsirtsis-v4v6-mipv4-01.txt

From: "Tsirtsis, George" <[email-masked]>
Date: Thu, 20 Apr 2006 07:26:09 -0700

Sorry, I meant to send the following e-mail to the list instead of just
to Kunstal.

-----Original Message-----
From: Tsirtsis, George 
Sent: Thursday, April 20, 2006 7:21 AM
To: Chowdhury, Kuntal
Subject: RE: [Mip4] FW: I-D ACTION:draft-tsirtsis-v4v6-mipv4-01.txt

Kuntal,

With respect to draft-navali-ip6-over-netmip4-00.txt, IMO this is work
for the NETLMM group. 

DS-MIPv4 solution in draft-tsirtsis-v4v6-mipv4-01.txt as well as similar
proposals that have been submitted by Pete and myself at different times
in the past extend MIPv4 without changing its basic semantics.

A network based version of MIPv4 is an orthogonal issue that I think
should be dealt with separately if the NETLMM or this WG wants to do
that.

George

> -----Original Message-----
> From: Chowdhury, Kuntal [mailto:[email-masked]]
> Sent: Tuesday, April 18, 2006 6:46 PM
> To: Henrik Levkowetz; Tsirtsis, George
> Cc: Pete McCann; [email-masked]
> Subject: RE: [Mip4] FW: I-D ACTION:draft-tsirtsis-v4v6-mipv4-01.txt
> 
> In principle, I support this work to progress in IETF. However, I
think
> that we need to have a discussion on which approach to adopt. We also
> wrote a draft on this line with a somewhat different approach:
> 
>
http://www.ietf.org/internet-drafts/draft-navali-ip6-over-netmip4-00.txt
> 
> I see a value in pursuing both the approaches as they address specific
> deployment scenarios.
> 
> -Kuntal
> 
> 
> > -----Original Message-----
> > From: Henrik Levkowetz [mailto:[email-masked]]
> > Sent: Monday, April 17, 2006 10:44 AM
> > To: Tsirtsis, George
> > Cc: Pete McCann; [email-masked]
> > Subject: Re: [Mip4] FW: I-D ACTION:draft-tsirtsis-v4v6-mipv4-01.txt
> >
> > Hi George,
> >
> > on 2006-04-17 16:34 Tsirtsis, George said the following:
> > > Pete/Henrik,
> > >
> > > This draft was just updated and it is now available on the I-D
> > > directory.
> >
> > Good, good.
> >
> > > Based on the discussion during the WG meeting we are requesting
for
> this
> > > proposal to be adopted as a working group draft.
> >
> > Right.  Well, we didn't have time for any proper discussion during
> > the meeting, and there were voices which called for that,
explicitly,
> > so let's start by hearing what people have to say about this
proposal.
> >
> > Speak up, people!
> >
> >
> > Regards,
> >
> > 	Henrik
> >
> >
> > > Comments and suggestions are always welcome.
> > >
> > > Regards
> > > George
> > >
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]]
> > > Sent: Friday, April 14, 2006 6:50 PM
> > > To: [email-masked]
> > > Subject: I-D ACTION:draft-tsirtsis-v4v6-mipv4-01.txt
> > >
> > > A New Internet-Draft is available from the on-line Internet-Drafts
> > > directories.
> > >
> > >
> > > 	Title		: Dual Stack Mobile IPv4
> > > 	Author(s)	: G. Tsirtsis, et al.
> > > 	Filename	: draft-tsirtsis-v4v6-mipv4-01.txt
> > > 	Pages		: 17
> > > 	Date		: 2006-4-14
> > >
> > > This specification provides IPv6 extensions to the Mobile IPv4
> > > [MIPv4] protocol. The extensions allow a dual stack node to use
IPv4
> > > and IPv6 home addresses as well as move between IPv4 and dual
stack
> > > network infrastructures.
> > >
> > > A URL for this Internet-Draft is:
> > >
http://www.ietf.org/internet-drafts/draft-tsirtsis-v4v6-mipv4-01.txt
> > >
> > > To remove yourself from the I-D Announcement list, send a message
to
> > > [email-masked] with the word unsubscribe in the
body
> of
> > > the message.
> > > You can also visit
> https://www1.ietf.org/mailman/listinfo/I-D-announce
> > > to change your subscription settings.
> > >
> > >
> > > Internet-Drafts are also available by anonymous FTP. Login with
the
> > > username
> > > "anonymous" and a password of your e-mail address. After logging
in,
> > > type "cd internet-drafts" and then
> > > 	"get draft-tsirtsis-v4v6-mipv4-01.txt".
> > >
> > > A list of Internet-Drafts directories can be found in
> > > http://www.ietf.org/shadow.html
> > > or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> > >
> > >
> > > Internet-Drafts can also be obtained by e-mail.
> > >
> > > Send a message to:
> > > 	[email-masked].
> > > In the body type:
> > > 	"FILE /internet-drafts/draft-tsirtsis-v4v6-mipv4-01.txt".
> > >
> > > NOTE:	The mail server at ietf.org can return the document in
> > > 	MIME-encoded form by using the "mpack" utility.  To use this
> > > 	feature, insert the command "ENCODING mime" before the "FILE"
> > > 	command.  To decode the response(s), you will need "munpack" or
> > > 	a MIME-compliant mail reader.  Different MIME-compliant mail
> > > readers
> > > 	exhibit different behavior, especially when dealing with
> > > 	"multipart" MIME messages (i.e. documents which have been split
> > > 	up into multiple messages), so check your local documentation on
> > > 	how to manipulate these messages.
> > >
> > >
> > > Below is the data which will enable a MIME compliant mail reader
> > > implementation to automatically retrieve the ASCII version of the
> > > Internet-Draft.
> > >
> >
> > --
> > Mip4 mailing list: [email-masked]
> >     Web interface: https://www1.ietf.org/mailman/listinfo/mip4
> >      Charter page:
http://www.ietf.org/html.charters/mip4-charter.html
> > Supplemental site: http://www.mip4.org/
> 
> 
> 
> "This email message and any attachments are confidential information
of
> Starent Networks, Corp. The information transmitted may not be used to
> create or change any contractual obligations of Starent Networks,
Corp.
> Any review, retransmission, dissemination or other use of, or taking
of
> any action in reliance upon this e-mail and its attachments by persons
or
> entities other than the intended recipient is prohibited. If you are
not
> the intended recipient, please notify the sender immediately -- by
> replying to this message or by sending an email to
> [email-masked] -- and destroy all copies of this
message
> and any attachments without reading or disclosing their contents.
Thank
> you."

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Basavaraj Patil <[email-masked]>
Date: Thu, 20 Apr 2006 17:18:01 -0500

George,

So we have many transition mechanisms for supporting IPv6 when a host
is attached to an IPv4 access today. Obviously none of them are able
to deal with mobility (i.e the host moving to different v4
subnets). Your I-D basically is provding yet another transition
mechanism for IPv6 with the added benefit of mobility. We are talking
about dual-stack mobile hosts here, right... And you would agree that
most IPv4 hosts do not have Mobile IPv4 client capability today. Given
that the host is a dual-stack node, it should support MIP6 as part of
its IPv6 stack. Hence it would be better to handle mobility using MIP6
and also provide IPv4 connectivity using such an approach.
In your I-D you state:

"
   On the other hand, and more importantly, it allows dual stack mobile
   nodes and networks to utilize a single protocol for the movement of
   both IPv4 and IPv6 stacks in the network topology.
"
The design team in MIP6/NEMO WG is essentially working on addressing
the same issue for DS nodes. Why not use IPv6 mobility as the baseline
mobility protocol?

The other point that I had was if connectivity to IPv6 islands is the
need of the hour with mobility, could you not address this by using a
Mobike solution that also provides transition GW capability on the GW
side? 

-Raj