Subject: RE: [Mip4] FW: I-D ACTION:draft-tsirtsis-v4v6-mipv4-01.txt

From: "Vijay Devarapalli" <[email-masked]>
Date: Mon, 17 Apr 2006 11:46:34 -0700

> -----Original Message-----
> From: Henrik Levkowetz [mailto:[email-masked]] 
> Sent: Monday, April 17, 2006 11:35 AM
> To: Vijay Devarapalli
> Cc: Tsirtsis, George; [email-masked]; Pete McCann
> Subject: Re: [Mip4] FW: I-D ACTION:draft-tsirtsis-v4v6-mipv4-01.txt
> 
> Hi Vijay
> 
> on 2006-04-17 20:00 Vijay Devarapalli said the following:
> > Hi all,
> > 
> > I believe we are heading in the wrong direction
> > with adopting this as a WG document. I am against
> > it.  
> > 
> > a similar mechanism was proposed back in 2002.
> > 
> http://folk.uio.no/paalee/publications/draft-mccann-mobileip-i
> pv6mipv4-03.txt
> > and it was rejected as the wrong approach at that
> > time. we are revisiting this.
> 
> <hat type="wg-participant">
> 
>   I believe that what may have been seen as wrong at that time,
>   being a distraction to getting MIPv6 completed and out the door,
>   could very well be seen as right today.  The benefits in terms
>   of making it possible to access IPv6 services when you have a
>   MIPv4 infrastructure in place makes it easier to motivate a roll-
>   out of IPv6 in an enterprise, even if the rest of the world does
>   not move to IPv6 at the same time, for instance.

most mobile nodes are dual stack. if an enterprise
is deploying IPv6, you think upgrading the home 
agent from MIPv4 to MIPv6 would be difficult? you 
only need to update the mobile node and the home 
agent. that would be trivial compared to upgrading 
the services in the enterpise network to IPv6. I 
dont buy the argument.

> 
> </hat>
> 
> > I tried to lookup the mailing list discussions
> > at that time, but I wasn't able to "search" the
> > mobileip archive. here is an URL for the archive.
> > http://playground.sun.com/mobile-ip/WG-archive/pre-2003/
> 
> 
> <hat type="chair">
> 
>   Lifting facts and arguments from the past may be helpful, but
>   can't override our application of reason to today's situation.

true.

>   If there is to be arguments against this proposal, I'd like to
>   see well-reasoned logic, rather than assumptions that decisions
>   taken at another time under different circumstances should be
>   authoritative for today.
> 
> </hat>

uh? being aware of what happened in the past is a 
good thing. I went looking into the archive to find 
more information on why the MobileIP WG did not adopt 
this approach. 

Vijay

> 
> 
> Regards,
> 
> 	Henrik
> 
> 
> 
> > Vijay
> > 
> >> -----Original Message-----
> >> From: Henrik Levkowetz [mailto:[email-masked]] 
> >> Sent: Monday, April 17, 2006 8:44 AM
> >> To: Tsirtsis, George
> >> Cc: Pete McCann; [email-masked]
> >> Subject: Re: [Mip4] FW: I-D ACTION:draft-tsirtsis-v4v6-mipv4-01.txt
> >> 
> >> Hi George,
> >> 
> >> on 2006-04-17 16:34 Tsirtsis, George said the following:
> >> > Pete/Henrik,
> >> > 
> >> > This draft was just updated and it is now available on the I-D
> >> > directory.
> >> 
> >> Good, good.
> >> 
> >> > Based on the discussion during the WG meeting we are 
> >> requesting for this
> >> > proposal to be adopted as a working group draft.
> >> 
> >> Right.  Well, we didn't have time for any proper discussion during
> >> the meeting, and there were voices which called for that, 
> explicitly,
> >> so let's start by hearing what people have to say about 
> this proposal.
> >> 
> >> Speak up, people!
> >> 
> >> 
> >> Regards,
> >> 
> >> 	Henrik
> 
> 

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 17 Apr 2006 20:59:19 +0200

Hi Vijay,

>> From: Henrik Levkowetz [mailto:[email-masked]] 
...
> the services in the enterpise network to IPv6. I 

Oh, I think that if the market availability of fine MIPv4 clients
is good, while the market availability of fine MIPv6 clients is
small or non-existent, this is a very strong argument.

The same goes for HAs, of course.  I'm sure you or I would not
have any trouble *upgrading* from one software to another.  That's
not the hard bit.  The hard bit is whether there is market
availability of products and support for them.

> more information on why the MobileIP WG did not adopt 

Fine, in that case.

	Henrik

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 17 Apr 2006 12:25:45 -0700

> small or non-existent, this is a very strong argument.

agreed.

> availability of products and support for them.

but implementations mystically appear when
there is demand for it. :)

"demand" is the key word here. there are many
MIPv6 client and home agent implementations. I
have attended many MIPv6 interop events and
seen many implementations. but most vendors are
waiting for demand before shipping the MIPv6
implementations.

Vijay

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 17 Apr 2006 17:51:09 -0700

>more information on why the MobileIP WG did not adopt 
Can you tell us why?

Regards,

--behcet