Subject: RE: [Mip4] FW: I-D ACTION:draft-tsirtsis-v4v6-mipv4-01.txt

From: "Vijay Devarapalli" <[email-masked]>
Date: Mon, 17 Apr 2006 11:00:30 -0700

Hi all,

I believe we are heading in the wrong direction
with adopting this as a WG document. I am against
it.  

a similar mechanism was proposed back in 2002.
http://folk.uio.no/paalee/publications/draft-mccann-mobileip-ipv6mipv4-03.txt
and it was rejected as the wrong approach at that
time. we are revisiting this.

I tried to lookup the mailing list discussions
at that time, but I wasn't able to "search" the
mobileip archive. here is an URL for the archive.
http://playground.sun.com/mobile-ip/WG-archive/pre-2003/

Vijay

> -----Original Message-----
> From: Henrik Levkowetz [mailto:[email-masked]] 
> Sent: Monday, April 17, 2006 8:44 AM
> To: Tsirtsis, George
> Cc: Pete McCann; [email-masked]
> Subject: Re: [Mip4] FW: I-D ACTION:draft-tsirtsis-v4v6-mipv4-01.txt
> 
> Hi George,
> 
> on 2006-04-17 16:34 Tsirtsis, George said the following:
> > Pete/Henrik,
> > 
> > This draft was just updated and it is now available on the I-D
> > directory.
> 
> Good, good.
> 
> > Based on the discussion during the WG meeting we are 
> requesting for this
> > proposal to be adopted as a working group draft.
> 
> Right.  Well, we didn't have time for any proper discussion during
> the meeting, and there were voices which called for that, explicitly,
> so let's start by hearing what people have to say about this proposal.
> 
> Speak up, people!
> 
> 
> Regards,
> 
> 	Henrik
> 	
> 
> > Comments and suggestions are always welcome.
> > 
> > Regards
> > George
> > 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] 
> > Sent: Friday, April 14, 2006 6:50 PM
> > To: [email-masked]
> > Subject: I-D ACTION:draft-tsirtsis-v4v6-mipv4-01.txt 
> > 
> > A New Internet-Draft is available from the on-line Internet-Drafts
> > directories.
> > 
> > 
> > 	Title		: Dual Stack Mobile IPv4
> > 	Author(s)	: G. Tsirtsis, et al.
> > 	Filename	: draft-tsirtsis-v4v6-mipv4-01.txt
> > 	Pages		: 17
> > 	Date		: 2006-4-14
> > 	
> > This specification provides IPv6 extensions to the Mobile IPv4 
> > [MIPv4] protocol. The extensions allow a dual stack node to 
> use IPv4 
> > and IPv6 home addresses as well as move between IPv4 and dual stack 
> > network infrastructures.
> > 
> > A URL for this Internet-Draft is:
> > http://www.ietf.org/internet-drafts/draft-tsirtsis-v4v6-mipv4-01.txt
> > 
> > To remove yourself from the I-D Announcement list, send a 
> message to 
> > [email-masked] with the word unsubscribe in 
> the body of
> > the message.  
> > You can also visit 
> https://www1.ietf.org/mailman/listinfo/I-D-announce 
> > to change your subscription settings.
> > 
> > 
> > Internet-Drafts are also available by anonymous FTP. Login with the
> > username
> > "anonymous" and a password of your e-mail address. After logging in,
> > type "cd internet-drafts" and then
> > 	"get draft-tsirtsis-v4v6-mipv4-01.txt".
> > 
> > A list of Internet-Drafts directories can be found in
> > http://www.ietf.org/shadow.html 
> > or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> > 
> > 
> > Internet-Drafts can also be obtained by e-mail.
> > 
> > Send a message to:
> > 	[email-masked].
> > In the body type:
> > 	"FILE /internet-drafts/draft-tsirtsis-v4v6-mipv4-01.txt".
> > 	
> > NOTE:	The mail server at ietf.org can return the document in
> > 	MIME-encoded form by using the "mpack" utility.  To use this
> > 	feature, insert the command "ENCODING mime" before the "FILE"
> > 	command.  To decode the response(s), you will need "munpack" or
> > 	a MIME-compliant mail reader.  Different MIME-compliant mail
> > readers
> > 	exhibit different behavior, especially when dealing with
> > 	"multipart" MIME messages (i.e. documents which have been split
> > 	up into multiple messages), so check your local documentation on
> > 	how to manipulate these messages.
> > 		
> > 		
> > Below is the data which will enable a MIME compliant mail reader
> > implementation to automatically retrieve the ASCII version of the
> > Internet-Draft.
> > 
> 
> -- 
> Mip4 mailing list: [email-masked]
>     Web interface: https://www1.ietf.org/mailman/listinfo/mip4
>      Charter page: http://www.ietf.org/html.charters/mip4-charter.html
> Supplemental site: http://www.mip4.org/
> 

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 17 Apr 2006 20:34:32 +0200

Hi Vijay

> time. we are revisiting this.

<hat type="wg-participant">

  I believe that what may have been seen as wrong at that time,
  being a distraction to getting MIPv6 completed and out the door,
  could very well be seen as right today.  The benefits in terms
  of making it possible to access IPv6 services when you have a
  MIPv4 infrastructure in place makes it easier to motivate a roll-
  out of IPv6 in an enterprise, even if the rest of the world does
  not move to IPv6 at the same time, for instance.

</hat>

> http://playground.sun.com/mobile-ip/WG-archive/pre-2003/

<hat type="chair">

  Lifting facts and arguments from the past may be helpful, but
  can't override our application of reason to today's situation.

  If there is to be arguments against this proposal, I'd like to
  see well-reasoned logic, rather than assumptions that decisions
  taken at another time under different circumstances should be
  authoritative for today.

</hat>

Regards,

	Henrik