Subject: RE: [Mip4] Proxy Mobile IPv4 in the WG charter

From: "MORAND Lionel RD-CORE-ISS" <[email-masked]>
Date: Fri, 17 Nov 2006 19:26:53 +0100

Hi, Kent
 
Could it possible to know which SDOs have adopted or are interested in such a solution?
 
BR,
 
Lionel

________________________________

	De : Kent Leung (kleung) [mailto:[email-masked]] 
	Envoyé : vendredi 17 novembre 2006 18:52
	À : [email-masked]
	Objet : [Mip4] Proxy Mobile IPv4 in the WG charter

	Hi.  The draft-leung-mip4-proxy-mode-01.txt draft describes using Mobile IPv4 in proxy mode to provide network-based mobility management.  There will need to be some more work on the draft.  But wanted to get some sense of support for Proxy Mobile IPv4 in this WG.  Certainly there are a few SDOs which have either adopted or interested in such mechanism.
	 
	Do folks want to take this on as a WG item eventually?
	 
	Kent

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: "Damic, Damjan" <[email-masked]>
Date: Tue, 21 Nov 2006 10:46:09 +0100

Hello,

I believe the Proxy MIP4 is worth the effort, and that MIP4 WG is the
appropriate place to address it.
Even though the idea originated by a different SDO, people (including
myself) believe having something standardized through IETF gives the
matter additional meaning and credibility.
A group work in IETF on such an item could therefore serve to provide a
critical feedback to the existing proposal, and possibly to align the
specification in the way the WG perceives it should be (as already
pointed by Alex and George).

Kind regards,
Damjan

>Date: Fri, 17 Nov 2006 09:51:52 -0800
>From: "Kent Leung \(kleung\)" <[email-masked]>
>Subject: [Mip4] Proxy Mobile IPv4 in the WG charter
>To: <[email-masked]>
>	
>
>Hi.  The draft-leung-mip4-proxy-mode-01.txt draft describes 
>using Mobile
>IPv4 in proxy mode to provide network-based mobility management.  There
>will need to be some more work on the draft.  But wanted to get some
>sense of support for Proxy Mobile IPv4 in this WG.  Certainly there are
>a few SDOs which have either adopted or interested in such mechanism.
>

---

From: "Kent Leung \(kleung\)" <[email-masked]>
Date: Tue, 28 Nov 2006 12:15:06 -0800

Hi George.  Sorry for the delay.
 
Good point about differentiating between standardizing a proxy MIPv4
protocol vs. existing proxy MIPv4 use case.  My proposal is to come up
with the former, defining simple and short spec on Proxy Mobile IPv4.
 
Thanks for the clarification.
 
Kent

From: Tsirtsis, George [mailto:[email-masked]] 
Sent: Monday, November 20, 2006 7:13 AM
To: Kent Leung (kleung); [email-masked]
Subject: RE: [Mip4] Proxy Mobile IPv4 in the WG charter

Hi Kent,

I think it makes sense for the PMIPv4 protocol to be standardized by
this group. I also think we should separate the way the protocol is used
in the field from what the generic protocol is that might be applicable
in various different systems. I think your draft is mixing the two
issues together. 

IMO we should have a very simple and hopefully sort specification
defining the changes (if any) to MIPv4 required so that the protocol can
run in proxy mode. In addition, if it is deemed necessary/useful, we can
have informational document(s) showing how PMIPv4 is used in various
systems. 

I have some specific comments on the protocol itself but we can talk
about that if/when this becomes a WG document.

Thanks

George 

From: Kent Leung (kleung) [mailto:[email-masked]] 
Sent: Friday, November 17, 2006 12:52 PM
To: [email-masked]
Subject: [Mip4] Proxy Mobile IPv4 in the WG charter

Hi.  The draft-leung-mip4-proxy-mode-01.txt draft describes using Mobile

Kent

---

From: "Kent Leung \(kleung\)" <[email-masked]>
Date: Tue, 28 Nov 2006 12:17:47 -0800

There is no NETLMM4 WG.  Mobile IPv4 is becoming more prevalent.  I
expect more work items being fed back from real world deployments.
 
Kent

From: Tsirtsis, George [mailto:[email-masked]] 
Sent: Monday, November 20, 2006 7:48 AM
To: Behcet Sarikaya
Cc: [email-masked]
Subject: RE: [Mip4] Proxy Mobile IPv4 in the WG charter

In the last IETF meeting there was agreement (to be confirmed on the
list) for a number of new items to be added to the MIP4 charter and a
few more things were left out because the WG has too many things to do.
I do not think MIP4 is going anywhere for a while longer.... 

From: Behcet Sarikaya [mailto:[email-masked]] 
Sent: Monday, November 20, 2006 10:31 AM
To: Tsirtsis, George
Cc: [email-masked]
Subject: Re: [Mip4] Proxy Mobile IPv4 in the WG charter

Is there a netlmm4 WG? IMHO pmip4 could be standardized there if any?
WGs can shut down if no new work left, and that is usually good
practice, there is nothing wrong in doing such a thing.

  No offense to any one.

Regards,

--behcet

----- Original Message ----
From: "Tsirtsis, George" <[email-masked]>
To: Kent Leung (kleung) <[email-masked]>; [email-masked]
Sent: Monday, November 20, 2006 9:13:03 AM
Subject: RE: [Mip4] Proxy Mobile IPv4 in the WG charter

Hi Kent,

Thanks

George 

Kent

---

From: "Kent Leung \(kleung\)" <[email-masked]>
Date: Tue, 28 Nov 2006 12:20:42 -0800

Hi Vidya.  We need a IPv4 signaling solution as well.  IPv4 is not going
away.  Mobile IPv4 use is growing.  We should have a good standard for
MIPv4 in proxy mode.
 
Kent

From: Narayanan, Vidya [mailto:[email-masked]] 
Sent: Monday, November 20, 2006 1:44 PM
To: Kent Leung (kleung); [email-masked]
Subject: RE: [Mip4] Proxy Mobile IPv4 in the WG charter

Hi Kent,
If NETLMM supported IPv4 endpoints, do we still need a standardized
PMIPv4 solution? Or, is this an effort to document what has been already
deployed? 
 
Regards,
Vidya

	From: Kent Leung (kleung) [mailto:[email-masked]] 
	Sent: Friday, November 17, 2006 9:52 AM
	To: [email-masked]
	Subject: [Mip4] Proxy Mobile IPv4 in the WG charter

	Hi.  The draft-leung-mip4-proxy-mode-01.txt draft describes
using Mobile IPv4 in proxy mode to provide network-based mobility
management.  There will need to be some more work on the draft.  But
wanted to get some sense of support for Proxy Mobile IPv4 in this WG.
Certainly there are a few SDOs which have either adopted or interested
in such mechanism.

	Kent

---

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Tue, 28 Nov 2006 17:09:37 -0500

Hi Kent,

Thanks for bringing this up. I support standardization of PMIP4 in IETF.
This is the only way we can make sure that a single PMIP4 protocol is
used across all SDOs. There is sufficient industry traction on PMIP4,
therefore it should be included in the MIP4 WG charter.

-Kuntal

> -----Original Message-----
> Sent: Tuesday, November 28, 2006 2:25 PM
> To: Alexandru Petrescu; Narayanan, Vidya
> Cc: [email-masked]
> Hi Alex.  WiMAX supports both client MIPv4 and proxy MIPv4 
> modes.  I prefer to keep the discussion focused on the need 
> to standardize MIPv4 in proxy mode in IETF.  I believe it 
> would be highly valuable specification and has potential 
> widespread use.
> 
> Kent 
> 
> -----Original Message-----
> From: Alexandru Petrescu [mailto:[email-masked]]
> Sent: Tuesday, November 21, 2006 9:51 AM
> To: Narayanan, Vidya
> Cc: Kent Leung (kleung); [email-masked]
> Narayanan, Vidya wrote:
> > Hi Kent, If NETLMM supported IPv4 endpoints, do we still need a 
> > standardized PMIPv4 solution?
> 
> Not sure what NETLMM is, or whether it supported IPv4 endpoints.
> 
> The other question is whether the known FA mode of MIP4 can 
> figure as a candidate for what WiMax nominates as Proxy MIP, 
> and the CCoA mode as what WiMax nominates Client MIP.
> 
> Alex
> 
> > Or, is this an effort to document what has been already deployed?
> > 
> > Regards, Vidya
> > 
> > 
> ----------------------------------------------------------------------
> > --
> >  *From:* Kent Leung (kleung) [mailto:[email-masked]] 
> *Sent:* Friday,
> 
> > November 17, 2006 9:52 AM *To:* [email-masked] *Subject:* 
> [Mip4] Proxy 
> > Mobile IPv4 in the WG charter
> > 
> > Hi.  The draft-leung-mip4-proxy-mode-01.txt draft describes using 
> > Mobile IPv4 in proxy mode to provide network-based mobility

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 28 Nov 2006 15:45:22 -0800 (PST)

I am neutral on PMIPv4 standardization, in fact may be we should not.
Since netlmm WG from the beginning has not ruled out a v4 solution and since netlmm WG decided to do PMIPv6, it seems logical that netlmm does PMIPv4 as well. Is there a problem with that?

--behcet

----- Original Message ----
From: "Chowdhury, Kuntal" <[email-masked]>
To: Kent Leung (kleung) <[email-masked]>; Alexandru Petrescu <[email-masked]>; "Narayanan, Vidya" <[email-masked]>
Cc: [email-masked]
Sent: Tuesday, November 28, 2006 4:09:37 PM
Subject: RE: [Mip4] Proxy Mobile IPv4 in the WG charter

Hi Kent,

-Kuntal