Subject: RE: [Mip4] Proxy Mobile IPv4 in the WG charter

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Wed, 29 Nov 2006 01:55:46 -0500

Behcet,
 
I am not clear on what you meant by "in fact may be we should not". We
should not what? Please clarify.
 
MIP4 and NETLMM both are IETF WGs. The goal is to define PMIP4 protocol
in IETF...so, as long as there is enough interest and support to get the
job done, the place should not matter very much.
 
-Kuntal

________________________________

	From: Behcet Sarikaya [mailto:[email-masked]] 
	Sent: Tuesday, November 28, 2006 5:45 PM
	To: Chowdhury, Kuntal
	Cc: [email-masked]
	Subject: Re: [Mip4] Proxy Mobile IPv4 in the WG charter

	I am neutral on PMIPv4 standardization, in fact may be we should
not.
	Since netlmm WG from the beginning has not ruled out a v4
solution and since netlmm WG decided to do PMIPv6, it seems logical that
netlmm does PMIPv4 as well. Is there a problem with that?

	--behcet

	----- Original Message ----
	From: "Chowdhury, Kuntal" <[email-masked]>
	To: Kent Leung (kleung) <[email-masked]>; Alexandru Petrescu
<[email-masked]>; "Narayanan, Vidya"
<[email-masked]>
	Cc: [email-masked]
	Sent: Tuesday, November 28, 2006 4:09:37 PM
	Subject: RE: [Mip4] Proxy Mobile IPv4 in the WG charter

	Hi Kent,
	
	Thanks for bringing this up. I support standardization of PMIP4
in IETF.
	This is the only way we can make sure that a single PMIP4
protocol is
	used across all SDOs. There is sufficient industry traction on
PMIP4,
	therefore it should be included in the MIP4 WG charter.
	
	-Kuntal

	> -----Original Message-----
	> From: Kent Leung (kleung) [mailto:[email-masked]] 
	> Sent: Tuesday, November 28, 2006 2:25 PM
	> To: Alexandru Petrescu; Narayanan, Vidya
	> Cc: [email-masked]
	> Subject: RE: [Mip4] Proxy Mobile IPv4 in the WG charter
	> 
	> Hi Alex.  WiMAX supports both client MIPv4 and proxy MIPv4 
	> modes.  I prefer to keep the discussion focused on the need 
	> to standardize MIPv4 in proxy mode in IETF.  I believe it 
	> would be highly valuable specification and has potential 
	> widespread use.
	> 
	> Kent 
	> 
	> -----Original Message-----
	> From: Alexandru Petrescu
[mailto:[email-masked]]
	> Sent: Tuesday, November 21, 2006 9:51 AM
	> To: Narayanan, Vidya
	> Cc: Kent Leung (kleung); [email-masked]
	> Subject: Re: [Mip4] Proxy Mobile IPv4 in the WG charter
	> 
	> Narayanan, Vidya wrote:
	> > Hi Kent, If NETLMM supported IPv4 endpoints, do we still
need a 
	> > standardized PMIPv4 solution?
	> 
	> Not sure what NETLMM is, or whether it supported IPv4
endpoints.
	> 
	> The other question is whether the known FA mode of MIP4 can 
	> figure as a candidate for what WiMax nominates as Proxy MIP, 
	> and the CCoA mode as what WiMax nominates Client MIP.
	> 
	> Alex
	> 
	> > Or, is this an effort to document what has been already
deployed?
	> > Regards, Vidya
----------------------------------------------------------------------
	> > --
	> >  *From:* Kent Leung (kleung) [mailto:[email-masked]] 
	> *Sent:* Friday,
	> 
	> > November 17, 2006 9:52 AM *To:* [email-masked] *Subject:* 
	> [Mip4] Proxy 
	> > Mobile IPv4 in the WG charter
	> > 
	> > Hi.  The draft-leung-mip4-proxy-mode-01.txt draft describes
using 
	> > Mobile IPv4 in proxy mode to provide network-based mobility 
	> > management.  There will need to be some more work on the
draft. But 
	> > wanted to get some sense of support for Proxy Mobile IPv4 
	> in this WG.
	> 
	> > Certainly there are a few SDOs which have either adopted or 
	> interested
	> 
	> > in such mechanism.
	> > 
	> > Do folks want to take this on as a WG item eventually?
	> > 
	> > Kent
	> > 
	> 
	> --
	> Mip4 mailing list: [email-masked]
	>     Web interface: https://www1.ietf.org/mailman/listinfo/mip4
	>      Charter page:
http://www.ietf.org/html.charters/mip4-charter.html
	> Supplemental site: http://www.mip4.org/
	> 
	
	--
	Mip4 mailing list: [email-masked]
	    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
	     Charter page:
http://www.ietf.org/html.charters/mip4-charter.html
	Supplemental site: http://www.mip4.org/

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: "Rao Satyanarayana-W60007" <[email-masked]>
Date: Wed, 29 Nov 2006 11:17:01 -0500

I think it makes sense to develop a specification for the operation of
PMIPv4. It would help interoperability.
If  I am a service provider I would like my network to work with both
CMIPv4 hosts as well as hosts without CMIPv4. If a proxy is involved to
provide such a transparency then it helps to understand the operations
of such a proxy agent and its location and its interaction if any with
the host for which it is acting as a proxy and its interaction with
other elements of the MIPv4 infrastructure and its configuration and
management aspects. 
 
I am neutral to whether the work should be done in MIPv4 WG or netLMM
WG.
 
- Satya Rao
Mobile Devices Technology Office
Motorola
Tel: 512-427-7335
Email: [email-masked] <mailto:[email-masked]> 

	From: Chowdhury, Kuntal [mailto:[email-masked]] 
	Sent: Wednesday, November 29, 2006 12:56 AM
	To: Behcet Sarikaya
	Cc: [email-masked]
	Subject: RE: [Mip4] Proxy Mobile IPv4 in the WG charter

	Behcet,
	 
	I am not clear on what you meant by "in fact may be we should
not". We should not what? Please clarify.
	 
	MIP4 and NETLMM both are IETF WGs. The goal is to define PMIP4
protocol in IETF...so, as long as there is enough interest and support
to get the job done, the place should not matter very much.
	 
	-Kuntal

		I am neutral on PMIPv4 standardization, in fact may be
we should not.
		Since netlmm WG from the beginning has not ruled out a
v4 solution and since netlmm WG decided to do PMIPv6, it seems logical
that netlmm does PMIPv4 as well. Is there a problem with that?

		--behcet

		----- Original Message ----
		From: "Chowdhury, Kuntal"
<[email-masked]>
		To: Kent Leung (kleung) <[email-masked]>; Alexandru
Petrescu <[email-masked]>; "Narayanan, Vidya"
<[email-masked]>
		Cc: [email-masked]
		Sent: Tuesday, November 28, 2006 4:09:37 PM
		Subject: RE: [Mip4] Proxy Mobile IPv4 in the WG charter

		Hi Kent,
		
		Thanks for bringing this up. I support standardization
of PMIP4 in IETF.
		This is the only way we can make sure that a single
PMIP4 protocol is
		used across all SDOs. There is sufficient industry
traction on PMIP4,
		therefore it should be included in the MIP4 WG charter.
		
		-Kuntal

		> > Hi Kent, If NETLMM supported IPv4 endpoints, do we
still need a 
endpoints.
		> > Or, is this an effort to document what has been
already deployed?
		> > Hi.  The draft-leung-mip4-proxy-mode-01.txt draft
describes using 
		> > management.  There will need to be some more work on
the draft. But 
		>     Web interface:
https://www1.ietf.org/mailman/listinfo/mip4
		
		--
		Mip4 mailing list: [email-masked]
		    Web interface:
https://www1.ietf.org/mailman/listinfo/mip4
		     Charter page:
http://www.ietf.org/html.charters/mip4-charter.html
		Supplemental site: http://www.mip4.org/