Subject: RE: [Mip4] Problem of using layer 2 triggers alone for the Low latencyHandofffor MIPv4

From: "ANTOINE Stephane RD-ILAB-LON" <[email-masked]>
Date: Fri, 19 Jan 2007 16:46:51 +0100

Hi Sebastian,

Find some comments in-line...
Thanks,

Stephane

> 		st> The specific procedure used to acquire the L3 
> 		information, such as the IP address of the 
> appropriate access 
> 		gateway is dependent on the access technology 
> over which the 
> 		low-latency handoff scheme is applied. For 
> instance, the 
> 		radio access point or base station identifier 
> could be used 
> 		to determine the L3 information associated with 
> the radio 
> 		access point or the base station (L2 entities). The L3 
> 		information could be statically or dynamically 
> configured at 
> 		the L2 entity based on the connectivity to an L3 entity 
> 		(access gateway).
> 		
> 		    
> 
> 	SA> It may be quite straightforward to statically 
> configure the Layer 2
> 	entity (Access Point (AP)) with L3 information (IP 
> address) of the
> 	Access Gateway (Foreign Agent) directly connected to it 
> and have this IP
> 	address advertised in the Beacon of the AP. However, it 
> becomes more
> 	problematic to have the AP advertise the IP address of 
> the new Foreign
> 	Agent (FA) the Mobile Node is going to handoff to. In 
> general the AP
> 	cannot guess which Foreign Agent the Mobile Node is 
> going to handoff to.
> 	The AP serving the Mobile Node may not be directly 
> connected to the new
> 	FA. For instance, handoff between a serving AP and a 
> target AP that are
> 	attached to two completely independent networks occurs 
> when moving
> 	between Wi-Fi and 3G. 
> 	
> 	  
> 
> st> The procedures by which the L2 entity discovers a connected or a 
> st> neighboring L3 entity are beyond the scope of this draft. 
> The layer 
> st> 2 trigger schemes proposed by this draft can be leveraged by L3 
> st> entity discovery schemes. The L3 entity discovery schemes could 
> st> range from a static configiration to a dynamic 
> configuration based 
> st> on the reachability of one or more L3 entities from any given L2 
> st> entity. 

SA> Having the L2 trigger based handoff initiated by a Layer 3 discovery
mechanism is part of the issues addressed in this draft. The document
does not preclude the use of Layer 2 triggers for the low latency draft
when using higher layer means to discover and initiate the handoff. The
Layer 2 triggers could result from the L3 discovery and initiation
process. Alternatively, Layer 2 triggers can be substituted for higher
layers triggers in a method where only the higher layer triggers are
initiating the low latency handoff. The object of this document is to
inform the community that higher layer triggers can be used to initiate
the Low Latency handoff.

Other criteria, such as the associated network 
> capacity, QoS 
> st> etc. could be used for the selection of an L3 entity that is 
> st> reachable from an L2 entity. This approach could be used across 
> st> diverse access technologies (Wi-Fi, 3G etc.)

SA> The selection of a L3 entity (FA), to handoff to, based on various
network characteristics, client profiles..., would typically be taken at
a higher level. Hence the introduction of the higher layer triggers.

> 
> 
> 	
> 
> 			Moreover, Layer 2 trigger will actually 
> occur in 
> 		response or in prevision to certain link events 
> such as the 
> 		fading of the relative signal noise ratio below 
> a certain level. 
> 		
> 		st> Yes.
> 		
> 		
> 			Relying only on link information to 
> initiate a handoff 
> 		does not generally gather enough information 
> for the Mobile 
> 		Node to handoff to the most suitable available 
> access network 
> 		at the most suitable time.
> 		
> 		st> See the previous response on L3 information 
> acquisition.
> 		
> 			Information from layers higher than 
> Layer 2 (that may 
> 		come from various protocols) can be used as triggers to 
> 		compensate the insufficiency of using Layer 2 
> triggers alone 
> 		for the Low latency Handoff for MIPv4.
> 		
> 		st> The L2 trigger information is used to 
> assist the upper 
> 		layer protocols, in the case of wireless mobility with 
> 		minimum latency, and not vice-versa. Using 
> access technology 
> 		specific schemes, the required L3 information, 
> such as the 
> 		serving access gateway IP address can be 
> obtained from the L2 
> 		trigger information.
> 		
> 		    
> 
> 	
> 	SA> The use of the Layer 2 trigger alone to assist the 
> upper layer
> 	protocols is exactly what we pinpoint as being an insufficiency.
> 
> st> The scope of the L2 trigger schemes for a low-latency 
> handoff allows a variety of techniques to acquire the 
> required L3 information, without specifically defining or 
> restricting them.

SA> The draft "Using Higher Layer Triggers for Low Latency Handoffs in
MIPv4" is extending the scope of the triggers used to initiate the low
latency handoff. It is introducing the use of Layer 3 or above triggers
without necessarily relying on layer 2 triggers. The draft is presenting
the motivation for this choice.
http://www.ietf.org/internet-drafts/draft-antoine-mip4-lowlatency-handof
f-triggers-00.txt 

> 
> 
> 	 If one
> 	relies only on Layer 2 trigger information, the Handoff 
> might always be
> 	initiated towards a network offering the highest signal 
> noise ratio.
> 	However the network offering the best signal noise 
> ratio is not always
> 	the most suitable network for a given Mobile Node to handoff to.
> 	One can introduce an overall system, involving higher 
> layer triggers
> 	that initiate the L3 handoff to the most suitable 
> network before the L2
> 	handoff actually takes place.
> 
> st> The draft proposes the use of L2 triggers to assist an L3 
> handoff, since L2 is closely tied with the nuances of the 
> associated wireless link technology.

SA> Using higher layer triggers might consist in passing Layer 2
information to higher layers where the decision to handoff to the most
preferable network is taken. 

> 
> 	 
> 	
> 	  
> 
> 			 
> 		
> 			I would also appreciate receiving some 
> feedback upon 
> 		the work presenting scenarios describing how 
> the low latency 
> 		Handoff for MIPv4 is initiated by higher layer triggers.
> 		
> 			
> 		
> http://www.ietf.org/internet-drafts/draft-antoine-mip4-lowlate
> 		ncy-handoff-triggers-00.txt 
> 		
> <http://www.ietf.org/internet-drafts/draft-antoine-mip4-lowlat
> 		ency-handoff-triggers-00.txt> 
> <http://www.ietf.org/internet-drafts/draft-antoine-mip4-lowlat
> ency-handoff-triggers-00.txt>  
> 		
> 			 
> 		
> 			Cheers
> 		
> 			 
> 		
> 			Stephane
> 		
> 			 
> 		
> 		
> 		
> 		    
> 
> 	
> 	  
> 
> 
> 

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Sebastian Thalanany <[email-masked]>
Date: Fri, 19 Jan 2007 12:24:23 -0600

Hi, Stephane,
                          Please note my comments in-line. Thanks.

Regards,
     Sebastian

>inform the community that higher layer triggers can be used to initiate
st> The low-latency draft proposes the L2 triggers to optimize L3 
handoff. It does not preclude other L3 or upper layer initiated handoff. 
The techniques proposed in the low-latency draft can be applied together 
with other L3 schemes.

>a higher level. Hence the introduction of the higher layer triggers.
st> This draft is based on the use of L2 triggers that are based on the 
radio-link conditions. The L3 and above entities are not implicitly 
aware of radio-link conditions. The intent of the draft is not to define 
conditions or triggers at L3 or above.

>http://www.ietf.org/internet-drafts/draft-antoine-mip4-lowlatency-handof
st> Good. Reliance on L2 conditions is essential, since the radio-link 
is stochastic in nature, and L3 and above layers cannot be expected to 
implicity determine radio-link conditions. L2 information is required by 
the L3 and above layers for handoff related optimization. The 
low-latency draft proposal does not preclude other L3 
conditions/triggers such as network capacity, load balancing etc. which 
could force a handoff in cases where the radio-link condition is not 
impacted.

>preferable network is taken. 
st> Yes. L3 and above triggers or conditions are beyond the scope of 
this draft.