Subject: RE: [Mip4] DHCP vs FA

From: "Arun SG" <[email-masked]>
Date: Mon, 8 Jan 2007 11:19:16 +0530

Just curious about the probable reason for the typical [or default]
behaviour of the MIP client - why it prefers FA CoA mode over Ccoa,
since if FA does not mandate registration, the MIP Client might very
well register directly at HA. Is it to do with accounting at FA or
something  different? 

Thanks,
Arun

-----Original Message-----
From: Kent Leung (kleung) [mailto:[email-masked]] 
Sent: Friday, January 05, 2007 11:48 PM
To: Sri Gundavelli (sgundave); Behcet Sarikaya
Cc: [email-masked]
Subject: RE: [Mip4] DHCP vs FA

Right.  Though typically the MIP client tend to favor the FA CoA mode of
operation in this case.

Kent 

-----Original Message-----
From: Sri Gundavelli (sgundave)
Sent: Thursday, January 04, 2007 2:51 PM
To: Behcet Sarikaya
Cc: [email-masked]
Subject: Re: [Mip4] DHCP vs FA

If the "R" bit is the agent advertisement is not set, it is up to the
mobile to decide on the FA-COA or CCOA mode of registration.

Sri

On Thu, 4 Jan 2007, Behcet Sarikaya wrote:

> Hi all,
>  I was reading RFC 3344 and noticed that it is not clear on the choice

> between the co-located care-of address mode using DHCP and FA provided
care-of address mode of operation. If MN does get a co-located care-of
address and there is an FA what happens then?
> If this had been discussed in the past, I'll appreciate if someone can
summarize the conclusion.
>
> Regards,
>
> --behcet
>
> ----- Original Message ----
> From: McCann Peter-A001034 <[email-masked]>
> To: [email-masked]
> Sent: Thursday, January 4, 2007 4:03:26 PM
> Subject: RE: [Mip4] I-D 
> ACTION:draft-ietf-mip4-mobike-connectivity-02.txt
>
>
> Thanks Vijay for submitting a new version.
>
> Can the people who raised issues please check this version to see that

> they were addressed?
>
> If there are no further issues we will proceed to send this version up

> to the IESG.
>
> -Pete
>
> [email-masked] wrote:
>> A New Internet-Draft is available from the on-line Internet-Drafts 
>> directories.
>> This draft is a work item of the Mobility for IPv4 Working Group of 
>> the IETF.
>>
>>     Title        : Secure Connectivity and Mobility using Mobile
> IPv4 and
>>     MOBIKE Author(s)    : V. Devarapalli, P. Eronen
>>     Filename    : draft-ietf-mip4-mobike-connectivity-02.txt
>>     Pages        : 15
>>     Date        : 2007-1-4
>>
>> Enterprise users require mobility and secure connectivity when they
>>    roam and connect to the services offered in the enterprise.
Secure
>>    connectivity is required when the user connects to the enterprise
>>    from an untrusted network.  Mobility is beneficial when the user
>>    moves, either inside or outside the enterprise network, and
>>    acquires a new IP address.  This document describes a solution
>>    using Mobile IPv4 and mobility extensions to IKEv2 (MOBIKE) to
>>    provide secure connectivity and mobility.
>>
>> A URL for this Internet-Draft is:
>>
> http://www.ietf.org/internet-drafts/draft-ietf-mip4-mobike-connectivit
> y-
> 02.txt
>>
>> To remove yourself from the I-D Announcement list, send a message to 
>> [email-masked] with the word unsubscribe in the body 
>> of the message.
>> You can also visit 
>> https://www1.ietf.org/mailman/listinfo/I-D-announce
>> to change your subscription settings.
>>
>> Internet-Drafts are also available by anonymous FTP. Login with the 
>> username "anonymous" and a password of your e-mail address. After 
>> logging in, type "cd internet-drafts" and then "get 
>> draft-ietf-mip4-mobike-connectivity-02.txt".
>>
>> A list of Internet-Drafts directories can be found in 
>> http://www.ietf.org/shadow.html or 
>> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>>
>> Internet-Drafts can also be obtained by e-mail.
>>
>> Send a message to:
>>     [email-masked].
>> In the body type:
>>     "FILE
> /internet-drafts/draft-ietf-mip4-mobike-connectivity-02.txt".
>>
>> NOTE:    The mail server at ietf.org can return the document in
>>     MIME-encoded form by using the "mpack" utility.  To use this
>>     feature, insert the command "ENCODING mime" before the "FILE"
>>     command.  To decode the response(s), you will need "munpack" or
>>     a MIME-compliant mail reader.  Different MIME-compliant mail
> readers
>>     exhibit different behavior, especially when dealing with
>>     "multipart" MIME messages (i.e. documents which have been split
>>     up into multiple messages), so check your local documentation on
>>     how to manipulate these messages.
>>
>> Below is the data which will enable a MIME compliant mail reader 
>> implementation to automatically retrieve the ASCII version of the 
>> Internet-Draft.
>
>
> --
> Mip4 mailing list: [email-masked]
>    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
>     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
> Supplemental site: http://www.mip4.org/

--
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Sri Gundavelli <[email-masked]>
Date: Sun, 7 Jan 2007 22:07:07 -0800 (PST)

For CCOA mode, the home agent needs to have a unique
tunnel for each mobile and that has a bearing on the
resources when compared to the FA-COA mode. This could
be one other reason.

Sri