Subject: [Mip4] New Version Notification for draft-gundavelli-mip4-multiple-tunnel-support-00 (fwd)

From: Sri Gundavelli <[email-masked]>
Date: Tue, 9 Dec 2008 19:25:36 -0800 (PST)

Please comment on this work item. We presented this
at Minneapolis.

Sri

---------- Forwarded message ----------
Date: Mon,  8 Dec 2008 00:51:42 -0800 (PST)
From: IETF I-D Submission Tool <[email-masked]>
To: [email-masked]
Cc: [email-masked]
Subject: New Version Notification for
     draft-gundavelli-mip4-multiple-tunnel-support-00

A new version of I-D, draft-gundavelli-mip4-multiple-tunnel-support-00.txt has been successfuly submitted by Sri Gundavelli and posted to the IETF repository.

Filename:	 draft-gundavelli-mip4-multiple-tunnel-support
Revision:	 00
Title:		 Multiple Tunnel Support for Mobile IPv4
Creation_date:	 2008-12-08
WG ID:		 Independent Submission
Number_of_pages: 17

Abstract:
This document defines extensions to Mobile IPv4 protocol for allowing
a mobile node or a mobile router with multiple interfaces to register
a care-of address for each of the available interfaces and to
simultaneously establish multiple Mobile IP tunnels to the home
agent, each through a different interface path.  This capability is
required for enabling a mobile node to utilize all the available
wireless access links and build an higher aggregated data pipe to the
home agent by setting the home address reachability over all of those
tunnel paths.

The IETF Secretariat.

--
Mip4 mailing list: [email-masked]
    Web interface: https://www.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Sri Gundavelli <[email-masked]>
Date: Tue, 9 Dec 2008 19:35:34 -0800 (PST)

Pointer to the draft.

http://www.ietf.org/internet-drafts/draft-gundavelli-mip4-multiple-tunnel-support-00.txt

On Tue, 9 Dec 2008, Sri Gundavelli wrote:

> A new version of I-D, draft-gundavelli-mip4-multiple-tunnel-support-00.txt 
> has been successfuly submitted by Sri Gundavelli and posted to the IETF 
> repository.
>

---

From: Qin Wu <[email-masked]>
Date: Wed, 10 Dec 2008 17:58:36 +0800

Hi Sri:
Two comments on this draft.
In section 1, you mention that 
In both of these modes, there will only be one interface on the mobile node that is receiving the traffic from the home agent.
However, this is not efficient and requires an approach where the mobile node can use more than one interfaces for reaching the home network.
[Qin]:It sounds reasonable to allow only one interface receive the traffic from the home agent. 
The reason is although we can allow several interfaces activate at the same time, It seems that more power will be consumed which is unacceptable for some real time applications.
On the other hand, multiple interfaces only can be used in multihoming scenarios I think. Each interface may support the different access technology.
 How come you make one mobile node with multiple interfaces register to the same home agent? Also it will causes IPv4 address resource exhaustion.
Therefore, which interface the user chooses mostly depends on the user preference or inter-technology requirement, e.g., he can choose one interface providing largest bandwidth.
In section 1, you also mention that
In the absence of any applied traffic policies, these multiple tunnel paths appear to the home agent and the mobile node as alternate routing paths 
[Qin] Too many tunnels will consume too much air interface resource? Is it true?

Thanks!
-Qin