Subject: RE: [Mip6] draft-soliman and draft-wakikawa

From: "Soliman, Hesham" <[email-masked]>
Date: Fri, 1 Apr 2005 18:52:50 -0500

Vijay, 

I've expressed my opinion on the genreal issue before.
Regarding this topic of comparison, I don't think the 
difference you expressed is worth writing new drafts
about. It would be much easier if you just suggest this to
us and we would discuss it. Instead, now we end up with
discussing very similar drafts for no apparent reason, which
takes more cycles.
I respect your right to write a new draft about whatever you
want. But for such a small differemce, you were welcome to
send a comment and discuss it...

FWIW I prefer not introducing a new option, the current
approach in draft-soliman fits easily within an implementation
as Conny already explained. Anyway, this is a secondary issue
and something that can be fine tuned much later in the process.

Hesham

 > -----Original Message-----
 > From: [email-masked] [mailto:[email-masked]]On 
 > Behalf Of
 > Vijay Devarapalli
 > Sent: Friday, April 01, 2005 6:36 PM
 > To: [email-masked]
 > Subject: [Mip6] draft-soliman and draft-wakikawa
 > 
 > 
 > Gerardo, Keiichi, Hesham and Henrik,
 > 
 > draft-soliman and draft-wakikawa both talk about binding a v4
 > CoA to a v6 HoA and setting an IPv6 over IPv4 tunnel between
 > the MN and the HA. the difference is in the way, the CoA is
 > conveyed to the HA. draft-soliman uses IPv4 mapped IPv6
 > address as the source address in the inner header. I believe
 > the packet format looks like the following.
 > 
 >    IPv4 hdr (src=CoA_v4, dst=HA_v4)
 >    IPv6 hdr (src=v4-mapped-v6-CoA, dst=HA_v6)
 >    Dst opts hdr
 >        HoA_v6
 >    Mobility hdr
 >        Binding Update
 > 
 > Hesham, let me know if this is not correct?
 > 
 > the HA extracts the IPv4 address from the v4-mapped-v6-CoA.
 > 
 > draft-wakikawa uses a mobility option for carrying the IPv4
 > address.
 > 
 >    IPv4 hdr (src=CoA_v4, dst=HA_v4)
 >    IPv6 hdr (src=HoA_v6, dst=HA_v6)
 >    Mobility hdr
 >        Binding Update
 >            IPv4 CoA mobility option
 > 
 > this is the main difference.
 > 
 > apart from this, is there is anything else in draft-soliman
 > that you think is important for the specific scenario we are
 > talking about (v6 MN/MR accessing v6 HA from a v4 only access
 > network).
 > 
 > draft-wakikawa, OTOH, also talks about the following. detailed
 > MN and HA behavior, IPsec SPD and SAD entries for securing the
 > IPv6-over-IPv4 tunnel, NAT traversal, how to negotiate a
 > particular tunneling mechanism and new binding ack status
 > values.
 > 
 > personally, I prefer a new mobility option to carry the IPv4
 > CoA, because it makes processing on the HA simple. but we can
 > have the WG decide on this. I am open.
 > 
 > Vijay
 > 
 > _______________________________________________
 > Mip6 mailing list
 > [email-masked]
 > https://www1.ietf.org/mailman/listinfo/mip6
 > 

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 01 Apr 2005 16:39:48 -0800

Hesham,

> send a comment and discuss it...

I was saying the opposite. show me something of value from
draft-soliman that is not there in draft-wakikawa and we will
take it up from there.. :)

> as Conny already explained. 

FWIW, we have implementations of draft-wakikawa too...

> Anyway, this is a secondary issue

I agree.

Vijay