Subject: RE: [nemo] Re: [Mip6] Consensus call on making IDdraft-wakikawa-nemo-v4tunnel a MIP6/NEMO WGs document

From: "Davis, Terry L" <[email-masked]>
Date: Thu, 31 Mar 2005 09:17:08 -0800

Carl

Amen!!!

I would be very interested if your requirement were in place: "One
requirement that I believe is highly desirable is the ease of deployment
of a solution that enables Mobile IPv6 traversal in IPv4 networks."

This would allow us to consider v6 for the mobile platform without
worrying about installing a full global v6 infrastructure to support
them.

Sri/Vijay

And I'd sure like it if the discussion considered options to "home
agents".  I fail to comprehend how I move state for routing, QoS,
security, and capacity for hundreds of users/applications on mobile
platforms around on a global scale through home agents, especially if
I'm joining someone else's network (i.e. one airport to the next).

Try imagining teleporting an engineering building from your corporate
campus instantly onto the campus of your biggest competitor and have all
network connections maintained, your VPN's not dropped, routing continue
un-interrupted, security maintained, QoS maintained, and you have
equivalent network capacity.  This is what we are beginning to try to do
with large mobile platforms today.  Now I don't honestly believe we can
achieve all of this; but it seems like this should be our goal.

Take care

Terry Davis
Connexion by Boeing

-----Original Message-----
From: Carl Williams [mailto:[email-masked]] 
Sent: Wednesday, March 30, 2005 10:12 PM
To: 'Sri Gundavelli'; 'Vijay Devarapalli'
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]
Subject: RE: [nemo] Re: [Mip6] Consensus call on making
IDdraft-wakikawa-nemo-v4tunnel a MIP6/NEMO WGs document

Hi Sri,

  Looking at things from an operational or deployment perspective:

  One requirement that I believe is highly desirable is the ease of
deployment of a solution that enables Mobile IPv6 traversal in IPv4
networks.  Additional network infrastructure and/or a complicated
protocol will take us further from the base MIPv6 protocol - which
impacts the ease of deployment and possible acceptance. 

   It would be highly desirable for operators and users not to have a
requirement that their Mobile IPv6 service be dependent on a separate
transition service.  

  Finally, co-existence of Mobile IPv6 (a feature of IPv6:) with IPv4
networks is a mandate that we must adhere to ASAP; otherwise, there will
be little acceptance to advance Mobile IPv6 adoption/deployment  [just
think if we waited for the core IPv6 specifications to become RFCs
before working on v6ops stuff - where would will be with IPv6 deployment
today].  draft-wakikawa-nemo-v4tunnel-01 limits the scope to what I
believe is the minimum scenario and requires little protocol changes.
Let's keep in mind the operator's perspective in the debate. 

   Carl

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Sri Gundavelli
Sent: Wednesday, March 30, 2005 4:27 PM
To: Vijay Devarapalli
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [nemo] Re: [Mip6] Consensus call on making ID
draft-wakikawa-nemo-v4tunnel a MIP6/NEMO WGs document

Hi Vijay,

On Wed, 30 Mar 2005, Vijay Devarapalli wrote:

> Sri,
>
> Sri Gundavelli wrote:
> > Hi Raj,
> >        In the last IETF nemo meeting, we raised some
> > issues on the approach chosen by this draft. We are
> > not convinced that the draft has explored and narrowed
> > down on the most common v4 traversal scenarios. The
> > basic assumption of the draft that the v6 Home Agent's
> > functionality is collapsed in to the transition gateway
> > is not valid and just addresses one scenario. The
> > requirement the draft imposes on having a V4 network
> > terminating on the v6 home agent is probably not
> > acceptible.
>
> if I understood you right, your concern is about how to make
> an IPv6 HA with an IPv4 interface accesible through the IPv4
> Internet. right?

The question is not about configuring a v4 address on the
interface of v6 home agent, it about the termination point
of the v4 network and the placement of a v6 home agent. You
cannot expect the v6 home agent and the transition gateway
service to be co-located. The point is that we should identify
the practical deployment sceanarios and go from there.

>
> > Also, the draft's claim that they are
> > avoiding one extra encap layer is not true, the moment
> > you move the transition gateway from the home agent,
> > indeed an extra encap layer is needed.
>
> we do want to keep it to just one level of encapsulation.
>

Other way to say is we would not an extra encap layer, when
the home agent and the transition gateway functions are spread
out.

> Vijay
>
> >
> > There were some other proposals for solving this problem
> > and one being "draft-thubert-nemo-ipv4-traversal-01.txt",
> > we should look at this work as well. Before we agree on
> > a solution, we should atleast semantically agree on the
> > problem statement and the scope. I remember you words,
> > we should not boil the ocean in the process, Agreed !
> > But, atleast we should have some amount of discussions on
> > the problem scope. My 2c.
> >
> > Regards
> > Sri
> >
> >
> >
> >
> >
> > On Wed, 30 Mar 2005 [email-masked] wrote:
> >
> >
> >>One of the major barriers to the deployment of Mobile IPv6 today is
> >>the fact that most access networks are IPv4 only. A number of hosts
> >>are already dual-stack capable. While Mobile IPv6 works well in IPv6
> >>networks, it is essential that IPv6 mobility service continue to
work
> >>even when the mobile host is attached to an IPv4 network. The same
> >>applies to a NEMO mobile router as well.
> >>
> >>A number of transition scenarios have been identified in IDs:
> >>1. draft-larsson-v6ops-mip-scenarios-01
> >>2. draft-tsirtsis-dsmip-problem-03
> >>While discussion of these scenarios in the larger scope makes sense,
> >>there is a need to focus on the most critical scenario that would
> >>address the MIP6 host and router problem. The problem in a single
> >>sentence can be stated as: "Mobile IPv6 hosts and routers (NEMO)
need
> >>to be able to reach its (IPv6) home agent and services when roaming
in
> >>and attached to an IPv4 access network."
> >>It makes sense to focus on just this one scenario and solve the
> >>problem immediately.
> >>
> >>The ID: draft-wakikawa-nemo-v4tunnel-01 solves the problem of a
MIPv6
> >>mobile node or a NEMO mobile router roaming onto a IPv4 only access
> >>network in a simple manner.
> >>It is intended that the standardization of this solution in the
IETFs
> >>MIP6 and/or NEMO working groups proceed. The working group chairs
have
> >>reviewed and discussed this work item. It has also been presented at
> >>the MIP6 and NEMO WGs at IETF62.
> >>
> >>The chairs would like to hear your thoughts in order to see if there
> >>is consensus to make it a WG document and progress it as a standards
> >>track RFC. Comments should be sent to both the NEMO and MIP6 WGs.
> >>
> >>If we have consensus, then the document will be pursued as a dual WG
> >>item and called draft-ietf-mip6-nemo-v4tunnel-xx.txt
> >>
> >>Make I-D draft-wakikawa-nemo-v4tunnel a MIP6/NEMO WG ID:
> >>	For 		[  ]
> >>	Against 	[  ]
> >>
> >>
> >>- MIP6 and NEMO WG chairs
> >>
> >>
> >>_______________________________________________
> >>Mip6 mailing list
> >>[email-masked]
> >>https://www1.ietf.org/mailman/listinfo/mip6
> >>
> >
> >
> > _______________________________________________
> > Mip6 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/mip6
>

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Fri, 1 Apr 2005 15:58:11 +0200

Doors uses the BU as keep alive. 

Just tune the Binding lifetime according to your needs. In general, 30s
was fine with us.

Pascal

| -----Original Message-----
| From: [email-masked] [mailto:[email-masked]] On Behalf
Of
| Alexandru Petrescu
| Sent: Friday, April 01, 2005 10:59 AM
| To: Vijay Devarapalli
| Cc: [email-masked]; [email-masked]; Pekka Savola
| Subject: Re: [nemo] Re: [Mip6] Consensus call on making
IDdraft-wakikawa-
| nemo-v4tunnel a MIP6/NEMO WGs document
| 
| Vijay Devarapalli wrote:
| >> - you specify UDP encapsulation for NAT traversal, but no keepalive
| >>
| >
| > okay. will fix this.
| 
| How are you going to fix this Vijay?  I use 15s keepalive with ICMP.
| Would you do similarly?
| 
| Alex

---

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Fri, 1 Apr 2005 18:22:37 +0200

Hi Raj:

I suggest that we agree on whether we want NAT/PAT/RevNAT traversal or
not. 

We had this debate some time ago at NEMO, and I presented this at IETF
56::
http://mobilenetworks.org/nemo/ietf56/slides/ietf56-nemo-ipv4traversal.p
pt 

That day, we voted that IPv4 traversal was a GOAL for the WG.

In particular, the discussion turned around NAT which appears to be
really centric to this problem. 

My personal sense is that we DO NEED (all sorts of) NAT traversal. And
it's not impossible if we accept that it works in an agreed upon 'MOST
CASES'. 

Pascal

| -----Original Message-----
| From: [email-masked] [mailto:[email-masked]] On Behalf
Of
| [email-masked]
| Sent: Friday, April 01, 2005 5:41 PM
| To: [email-masked]; [email-masked]
| Subject: [nemo] RE: [Mip6] Consensus call on making
IDdraft-wakikawa-nemo-
| v4tunnel a MIP6/NEMO WGs document
| 
| 
| A couple of clarifications regarding the consensus call:
| 
| 1. The intention is to address the following scenario:
| "MIPv6 and NEMO capable Mobile hosts/routers attaching to an IPv4
| access network need the capability to create a tunnel and be connected
| to their MIP6 home agents."
| This is the scenario that is most applicable for MIP6 deployment.
| There are plenty of other scenarios as well. But they are much more
| of academic interest at this time and hence not really in the scope
| of this discussion. So I would suggst that we do not go off on a
tangent
| discussing all these other scenarios.
| 
| Do you agree/disagree that the above scenario is the one that needs
| to be solved ASAP?
| (Note: It does not imply that other scenarios are irrelevant. It
simply
| means that this is the scenario worth working on and has the most
| significant priority or value for MIP6 deployment.)
| 
| 2. ID:  draft-wakikawa-nemo-v4tunnel can be used as the baseline. It
| does not imply that we are ruling out draft-soliman-v4v6-mipv6 or any
| other. The IDs can be combined w.r.t the parts that address this
scenario.
| Additionally once it is a WG document, what goes into the ID is
decided
| by the WG. So lets not get into arguments of what or whose draft is
the
| one that should be made the WG document.
| 
| -Basavaraj

---

From: "Soliman, Hesham" <[email-masked]>
Date: Fri, 1 Apr 2005 15:57:36 -0500

> Do you agree/disagree that the above scenario is the one that needs
 > to be solved ASAP?

=> I agree.

 > (Note: It does not imply that other scenarios are 
 > irrelevant. It simply
 > means that this is the scenario worth working on and has the most 
 > significant priority or value for MIP6 deployment.)
 > 
 > 2. ID:  draft-wakikawa-nemo-v4tunnel can be used as the baseline. It
 > does not imply that we are ruling out draft-soliman-v4v6-mipv6 or any
 > other. 

=> I don't see how it doesn't imply that. I think we should agree
on the scenario first, without associating it with either draft-wakikawa
or draft-soliman. Once we agreed, we can discuss how to solve the 
problem. I disagree with making draft-wakikawa a baseline. 

Hesham

The IDs can be combined w.r.t the parts that address 
 > this scenario.
 > Additionally once it is a WG document, what goes into the ID 
 > is decided
 > by the WG. So lets not get into arguments of what or whose 
 > draft is the
 > one that should be made the WG document.
 > 
 > -Basavaraj
 > 
 > 

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

---

From: Gerardo Giaretta <[email-masked]>
Date: Mon, 04 Apr 2005 10:10:29 +0200

> 
> A couple of clarifications regarding the consensus call:
> 
> 1. The intention is to address the following scenario:
> "MIPv6 and NEMO capable Mobile hosts/routers attaching to an IPv4
> access network need the capability to create a tunnel and be connected
> to their MIP6 home agents."
> This is the scenario that is most applicable for MIP6 deployment.
> There are plenty of other scenarios as well. But they are much more
> of academic interest at this time and hence not really in the scope
> of this discussion. So I would suggst that we do not go off 
> on a tangent
> discussing all these other scenarios.
> 
> (Note: It does not imply that other scenarios are irrelevant. 
> It simply

I agree on the priority of this scenario.

--Gerardo

> other. The IDs can be combined w.r.t the parts that address 
> this scenario.

Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please send an e_mail to
[email-masked]. Thank you
====================================================================