Subject: Re: [nemo] Re: [Mip6] Consensus call on makingIDdraft-wakikawa-nemo-v4tunnel a MIP6/NEMO WGs document

From: Brijesh Kumar <[email-masked]>
Date: Wed, 30 Mar 2005 21:01:07 -0500

Hi Raj:

I too would support Sri's excellent analysis.

I am very surprised to see this consensus mail, given that during the last IETF meeting, several people had raised the concerns similar to what Sri has described  in his mail regarding that draft. Not  clear what has changed since then. 

--bk

----- Original Message -----
From: Sri Gundavelli <[email-masked]>
Date: Wednesday, March 30, 2005 5:38 pm
Subject: [nemo] Re: [Mip6] Consensus call on making IDdraft-wakikawa-nemo-v4tunnel a	MIP6/NEMO WGs document

> Hi Raj,
>       In the last IETF nemo meeting, we raised some
> issues on the approach chosen by this draft. We are
> not convinced that the draft has explored and narrowed
> down on the most common v4 traversal scenarios. The
> basic assumption of the draft that the v6 Home Agent's
> functionality is collapsed in to the transition gateway
> is not valid and just addresses one scenario. The
> requirement the draft imposes on having a V4 network
> terminating on the v6 home agent is probably not
> acceptible. Also, the draft's claim that they are
> avoiding one extra encap layer is not true, the moment
> you move the transition gateway from the home agent,
> indeed an extra encap layer is needed.
> 
> There were some other proposals for solving this problem
> and one being "draft-thubert-nemo-ipv4-traversal-01.txt",
> we should look at this work as well. Before we agree on
> a solution, we should atleast semantically agree on the
> problem statement and the scope. I remember you words,
> we should not boil the ocean in the process, Agreed !
> But, atleast we should have some amount of discussions on
> the problem scope. My 2c.
> 
> Regards
> Sri
> 
> 
> 
> 
> 
> On Wed, 30 Mar 2005 [email-masked] wrote:
> 
> >
> > One of the major barriers to the deployment of Mobile IPv6 today is
> > the fact that most access networks are IPv4 only. A number of hosts
> > are already dual-stack capable. While Mobile IPv6 works well in IPv6
> > networks, it is essential that IPv6 mobility service continue to 
> work> even when the mobile host is attached to an IPv4 network. 
> The same
> > applies to a NEMO mobile router as well.
> >
> > A number of transition scenarios have been identified in IDs:
> > 1. draft-larsson-v6ops-mip-scenarios-01
> > 2. draft-tsirtsis-dsmip-problem-03
> > While discussion of these scenarios in the larger scope makes sense,
> > there is a need to focus on the most critical scenario that would
> > address the MIP6 host and router problem. The problem in a single
> > sentence can be stated as: "Mobile IPv6 hosts and routers (NEMO) 
> need> to be able to reach its (IPv6) home agent and services when 
> roaming in
> > and attached to an IPv4 access network."
> > It makes sense to focus on just this one scenario and solve the
> > problem immediately.
> >
> > The ID: draft-wakikawa-nemo-v4tunnel-01 solves the problem of a 
> MIPv6> mobile node or a NEMO mobile router roaming onto a IPv4 
> only access
> > network in a simple manner.
> > It is intended that the standardization of this solution in the 
> IETFs> MIP6 and/or NEMO working groups proceed. The working group 
> chairs have
> > reviewed and discussed this work item. It has also been 
> presented at
> > the MIP6 and NEMO WGs at IETF62.
> >
> > The chairs would like to hear your thoughts in order to see if there
> > is consensus to make it a WG document and progress it as a standards
> > track RFC. Comments should be sent to both the NEMO and MIP6 WGs.
> >
> > If we have consensus, then the document will be pursued as a 
> dual WG
> > item and called draft-ietf-mip6-nemo-v4tunnel-xx.txt
> >
> > Make I-D draft-wakikawa-nemo-v4tunnel a MIP6/NEMO WG ID:
> > 	For         	[  ]
> > 	Against 	[  ]
> >
> >
> > - MIP6 and NEMO WG chairs
> >
> >
> > _______________________________________________
> > Mip6 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/mip6
> >
> 
> 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Soliman, Hesham" <[email-masked]>
Date: Sat, 2 Apr 2005 03:31:03 -0500

Hi Raj, 

I misunderstood your question, so I take back the yes below
about the scenario. I don't see how or why you picked this 
scenario in the first place. I do think we need a list of 
priorities for scenarios to consider but we need 
to do that in the context of draft-larsson which is the only
doc that lists all scenarios. Once we have that discussion
we can pick scenarios to consider for solutions.

Hesham

 > -----Original Message-----
 > From: [email-masked] [mailto:[email-masked]]On 
 > Behalf Of
 > Soliman, Hesham
 > Sent: Friday, April 01, 2005 3:58 PM
 > To: [email-masked]; [email-masked]; [email-masked]
 > Subject: RE: [nemo] RE: [Mip6] Consensus call on
 > makingIDdraft-wakikawa-nemo-v4tunnel a MIP6/NEMO WGs document
 > 
 > 
 > 
 >  > Do you agree/disagree that the above scenario is the one 
 > that needs
 >  > to be solved ASAP?
 > 
 > => I agree.
 > 
 >  > (Note: It does not imply that other scenarios are 
 >  > irrelevant. It simply
 >  > means that this is the scenario worth working on and has the most 
 >  > significant priority or value for MIP6 deployment.)
 >  > 
 >  > 2. ID:  draft-wakikawa-nemo-v4tunnel can be used as the 
 > baseline. It
 >  > does not imply that we are ruling out 
 > draft-soliman-v4v6-mipv6 or any
 >  > other. 
 > 
 > => I don't see how it doesn't imply that. I think we should agree
 > on the scenario first, without associating it with either 
 > draft-wakikawa
 > or draft-soliman. Once we agreed, we can discuss how to solve the 
 > problem. I disagree with making draft-wakikawa a baseline. 
 > 
 > Hesham
 > 
 > The IDs can be combined w.r.t the parts that address 
 >  > this scenario.
 >  > Additionally once it is a WG document, what goes into the ID 
 >  > is decided
 >  > by the WG. So lets not get into arguments of what or whose 
 >  > draft is the
 >  > one that should be made the WG document.
 >  > 
 >  > -Basavaraj
 >  > 
 >  > 
 > 
 > ===========================================================
 > This email may contain confidential and privileged material 
 > for the sole use
 >  of the intended recipient.  Any review or distribution by 
 > others is strictly
 >  prohibited.  If you are not the intended recipient please 
 > contact the sender
 >  and delete all copies.
 > ===========================================================
 > 
 > 
 >