Subject: RE: [Mip6] draft-soliman and draft-wakikawa

From: Gerardo Giaretta <[email-masked]>
Date: Mon, 04 Apr 2005 10:58:49 +0200

Hi Vijay,

please see below..

> 
> Gerardo, Keiichi, Hesham and Henrik,
> 
> draft-soliman and draft-wakikawa both talk about binding a v4
> CoA to a v6 HoA and setting an IPv6 over IPv4 tunnel between
> the MN and the HA. the difference is in the way, the CoA is
> conveyed to the HA. draft-soliman uses IPv4 mapped IPv6
> address as the source address in the inner header. I believe
> the packet format looks like the following.
> 
>    IPv4 hdr (src=CoA_v4, dst=HA_v4)
>    IPv6 hdr (src=v4-mapped-v6-CoA, dst=HA_v6)
>    Dst opts hdr
>        HoA_v6
>    Mobility hdr
>        Binding Update
> 
> Hesham, let me know if this is not correct?
> 
> the HA extracts the IPv4 address from the v4-mapped-v6-CoA.
> 
> draft-wakikawa uses a mobility option for carrying the IPv4
> address.
> 
>    IPv4 hdr (src=CoA_v4, dst=HA_v4)
>    IPv6 hdr (src=HoA_v6, dst=HA_v6)
>    Mobility hdr
>        Binding Update
>            IPv4 CoA mobility option
> 
> this is the main difference.
> 
> apart from this, is there is anything else in draft-soliman
> that you think is important for the specific scenario we are
> talking about (v6 MN/MR accessing v6 HA from a v4 only access
> network).
> 
> draft-wakikawa, OTOH, also talks about the following. detailed
> MN and HA behavior, IPsec SPD and SAD entries for securing the
> IPv6-over-IPv4 tunnel, NAT traversal, how to negotiate a
> particular tunneling mechanism and new binding ack status
> values.
> 
> personally, I prefer a new mobility option to carry the IPv4
> CoA, because it makes processing on the HA simple. but we can
> have the WG decide on this. I am open.
> 

my point was that I'd like to understand the rationale behind this
choice (is it only that it makes processing on HA simpler? how do you
measure this simpleness?). As stated before, I'm not adovacting any
draft, just trying to understand the best approach to register a IPv4
CoA. However, I think this is a secondary issue and we should address it
after we all agree on the scenario(s) to be considered. 

--Gerardo

> Vijay
> 
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mip6
> 

Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please send an e_mail to
[email-masked]. Thank you
====================================================================

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Ryuji Wakikawa <[email-masked]>
Date: Mon, 4 Apr 2005 18:40:56 +0900

> after we all agree on the scenario(s) to be considered.

Hello Gerardo

Supporting NAT traversal or not.
For mobile node, it's simpler to clear out MIP6 tunnel and use v4-v6 
tunnel.
It also removes HoA option from packets while MN is in Ipv4 networks.
IPsec protection is also different. In our draft, MN establishes SA for 
IPv4 addresses.

what else..

regards,
ryuji