Subject: RE: v4 CoA and route optimization [Re: [Mip6] draft-soliman anddraft-wakikawa]

From: "Soliman, Hesham" <[email-masked]>
Date: Mon, 4 Apr 2005 11:29:31 -0400

> Note that AFAIK, NAT traversal between the bidirectional 
 > MN-HA tunnel 
 > is likely going to be rather simple (if keepalives are considered OK 
 > in the scenario; as Hesham points out, they might be completely 
 > unacceptable in some sceanrios [but that's why it could be 
 > possible to 
 > turn them off it there is no NAT on the path]).

=> Exactly right. This is why in draft-soliman the choice was made
to not include the NAT traversal by default. It would be nice 
if something can be added/removed when needed. For instance, 
when managing local mobility there is no need for NAT traversal, 
when managing global mobility you might need it. 
I haven't read doors/teredo in a looong time and can't remember
if there is anything that can be used to turn this on/off.

Hesham

 > -- 
 > Pekka Savola                 "You each name yourselves king, yet the
 > Netcore Oy                    kingdom bleeds."
 > Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
 > 
 > _______________________________________________
 > Mip6 mailing list
 > [email-masked]
 > https://www1.ietf.org/mailman/listinfo/mip6
 > 

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Sri Gundavelli <[email-masked]>
Date: Mon, 4 Apr 2005 10:41:23 -0700 (PDT)

Hi Hesham,

> if there is anything that can be used to turn this on/off.

Not sure, if I understood what you mean by "turn of NAT traversal".
NAT traversal is based on the need. Doors applies some what
similar to 3519 NAT detection logic.

We plan to revise the Doors draft and clarify text where ever needed.

Sri