Subject: RE: [Mip6] draft-dupont-mip6-dhaadharmful-00.txt

From: "Narayanan Vidya-CVN065" <[email-masked]>
Date: Tue, 25 Oct 2005 14:44:22 -0400

I'm trying to catch up with the plethora of emails here :) 

Lets distinguish VRRP-based mechanisms from "load balancing" mechanisms
- fundamentally, one aims at failover and the other aims at load
balancing. Architecturally, these are different. 

A few questions to ask here may be the following: 

1. Are we working on failover mechanisms in the WG? 

2. Are we working on load balancing mechanisms in the WG? 

3. Do we expect a common architecture/solution to solve the two? 

If the answer to 3 is 'yes', then I think we are limited in the number
of solutions to consider (and this, I believe, is likely to be a good
thing). 

Regards,
Vidya

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: Tuesday, October 25, 2005 1:24 PM
> To: Petrescu Alexandru-AAP021
> Cc: Narayanan Vidya-CVN065; [email-masked]; Kilian Weniger; James Kempf
> Subject: Re: [Mip6] draft-dupont-mip6-dhaadharmful-00.txt 
> 
>  In your previous mail you wrote:
> 
>    > => we agree: current DHAAD design is not stupid, it has 
> only two real
>    > problems:
>    >  - the DHAAD idea itself is in danger because HA 
> assignment is better
>    
>    By "HA assignment" you mean HA Switch message and draft?
> 
> => no, I mean a HA assignment mechanism in general, including 
> (i.e., mainly :-) any still to be invented mechanism.
> HA switch message is fine but is clearly *re*-assignment.
> 
>    If yes, that
>    draft alone does not help for bootstrapping IMHO.  If 
> DHAAD can be made
>    to work with non-anycast addresses then DHAAD+MPD is a 
> good idea to do
>    bootstrapping simple (MPD is Mobile Prefix Discovery).
>    
> => I don't understand why MPD is for when you have HA 
> discovery/assignment (the mobile prefix is simply the prefix 
> of the HA address)... I should have missed something, for 
> instance there is more than one MP?
> 
>    >  - the current mechanism has some operational issues, 
> mainly its lack
>    >    of reasonably easy security and the spurious but 
> common ICMP filtering.
>    > My draft is about the second but the first is more 
> critical and drastic...
>    
>    I don't see anything critical or drastic in HA assignment 
> being proposed
>    as better than DHAAD.
> 
> => the question is drastic, i.e., if the answer is yes all 
> discussions about the best DHAAD mechanism are lost bits...
> 
>    It can complement DHAAD and work together with it
>    (HA Switch, DHAAD Req, DHAAD Reply).  I don't think HA 
> Switch is about
>    to remove DHAAD altogether.
> 
> => HA assignment should as it will give no choice, i.e., 
> nothing to discover.
>    
>    If DHAAD disappears altogether it's because it's bound to anycast
>    addresses and nobody cared to put on paper the non-anycast 
> DHAAD that
>    works ok on at least two implementations.
>    
> => I make a difference between the DHAAD function and the 
> current mechanism. Here the first question is about the 
> function and the second about the mechanism.
> 
>    I think I agree, although my experience with VRRP is very limited.
>    
> => I have a (bad in fact :-) experience with HSRP which is 
> the Cisco proprietary protocol before VRRP.
> 
> Regards
> 
> [email-masked]
> 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Francis Dupont <[email-masked]>
Date: Tue, 25 Oct 2005 21:24:55 +0200

=> good luck (:-)

   
   
=> yes, "Improving home agent reliability" is in the charter and
clearly something needed for deployment.

=> it is not explicitely in the charter.

=> I believe the answer is no because failover is far easier.

=> but a 'yes' to 3 can be an obstacle to find quickly good solutions
for failover...

Regards

PS: the right way is to get feedback from operators: the goal of the IETF
is not to produce X pages of junk specs per day, but to provide good
(i.e., fulfilling real requirements) specs to operators and customers.
At least it should be the goal...

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 25 Oct 2005 16:18:38 -0700

> At least it should be the goal...

well, the feedback I have gotten so far....

Dont worry about HA assignment. We know how to assign servers
to terminals that attach to our networks.

so maybe we need to sit back and relax a bit. wait
and see how MIPv6 is deployed and then develop
solutions that might actually be used. :)

Vijay

---

From: Francis Dupont <[email-masked]>
Date: Wed, 26 Oct 2005 10:15:53 +0200

=> but this is only the integrated scenario.

=> there is at least an operator asking for HA assignment and
I believe we can get a consensus about the fact that HA assignment
is better than HA discovery.

Regards

---

From: Brian Haley <[email-masked]>
Date: Wed, 26 Oct 2005 10:38:34 -0400

I finally caught-up on this thread :)

> is better than HA discovery.

I believe there is also at least one operator asking for HA 
re-assignment, which was one reason for the ha-switch draft.

I do agree we need more input from our "customers", I surely don't want 
to invest any time in a draft that never gets used, but we've got to put 
a few basic tools in the MIPv6 toolbag.

-Brian