Subject: RE: [Mip6] General comments/questions on MIPv6 bootstrapping

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Wed, 26 Oct 2005 15:03:48 -0400

> Maybe, some text is needed to explain how and when the MN knows that
it
> cannot get the HA address with the DHCP-based mechanism and decides to
> use finally DNS-based mechanism.

This was discussed in DT. If the MN supports the DHCP based HA
bootstrapping scheme, it should send a DHCP Information Request for HA
info as soon as it connects in the access network. To reduce setup
delay, the MN can also send a DNS query to discover HA info
simultaneously. If it receives HA info from both DHCP and DNS servers,
then the HA info from DHCP takes precedence. If not, the HA info from
either one is used by the MN.

The operators can decide whether the MN needs to send DHCP and DNS
queries simultaneously or it does DHCP first and then falls back on DNS
if DHCP does not provide HA info. This is a MN configuration issue,
IMHO.

-Kuntal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> COMBES Jean-Michel RD-MAPS-ISS
> Sent: Tuesday, October 25, 2005 10:20 AM
> To: Vijay Devarapalli
> Cc: [email-masked]
> Subject: RE: [Mip6] General comments/questions on MIPv6 bootstrapping
> 
> 
> 
> 
> 
> > -----Original Message-----
> > From: Vijay Devarapalli [mailto:[email-masked]]
> > Sent: Monday, October 24, 2005 10:32 PM
> > To: COMBES Jean-Michel RD-MAPS-ISS
> > Cc: [email-masked]
> > Subject: Re: [Mip6] General comments/questions on MIPv6
bootstrapping
> >
> > COMBES Jean-Michel RD-MAPS-ISS wrote:
> > > Hi again,
> > >
> > > I was waiting for the proposal for the integrated scenario
> > before to
> > > do this email.
> > >
> > > I have 2 main comments/questions.
> > >
> > > The first one is regarding the fact that we have two (very)
> > different
> > > mechanisms for only one functionality (on one side
> > DNS+IKEv2, on the
> > > other side PANA+AAA+DCHP).
> >
> > there are 4 mains problems in MIP6 bootstrapping
> >
> > 1. home agent discovery
> > 2. home address configuration
> > 3. security association setup
> > 4. DNS update for the MN
> >
> > draft-ietf-mip6-bootstrapping-split and
> > draft-ietf-mip6-bootstrapping-integrated-dhc differ only on
> > 1). the solutions for 2), 3) and 4) are the same in both drafts.
> 
> OK.
> 
> >
> >  > So, personally, I am a little afraid how all
> > > this will be managed in the user's terminal and in the
> > MSP's network.
> > > E.g., what will be the trigger in the terminal to know which is
the
> > > bootstrapping mechanism the terminal has to use?
> >
> > we have some text on this in the integrated draft. the mobile
> > node could be configured to use either DHCPv6 or DNS for HA
> > discovery. based on the configuration the MN uses a
> > particular mechanism for HA discovery. in case both are
> > available and the MN gets a response through a DHCP reply and
> > DNS reply, the DHCP response has precedence. do you see a
> > need for more text on this? let us know if there are any
> > issues we havent considered.
> 
> Maybe, some text is needed to explain how and when the MN knows that
it
> cannot get the HA address with the DHCP-based mechanism and decides to
> use finally DNS-based mechanism.
> 
> >
> > > My second comment is regarding the interoperability with NEMO. I
> > > believe that if MIPv6 is deployed soon, NEMO will be
> > deployed at the
> > > same time because the protocol is as mature as MIPv6. So I
> > would like
> > > to know if the bootstrapping mechanisms working for MIPv6,
> > will work with NEMO too.
> > > I would like to avoid to add new mechanisms again and so
> > increase the
> > > complexity in a deployement architecture.
> >
> > for NEMO, in addition to the 4 problems listed above, a
> > mobile network prefix needs to be configured. for that there
> > are two drafts being progressed in the NEMO WG.
> >
> > http://www.ietf.org/internet-drafts/draft-ietf-nemo-dhcpv6-pd-00.txt
> > http://www.ietf.org/internet-drafts/draft-ietf-nemo-prefix-del
> > egation-00.txt
> >
> > these drafts were written up even before the boostrapping
> > work started in the MIP6 WG. is there anything else that
> > needs to be addressed for NEMO bootstrapping?
> 
> IMO, the other one is to be able to do the difference between a MIPv6
HA
> discovery and a NEMO HA discovery. But it seems that the DHCP-based
and
> the DNS-based mechanisms are easily adaptable to allow this.
> 
> >
> > Vijay
> >
> >
> >
> 
> Regards.
> 
> JMC.
> 
> France Telecom - R&D Division - MAPS/NSS
> Jean-Michel COMBES, Internet/Intranet Security
> E-Mail: [email-masked]
> Phone: +33 (0)1 45 29 45 94
> Fax: +33 (0)1 45 29 65 19
> Mobile: +33 (0)6 07 29 30 16
> 
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mip6

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Francis Dupont <[email-masked]>
Date: Wed, 26 Oct 2005 23:42:44 +0200

it

   
=> hum, I can guess what shall happen in the real world: the MN tries
DHCP first just because DHCP will give the local DNS server address.
If it doesn't get a DHCP reply it is in deep trouble, if it doesn't
get the HA info it retries using the DNS (through the local DNS
servers)...

Regards

[email-masked]