Subject: RE: [Mip6] General comments/questions on MIPv6 bootstrapping

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Wed, 26 Oct 2005 17:55:05 -0400

> => hum, I can guess what shall happen in the real world: the MN tries
> DHCP first just because DHCP will give the local DNS server address.
> If it doesn't get a DHCP reply it is in deep trouble, if it doesn't
> get the HA info it retries using the DNS (through the local DNS
> servers)...
>

In real world the MN may have other ways to get the local DNS server
info e.g. PPP (this was also discussed in DT) or pre-configuration. The
MN won't be in "deep trouble" if it has other ways to acquire local DNS
address, after all.

-Kuntal

> -----Original Message-----
> From: [email-masked] [mailto:Francis.Dupont@enst-
> bretagne.fr]
> Sent: Wednesday, October 26, 2005 4:43 PM
> To: Chowdhury, Kuntal
> Cc: COMBES Jean-Michel RD-MAPS-ISS; [email-masked]
> Subject: Re: [Mip6] General comments/questions on MIPv6 bootstrapping
> 
>  In your previous mail you wrote:
> 
>    > Maybe, some text is needed to explain how and when the MN knows
that
>    it
>    > cannot get the HA address with the DHCP-based mechanism and
decides
> to
>    > use finally DNS-based mechanism.
> 
>    This was discussed in DT. If the MN supports the DHCP based HA
>    bootstrapping scheme, it should send a DHCP Information Request for
HA
>    info as soon as it connects in the access network. To reduce setup
>    delay, the MN can also send a DNS query to discover HA info
>    simultaneously. If it receives HA info from both DHCP and DNS
servers,
>    then the HA info from DHCP takes precedence. If not, the HA info
from
>    either one is used by the MN.
> 
>    The operators can decide whether the MN needs to send DHCP and DNS
>    queries simultaneously or it does DHCP first and then falls back on
DNS
>    if DHCP does not provide HA info. This is a MN configuration issue,
>    IMHO.
> 
> => hum, I can guess what shall happen in the real world: the MN tries
> DHCP first just because DHCP will give the local DNS server address.
> If it doesn't get a DHCP reply it is in deep trouble, if it doesn't
> get the HA info it retries using the DNS (through the local DNS
> servers)...
> 
> Regards
> 
> [email-masked]

"This email message and any attachments are confidential information of Starent Networks, Corp. The information transmitted may not be used to create or change any contractual obligations of Starent Networks, Corp.  Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this e-mail and its attachments by persons or entities other than the intended recipient is prohibited. If you are not the intended recipient, please notify the sender immediately -- by replying to this message or by sending an email to [email-masked] -- and destroy all copies of this message and any attachments without reading or disclosing their contents. Thank you."

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Francis Dupont <[email-masked]>
Date: Thu, 27 Oct 2005 00:50:39 +0200

In real world the MN may have other ways to get the local DNS server
   info e.g. PPP (this was also discussed in DT)

=> where is the DNS stuff in IPv6CP?

   or pre-configuration.

=> pre-configuration in a roaming environment?

   The MN won't be in "deep trouble" if it has other ways to acquire local DNS
   address, after all.

=> LLMNR? I believe more in manual configuration (written on the blackboard:
the WEP key is XXX, the DNS server is YY::YY, :-).
   
Believe me or not, the lightweight DHCPv6 service *is* the service which
will distribute local DNS server(s) address(es).

Regards