Subject: RE: [Mip6] comment on draft-ietf-mip6-nemo-v4traversal-00

From: "Soliman, Hesham" <[email-masked]>
Date: Fri, 28 Oct 2005 14:16:54 -0400

> > => No that's wrong. DSMIPv6 provides static or dynamic IPv4 home 
 > > addresses based on the request in the BU. Instead of the NAI, the 
 > > IPv6 home address is used. A NAI could also be used if we had a 
 > > standard NAI extension in MIPv6.
 > 
 > Ok.
 > 
 > NAI is implemented and deployed in some v4-only access networks, and
 > MIP4 uses it.  If MIP4 is not on the terminal then that would not be
 > used, right?

=> ?? i don't understand how this is relevant to DSMIPv6. 
I said "A NAI could also be used if we had a 
standard NAI extension in MIPv6."

 > > => No. Movement detection is done based on Router 
 > Discovery. That's 
 > > what MIPv4 assumes...It only extends RFC 1256. You don't need that 
 > > extension if you're not using MIPv4, you detect movement 
 > based on RFC
 > >  1256. That's something we can detail in the draft.
 > 
 > Ok, so DSMIPv6 would be extended with Router Discovery.

=> No, router discovery is an IPv4 feature. DSMIPv6 could monitor
changes in RAs to detect movement.

 > Ok, so proxy ARP for the IPv4 Home Address would be something that
 > should be included in DSMIPv6.

=> Yes.

 > 
 > Because if any of these features for permanent IPv4 Home 
 > Addresses are
 > not included, a user may be found in the situation to run 
 > both MIP4 and
 > DSMIPv6 in order to have permanent IPv4 Home Addresses, no?

=> No. I don't understand how you came to that conclusion.

Hesham

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 28 Oct 2005 21:23:55 +0200

> changes in RAs to detect movement.

Right.

The most appropriate current reference for detecting changes in
attachment to IPv4 only networks would probably be the IPv4 DNA
document, currently draft-ietf-dhc-dna-ipv4-17.txt.

	Henrik