Subject: RE: [Mip6] General comments/questions on MIPv6 bootstrapping

From: "COMBES Jean-Michel RD-MAPS-ISS" <[email-masked]>
Date: Tue, 25 Oct 2005 17:20:09 +0200

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]] 
> Sent: Monday, October 24, 2005 10:32 PM
> To: COMBES Jean-Michel RD-MAPS-ISS
> Cc: [email-masked]
> Subject: Re: [Mip6] General comments/questions on MIPv6 bootstrapping
> 
> COMBES Jean-Michel RD-MAPS-ISS wrote:
> > Hi again,
> > 
> > I was waiting for the proposal for the integrated scenario 
> before to 
> > do this email.
> > 
> > I have 2 main comments/questions.
> > 
> > The first one is regarding the fact that we have two (very) 
> different 
> > mechanisms for only one functionality (on one side 
> DNS+IKEv2, on the 
> > other side PANA+AAA+DCHP).
> 
> there are 4 mains problems in MIP6 bootstrapping
> 
> 1. home agent discovery
> 2. home address configuration
> 3. security association setup
> 4. DNS update for the MN
> 
> draft-ietf-mip6-bootstrapping-split and
> draft-ietf-mip6-bootstrapping-integrated-dhc differ only on 
> 1). the solutions for 2), 3) and 4) are the same in both drafts.

OK.

> 
>  > So, personally, I am a little afraid how all
> > this will be managed in the user's terminal and in the 
> MSP's network.
> > E.g., what will be the trigger in the terminal to know which is the 
> > bootstrapping mechanism the terminal has to use?
> 
> we have some text on this in the integrated draft. the mobile 
> node could be configured to use either DHCPv6 or DNS for HA 
> discovery. based on the configuration the MN uses a 
> particular mechanism for HA discovery. in case both are 
> available and the MN gets a response through a DHCP reply and 
> DNS reply, the DHCP response has precedence. do you see a 
> need for more text on this? let us know if there are any 
> issues we havent considered.

Maybe, some text is needed to explain how and when the MN knows that it
cannot get the HA address with the DHCP-based mechanism and decides to
use finally DNS-based mechanism.

> 
> > My second comment is regarding the interoperability with NEMO. I 
> > believe that if MIPv6 is deployed soon, NEMO will be 
> deployed at the 
> > same time because the protocol is as mature as MIPv6. So I 
> would like 
> > to know if the bootstrapping mechanisms working for MIPv6, 
> will work with NEMO too.
> > I would like to avoid to add new mechanisms again and so 
> increase the 
> > complexity in a deployement architecture.
> 
> for NEMO, in addition to the 4 problems listed above, a 
> mobile network prefix needs to be configured. for that there 
> are two drafts being progressed in the NEMO WG.
> 
> http://www.ietf.org/internet-drafts/draft-ietf-nemo-dhcpv6-pd-00.txt
> http://www.ietf.org/internet-drafts/draft-ietf-nemo-prefix-del
> egation-00.txt
> 
> these drafts were written up even before the boostrapping 
> work started in the MIP6 WG. is there anything else that 
> needs to be addressed for NEMO bootstrapping?

IMO, the other one is to be able to do the difference between a MIPv6 HA
discovery and a NEMO HA discovery. But it seems that the DHCP-based and
the DNS-based mechanisms are easily adaptable to allow this.

> Vijay

Regards. 

JMC.

France Telecom - R&D Division - MAPS/NSS   
Jean-Michel COMBES, Internet/Intranet Security
E-Mail: [email-masked]
Phone: +33 (0)1 45 29 45 94
Fax: +33 (0)1 45 29 65 19
Mobile: +33 (0)6 07 29 30 16

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 25 Oct 2005 11:55:58 -0700

> use finally DNS-based mechanism.

there is some text in section 3.3 on this.

    In the fallback case, the mobile node is not able to acquire the home
    agent information via DHCPv6.  The mobile node performs DNS queries
    to discover the home agent address as defined in [BOOT-SPLIT].  To
    perform DNS based home agent discovery, the mobile node needs to know
    the DNS server address.  How the mobile node knows the DNS server
    address is outside the scope of this document.

the current assumption is that the if the MN finds no HA
information in the DHCP reply when it had requested the
HA information, it falls back to using DNS.

> the DNS-based mechanisms are easily adaptable to allow this.

to my understanding, that is correct. there is no plan
to develop another mechanism to discover a HA in the
NEMO WG. MIP6 bootstrap mechanisms for HA discovery,
MR HoA configuration, IPsec SA setup and DNS update for
the HoA should be re-used in NEMO.

Vijay