Subject: RE: [Mip6] Mip6 and AAA?

From: Gerardo Giaretta <[email-masked]>
Date: Thu, 20 Oct 2005 00:29:06 +0200

Hi Vidya, 

> Hi Gerardo,
>  
> > Concerning mip6-auth stuff, as you know, this is actually out 
> > of the scope of the bootstrapping DT work. There has been 
> > some discussion in the DT but so far we have decided to focus 
> > on IPsec SA setup. I wonder if there is interest to work on a 
> > bootstrapping solution for mip6-auth and related AAA 
> > interaction. Notice that mip6-auth is currenlty informational.
> > 
> 
> This was my point. If this is out of scope of the DT draft, 
> maybe it needs to be addressed separately. 

I agree. Current DT is not "chartered" for that.

> But, it seems like 
> the definition of such AVPs is important for the deployment 
> of the auth protocol. 
> 

Any hint from 3GPP2 plan about this? mip6-auth most important deployment scenario is 3GPP2, AFAIK.

As a side note, notice that some requirements listed in AAA-HA goals draft may apply to both IPsec SA and mip6-auth scenarios.

--Gerardo

> Vidya
> 
> 
> > --Gerardo
> > 
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]] 
> > On Behalf 
> > > Of Narayanan Vidya-CVN065
> > > Sent: mercoledì 19 ottobre 2005 23.33
> > > To: Vijay Devarapalli
> > > Cc: [email-masked]
> > > Subject: RE: [Mip6] Mip6 and AAA?
> > > 
> > > There isn't a scenario in draft-ietf-mip6-aaa-ha-goals that 
> > addresses 
> > > the case where the auth protocol is used in place of IPSec 
> > SA between 
> > > the MN and HA - scenarios 3 & 4 in the draft refer to the 
> > case where 
> > > the HA is contacting the AAA server for mip6 service 
> authorization, 
> > > not necessarily authentication of the MN itself. Of course, 
> > this can 
> > > be easily extended, but I am not sure if the AAA 
> attributes will be 
> > > the same - I would expect different AVPs to be defined for this 
> > > purpose.
> > > 
> > > Maybe it makes sense to have a scenario 5 there that talks 
> > about this 
> > > case - the MN sends a BU with the MN-AAA Auth option and 
> > the HA sends 
> > > the BU to the AAAH for authentication and authorization?
> > > 
> > > Also, draft-tschofenig-mip6-aaa-ha-diameter-00 doesn't 
> really have 
> > > text in it about BU exchange between the HA and AAA - not 
> > sure if that 
> > > matters.
> > > 
> > > Vidya
> > > 
> > > > -----Original Message-----
> > > > From: Vijay Devarapalli [mailto:[email-masked]]
> > > > Sent: Wednesday, October 19, 2005 3:40 PM
> > > > To: Narayanan Vidya-CVN065
> > > > Cc: [email-masked]
> > > > Subject: Re: [Mip6] Mip6 and AAA?
> > > > 
> > > > Narayanan Vidya-CVN065 wrote:
> > > > > All,
> > > > > In order to use the MN-AAA authentication mobility option
> > > > defined in
> > > > > the Auth protocol, are there plans to define a Diameter mip6 
> > > > > application or RADIUS mip6 attributes? Alternatively, in
> > > > Diameter, I
> > > > > would think new AVPs may be defined for the NASREQ 
> application.
> > > > >  
> > > > > I'm just trying to understand if any work is done/planned
> > > > in this space.
> > > > 
> > > > as part of the mip6 bootstrapping work, we have 
> > identified the need 
> > > > to define some AAA messages between the NAS and the AAAH 
> > and between 
> > > > the HA and the AAAH.
> > > > 
> > > > draft-ietf-mip6-aaa-ha-goals-00.txt is supposed to 
> > capture the AAA 
> > > > requirments. the plan is to talk about both RADIUS and Diameter 
> > > > requirements in the same document. this draft needs to 
> be updated.
> > > > 
> > > > Vijay
> > > > 
> > > > 
> > > 
> > > _______________________________________________
> > > Mip6 mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/mip6
> > > 
> > 
> > 
> > Gruppo Telecom Italia - Direzione e coordinamento di Telecom 
> > Italia S.p.A.
> > 
> > ====================================================================
> > CONFIDENTIALITY NOTICE
> > This message and its attachments are addressed solely to the 
> > persons above and may contain confidential information. If 
> > you have received the message in error, be informed that any 
> > use of the content hereof is prohibited. Please return it 
> > immediately to the sender and delete the message. Should you 
> > have any questions, please send an e_mail to 
> > [email-masked]. Thank you 
> > ====================================================================
> > 
> 

Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please send an e_mail to
[email-masked]. Thank you
====================================================================

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 19 Oct 2005 23:00:16 -0700

> Any hint from 3GPP2 plan about this? mip6-auth most important deployment scenario is 3GPP2, AFAIK.

PDSN-AAAH and HA-AAAH interfaces for MIPv6 have been specified
in the 3GPP2 specs itself. no IETF specs needed.

Vijay