Subject: RE: [Mip6] I-D ACTION:draft-ietf-mip6-nemo-v4traversal-00.txt

From: "Soliman, Hesham" <[email-masked]>
Date: Tue, 25 Oct 2005 12:28:36 -0400

Alex, 

 > Right, I also think the current draft still tries to address too many
 > scenarios.  I would keep in it only running MIP6 over a 
 > v4-only access
 > network, with NAT traversal.  I would separate from it all 
 > NEMO aspects
 > be it v4 or v6, I would separate also giving v4-home-address through
 > MIP6 through v4-only access network.

=> If this is a matter of taste then we can disagree on this
without discussion. But I prefer it to be a technical matter
that we can discuss. So, if there are reasons for your preference
above please state them so we can discuss them.

Hesham

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 25 Oct 2005 18:37:56 +0200

Soliman, Hesham wrote:

> Alex,
> 
>> Right, I also think the current draft still tries to address too 
>> many scenarios.  I would keep in it only running MIP6 over a 
>> v4-only access network, with NAT traversal.  I would separate from
>>  it all NEMO aspects be it v4 or v6, I would separate also giving 
>> v4-home-address through MIP6 through v4-only access network.
> 
> => If this is a matter of taste then we can disagree on this without
>  discussion. But I prefer it to be a technical matter that we can 
> discuss.

Absolutely, so do I.  So I will use the efficiency argument.  The
efficiency argument is used throughout the document to motivate some of
the decisions.  I'll use the same argument if you agree.

> So, if there are reasons for your preference above please state them 
> so we can discuss them.

Yes, the technical reason for that draft to not address giving v4 access
to LFNs by an IPv6 MR connecting to a v4-only network is the following.

A MIP4 MR connecting to a v4 access network can give IPv4 access
naturally to its IPv4 LFNs.  An MR that would use MIP6 (instead of MIP4)
to give IPv4 access to LFNs when MR connected to v4-only access network
is inefficient.  The inefficiency comes from v4-in-v6-in-v4
encapsulation, whereas if MIP4 were used in this case it would have been
v4-in-v4.

Would you discuss?

Alex

> 
> Hesham
> 
> =========================================================== This 
> email may contain confidential and privileged material for the sole 
> use of the intended recipient.  Any review or distribution by others
>  is strictly prohibited.  If you are not the intended recipient
> please contact the sender and delete all copies.