Subject: Re: [Mip6] comments to boostrapping (split)

From: Ryuji Wakikawa <[email-masked]>
Date: Thu, 01 Dec 2005 14:19:23 +0900

Hi Vijay

At Wed, 30 Nov 2005 11:28:40 -0800,
vijay wrote:
> 
> Hi Ryuji,
> 
> Ryuji Wakikawa wrote:
> > Hello Authors
> > 
> > Thanks for this documentation and sorry for my delay comments. 
> > Some comments maybe already pointed out.
> > 
> > Editorial
> > - MIP6 and Mobile IPv6 are mixed in the document.
> > - Mobile Node, Host, MN are also mixed.
> >   (This split scenario is applied to MR as well, using mobile host
> >   should be avoided. Mobile Node is safer)
> > - Fig3, 4 HA must send BA instead of BU.
> > 
> > 
> > Overall 
> > 
> > - The draft mentions localized HA for route optimization and load
> >   balancing etc.  The provided texts are a bit unclear. what is the
> >   relationship between home prefix and home agents? When MN gets a
> >   localized HA, will it associate different home network served by
> >   each localized HA?
> 
> if the MN gets a local HA, then its home prefix and home address
> will change. it will be from the local HA.

right. This drawback should be mentioned in the doc.

> > - The section 5.3.2 for autoconfigured home address assignment looks
> >   weak.  Although the document recommends some operations, but what is
> >   the statement of DT? There are several limitation compared to IKE
> >   HoA assignment in terms of pre-configured homeprefix/length, assumed
> >   64 length. Shouldn't MIP6 use autoconfigured address?
> 
> the preferred solution is where the MN does not assume anything
> about the home prefix length. in this case, the MN first sends
> a MIP6_HOME_PREFIX attribute in the CFG_REQUEST messages, gets
> the home prefix through the CFG_REPLY message, auto-configures
> a HoA and then sets up IPsec SAs in the subsequent
> CREATE_CHILD_SA exchange. maybe this should be made more
> explicit.

yes. 

> > - When HA assigns static HoA to MN (from HA's address pool), can HA
> >   skip proxy DAD? It looks redundant. 
> 
> unless you have MNs on the home link trying to configure
> addresses from the same prefix as HA's address pool.

ok. 

> > - When the static address configuration through IKE, is it possible MN
> >   requests the previous used HoA to HA? (sorry I did not check IKE doc)
> 
> yes. it can propose a HoA in the INTERNAL_IP6_ATTRIBUTE
> in the CFG_REQUEST message.
> 
> > - For DNS refreshment, the document proposes a new timer for DNS
> >   address expiration. Why not HA delete the HoA from DNS when BC for
> >   the target MN is expired?
> 
> this timer is more related to a cleanup the HA needs to
> perform once in a while.

The comment is not accurate.
My concern is, while the DNS timer is still active, the HA assigns the
same address to other MN. This is problem.
Does the draft say that HA must not assign the HoA which is no longer in
BC, but DNS timer is still active.

Related question is how HA does HoA/IPsec garbage collection. From HA
side, it is hard to decide whether MN goes sleep or not.
Can HA treat the HoA which BC and DNS timer are expired as free HoA?
But it's possible that the MN is active, but network is temporary
down. Then, the BC and DNS timer are out. Does the MN perform
bootstrapping again? 

> > - For DNS refreshment, HA has to wait for sending BA till DNS update
> >   is completed. It depends on how long it takes for DNS update,
> >   but MN cannot start communication before the BA. I am not sure using
> >   BU and BA for DNS update is right way. Defining other message is
> >   possible solution.
> 
> this is only for the first registration. why do you think
> DNS update would take a long time?

Do you have any number for the time?
The first BA wait timer is 1.5sec or 1 sec. 

> > - No alignment requirement for DNS update mobility option? 
> 
> nope. FQDN is just a string.

ok.

> > - What the MN's operation when DNS update is fail?
> >   (i.e. return code 128-130).
> 
> the MN does not have a valid DNS entry if the DNS update
> fails.

You mean MN stop sending the option?

> > - The document makes clear how to bootstrap when MN does not have any
> >   information. However, MN needs to do all the steps every time it
> >   boots up?  what is the trigger for the bootstrapping operation? 
> >   For example, my PDA often turn off the power (or WLAN goes to the
> >   dormant mode). When the node is up or WLAN is up, how does MN
> >   recover the MIP operation? Is this up to implementations?  Is it
> >   possible to cache bootstrapping information such as Home
> >   prefix/length, HA, etc?
> 
> I think this is deployment specific. its the configuration
> on the mobile node and the HA that decides this.

that's one option. 

However, MIP6 has several features which may use for the trigger
decision.  The information includes prefix obtained by MPS/MAP, Home
Agent list (obtained by RA), etc.  The bootstrapping scheme may
suggest to use these feature somehow to trigger the bootstrapping?

> > - This document relies on IKEv2. It might be helpful if it gives
> >   information or pointer for the case of IKEv1.
> 
> draft-devarapalli-mip6-ikev1-bootstrap-00.txt :)

Yes. I want this pointer in the doc. 

ryuji

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Francis Dupont <[email-masked]>
Date: Thu, 01 Dec 2005 15:51:18 +0100

In your previous mail you wrote:

   Related question is how HA does HoA/IPsec garbage collection.

=> for IPsec it can be done by the peer dead detection and/or
simply when the final IKE SA is closed. For the HoA I propose
to follow the solution for DHCP and DNS. Note as the MN can't
remove an RR when it has lost the connectivity a dynamic allocated
HoA should not be assigned to another MN (there are enough of
them :-).

   Does the MN perform bootstrapping again?

=> yes at least for IPsec.
   
Regards

[email-masked]

PS: look at draft-ietf-dhc-dhcp-dns-12.txt (expired) for the procedures
to add and remove AAAA and PTR RRs. But as I've tried to explain
from beginning, it is a question for IKE CFG stuff, *not* for MIPv6.
For instance, MIPv6 should stay far from the DHCID thread
(cf draft-ietf-dhc-ddns-resolution-10.txt).

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 01 Dec 2005 11:39:01 -0800

> down. Then, the BC and DNS timer are out. Does the MN perform

it is probably safer for the HA to not assign the HoA
immediately as soon as the binding cache expires to
another mobile node.

> The first BA wait timer is 1.5sec or 1 sec. 

since the HA and DNS server are in the same network,
it would be lot less than 1 second.

yes.

> suggest to use these feature somehow to trigger the bootstrapping?

sure.

Vijay

---

From: Ryuji Wakikawa <[email-masked]>
Date: Fri, 9 Dec 2005 02:48:56 +0900

Hi Francis and Vijay

> to follow the solution for DHCP and DNS. Note as the MN can't

OK, it's clear now.
So, HA must watch the IPsec status of a HoA which will now assigned  
to new MN.

> HoA should not be assigned to another MN (there are enough of

To solve this issue, HA must wait for binding expiration at CN sides.
The time  will be the home registered binding's lifetime, because the  
binding lifetime for CN is
equal to or less than the binding lifetime at HA.

So, before assigning the HoA, HA must check
1. IPsec status check
2. No binding for HoA in BC.

Isn't it important to mention in the spec?

ryuji