Subject: Re: [Mip6] A question about MIPv6!

From: johnny pan <[email-masked]>
Date: Mon, 9 Jan 2006 18:02:44 +0800 (CST)

So when will the RRT begin? Can this happen: after a short time of data transmission between MN and CN through bi-direnctional tunnel,  MN start RRT and send BU to CN, after that MN switch the transmisson directly to CN? Can this happen? Or it is for sure that after MN register with HA, it will start RRT and register with CN at once before any data transmission between MN and CN, if CN support MIPv6 and have a binding cache?
  When i disscuss this with my classmate, we cannot agree with each other, and we cannot find enough evidence in RFC3775, so i hope i can get some help here.
  His opinion about the procedure is as follow:
  1.MN register with HA and get a CoA
  2.begin RRT with CN at once before any data transmission, and through which MN will know whether CN support RO. If CN does support RO, MN will send data directly to CN; if not, all data transmission will pass HA. It can be described as a procedure of "Register with HA->RRT->direct data transmission".
  And my opion is:
  1.MN register with HA and get a CoA
  2.MN or CN may initiate data communication first, and becauce MN have no information about CN(if MN send data to the "unknown" CN first), this kind of communication will have to pass HA. After some time of data transmission, MN initiate the RRT and register with CN. It can be described as a procedure of "Register with HA->data transmission->RRT->new transmission route".
  I don't know who is right. So what do you think? Thank you so much!
   
  ps: I am a postgraduate student and also a part-time tourist guide of Beijing. If anyone answer this letter and help me to solve this problem, i will offer you a free interpretation.
   
  Regards

---------------------------------
  
  pann
  2006-01-09

---------------------------------
  
  发件人： Francis Dupont
  发送时间： 2006-01-09 01:27:48
  收件人： johnny pan
  抄送： [email-masked]
  主题： Re: [Mip6] A question about MIPv6!
   
     In  your  previous  mail  you  wrote:
   
           Does  that  mean  before  MN  initiate  the  Return  Routability  test  and
     the  Binding  Update  between  MN  and  CN,  the  communication  between  MN
     and  CN  must  forwarded  by  HA  through  the  bi-directional  tunnel
     between  MN  and  HA?
   
  = >  this  is  the  standard  behavior  but  is  not  mandatory,  i.e.,  the  MN  or
  the  CN  may  launch  a  RR  test  before  sending  the  first  traffic  packet.
  (The  real  issue  is  this  needs  a  priori  knowledge  of  future  communications)
   
       I  don't  know  whether  my  understanding  is  right  or  not.  The  two  modes  of
       Reverse  Tunneling  and  RO    only  one  of  them  could  be  used?
   
  = >  Routing  Optimization  is  as  its  name  suggests  an  *optimization*.
   
  Regards
       
  [email-masked]

---------------------------------
 雅虎1G免费邮箱百分百防垃圾信
 雅虎助手¨D搜索、杀毒、防骚扰  

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Francis Dupont <[email-masked]>
Date: Mon, 09 Jan 2006 11:49:56 +0100

His opinion about the procedure is as follow:
     1.MN register with HA and get a CoA
     2.begin RRT with CN at once before any data transmission, and
     through which MN will know whether CN support RO. If CN does
     support RO, MN will send data directly to CN; if not, all data
     transmission will pass HA. It can be described as a procedure of
     "Register with HA->RRT->direct data transmission".

     And my opinion is:
     1.MN register with HA and get a CoA
     2.MN or CN may initiate data communication first, and becauce MN
     have no information about CN(if MN send data to the "unknown" CN
     first), this kind of communication will have to pass HA. After
     some time of data transmission, MN initiate the RRT and register
     with CN. It can be described as a procedure of "Register with
     HA->data transmission->RRT->new transmission route".

=> in fact both are possible, it is a matter of implementation.
At one possible exception, IMHO all implementations are reactive
(i.e., launch RRT only when some unoptimized traffic is seen on
the MN-HA tunnel) but some offer an API which can be used to
support the preactive (i.e., the first option) way.
BTW RFC 3775 gives some hints in the 11.7.2 section with this statement
at the beginning:

   Considerations regarding when (and if) to initiate the procedure
   depend on the specific movement and traffic patterns of the mobile
   node and are outside the scope of this document.

but just after there are the conditions for triggering RRT from
received traffic on the tunnel:

   In addition, the mobile node MAY initiate the correspondent
   registration in response to receiving a packet that meets all of the
   following tests:

this is why I use the term "hints" (:-).

Regards

PS: the possible exception is from a very old discussion in this list
where an implementor described the proactive way (which has interesting
security properties).

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 09 Jan 2006 13:46:52 -0800

Hello Johnny,

Following up on what Francis wrote, I'd agree except that
it's probably better to characterize the initiation of RRT as
"whenever". It can be before or after the initiation of some
other data communication. Of course it's a waste of time
if there aren't going to be any data to communicate. As I
remember, the exact timing to run RRT is left as "out of scope"
because nobody had a convincing answer whether anything
needed to be mandated or specified about it. For instance,
if a mobile system only needs to communicate a single packet
to a correspondent node, it makes little sense to do RRT.

It's also likely to be wise to deregister bindings after the
applications are finished and no more data needs to be
communicated.

Regards,
Charlie P.