Subject: [Mip6] A question about MIPv6!

From: johnny pan <[email-masked]>
Date: Sun, 8 Jan 2006 18:22:54 +0800 (CST)

Hello everybody, i have a question about RFC3775 and i hope somebody can solve my puzzle.
  It's about the procedure of the MIPv6. 
  When MN move into the foreign network, it register in HA with its CoA, and then the outside CN or MN itself may initiate the first communication with each other. Does that mean whoever initiate the communication, the first packet must pass the HA through the IPv6-in-IPv6 tunnel? Does MIPv6 differ from MIPv4 in this point? Because as i know in MIPv4, the packets sent by MN will be directed toward CN, but the packets return from CN will pass the tunnel between HA and MN.
  Does that mean before MN initiate the Return Routability test and the Binding Update between MN and CN, the communication between MN and CN must forwarded by HA through the bi-directional tunnel between MN and HA?  In my opinion, the procedure is:
  1.Registration of MN with HA.
  2.Communications between MN and CN through HA with the bi-directional tunnel.
  3.MN initiate the Return Routability test, and then send Binding Update to CN
  4.After the BU and BA between MN and CN, communication between MN and CN can be set up directly without the participation of HA.
  I don't know whether my understanding is right or not. The two modes of Reverse Tunneling and RO  only one of them could be used? or just they can be used both according to the accomplishment of RRT and Binding Update procedure between MN and CN.
   
  Thank you so much!

---------------------------------
  
  pann
  2006-01-08

---------------------------------
 雅虎1G免费邮箱百分百防垃圾信
 雅虎助手¨D搜索、杀毒、防骚扰  

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Francis Dupont <[email-masked]>
Date: Sun, 08 Jan 2006 18:27:03 +0100

In your previous mail you wrote:

     Does that mean before MN initiate the Return Routability test and
  the Binding Update between MN and CN, the communication between MN
  and CN must forwarded by HA through the bi-directional tunnel
  between MN and HA?

=> this is the standard behavior but is not mandatory, i.e., the MN or
the CN may launch a RR test before sending the first traffic packet.
(The real issue is this needs a priori knowledge of future communications)

   I don't know whether my understanding is right or not. The two modes of
   Reverse Tunneling and RO  only one of them could be used?

=> Routing Optimization is as its name suggests an *optimization*.

Regards
   
[email-masked]