Subject: [Mip6] INTERNAL_IP6_SUBNET attribute

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 09 May 2006 11:44:04 -0700

hello all,

currently, draft-ietf-mip6-ikev2-ipsec-06 says

>    The
>    mobile node MAY also include the INTERNAL_IP6_SUBNET attribute if it
>    wants to obtain information about the IPv6 prefixes on the home link.

and draft-eronen-ipsec-ikev2-clarifications-09.txt
(which is with the IESG right now) says

>    It is less clear what the attributes mean in CFG_REQUESTs, and
>    whether other lengths than zero make sense in this situation (but for
>    INTERNAL_IP6_SUBNET, zero length is not allowed at all!).  Currently
>    this document recommends that implementations should not include
>    INTERNAL_IP4_SUBNET or INTERNAL_IP6_SUBNET attributes in
>    CFG_REQUESTs.

draft-eronen also has more text clarifying the use of
INTERNAL_IP6_SUBNET attribute. I don't think we can use
it to obtain the home prefix. so I propose removing the
text about using the INTERNAL_IP6_SUBNET from
draft-ietf-mip6-ikev2-ipsec-06.

to obtain the home prefix, there are two options.

1. use the MIP6_HOME_PREFIX attribute during IKEv2
negotiation. this attribute is defined in
draft-ietf-mip6-bootstrapping-split-02.txt

2. run Mobile Prefix Discovery with the home agent later.

Vijay

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Francis Dupont <[email-masked]>
Date: Tue, 09 May 2006 22:31:02 +0200

In your previous mail you wrote:

   ...
   
=> I agree the whole thing is not clear and should be handled by
the bootstrapping documents... So we have two choices:
 - simply remove the INTERNAL_IP6_SUBNET statement
 - replace it by a reference to a bootstrapping document.
I am in favor of the first option because I'd like to avoid to introduce
a reference to an I-D but perhaps I am a bit too conservative here.

Thanks

[email-masked]

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 09 May 2006 13:33:58 -0700

Francis Dupont wrote:
> I am in favor of the first option

me too.

Vijay