Subject: RE: [Mip6] RE: [netlmm] Network-based mobility - NETLMM DT SolutionVsA solutionbased on MIP6

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Tue, 17 Oct 2006 20:45:26 -0400

> -----Original Message-----
> From: Kent Leung (kleung) [mailto:[email-masked]]
> Sent: Monday, October 16, 2006 11:48 PM
> To: Narayanan, Vidya; [email-masked]
> Cc: [email-masked]
> Subject: RE: [Mip6] RE: [netlmm] Network-based mobility - NETLMM DT
> SolutionVsA solutionbased on MIP6
> 
> Hi Vidya.  Sorry for the delay.
> 
> Some SDOs have adopted PMIPv4 but not for localized MM within the
access
> network (which is the scope of NetLMM).
> 
[KC>] PMIP (4 and 6) is used for network based mobility management for
simple IP sessions. Whether the scope is NOT localized is a subjective
discussion.

> I think we should clarify the difference between non-MIPv6 mobility
> option re-use vs. re-usable MIPv6 Home Agent.  Maybe this is something
> the PMIPv6 camp should sort out first? ;)

[KC>] Aren't you also in that camp now? Ref, your newly revived I-D on
pmip6. So, why don't you answer your own question?

> I believe this is part of the questions posed by Phil on the consensus
> call results.
> 
> Kent
> 
> 
> 
> -----Original Message-----
> From: Narayanan, Vidya [mailto:[email-masked]]
> Sent: Wednesday, October 11, 2006 6:42 PM
> To: Kent Leung (kleung); [email-masked]
> Cc: [email-masked]
> Subject: [Mip6] RE: [netlmm] Network-based mobility - NETLMM DT
Solution
> VsA solutionbased on MIP6
> 
> Hi Kent,
> If there is a need for IPv4 signaling usage, I agree with you. But,
I'm
> not so sure that there is a need for that, practically speaking. I
think
> many of those who want v4-signaled network-based mobility have gone a
> non-standard PMIPv4 route already - is that not true?
> 
> If we have a real need for IPv4 signaling, then we could potentially
say
> that there is a need for two different standards in this space - one
> that allows for running over IPv4 and another that allows maximum
re-use
> of already defined mobility options.
> 
> But, if the industry adopted the latter solution today for sake of
> re-use, do we ever expect the former one being deployed? Or, would the
> world simply do v6-in-v4 tunneling or the non-standard PMIPv4 when a
> solution over v4 is needed?
> 
> I don't know the answer :)
> 
> Vidya
> 
> > -----Original Message-----
> > From: Kent Leung (kleung) [mailto:[email-masked]]
> > Sent: Wednesday, October 11, 2006 9:51 AM
> > To: Narayanan, Vidya; [email-masked]
> > Cc: [email-masked]
> > Subject: RE: [netlmm] Network-based mobility - NETLMM DT Solution Vs
A
> 
> > solutionbased on MIP6
> >
> > Hi Vidya.  I don't see why running NetLMM signaling over IPv4 should
> > be precluded by design?  Having such flexibility is a valuable asset
> > for a standards based network-control mobility management protocol,
> > IMHO.
> >
> > Kent
> >
> > -----Original Message-----
> > From: Narayanan, Vidya [mailto:[email-masked]]
> > Sent: Friday, October 06, 2006 8:24 PM
> > To: [email-masked]
> > Cc: [email-masked]
> > Subject: [netlmm] Network-based mobility - NETLMM DT Solution Vs A
> > solutionbased on MIP6
> >
> >
> > <snip>
> > What does the NETLMM DT Solution bring, by being totally different
> > from MIP6?
> > --------------------------------------------------------------
> > ----------
> > ------
> >
> > 1. The protocol can be evolved to using a reliable transport
protocol
> > like SCTP at some point.
> > 2. The protocol can run over IPv4 without changes.
> >
> > While these seem like good goals, what is the practical need for the
> > above goals? For instance, is IPv4 signaling a necessity for a
NETLMM
> > solution?
> >
> > <snip>
> >
> 
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mip6
> 
> _______________________________________________
> netlmm mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/netlmm

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Kent Leung \(kleung\)" <[email-masked]>
Date: Tue, 17 Oct 2006 17:53:03 -0700

Hi Kuntal.
<snip>
access

KL> An objective way to look at it is from the reference interface
perspective.

KL> The answer is in the draft. :)  Do you have an opinion?

Kent

---

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Tue, 17 Oct 2006 21:38:36 -0400

Hi Kent,

See inline....

-Kuntal

> Sent: Tuesday, October 17, 2006 7:53 PM
> To: Chowdhury, Kuntal
> Cc: [email-masked]; [email-masked]
[KC>] If the discussion gets too SDO specific (which I believe is going
to happen), I would suggest we take this offline. MIP4 is used for
inter-RNC mobility management in the radio access network in an SDO.
What do you call that? NOT global mobility I guess :-)

> KL> The answer is in the draft. :)  Do you have an opinion?
[KC>] You can get a hint of my opinion in the I-D that we (Ajoy and I)
submitted. FYI...we have an I-D on pmip6 (aka netmip6) which we are
pursing all along w/o shifting position. The I-D is :
http://www.ietf.org/internet-drafts/draft-chowdhury-netmip6-01.txt

We do not propose non-MIP6 MO for *mobility management* in this I-D. The
essence of pmip6 is the compatibility with mip6. Maximum reuse of mip6
MO should be the guideline and re-inventing the wheel for the heck of it
should be avoided. So, the approach that introduces NEW MO for pmip6
seems to defeat the very purpose i.e. reuse mip6 protocol for proxy mip6
operation, IMHO.