Subject: RE: [Mip6] concensus: issue 76: Alt CoA should not be usedwhen traversingIPv4 NAT

From: "Soliman, Hesham" <[email-masked]>
Date: Tue, 31 Oct 2006 19:53:31 -0800

> well, if there is a NAT on the path the source
 > address on the outer IPv4 header is modified.
 > anytime a packet goes through a NAT, we have
 > this problem. this is a common problem. so I
 > don't think we should design a DS-MIPv6
 > specific mechanism to protect  an address that
 > is modified by the NAT. its not worth it.

=> You keep repeating that and I keep answering as follows: If there is
an alt-coa in the packet then the HA has no way of knowing if there was
a NAT or not without checking it first, it can't simply compare the
outer headers...Again, this has nothing to do with the presence of the
NAT and everything to do with the presence of the alt-CoA...

So it makes zero sense to say that the "HA should ignore the alt-coa if
a NAT were detected" because the HA can't possibly know that a NAT was
en route without inspecting the alt-coa....

Hesham

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 31 Oct 2006 20:00:20 -0800

Soliman, Hesham wrote:
> outer headers...

I actually agree with this. :)

Again, this has nothing to do with the presence of the
> en route without inspecting the alt-coa....

hmmm... there is a misunderstanding. I didn't
say ignore the alt-CoA option. I said the HA
should not use the contents of the altCoA
option as the CoA when it detects a NAT.

it does not matter if the HA compares the source
address on the outer IPv4 header with the source
address of the inner header or the contents of
the altCoA option to detect the presence of a
NAT. its the same for me.

Vijay