Subject: [Mip6] NETLMM and PMIPv6 (RE: [netlmm] Consensus call to makedraft-giaretta-netlmm-dt-protocol-02.txt a WG draft)

From: "Narayanan, Vidya" <[email-masked]>
Date: Thu, 5 Oct 2006 15:51:00 -0700

(Cross-posting to MIP6)

All,
I would like to understand how making this document a WG document
impacts any Proxy MIP6 solution that may be standardized at the IETF.
Jari's email on the MIP6 ML indicated that he would like to see this
discussion happen before a decision is made about the NETLMM DT
document. 

Personally, I think that the fundamental requirements are almost
identical in both cases. I think summarizing the differences in
requirements and discussing whether standardizing both solutions makes
sense would be worthwhile at this time. 

Thoughts? 

Vidya 

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]] 
> Sent: Thursday, October 05, 2006 9:20 AM
> To: [email-masked]
> Subject: [netlmm] Consensus call to 
> makedraft-giaretta-netlmm-dt-protocol-02.txt a WG draft
> 
> Folks,
> 
> Henrik has done a super job in editing the results of the 
> interim meeting into the DT draft, keeping the list informed 
> all the while. So, now it's time to consider whether to make 
> the draft a WG draft. Please take a look at the draft and 
> send a posting to the list with your opinion. You can find 
> the draft here:
> 
> http://www1.tools.ietf.org/wg/netlmm/dt-draft/draft-giaretta-n
etlmm-dt-protocol-02.txt
> 
> until it is posted in the Internet Drafts repository.
> 
> Please remember that this consensus call is only whether or 
> not to make the draft a WG draft, and that this decision does 
> not lock in the current text. 
> After a draft becomes a WG draft, it is still subject to 
> discussion and modification based on WG consensus; in fact, 
> it is expected that WG members take the time and make the 
> effort to review the draft and make sure there are no 
> technical problems.
> 
> The consenus call will remain open for a week until next 
> Thurs. Oct. 12. 
> Please try to post your opinion before then.
> 
>             jak 
> 
> 
> _______________________________________________
> netlmm mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/netlmm
> 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 06 Oct 2006 14:33:13 +0200

Narayanan, Vidya wrote:
> (Cross-posting to MIP6)
> 
> All, I would like to understand how making this document a WG 
> document impacts any Proxy MIP6 solution that may be standardized at 
> the IETF. Jari's email on the MIP6 ML indicated that he would like to
> see this discussion happen before a decision is made about the NETLMM
> DT document.
> 
> identical in both cases.

Except that reqs/ps and security context is precisely described in
netlmm WG items while for PMIPv6 we have no other reqs.

The netlmm problem statement document discusses problems with existing
(at that time) approaches to "netlmm" concepts - h/fmipv6, cellular IP,
gtp.  At the time of that writing the PMIPv6 documents did not yet exist
(draft-chowdhury-netmip6-00.txt and
draft-gundavelli-netlmm-mip6-proxy-00.txt)

Do you think the netlmm PS document should be updated to discuss issues
with netmip6 and with netlmm-mip6-proxy protocols?

I have some ideas in that space.  For example,
draft-gundavelli-netlmm-mip6-proxy-00.txt states that it improves
handover performance (because MN "just" does "normal" IPv6 attachment,
instead of mobility-related messaging).  Later on it states that MN uses
DHCP.  Using DHCP is known to be a strong bottleneck for handover
performance, with many implementations.  The DHCP issues for "netlmm"
concepts have been largely discussed here, and documented here.

> I think summarizing the differences in requirements and discussing 
> whether standardizing both solutions makes sense would be worthwhile
>  at this time.

Do you mean we should standardize PMIPv6 just because netlmm protocol is 
being pursued?

Alex

---

From: Julien Laganier <[email-masked]>
Date: Fri, 6 Oct 2006 15:07:42 +0200

Hi Vidya,

On Friday 06 October 2006 00:51, Narayanan, Vidya 
> (Cross-posting to MIP6)

[ Perhaps this discussion should happen on a single
  ML? I am not though. ]

> All,
> I would like to understand how making this document
> a WG document impacts any Proxy MIP6 solution that
> may be standardized at the IETF. Jari's email on the 
> MIP6 ML indicated that he would like to see this
> discussion happen before a decision is made about
> the NETLMM DT document.

My understanding of Jari's note was slighty different. 
I understood that amongst other things he asked:

 - what are the requirements that are not fullfiled
   with today's solutions?

 - people interested in PMIP6 to talk to NetLMM WG 
   *now* if their requirements are close to what
   NetLMM does.

> Personally, I think that the fundamental
> requirements are almost identical in both cases.

Agree.

> I think summarizing the differences in requirements
> and discussing whether standardizing both solutions
> makes sense would be worthwhile at this time.

Discussing differences in requirements would definitely 
make sense. 

However, because as you noted they seems to be almost 
identical I do not think it makes sense to standardize 
both solutions -- that wouldn't be good from a 
standardization point of view.

Rather, those (supposedly few) requirements that are 
presently not fullfilled by a NetLMM solution should 
be worked on so that we satisfies all of them with a 
single protocol.

Best regards,

--julien

---

From: "Tsirtsis, George" <[email-masked]>
Date: Fri, 6 Oct 2006 06:44:24 -0700

It is well known that I do not like NETLMM at all, whether it is done in
NETLMM or MIPv6 WG. Putting my personal opinion aside, however, I would
like to say this:

Let's assume that the requirements for NETLMM and PMIPv6 are virtually
identical, which I think is a reasonable assumption.

NETLMM is currently attempting to address these requirements by
designing a protocol from scratch.

A PMIPv6 based design would presumably define the delta from the
standard MIPv6 solution required. The solution should also be able to
re-use at least some of the extensions already defined in MIPv6 and
maybe even allow for MIPv6 and PMIPv6 mobiles and networks to coexist.
Such assumptions should, however, be scrutinized if/when PMIPv6 design
is done, to make sure they still whole water.

Redesigning things from scratch is some times a good thing but the new
design has to be significantly better to counteract the risk inherent
with any new approach. Green field designs are also best done by small
groups of people and they come with running code, rather than design by
committees (no offence to NETLMM).
Extending an existing protocol is always an easier and more palpable
approach. Arguably, when the delta between the old and the new approach
is not that significant, extending an existing protocol is highly
preferable. This way, it is easy for everyone to come up to speed with
the changes and gives everyone a warm fuzzy feeling about the whole
thing (whether such feeling is justified or not is another story).

I think proponents of PMIPv6 are making a mistake by pretending that
PMIPv6 will somehow be different from NETLMM. Instead there should be a
discussion about the benefits of extending the existing approach vs the
perceived risks involved with reinventing the wheel. If the majority of
the NETLMM crowed is willing to take the risk then I do not think you
can do much about it.

I still think that having two competing solutions in the IETF is a bad
idea, unless one of them becomes "experimental" so that the effort is
captured but it is clear that the IETF has only fully defined one thing!

In fact what I think is that the IETF does not need a solution to any of
this but I guess I have said this already :-)

Regards
George

> From: Julien Laganier [mailto:[email-masked]]
> Sent: Friday, October 06, 2006 9:08 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: NETLMM and PMIPv6 (RE: [netlmm] Consensus call
tomakedraft-
> giaretta-netlmm-dt-protocol-02.txt a WG draft)
> 
> Hi Vidya,
>

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Fri, 6 Oct 2006 19:52:15 -0700

Putting the fact that George dislikes any kind of network-based mobility
aside :), I have to agree with a few of his points in the email below. 

Specifically, we should be having the discussion on what we can re-use
with a network-based mobility solution based on MIP6 vs. a total
re-design.

I will try to get a thread going on that topic shortly and hopefully, we
can make some progress in figuring this out and getting consensus. 

Vidya

> From: Tsirtsis, George [mailto:[email-masked]] 
> Sent: Friday, October 06, 2006 6:44 AM
> To: Julien Laganier; [email-masked]
> Cc: [email-masked]
> Subject: RE: NETLMM and PMIPv6 (RE: [netlmm] Consensus 
> calltomakedraft-giaretta-netlmm-dt-protocol-02.txt a WG draft)
> 
> It is well known that I do not like NETLMM at all, whether it 
> is done in NETLMM or MIPv6 WG. Putting my personal opinion 
> aside, however, I would like to say this:
> 
> Let's assume that the requirements for NETLMM and PMIPv6 are 
> virtually identical, which I think is a reasonable assumption.
> 
> NETLMM is currently attempting to address these requirements 
> by designing a protocol from scratch.
> 
> A PMIPv6 based design would presumably define the delta from 
> the standard MIPv6 solution required. The solution should 
> also be able to re-use at least some of the extensions 
> already defined in MIPv6 and maybe even allow for MIPv6 and 
> PMIPv6 mobiles and networks to coexist.
> Such assumptions should, however, be scrutinized if/when 
> PMIPv6 design is done, to make sure they still whole water.
> 
> Redesigning things from scratch is some times a good thing 
> but the new design has to be significantly better to 
> counteract the risk inherent with any new approach. Green 
> field designs are also best done by small groups of people 
> and they come with running code, rather than design by 
> Extending an existing protocol is always an easier and more 
> palpable approach. Arguably, when the delta between the old 
> and the new approach is not that significant, extending an 
> existing protocol is highly preferable. This way, it is easy 
> for everyone to come up to speed with the changes and gives 
> everyone a warm fuzzy feeling about the whole thing (whether 
> such feeling is justified or not is another story).
> 
> PMIPv6 will somehow be different from NETLMM. Instead there 
> should be a discussion about the benefits of extending the 
> existing approach vs the perceived risks involved with 
> reinventing the wheel. If the majority of the NETLMM crowed 
> is willing to take the risk then I do not think you can do 
> much about it.
> 
> I still think that having two competing solutions in the IETF 
> is a bad idea, unless one of them becomes "experimental" so 
> that the effort is captured but it is clear that the IETF has 
> only fully defined one thing!
> 
> In fact what I think is that the IETF does not need a 
> solution to any of this but I guess I have said this already :-)
> 
> Regards
> George
> 
> 
> > > impacts any Proxy MIP6 solution that may be standardized at the 
> > > IETF. Jari's email on the
> discussion happen 
> > > before a decision is made about the NETLMM DT document.
> > 
> > Discussing differences in requirements would definitely make sense.
> > 
> identical I do 
> > not think it makes sense to standardize both solutions -- that 
> > wouldn't be good from a standardization point of view.
> > 
> > Rather, those (supposedly few) requirements that are presently not 
> > fullfilled by a NetLMM solution should be worked on so that we 
> > satisfies all of them with a single protocol.
> > 
> > Best regards,
> > 
> > --julien
> >

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Fri, 6 Oct 2006 20:01:54 -0700

Hi Alex,

> From: Alexandru Petrescu [mailto:[email-masked]] 
> Sent: Friday, October 06, 2006 5:33 AM
> To: Narayanan, Vidya
> Cc: James Kempf; [email-masked]; [email-masked]
> to makedraft-giaretta-netlmm-dt-protocol-02.txt a WG draft)
> 
> Narayanan, Vidya wrote:
> > (Cross-posting to MIP6)
> > 
> > All, I would like to understand how making this document a 
> WG document 
> Except that reqs/ps and security context is precisely 
> described in netlmm WG items while for PMIPv6 we have no other reqs.
> 

I don't believe we need a separate requirements document. As I said, the
requirements in my view are the same as those that drove NETLMM in the
first place. In addition, I think PMIPv6 is aiming at a solution that
can provide maximum re-use of already defined functionality. While that
is a goal in NETLMM, it has not been realized in the DT protocol. Also,
there seem to be multiple interpretations of that goal - so, there is
not a high degree of clarity to the re-use goal. 

> The netlmm problem statement document discusses problems with 
> existing (at that time) approaches to "netlmm" concepts - 
> h/fmipv6, cellular IP, gtp.  At the time of that writing the 
> PMIPv6 documents did not yet exist (draft-chowdhury-netmip6-00.txt and

The latter document did exist and was taken as input by the DT. I have
to believe that the DT had a discussion about this approach vs a totally
new protocol - but, I can't speak for it, as I have not seen the DT
archives. 

> Do you think the netlmm PS document should be updated to 
> discuss issues with netmip6 and with netlmm-mip6-proxy protocols?
> 

No. Rather, we should be evaluating a solution that allows maximum
re-use of functionality defined for MIP6, as that is what seems to be
gaining momentum in the industry. 

> draft-gundavelli-netlmm-mip6-proxy-00.txt states that it 
> improves handover performance (because MN "just" does 
> "normal" IPv6 attachment, instead of mobility-related 
> messaging).  Later on it states that MN uses DHCP.  Using 
> DHCP is known to be a strong bottleneck for handover 

The discussion is not specifically about the solution in that draft. It
is about how much re-use of existing protocols and functionality should
be feasible from the protocol defined for network-based mobility -
re-use allows faster deployment and hence the interest in the industry.
OTOH, if we do an analysis and find that such a re-use is inefficient
and will hurt us in the long run, it is another story. In this case, I
think a number of people believe that the re-use is practical. 

> Do you mean we should standardize PMIPv6 just because netlmm 
> protocol is being pursued?
> 

No. It is a question of whether we want to allow a PMIPv6 solution to be
designed the right way, in a manner that can be used by multiple SDOs or
let each SDO define its own flavor of it. Otherwise, the onus is on us
to prove that the right solution for network-based mobility is in fact
what is described in draft-giaretta-netlmm-dt-protocol-02. This study
needs to occur for any concrete proof of that - as of now, many people
are not seeing that. 

Vidya

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Fri, 6 Oct 2006 20:06:58 -0700

Hi Julien, 

> From: julien laganier [mailto:[email-masked]] On 
> Behalf Of Julien Laganier
> Sent: Friday, October 06, 2006 6:08 AM
> To: [email-masked]
> Cc: Narayanan, Vidya; James Kempf; [email-masked]

I cross-posted, since the discussion on PMIPv6 was ongoing on MIP6. If
all the interested people are on both lists, I can limit this to just
NETLMM. But, I am not sure of that. 

>    *now* if their requirements are close to what

Quoting from Jari's email - "They (NETLMM) do not have an official WG
solution specification yet, but they will soon and I don't think they
expect to keep in the WG process for too long after that. If you want to
have an effect the time to voice your opinion is now." 

That seems to imply the dependency. In any case, we should be having
this discussion. 

> be worked on so that we satisfies all of them with a 

Ideally, I would agree with you. But, we should look at the differences
in requirements and make a decision. I hope we can hash this all out
among all the people working on NETLMM and PMIPv6 respectively. 

Regards,
Vidya