Subject: 回复:[Mip6] Proxy Mobile IPv6 - I-D Submission

From: huangzhigang 50541 <[email-masked]>
Date: Wed, 18 Oct 2006 17:24:10 +0800

Hi all,

I have some questions about the draft:
1. There is no HA address in the Visitor List, how can PMA get to know HA address when it encapsulate the packets from MN? 
2. When MN moves to a new PMA, does the old PMA need to remove the MN from the Visitor List? and how?
3. I think the case of the response to RS with multicast RA should be described in the draft.

----- 原邮件 -----
发件人: Sri Gundavelli <[email-masked]>
日期: 星期一, 十月 16日, 2006 下午8:36
主题: [Mip6] Proxy Mobile IPv6 - I-D Submission

> Attached is the draft on Proxy Mobile IPv6 that we have
> posted today. Please review and comment on this work.
> 
> Regards
> Sri
> 
> -------- Original Message --------
> Subject: I-D Submission: draft-sgundave-mip6-proxymip6-00.txt
> Date: Mon, 16 Oct 2006 05:25:39 -0700
> From: Sri Gundavelli <[email-masked]>
> To: [email-masked]
> 
> Hi,
> 
> Please find the attached internet-draft
> 
>   draft-sgundave-mip6-proxymip6-00.txt
> 
> This is an individual submission for the Mobile IPv6 working group.
> Please post this to the archives.
> 
> Thanks
> Sri
> 
> 
_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6
_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Sri Gundavelli <[email-masked]>
Date: Wed, 18 Oct 2006 06:59:16 -0700 (PDT)

Hi Huang,

Thanks for the review. Please see inline ..

> 1. There is no HA address in the Visitor List, how can PMA get to know HA address when it encapsulate the packets from MN?

When the mobile station attaches to the access link, the access
authentication procedures kick in and as part of this procedure,
the access router (proxy mobile agent) identifies the mobile station
and pulls out its profile from a policy store such as AAA. The
policy would have the home agent/home prefix attribute and that
will be used for sending the proxy binding update. Later in the
data path, the injected source based route, over the tunnel with
the home agent as the destination would handle the packet routing.

> 2. When MN moves to a new PMA, does the old PMA need to remove the MN from the Visitor List? and how?

Good point.

Registration revocation as in the base MIP6, is enforced as part of the
new registration. When the mobile station moves from AR1 to AR2, the
proxy registration from AR2, will force the home agent to move the
MN route from the previous tunnel AR1 to AR2. However, we did think
of defining a new message at AR1, when it detects a layer-2 event
when the moves out, it can certainly send PBU with 0 life. Minor
extension, we can do that.

> 3. I think the case of the response to RS with multicast RA should be described in the draft.

Sure. We can do that. The RA will have the properties of the mobile
station's home link. The advertised prefix, address configuration
modes (stateful/stateless), Router life time ..etc will all be
consistent with the home link.

We can certainly add more text.

>
>
> ----- ԭ�ʼ� -----
> ������: Sri Gundavelli <[email-masked]>
> ����: ����һ, ʮ�� 16��, 2006 ����8:36
> ����: [Mip6] Proxy Mobile IPv6 - I-D Submission
>