Subject: [Mip6] Re: [Dime] Impact of RFC 4285 for Diameter MIP6 Bootstrapping Work

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 12 Oct 2006 11:15:10 -0700

looks like nobody replied to this email. :)

Hannes Tschofenig wrote:
> Hi all,
> 
> in the DIME working group we are currently producing documents that 
> relate to the backend solution of the
> 
> * Integrated Scenario
>   draft-ietf-mip6-bootstrapping-integrated-dhc-01
> 
> * Split Scenario
>   draft-ietf-mip6-bootstrapping-split-02
> 
> Now, the question came up whether we have to consider RFC 4285 
> ('Authentication Protocol for Mobile IPv6') for our work as well.

currently it is not clear if we are going to do any
further work on RFC 4285 in the MIP6 WG. so my
suggestion is to assume only the use of IKEv2 (with
and without EAP).

but it would be good to keep the solution flexible
so that it can be extended later for 4285 if required.

Vijay

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Thu, 12 Oct 2006 14:49:49 -0700

I missed this email earlier too :)  

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]] 
> Sent: Thursday, October 12, 2006 11:15 AM
> To: Hannes Tschofenig
> Cc: [email-masked]; [email-masked]
> Subject: [Mip6] Re: [Dime] Impact of RFC 4285 for Diameter 
> MIP6Bootstrapping Work
> 
> currently it is not clear if we are going to do any further 
> work on RFC 4285 in the MIP6 WG. so my suggestion is to 
> assume only the use of IKEv2 (with and without EAP).
> 

Agree on the above with Vijay. 

Vidya

> but it would be good to keep the solution flexible so that it 
> can be extended later for 4285 if required.
> 
> Vijay
>

---

From: "Gerardo Giaretta" <[email-masked]>
Date: Fri, 13 Oct 2006 09:36:33 +0200

> suggestion is to assume only the use of IKEv2 (with

Agree with Vijay, this is also the assumption for the AAA goals draft.

--Gerardo

> DiME mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dime
>

---

From: Madjid Nakhjiri <[email-masked]>
Date: Thu, 19 Oct 2006 13:02:19 -0700

I would agree with Vijay as well. But, we need to see if we have the process
in place for this to happen and what the consequences for inserting that
process is. 

These specs are being produced addressing the set of requirements in HA-AAAH
document (not sure if other requirement docs are in place).

The way I understand it that requirement documents were not written to
address the 4285 requirements specifically. 

If my understanding incorrect and people think the requirement docs include
4285-related requirements, then, that is fine and hopefully the specs will
address most of the 4285 needs (except possibly some AVPs that may be added
later) either initially or through revisions.

However, if my understanding is correct and the requirements docs do not
include 4285 requirements, why would we expect the design specs will
automatically? 

Does the group feel it want to spend time issuing a set of requirements to
meet 4285 needs and then design accordingly? If not, then I think we should
just accept that the outcoming specs simply MAY support 4285. I am sure the
two WGs do not appreciate this issue being raised two years down the road.

What I am missing here?

R,

Madjid

-----Original Message-----
From: Vijay Devarapalli [mailto:[email-masked]] 
Sent: Thursday, October 12, 2006 11:15 AM
To: Hannes Tschofenig
Cc: [email-masked]; [email-masked]
Subject: [Mip6] Re: [Dime] Impact of RFC 4285 for Diameter MIP6
Bootstrapping Work

Vijay

---

From: Madjid Nakhjiri <[email-masked]>
Date: Thu, 19 Oct 2006 13:04:04 -0700

Ok, so I see I spend a long email without reading the rest of the thread. 
Do we feel the AAA goal draft efficiently captures the 4285 requirements?
If yes, sorry for clogging your mailboxes..

R,

Madjid

-----Original Message-----
From: Gerardo Giaretta [mailto:[email-masked]] 
Sent: Friday, October 13, 2006 12:37 AM
To: Vijay Devarapalli
Cc: [email-masked]; [email-masked]
Subject: Re: [Dime] Impact of RFC 4285 for Diameter MIP6 Bootstrapping Work

--Gerardo

---

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 19 Oct 2006 16:32:32 -0400

Madjid,

> If yes, sorry for clogging your mailboxes..

That is my feeling and is why I had the following comment on aaa-ha-goals draft:

"
  YO: This document seems to assume the use of IPsec between MN and HA
  for securing Mobile IPv6 signaling.  But the AAA interface could
  also be used for RFC 4285.  So I think it might be good to mention
  in this section that the document may not preclude the use of
  alternative methods for securing Mobile IPv6 signaling between MN
  and HA while this document focuses on the use of IPsec between MN
  and HA.
"

Yoshihiro Ohba

---

From: Madjid Nakhjiri <[email-masked]>
Date: Thu, 19 Oct 2006 14:15:14 -0700

Hi Yoshi,

I agree, no point on insisting that solutions would support 4285, if 4285
requirements are not included. I can think of aspects of 4285 that can be
problematic, but won't mention them now, since I don't want to be accused of
opening the pandora's box while aaa-ha-goals is going through last call or
the dime docs are underway :) 

We should not make claims we cannot back up later as that might derail the
standardization process two years from now. As Persians say (after a lousy
marketing translation) "A small quarrel in the beginning better than a
bloody peace at the end"

R,

Madjid

-----Original Message-----
From: Yoshihiro Ohba [mailto:[email-masked]] 
Sent: Thursday, October 19, 2006 1:33 PM
To: Madjid Nakhjiri
Cc: 'Gerardo Giaretta'; 'Vijay Devarapalli'; [email-masked]; [email-masked]
Subject: Re: [Mip6] RE: [Dime] Impact of RFC 4285 for Diameter MIP6
Bootstrapping Work

Madjid,

> If yes, sorry for clogging your mailboxes..

That is my feeling and is why I had the following comment on aaa-ha-goals
draft:

"

Yoshihiro Ohba

---

From: "Gerardo Giaretta" <[email-masked]>
Date: Fri, 20 Oct 2006 10:02:18 +0200

Hi Yoshi and Madjid,

the AAA goals draft does not include any specific goal for rfc4285.
This issue was raised in Montreal and during MIP6 re-chartering
discussion. The outcome of the discussion was that there is no a clear
interest now in the IETF to standardize a bootstrapping solution for
rfc4285 and a Diameter Application that supports rfc4285. MIP6 chairs
and Jari mentioned that they may ask for rfc4285 support if
significant interest will be raised. Remember also that rfc4285 is
informational and the Diameter Application will be PS: not sure how to
this difference would be handled.

Having said that, I think that the approach taken so far in the design
of the Diameter Application is flexible enough to include rfc4285
later without any big change: the authorization application does not
need to be changed for rfc4285 support and we may define another
application for authentication purposes. Therefore the
authentication/authorization split seems a correct approach in order
to introduce rfc4285 support later.

--Gerardo

---

From: "Julien Bournelle" <[email-masked]>
Date: Fri, 20 Oct 2006 11:30:12 +0200

Hi all,

 concerning support for rfc4285, I think we'll need messages to carry the BU
 from the HA to the AAAH for the authentifcation. As such, a new application
 may be necessary. As a consequence, the authorization and accounting part
 may be handled by the same application.

 This application would be similar to the RFC4004 (without FA...).

 Just my 2 cents,

 Julien

---

From: Madjid Nakhjiri <[email-masked]>
Date: Fri, 20 Oct 2006 10:27:42 -0700

Hi Julien

Your 2 cents are part of the nickel (5 cents) that I did not want to bring
up:) I said this once before, 4285 is a lot like MIP4 key bootstrapping
process. You can look at the combination of 4004 and Nakhjiri-radius-mip4-02
to see all kinds of things needed.
 
Gerardo, here are the issues: 
1) We don't have a set of requirements on 4285 (read non-existing 4285
requirement).
2) We don't even know we want to meet these requirement, even if they
existed?? I.e. MUST or SHOULD the AAA goals include those requirements?
That translates into MUST we or SHOULD the solutions meet the requirements,
once they are developed?

Personally, I think, we don't have any answer to issue 1 and we have already
said the answer to question 2 is no. 

I think without a thorough analysis of the 4285 requirements and without a
MUST/SHOULD meet requirements, we should just move on, without rubber
stamping the solution document as something that supports 4285? The solution
MAY support for 4285, but it is not a requirement.

Your statement on
> later without any big change

Sounds like a MAY meet the requirements to me! Any other solution may or may
not do it:)

As engineers we design based on requirements, no?

R,

Madjid

-----Original Message-----
From: Julien Bournelle [mailto:[email-masked]] 
Sent: Friday, October 20, 2006 2:30 AM
To: Gerardo Giaretta
Cc: Madjid Nakhjiri; Yoshihiro Ohba; [email-masked]; [email-masked]
Subject: Re: [Mip6] RE: [Dime] Impact of RFC 4285 for Diameter MIP6
Bootstrapping Work

Hi all,

 Just my 2 cents,

 Julien

---

From: Jari Arkko <[email-masked]>
Date: Thu, 26 Oct 2006 16:18:45 +0300

I believe you should do the work based on the WG draft.
(But I don't think anyone minds if the solution happens
to support or be easily adoptable for RFC 4285 too. But
don't go out of your way to achieve that.)

--Jari

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 26 Oct 2006 21:31:11 +0200

Hi Jari,

> don't go out of your way to achieve that.)

Thanks for the quick response.

Ciao
Hannes

---

From: Basavaraj Patil <[email-masked]>
Date: Mon, 30 Oct 2006 17:21:45 -0600

Hannes,

We will try and get some more input to the work in DIME w.r.t the
bootstrapping requirements.

The bootstrapping solution in MIP6 (until now) has been based on the
assumption that the security for signaling between the MN and HA is via
IPsec. We have not really considered RFC4285 in the bootstrapping work.
However there is a draft (by Vijay Devarapalli) that proposes a solution for
bootstrapping with RFC4285.

I would suggest that you focus on the WG I-D (
draft-ietf-mip6-aaa-ha-goals-03.txt)  but as Jari said if you can cover the
other case, i.e RFC4285 as well without extra effort that would be good.

-Raj

On 10/26/06 7:40 AM, "ext Hannes Tschofenig" <[email-masked]>
wrote:

> Hi Raj,
> Hi Gopal,
> 
> some time back I have posted the attached mail to the list soliciting
> guidance for the Diameter MIP6 bootstrapping work.
> Unfortunately, we haven't received a lot of feedback and guidance on
> this issue.
> 
> We are making progress with our work and we would like to know ahead of
> time whether we should develop a backend solution based on
> (a) 
> http://www.ietf.org/internet-drafts/draft-ietf-mip6-aaa-ha-goals-03.txt, or
> (b) 
> http://www.ietf.org/internet-drafts/draft-ietf-mip6-aaa-ha-goals-03.txt
> and http://www.ietf.org/rfc/rfc4285.txt.
> 
> Ciao
> Hannes
> 
> Hannes Tschofenig wrote:
>> Hi all,
>> 
>> Thoughts?