Subject: RE: [Mip6] RE: [netlmm] Network-based mobility - NETLMM DTSolutionVsA solutionbased on MIP6

From: "Kent Leung \(kleung\)" <[email-masked]>
Date: Tue, 17 Oct 2006 18:26:57 -0700

BTW, I believe the DT document is the right solution for network-based
localized MM.  It's a clean protocol that's designed for network node
signaling, without having excess baggage of a protocol used for host
control.  However, there's interest to revive PMIPv6 too.  Depending on
the application, one can choose the right fit, IMHO.  IPv6 over PMIPv4
might be another option to debate.    

Kent

<snip>

[KC>] Aren't you also in that camp now? Ref, your newly revived I-D on
pmip6. So, why don't you answer your own question?

<snip>

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Wed, 18 Oct 2006 00:58:07 -0400

> -----Original Message-----
> From: Kent Leung (kleung) [mailto:[email-masked]]
> Sent: Tuesday, October 17, 2006 8:27 PM
> To: Chowdhury, Kuntal
> Cc: [email-masked]; [email-masked]
> Subject: RE: [Mip6] RE: [netlmm] Network-based mobility - NETLMM
> DTSolutionVsA solutionbased on MIP6
> 
[KC>] There is interest in v6 over PMIPv4 too. There are two I-Ds
already:

http://www.join.uni-muenster.de/Dokumente/drafts/draft-navali-ip6-over-n
etmip4-00.txt

http://www.ietf.org/internet-drafts/draft-premec-mip4-ip6-proxy-mip4-00.
txt

---

From: "Zhang, Qiang [NTK]" <[email-masked]>
Date: Thu, 19 Oct 2006 09:19:20 -0500

The PMIP6 approach seems to fit both the "global" and "localized" mobility management concepts depending on the usage models, e.g. it supports either intra or inter access network roaming given proper AAA brokerage infrastructure. Given two DTs are defining the similar PMIP AR signaling and routing and the netlmm and MIP6 are not really mutually exclusive, I guess this addresses a overlap portion of the design, a reasonable compromise may be to define this in one of the WGs and cross reference or extend it to fit into the other

-----Original Message-----
From: Chowdhury, Kuntal [mailto:[email-masked]] 
Sent: Tuesday, October 17, 2006 9:39 PM
To: Kent Leung (kleung)
Cc: [email-masked]; [email-masked]
Subject: RE: [Mip6] RE: [netlmm] Network-based mobility - NETLMM DTSolutionVsA solutionbased on MIP6 

Hi Kent,

See inline....

-Kuntal

> Sent: Tuesday, October 17, 2006 7:53 PM
> To: Chowdhury, Kuntal
> Subject: RE: [Mip6] RE: [netlmm] Network-based mobility - NETLMM DT 
> SolutionVsA solutionbased on MIP6
> 
> Hi Kuntal.
> <snip>
> >
> > Some SDOs have adopted PMIPv4 but not for localized MM within the
> access
> > network (which is the scope of NetLMM).
> >
> [KC>] PMIP (4 and 6) is used for network based mobility management for 
> simple IP sessions. Whether the scope is NOT localized is a subjective 
> discussion.
> 
> KL> An objective way to look at it is from the reference interface
> perspective.
> 
[KC>] If the discussion gets too SDO specific (which I believe is going to happen), I would suggest we take this offline. MIP4 is used for inter-RNC mobility management in the radio access network in an SDO.
What do you call that? NOT global mobility I guess :-)

> 
> > I think we should clarify the difference between non-MIPv6 mobility 
> > option re-use vs. re-usable MIPv6 Home Agent.  Maybe this is
something
> 
> > the PMIPv6 camp should sort out first? ;)
> 
> KL> The answer is in the draft. :)  Do you have an opinion?
> 
[KC>] You can get a hint of my opinion in the I-D that we (Ajoy and I) submitted. FYI...we have an I-D on pmip6 (aka netmip6) which we are pursing all along w/o shifting position. The I-D is :
http://www.ietf.org/internet-drafts/draft-chowdhury-netmip6-01.txt

We do not propose non-MIP6 MO for *mobility management* in this I-D. The essence of pmip6 is the compatibility with mip6. Maximum reuse of mip6 MO should be the guideline and re-inventing the wheel for the heck of it should be avoided. So, the approach that introduces NEW MO for pmip6 seems to defeat the very purpose i.e. reuse mip6 protocol for proxy mip6 operation, IMHO.