Subject: [Mip6] Summary of consensus call on adopting I-D: draft-muhanna-mip6-binding-revocation

From: Basavaraj Patil <[email-masked]>
Date: Wed, 05 Sep 2007 16:15:57 -0500

Consensus call details are at:
http://www1.ietf.org/mail-archive/web/mip6/current/msg06633.html

There is general consensus on specifying binding revocation for MIP6 based
on the responses received on the MIP6 ML.
However there have been a few concerns raised as well about whether there is
a need for binding revocation at all for MIP6. All the responses agree that
revocation is required for Proxy MIP (PMIP) and possibly for MONAMI6 but not
necessarily for MIP6.

The authors have provided some arguments and scenarios justifying the need
for revocation for MIP6. However it has been pointed out the same result can
be achieved via the use of the HA-Switch mechanism which is already being
specified by the MIP6 WG.

It has also been noted that this I-D if it were to be taken up as a WG item
would have to be a joint MIP6/NETLMM WG effort.

In terms of next steps, I will discuss the conclusion and outcome of the
consensus call with our AD, Jari Arkko and the Netlmm chairs and decide how
to proceed.

Appreciate all the responses and feedback.

-Raj

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Wed, 5 Sep 2007 18:34:02 -0500

Hi Raj,
Please one comment below.

> There is general consensus on specifying binding revocation 
> for MIP6 based on the responses received on the MIP6 ML.
> However there have been a few concerns raised as well about 
> whether there is a need for binding revocation at all for 
> MIP6. All the responses agree that revocation is required for 
> Proxy MIP (PMIP) and possibly for MONAMI6 but not necessarily 
> for MIP6.
> 
> The authors have provided some arguments and scenarios 
> justifying the need for revocation for MIP6. However it has 
> been pointed out the same result can be achieved via the use 
> of the HA-Switch mechanism which is already being specified 
> by the MIP6 WG.

[Ahmad]
I humbly disagree. The current HA-Switch draft which already in IESG
Last Call is intended for a different purpose. The draft is meant to
enable the Home Agent (due to specific HA operational conditions) to
inform the MN of an alternative Home Agent in order to continue receive
MIPv6 service. Which is opposite to what revocation is meant by
terminating the MN MIPv6 services.

> 
> It has also been noted that this I-D if it were to be taken 
> up as a WG item would have to be a joint MIP6/NETLMM WG effort.
> 
> In terms of next steps, I will discuss the conclusion and 
> outcome of the consensus call with our AD, Jari Arkko and the 
> Netlmm chairs and decide how to proceed.
>

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Wed, 5 Sep 2007 17:03:07 -0700

Hi Raj,
One clarification below.  

> -----Original Message-----
> From: Basavaraj Patil [mailto:[email-masked]] 
> Sent: Wednesday, September 05, 2007 2:16 PM
> To: Mobile IPv6 Mailing List
> Subject: [Mip6] Summary of consensus call on adopting I-D: 
> draft-muhanna-mip6-binding-revocation
> 
> 
> Proxy MIP (PMIP) 

I think it is too early to conclude this, given that we have not had a
discussion in the NETLMM WG yet.  Should this work be undertaken for
MIP6, Jonne and I will work on getting the necessary feedback from the
NETLMM WG.  

Thanks,
Vidya

>and possibly for MONAMI6 but not necessarily 
> for MIP6.
>

---

From: Basavaraj Patil <[email-masked]>
Date: Fri, 07 Sep 2007 10:27:44 -0500

Hi Vidya,

I agree that there would be a need for a dialog in Netlmm and consensus to
specify it as a feature for PMIP as well prior to take=ing it up.

Lets discuss with Jari as well on next-steps.

-Raj

---

From: Jari Arkko <[email-masked]>
Date: Tue, 18 Sep 2007 15:03:38 +0300

Hi all,

I took a look at the document myself, and we had a conference
call with the MIP6 and NETLMM chairs.

I think the proposed functionality makes sense, and is not
a good fit for the ha-switch draft, at least not as currently
written.

I tend to agree with others who stated that the main
practical use case is for proxy MIP. It is conceivable
that it would be used for pure host MIP as well (e.g.,
pre-paid mobility service that is not tied to network
access), but I'm not sure how much demand there is
for that. In any case, I think this should be done in
MIP6/MEXT so that its available for host, network,
and proxy mobility.

However, after discussion with the NETLMM chairs
we came to the conclusion that the work should
wait a few months. This is necessary, as the main
users should get to review that the functionality
matches their requirements. But neither the
chairs or me are willing to request more work
from the group before they have completed
some of the current documents. I.e., lets
wait until Netlmm base has been submitted
to the IESG. This also gives us time to add
a work item in the MEXT charter for the work.

Jari

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Thu, 20 Sep 2007 14:26:54 -0500

Hi Jari,

Thanks for taking an action on this and we appreciate your views.

Its our view as well, that the binding revocation protocol should be
defined once and be applied for both host-based and network-based
protocols. The draft is written with that intent and we will update it
as needed to reflect all the use cases. Of course, we agree that the
obvious use case is for PMIP6 and some use cases in client based
mobility as well.

We realize that the NETLMM WG is very busy and will not have the time to
review this document, which got the consensus from WG for adoption, or
for that matter any new document, till the base Proxy Mobile IPv6 specs
make it to IESG. We will wait till that time and in the mean while we
will improve the document, based on the feedback we received so far.

We look forward to see this work be listed as the chartered item in MEXT
WG and also be listed in the NETLMM charter as a required document for
reviews from the WG.

Thanks for your leadership.

Regards,
Ahmad

> From: Jari Arkko [mailto:[email-masked]] 
> Sent: Tuesday, September 18, 2007 7:04 AM
> To: Basavaraj Patil
> Cc: Mobile IPv6 Mailing List
> Subject: Re: [Mip6] Summary of consensus call on adopting 
> I-D: draft-muhanna-mip6-binding-revocation
> 
> Hi all,
> 
> I think the proposed functionality makes sense, and is not a 
> good fit for the ha-switch draft, at least not as currently written.
> 
> practical use case is for proxy MIP. It is conceivable that 
> it would be used for pure host MIP as well (e.g., pre-paid 
> mobility service that is not tied to network access), but I'm 
> not sure how much demand there is for that. In any case, I 
> think this should be done in MIP6/MEXT so that its available 
> for host, network, and proxy mobility.
> 
> However, after discussion with the NETLMM chairs we came to 
> the conclusion that the work should wait a few months. This 
> is necessary, as the main users should get to review that the 
> functionality matches their requirements. But neither the 
> chairs or me are willing to request more work from the group 
> before they have completed some of the current documents. 
> I.e., lets wait until Netlmm base has been submitted to the 
> IESG. This also gives us time to add a work item in the MEXT 
> charter for the work.
> 
> Jari
> 
> 
>

---

From: Jari Arkko <[email-masked]>
Date: Fri, 21 Sep 2007 08:05:58 +0200

> We will wait till that time and in the mean while we

Great - thanks!

Jari