Subject: Re: RE: [Mip6] I-D ACTION:draft-ietf-mip6-hiopt-06.txt

From: Heejin Jang <[email-masked]>
Date: Thu, 06 Sep 2007 02:12:44 +0000 (GMT)

Hi, Kilian. 
 
In the stateless DHCP, an MN can request the required information to a DHCP server 
with an Information-Request message whenever it needs. An HN Identifier Option is 
not exception. It can be sent at any time after network authentication or long after network authentication
when the MN decides to run MIPv6 by using the proposed bootstrapping mechanism.

- Best Regards, 
Heejin.

------- Original Message -------
Sender : Kilian Weniger<[email-masked]>
Date   : 2007-08-29 17:03
Title  : RE: [Mip6] I-D ACTION:draft-ietf-mip6-hiopt-06.txt

Hi Hee Jin Jang,

I have a question about this draft: Does this draft require the mobile
node to send a DHCP Information Request with Home Network Identifier
Option just after network authentication is completed? Or may the mobile
node send the DHCP Information Request to obtain home network
information at any time after network authentication? 

For instance, the mobile node may want to bootstrap MIPv6 only when it
starts an application that requires session continuity, which may be
long after network authentication has been completed. 

I think this should be clarified in the draft.

Regards,

Kilian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Dienstag, 28. August 2007 21:15
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Mip6] I-D ACTION:draft-ietf-mip6-hiopt-06.txt 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
> This draft is a work item of the Mobility for IPv6 Working 
> Group of the IETF.
> 
>     Title        : DHCP Option for Home Information 
> Discovery in MIPv6
>     Author(s)    : H. Jang, et al.
>     Filename    : draft-ietf-mip6-hiopt-06.txt
>     Pages        : 23
>     Date        : 2007-8-28
>     
> This draft defines a DHCP-based scheme to enable dynamic discovery of
>    Mobile IPv6 home network information.  New DHCP options are defined
>    which allow a mobile node to request the home agent IP 
> address, FQDN,
>    or home subnet prefix and obtain it via the DHCP response.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-mip6-hiopt-06.txt
> 
> To remove yourself from the I-D Announcement list, send a message to 
> [email-masked] with the word unsubscribe in 
> the body of 
> the message. 
> You can also visit 
> https://www1.ietf.org/mailman/listinfo/I-D-announce 
> to change your subscription settings.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the 
> username "anonymous" and a password of your e-mail address. After 
> logging in, type "cd internet-drafts" and then 
> "get draft-ietf-mip6-hiopt-06.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
>     [email-masked].
> In the body type:
>     "FILE /internet-drafts/draft-ietf-mip6-hiopt-06.txt".
>     
> NOTE:    The mail server at ietf.org can return the document in
>     MIME-encoded form by using the "mpack" utility.  To use this
>     feature, insert the command "ENCODING mime" before the "FILE"
>     command.  To decode the response(s), you will need "munpack" or
>     a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
>     exhibit different behavior, especially when dealing with
>     "multipart" MIME messages (i.e. documents which have been split
>     up into multiple messages), so check your local documentation on
>     how to manipulate these messages.
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 

Panasonic R&D Center Germany GmbH
63225 Langen, Hessen, Germany
Reg: AG Offenbach (Hessen) HRB 33974
Managing Director: Thomas Micke

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Kilian Weniger" <[email-masked]>
Date: Thu, 6 Sep 2007 08:58:36 +0200

Hi Heejin,

thanks for your clarification. Good to hear that requesting home network
information at any time is supported.

However, it is not yet totally clear to me how this works based on the
current text in the draft: According to section 4.2 of
draft-ietf-mip6-hiopt-06.txt, the home network information is delivered
from AAAH to the NAS/DHCP relay at the time of MN's network auth and the
DHCP relay shall forward this information at the time of receiving the
DHCP Request from the MN:

  "...
   Upon receiving the MIP6 related RADIUS or Diameter attributes
   returned by the AAAH, the NAS passes the information to the
   collocated DHCP relay agent.
   
   Upon receiving the Information Request from the mobile node, the DHCP
   relay agent MUST forward the message to the DHCP server....
   If the relay agent determines that the NAS has passed home network
   information for this mobile node, the relay agent MUST include the
   received home network information in the MIP6 Relay Agent option, and
   attach this option in the Relay-Forward message. "

How is it ensured that the NAS/DHCP relay still has the MN's home
network information at the time of receiving the DHCP Information
Request from the MN, if network auth has happened long time ago? 

Does draft-ietf-mip6-hiop require that the NAS/DHCP relay stores the
home network information received from AAAH during network auth until
the MN leaves this NAS? Or should the NAS interact with the AAAH again
upon receiving the DHCP Request from the MN in this case? 

BR,

Kilian

> From: Heejin Jang [mailto:[email-masked]] 
> Sent: Donnerstag, 6. September 2007 04:13
> To: Kilian Weniger
> Cc: ???; [email-masked]
> Subject: Re: RE: [Mip6] I-D ACTION:draft-ietf-mip6-hiopt-06.txt
> 
> Hi, Kilian. 
>  
> not exception. It can be sent at any time after network 
> authentication or long after network authentication