Subject: [MLS] Turning mandatory extensions into fields

From: Théophile Wallez <[email-masked]>
Date: Fri, 21 May 2021 23:03:56 +0200

Hello All,

The MLS spec includes some extensions that are mandatory.
Considering that this is v1 of the spec, why not just make these into fields and take them out of extensions?

In particular, in the current draft, the parent hash is only an extension, but it is mandatory when the leaf is generating an UpdatePath.
Let us make it a field in KeyPackage?
Having it as an extension hides its importance for security, and makes the draft confusing to read.
Also, it is a bit weird that parent_hash is a field in ParentNode, and it is an extension in KeyPackage.

We propose the following changes:

> New structure:
> struct {
>     opaque parent_hash_value<0..255>;
> } ParentHash;
>
> New field in KeyPackage:
> optional<ParentHash> parent_hash;
>
> This optional field must be present in the `leaf_key_package` of an UpdatePath (same constraints as the current extension).

Or:

> New field in KeyPackage:
> opaque parent_hash<0..255>;
>
> `parent_hash` must be non-empty in the `leaf_key_package` of an UpdatePath (same constraints as the current extension).

Best regards,
Théophile, Benjamin, and Karthik

---

From: Raphael Robert <[email-masked]>
Date: Sat, 22 May 2021 12:20:10 +0200

Hi Théophile,

The current scheme was introduced a while ago when we merged the the KeyPackages that clients publish ahead of time (previously called init keys) with the KeyPackages that clients use in their leaf nodes.
The reason was that there was quite some overlap between the two structs and the logical consequence was that data that differs for the two use cases was expressed as extensions.

I’d be open to discussing disambiguating this again and I think I’m not the only one. This would also pave the way for Joël’s proposal to have an additional public key in the init keys in order to improve FS for members who don’t update quickly.

Thanks

Raphael

> On 21. May 2021, at 23:03, Théophile Wallez <[email-masked]> wrote:
> 
> Hello All,
> 
> Théophile, Benjamin, and Karthik_______________________________________________
> MLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mls