Subject: [MLS] Fwd: New Version Notification for draft-knodel-e2ee-definition-01.txt

From: Mallory Knodel <[email-masked]>
Date: Fri, 7 May 2021 10:59:23 -0400

Hi all,

There's been oblique discussion of this draft, thanks to Alec's citation 
in his recent effort.

My co-authors and I thought we should go ahead and share a -01 version 
with the group. Most of our feedback so far has been around better 
definition of an end, so we broke that into its own sub-section.

The goal is to clearly define e2ee in three different ways: constituent 
formal definition, functionalities, and user expectations. This assumes 
a technology is defined by its properties. Conversely, we are not trying 
to define properties by the technology in use, eg "this app is secure 
because it's e2ee", which is totally valid. But without our effort, it's 
becomes circular.

Lastly I'll just mention that while we aim to define e2ee, we also end 
up defining a few other terms as well. It's perhaps worth considering 
this a terminology draft for the mls working group, as Raphael just 
suggested. We are certainly open to that, so please help us by opening 
issues or sending pull requests to help solidify those terms: 
https://github.com/mallory/e2ee/edit/main/draft-e2ee.md.

Any and all reviews welcome,

-Mallory

-------- Forwarded Message --------
Subject: 	New Version Notification for draft-knodel-e2ee-definition-01.txt
Date: 	Fri, 07 May 2021 07:48:53 -0700
From: 	[email-masked]
To: 	Sofía Celi <[email-masked]>, Fred Baker 
<[email-masked]>, Fred Baker <[email-masked]>, 
Gurshabad Grover <[email-masked]>, Mallory Knodel 
<[email-masked]>, Olaf Kolkman <[email-masked]>, Sofia Celi 
<[email-masked]>

A new version of I-D, draft-knodel-e2ee-definition-01.txt
has been successfully submitted by Mallory Knodel and posted to the
IETF repository.

Name: draft-knodel-e2ee-definition
Revision: 01
Title: Definition of End-to-end Encryption
Document date: 2021-05-07
Group: Individual Submission
Pages: 12
URL: https://www.ietf.org/archive/id/draft-knodel-e2ee-definition-01.txt
Status: https://datatracker.ietf.org/doc/draft-knodel-e2ee-definition/
Htmlized: https://datatracker.ietf.org/doc/html/draft-knodel-e2ee-definition
Htmlized: https://tools.ietf.org/html/draft-knodel-e2ee-definition-01
Diff: https://www.ietf.org/rfcdiff?url2=draft-knodel-e2ee-definition-01

Abstract:
End-to-end encryption (E2EE) is an application of cryptography in
communications systems between endpoints. E2EE systems are unique in
providing features of confidentiality, integrity and authenticity for
users. Improvements to E2EE strive to maximise the system's security
while balancing usability and availability. Users of E2EE
communications expect trustworthy providers of secure implementations
to respect and protect their right to whisper.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Raphael Robert <[email-masked]>
Date: Fri, 7 May 2021 23:06:08 +0200

Thanks for sharing Mallory!

I like that it has a wholistic approach and that it is based on prior research.
I need to think a bit more about it in general, what comes to mind right now in no particular order:

 - What are the possible synergies between your draft and the MLS architecture draft (https://tools.ietf.org/html/draft-ietf-mls-architecture-06 <https://tools.ietf.org/html/draft-ietf-mls-architecture-06>)?
 - Topics that could possibly be expanded: authentication, metadata (e.g. persisted metadata vs. observable metadata)
 - End user expectations: As mentioned for Alec’s draft as well, I think end user expectations are the center piece. Bridging the gap between academic definitions and the UX of secure messengers would provide some real value in my mind.

In essence, it’s great to have this draft and it is relevant for MLS in my mind. Thanks again for sharing!

Raphael

> On 7. May 2021, at 16:59, Mallory Knodel <[email-masked]> wrote:
> 
> Hi all,
> 
> There's been oblique discussion of this draft, thanks to Alec's citation in his recent effort.
> 
> My co-authors and I thought we should go ahead and share a -01 version with the group. Most of our feedback so far has been around better definition of an end, so we broke that into its own sub-section.
> 
> The goal is to clearly define e2ee in three different ways: constituent formal definition, functionalities, and user expectations. This assumes a technology is defined by its properties. Conversely, we are not trying to define properties by the technology in use, eg "this app is secure because it's e2ee", which is totally valid. But without our effort, it's becomes circular.
> 
> Lastly I'll just mention that while we aim to define e2ee, we also end up defining a few other terms as well. It's perhaps worth considering this a terminology draft for the mls working group, as Raphael just suggested. We are certainly open to that, so please help us by opening issues or sending pull requests to help solidify those terms: https://github.com/mallory/e2ee/edit/main/draft-e2ee.md <https://github.com/mallory/e2ee/edit/main/draft-e2ee.md>.
> 
> From:	[email-masked] <mailto:[email-masked]>
> To:	Sofía Celi <[email-masked]> <mailto:[email-masked]>, Fred Baker <[email-masked]> <mailto:[email-masked]>, Fred Baker <[email-masked]> <mailto:[email-masked]>, Gurshabad Grover<[email-masked]> <mailto:[email-masked]>, Mallory Knodel <[email-masked]> <mailto:[email-masked]>, Olaf Kolkman <[email-masked]> <mailto:[email-masked]>, Sofia Celi <[email-masked]> <mailto:[email-masked]>
> 
> 
> URL: https://www.ietf.org/archive/id/draft-knodel-e2ee-definition-01.txt <https://www.ietf.org/archive/id/draft-knodel-e2ee-definition-01.txt>
> Status: https://datatracker.ietf.org/doc/draft-knodel-e2ee-definition/ <https://datatracker.ietf.org/doc/draft-knodel-e2ee-definition/>
> Htmlized: https://datatracker.ietf.org/doc/html/draft-knodel-e2ee-definition <https://datatracker.ietf.org/doc/html/draft-knodel-e2ee-definition>
> Htmlized: https://tools.ietf.org/html/draft-knodel-e2ee-definition-01 <https://tools.ietf.org/html/draft-knodel-e2ee-definition-01>
> Diff: https://www.ietf.org/rfcdiff?url2=draft-knodel-e2ee-definition-01 <https://www.ietf.org/rfcdiff?url2=draft-knodel-e2ee-definition-01>
> 
> Abstract:
> _______________________________________________
> MLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mls

---

From: Mallory Knodel <[email-masked]>
Date: Mon, 10 May 2021 12:30:00 -0400

Thanks Raphael, those are all excellent suggestions. I think Gurshabad 
and I have a grip on their essence, so will make an attempt at -02 for 
the second points and I'll re-review draft-architecture with your first 
question in mind. Perhaps at the next MLS meeting we can as a group 
spend some time together to think about scope wrt other wg drafts.

-Mallory

On 5/7/21 5:06 PM, Raphael Robert wrote:
>  - What are the possible synergies between your draft and the MLS 
> architecture draft 
> (https://tools.ietf.org/html/draft-ietf-mls-architecture-06)?
>  - Topics that could possibly be expanded: authentication, metadata 
> (e.g. persisted metadata vs. observable metadata)
>  - End user expectations: As mentioned for Alec’s draft as well, I 
> think end user expectations are the center piece. Bridging the gap 
> between academic definitions and the UX of secure messengers would 
> provide some real value in my mind.
>
>> My co-authors and I thought we should go ahead and share a -01 
>> version with the group. Most of our feedback so far has been around 
>> better definition of an end, so we broke that into its own sub-section.
>>
>> The goal is to clearly define e2ee in three different ways: 
>> constituent formal definition, functionalities, and user 
>> expectations. This assumes a technology is defined by its properties. 
>> Conversely, we are not trying to define properties by the technology 
>> in use, eg "this app is secure because it's e2ee", which is totally 
>> valid. But without our effort, it's becomes circular.
>>
>> Lastly I'll just mention that while we aim to define e2ee, we also 
>> end up defining a few other terms as well. It's perhaps worth 
>> considering this a terminology draft for the mls working group, as 
>> Raphael just suggested. We are certainly open to that, so please help 
>> us by opening issues or sending pull requests to help solidify those 
>> terms: https://github.com/mallory/e2ee/edit/main/draft-e2ee.md.
>>
>> Htmlized: 
>> https://datatracker.ietf.org/doc/html/draft-knodel-e2ee-definition
>> until the htmlized version and diff are available at tools.ietf.org 
>> <http://tools.ietf.org>.
>>
>> The IETF Secretariat
>>
>>
-- 
Mallory Knodel
CTO, Center for Democracy and Technology
gpg fingerprint :: E3EB 63E0 65A3 B240 BCD9 B071 0C32 A271 BD3C C780

---

From: Raphael Robert <[email-masked]>
Date: Mon, 10 May 2021 21:52:33 +0200

Thanks Mallory, I’d be up for that! I definitely need to carve out some more time in order to provide some more concrete feedback until then.

Raphael

> On 10. May 2021, at 18:30, Mallory Knodel <[email-masked]> wrote:
> 
> Thanks Raphael, those are all excellent suggestions. I think Gurshabad and I have a grip on their essence, so will make an attempt at -02 for the second points and I'll re-review draft-architecture with your first question in mind. Perhaps at the next MLS meeting we can as a group spend some time together to think about scope wrt other wg drafts.
> 
> -Mallory
> 
>>> On 7. May 2021, at 16:59, Mallory Knodel <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> Hi all,
>>> 
>>> To:	Sofía Celi <[email-masked]> <mailto:[email-masked]>, Fred Baker <[email-masked]> <mailto:[email-masked]>, Fred Baker <[email-masked]> <mailto:[email-masked]>, Gurshabad Grover <[email-masked]> <mailto:[email-masked]>, Mallory Knodel <[email-masked]> <mailto:[email-masked]>, Olaf Kolkman <[email-masked]> <mailto:[email-masked]>, Sofia Celi <[email-masked]> <mailto:[email-masked]>
>>> 
>>> 
>>> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
>>> 
>>> The IETF Secretariat
>>> 
>>> 
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/mls <https://www.ietf.org/mailman/listinfo/mls>
>> 
> -- 
> Mallory Knodel