Subject: [MLS] Extensibility question

From: thomas leavy <[email-masked]>
Date: Thu, 12 Aug 2021 13:32:13 -0400

Hello,

I’ve been checking out the protocol and architecture docs and I’m a bit confused about how extensions should be developed. Section 12 talks about extensions in key packages being able “to describe client capabilities and aspects of their participation in the group”. 

I was thinking about this using the example of a basic moderation extension where each leaf would have a flag inside an extension indicating their moderator status. However, I can’t figure out how one would implement updates to a members’s status using the current set of proposals? Are proposals meant to also be an extendable set where extensions can define their own, or is there a better existing solution already in the specification?

---

From: Raphael Robert <[email-masked]>
Date: Thu, 12 Aug 2021 22:50:22 +0200

Hi Thomas,

There’s been an ongoing discussion about it, that received an update just a few hours ago: https://github.com/mlswg/mls-protocol/issues/473#issuecomment-897818956 <https://github.com/mlswg/mls-protocol/issues/473#issuecomment-897818956>

Raphael

> On 12. Aug 2021, at 19:32, thomas leavy <[email-masked]> wrote:
> 
> Hello,
> 
> _______________________________________________
> MLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mls