Subject: [MLS] Notes from last week's virtual interim

From: Richard Barnes <[email-masked]>
Date: Mon, 7 Feb 2022 15:49:06 -0500

Hi all,

Some notes below from the virtual interim last Thursday.

Thanks,
--Richard

#572 - Split the Group State section into Group Context and Transcript
Hashes

* Small, pretty purely editorial change
* Merged

#573 - Remove endpoint_id

* Some discussion confirming that we don't need endpoint_id
* Largely based on the continuity requirements in #509
* Merged

#575 - Split LeafNode from KeyPackage

* Concern about not having lifetime scoping on prepublished LeafNode
signature
* General invariant: Signature always covers (a) lifetime or (b) group ID
* Note alternative architecture proposed in #539 with two types of leaves
  * Could have a helper object to capture commonality between the two types
* TODO(Richard) - Revise PR

#523 - Move wire_format to a separate tagged-union structure MLSMessage

* On the question of whether to cover all types:
  * Yes, the MLSMessage wrapper should be universal
  * ... including covering KeyPackage
* TODO(Théophile) Update PR then ready to merge

#576 - Make credential succession checking the AS's job

* Depends on what the boundary of the AS is:
  * Checking credential is valid
  * Also checking (credential -> credential) transitions
* Moving this check to KP validation section would make it clearer
* TODO(Konrad) - Make a PR

#574 - Consistency between "optional that MUST contain a value when …" and
selects

* General agreement that selects are clearer than optionals
* TODO(Théophile) - Make a PR

#559 - Remove redundant nodes from the tree

* Clarified the defition of "redundant" using some pictures
* TODO(Marta) - Make a PR

#577 - Add message/mls MIME Type

* General agreement that this is a fine thing to do
* Should this be a section or a separate doc?
* How should we handle versioning?
  * Internal to the protocol, e.g., field in MLSMessage
  * Field in the MIME type
  * MIME type per version
* TODO(Rohan) - Make a PR

---

From: Sean Turner <[email-masked]>
Date: Tue, 8 Feb 2022 11:04:15 -0500

Immortalized here:
https://github.com/mlswg/wg-materials/blob/main/virtual-interim-recurring/02-03-2022.md
and
https://datatracker.ietf.org/meeting/interim-2022-mls-01/materials/minutes-interim-2022-mls-01-202202031000-00

> On Feb 7, 2022, at 15:49, Richard Barnes <[email-masked]> wrote:
> 
> #572 - Split the Group State section into Group Context and Transcript Hashes
> 
> * Concern about not having lifetime scoping on prepublished LeafNode signature
> #574 - Consistency between "optional that MUST contain a value when …" and selects
>