Subject: [MMUSIC] Tool starting mode attributes in SDP

From: [email-masked]
Date: Fri, 26 Jul 2002 12:53:28 +0300 (EEST)

Hello all,

In the latest SDP draft are defined four complementary attributes
which specify how to start the media tools:
a=recvonly
a=sendonly
a=sendrecv
a=inactive

In my opinion only ONE attribute of this types makes sense
at session-level and at each media level.
This is obvious, of course, but the current draft text allows for MORE
THAN ONE starting mode attribute per session and per media level.

Even if it is obvious, maybe you would like to explicitly enforce this
matter in the next draft.

Best regards,
Dan Firac,
Software Engineer,
Redline Communications,
Romania.
+40 723 260 623

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Colin Perkins <[email-masked]>
Date: Fri, 26 Jul 2002 13:47:30 -0400

>matter in the next draft.

Do you have a suggested wording change? This doesn't seem like something
that can easily be enforced in the ABNF.

Colin

---

From: Bryan Thale <[email-masked]>
Date: Fri, 26 Jul 2002 13:48:36 -0500

How about...

"a=toolmode:" *SP ("recvonly" / "sendonly" / "sendrecv") [ 1*SP "inactive"
] CRLF

or, since that involves a protocol change...

toolmode = [ "a=" ( "recvonly" / "sendonly" / "sendrecv") CRLF
            [ "a=inactive" CRLF ] ]

which only involves a change to the ABNF.  The problem with the latter
approach is that it doesn't reliably disambiguate between a session default
and a media override.  Does a media level "a=recvonly" override a session
level "a=sendonly"? No, according to sdp-new-10, Section 6

> The connection (`c=') and attribute (`a=') information in the session-
> level section applies to all the media of that session unless overridden
> by connection information or an attribute of the same name in the media
> description.
>
Bryan.

--
Bryan Thale
Networks & Infrastructure Research, Motorola Labs
mailto:[email-masked]

---

From: Colin Perkins <[email-masked]>
Date: Fri, 26 Jul 2002 15:06:48 -0400

Right, the problem is the override between session and media level. I don't
think we can express that in the ABNF. 

Colin