Subject: [MMUSIC] ABNF inconsistency in draft-ietf-sdp-new-10.txt

From: [email-masked]
Date: Thu, 18 Jul 2002 17:41:15 +0300 (EEST)

Hello all,

In the latest SDP draft is presented an example for "r" fields
at page 16:
r=604800 3600 0 90000

Note that the first offset from the list is 0!

The following ABNF definitions are extracted from the same draft:
repeat-fields= "r=" repeat-interval SP typed-time 1*(SP typed-time)
typed-time= POS-DIGIT *DIGIT [fixed-len-time-unit]

So, the ABNF definition of 'typed-time' cannot match zeros, and
that makes your EXAMPLE INCORRECT.

I have also sent some comment on a redundancy regarding email-safe /
email and phone ABNF definition.
But nobody seemed to care about them...

Is this mailing-list still on?
Dan Firac,
Software Engineer,
Redline Communications,
Romania.
+40 723 260 623

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Colin Perkins <[email-masked]>
Date: Sun, 21 Jul 2002 22:18:50 +0900

>that makes your EXAMPLE INCORRECT.

This was raised on the mailing list recently, and will be fixed in the next
version. 

>But nobody seemed to care about them...

Sorry, didn't have time yet to read them yet. It's on my list of things to
do...

Colin