Subject: [MMUSIC] Using static payload types for dynamic codecs

From: "Christer Holmberg (SE/LMF)" <[email-masked]>
Date: Thu, 21 Aug 2003 17:13:04 +0200

Hi,

This mail is related to an issue which has came up at the SIPit interop event.

Page 39 in sdp-new-13 says the following:

"RTP payload formats under the "RTP/AVP" protocol that have been
assigned static payload types MUST use the static payload type as
their "fmt" value.  For payload formats under "RTP/AVP" that have
a dynamic payload type number, the dynamic payload type number is
given as the "fmt" and an additional "rtpmap" attribute specifies
registration for the payload format."

My question is: is it allowed, when using a dynamic codec, to "override" a static payload type, using rtpmap, for that codec.

For example, 0 is the statically defined payload type for PCMU. Now, is the following allowed:

m=audio 99999 0
a=rtpmap: 0 DYNAMIC_CODEC/8000

I can't find anywhere in the sdp draft text saying that this is forbidden (I appologise if it's there and I've just missed it), and RFC3551 (chapter 3) doesn't forbid it either, so...

Regards,

Christer Holmberg
Ericsson Finland

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: "Hearty, John" <[email-masked]>
Date: Thu, 21 Aug 2003 10:05:37 -0600

This RFC 3551 text seems to answer your question most directly, the last
MAY allows it.:

3.  Registering Additional Encodings
<snip>
   This profile reserves payload type numbers in the range 96-127
   exclusively for dynamic assignment.  Applications SHOULD first use
   values in this range for dynamic payload types.  Those applications
   which need to define more than 32 dynamic payload types MAY bind
   codes below 96, in which case it is RECOMMENDED that unassigned
   payload type numbers be used first.  However, the statically assigned
   payload types are default bindings and MAY be dynamically bound to
   new encodings if needed.  Redefining payload types below 96 may cause
   incorrect operation if an attempt is made to join a session without
   obtaining session description information that defines the dynamic
   payload types.

John

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Christer Holmberg (SE/LMF)
> Sent: Thursday, August 21, 2003 9:13 AM
> To: [email-masked]'
> Subject: [MMUSIC] Using static payload types for dynamic codecs
> 
> 
> Hi,
> 
> This mail is related to an issue which has came up at the SIPit
interop
> event.
> My question is: is it allowed, when using a dynamic codec, to
"override" a
> static payload type, using rtpmap, for that codec.
> 
> For example, 0 is the statically defined payload type for PCMU. Now,
is
> the following allowed:
> I can't find anywhere in the sdp draft text saying that this is
forbidden
> (I appologise if it's there and I've just missed it), and RFC3551
(chapter
> 3) doesn't forbid it either, so...
> 
> Regards,
> 
> Christer Holmberg
> Ericsson Finland
> 
> 
>

---

From: "Christer Holmberg (SE/LMF)" <[email-masked]>
Date: Thu, 21 Aug 2003 18:22:15 +0200

Hi John,

Yes, RFC 3551 allows it. The question is if SDP allows it. One COULD use SDP for another transport than RTP, so I really think the SDP spec should define if it's allowd or not in SDP.

Thanks for your comments!

Regards,

Christer Holmberg
Ericsson Finland

> From: Hearty, John [mailto:[email-masked]]
> Sent: 21. elokuuta 2003 19:06
> To: Christer Holmberg (SE/LMF); [email-masked]
> Subject: RE: [MMUSIC] Using static payload types for dynamic codecs
> 
> 
>