Subject: Re: [MMUSIC] RTSP and mobility

From: Magnus Westerlund <[email-masked]>
Date: Tue, 19 Aug 2003 13:57:13 +0200

Hi Enrico,

I have not had time to read the paper by Schulzrinne. However from what 
I understand this should be possible to do in RTSP. However it touches 
upon grey zones in the specification in two ways. The connection between 
RTSP message transport and session, that should not exist. And the usage 
of SETUP to change transport parameters. Therefore I am not surprised 
that the Darwin server does not work in your experiments.

I think the Darwin server connects the TCP connection to the session and 
that the session actually is deleted if the TCP connection is removed.

There is no discussion of how to use RTSP for application layer 
mobility. Are there a need for such a chapter in the specification or as 
a separate draft?

Best Regards

Magnus

Enrico Balatti wrote:

> Dear Ashutosh,
> 
> thank you for you quickly reply.
> 
> I tried to implement what the paper says about RTSP mobility.
> The Client now send the SETUP after the handoff, but the RTSP
> server (Darwin Streaming Server) doesn't respond with any message.
> 
> Looking the Server source code I think that the Server doesn't
> accept the incoming SETUP message because it doesn't belong to
> any opend RTSP session (it is like there is a relation between 
> the session and the transport socket and the session accepts packet
> from its client socket). Therefore if the packet arrive with a source 
> address different (due to mobility), the packet is rejected.
> 
> I don't know if this mean that the Server is not RTSP standard compliant.
> 
> Do you know where the RTSP specification 
> talks about the RTSP application-mobility?
> 
> Thanks,
> Enrico
> 
> 
> -----Original Message-----
> From: Ashutosh Dutta [mailto:[email-masked]]
> Sent: martedì 22 luglio 2003 18.49
> To: Enrico Balatti
> Cc: [email-masked]
> Subject: Re: [MMUSIC] RTSP and mobility 
> 
> 
> 
> Enrico,
>        please see the paper
>        
>        http://www.cs.columbia.edu/~hgs/papers/Schu0007_Application.pdf,
>        it talks about some issues related to RTSP and mobility when IP
>        address  changes on the  mobile because  of subnet  movement or
>        domain movement.
> 
> Thanks
> Ashutosh
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mmusic
> 

-- 

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Ashutosh Dutta <[email-masked]>
Date: Tue, 19 Aug 2003 08:56:26 -0400

A combination of  SETUP and PLAY as described in 10.4  and 10.5 of RFC
2326 should be able to handle the mobility of RTP stream. It should be
similar to  using SIP Re-INVITE  to take care of  mid-session mobility
for RTP stream. It  could be that SETUP message has to  be over UDP to
make it work instead of TCP in case of IP address change?

Thanks
Ashutosh

> Hi Enrico,
> 
> I have not had time to read the paper by Schulzrinne. However from what=20
> I understand this should be possible to do in RTSP. However it touches=20
> upon grey zones in the specification in two ways. The connection between =
> 
> RTSP message transport and session, that should not exist. And the usage =
> 
> of SETUP to change transport parameters. Therefore I am not surprised=20
> I think the Darwin server connects the TCP connection to the session and =
> 
> There is no discussion of how to use RTSP for application layer=20
> mobility. Are there a need for such a chapter in the specification or as =
> 
> a separate draft?
> 
> Best Regards
> 
> Magnus
> 
> Enrico Balatti wrote:
> 
> > Dear Ashutosh,
> >=20
> >=20
> >=20
> > any opend RTSP session (it is like there is a relation between=20
> > from its client socket). Therefore if the packet arrive with a source=20
> >=20
> > I don't know if this mean that the Server is not RTSP standard complian=
> t.
> >=20
> > Do you know where the RTSP specification=20
> >=20
> >=20
> >=20
> > Sent: marted=EC 22 luglio 2003 18.49
> > To: Enrico Balatti
> > Cc: [email-masked]
> > Subject: Re: [MMUSIC] RTSP and mobility=20
> >=20
> >=20
> >=20
> > Enrico,
> >        please see the paper
> >       =20
> >        http://www.cs.columbia.edu/~hgs/papers/Schu0007_Application.pdf,=
> 
> >=20
> >=20
> >=20
> --=20

Ashutosh

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 19 Aug 2003 11:15:53 -0400

Since this is a source of interoperability problems, some basic 
discussions on transport behavior seems helpful for the base spec. You 
can't fix the problems with an additional spec. I don't think this has 
to be complicated, but address changes are now not uncommon for 
long-lived sessions (e.g., due to multi-homed hosts, DHCP or moving 
around between 802.11 APs.)

Magnus Westerlund wrote:

>> any opend RTSP session (it is like there is a relation between the 
>> session and the transport socket and the session accepts packet
>> Do you know where the RTSP specification talks about the RTSP 
>> application-mobility?
>>
>> Thanks,
>> Enrico
>>
>>

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 19 Aug 2003 18:49:31 +0200

Hi Henning & Enrico

Yes, I don't see a problem with this. In the updated specification this 
is the main reason why we maintain and strength the requirement that the 
RTSP session shall be independent of the RTSP message transport.

Henning, you are probably correct that the it only a few paragraphs to 
explain how to achieve application layer mobility and that way provide 
robustness.

Unless some one objects I would propose that we add some text on this 
issue in the RTSP core specification.

Cheers

Magnus

Henning Schulzrinne wrote:
>> I have not had time to read the paper by Schulzrinne. However from 
>> what I understand this should be possible to do in RTSP. However it 
>> touches upon grey zones in the specification in two ways. The 
>> connection between RTSP message transport and session, that should not 
>> exist. And the usage of SETUP to change transport parameters. 
>> Therefore I am not surprised that the Darwin server does not work in 
>> your experiments.
>>
>> I think the Darwin server connects the TCP connection to the session 
>> and that the session actually is deleted if the TCP connection is 
>> removed.
>>
>> mobility. Are there a need for such a chapter in the specification or 
>> as a separate draft?
>>
>> Best Regards
>>
>> Magnus
>>
>> Enrico Balatti wrote:
>>
>>> Dear Ashutosh,
>>>

-- 

Magnus Westerlund

---

From: Tom Marshall <[email-masked]>
Date: Tue, 19 Aug 2003 10:17:50 -0700

In order to make this work, don't you also need to s/MAY/MUST/ in the first
paragraph of 10.4?  This would seem to be a controversial change.

-- 
Did you ever notice that fat chance and slim chance mean the same thing?

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 20 Aug 2003 09:36:27 +0200

Hi Tom,

Yes, you are correct that the current MAY would need to be changed to 
MUST to always allow it. Performing this change may be a bit to much 
change. I think that it would be better to explain why support of this 
functionality is good, based on that it makes Application layer mobility 
possible. If there is need to learn the support for this, we should 
define a feature tag for it.

Is anybody willing to look through the specification to see if there are 
any more conflicts or limitations and provide a draft informational text 
about this?

Best Regards

Magnus

Magnus Westerlund