Subject: [MMUSIC] rtpmap is legal in session description level

From: [email-masked]
Date: Thu, 11 Dec 2003 14:59:43 +0100

Hello,

Does the mechanism "if something is not in media description, it is looked up in the session description" works for attribute fields with rtpmap attributes?

In other words, is it a valid SDP?:

   v=0
   o=alice 2890844526 2890844526 IN IP4 10.2.3.4
   s=
   c=IN IP4 10.2.3.4
   t=0 0
   a=rtpmap:97 L16/8000
   a=rtpmap:98 L16/11025/2
   m=audio 49170 RTP/AVP 96 97 98
   a=rtpmap:96 L8/8000

does the order of the 'a' fields matter?

Thanks, best regards:
Viktor Bekesi

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Colin Perkins <[email-masked]>
Date: Thu, 11 Dec 2003 15:18:00 +0000

--> [email-masked] writes:
> Does the mechanism "if something is not in media description, it is
> looked up in the session description" works for attribute fields with
> rtpmap attributes?

According to draft-ietf-mmusic-sdp-new-15, yes. I suspect this is a bug
that needs to be fixed, though...

Colin