Subject: [MMUSIC] Re: comedia and TLS

From: "John Lazzaro" <[email-masked]>
Date: Fri, 20 Feb 2004 10:30:33 -0800

> Jonathan Lennox <lennox at cs.columbia.edu> writes:
>
> [...] Do people have thoughts on all of this?  Does it seem sensible, 
> or is there
> anything I've overlooked or need to explain more closely?
>
> I'm willing to write some text for the comedia draft specifying all of 
> this,
> if people are interested.

Maybe we should consider splitting off TLS comedia functionality into
its own I-D ... so that the deliberations on TLS security issues can be
decoupled from getting basic TCP session support completed.

---
John Lazzaro
http://www.cs.berkeley.edu/~lazzaro
lazzaro [at] cs [dot] berkeley [dot] edu
---

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: David Yon <[email-masked]>
Date: Fri, 20 Feb 2004 13:41:50 -0500

Given the length of time comedia has remained in limbo, and my limited 
availability to maintain it, I would favor a split as well.  There are 
potentially a lot of issues raised by fleshing out TLS to include 
certificate validation information within SDP that have nothing to do with 
basic TCP.

The only question I would have is whether I should pull all mention of TLS 
from the original comedia.

At 01:30 PM 2/20/2004, John Lazzaro wrote:
>>[...] Do people have thoughts on all of this?  Does it seem sensible, or 
>>is there
>>I'm willing to write some text for the comedia draft specifying all of this,

---

From: Jonathan Lennox <[email-masked]>
Date: Wed, 25 Feb 2004 17:43:06 -0500

> certificate validation information within SDP that have nothing to do with 

I'm fine with a split as well.  I'm also willing to be an author or
co-author of the comedia TLS draft.

> from the original comedia.

I'd say pull any normative mentions, but informative mentions would be okay
(E.g., some text like "this framework could also be used for other
connection-oriented protocols, such as SCTP or TLS; however, this
specification does not define protocol identifiers for these protocols.")

-- 
Jonathan Lennox
lennox at cs dot columbia dot edu