Subject: [MMUSIC] Transport header protocol/profile/lower-layer ABNF

From: Magnus Westerlund <[email-masked]>
Date: Wed, 10 Nov 2004 22:46:22 +0100

Hi,

 >
 > I would also suggest that we modify the BNF to reflect the fact that the
 > "profile" makes sense with RTP and not necessarily with other proprietary
 > transport protocols.
 >
 > Current syntax:
 >     transport-id    =  transport-prot "/" profile ["/" lower-transport]
 >                        ; no LWS is allowed inside transport-id
 >     transport-prot    =  "RTP" / token
 >     profile           =  "AVP" / token
 >     lower-transport   =  "TCP" / "UDP" / token
 >
 > We could modify the BNF so that everything remains the same for RTP, but
 > for other transport protocols, we could make the "profile" optional.
 >
 > Proposed:
 >     transport-id    =  [ rtp-trans | other-trans ]
 >                        ; no LWS is allowed inside transport-id
 >     rtp-trans       =  "RTP" "/" profile ["/" lower-transport]
 >                        ; no LWS is allowed inside transport-id
 >     profile           =  "AVP" / token
 >     lower-transport   =  "TCP" / "UDP" / token
 >
 >     other-trans     = token [ "/" token ]*
 >

I assume that you mean to have
other-trans = token *("/" token)

I think that this is maybe not a bad idea as it seems more general. It 
however seem to have an  interoperability issue as a old receiver could 
throw up over the lack of a "/" after the first token.

More input on this question is appropriate.

Cheers

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Rishi Mathew <[email-masked]>
Date: Fri, 12 Nov 2004 16:47:13 -0800

Magnus,

Comment inline...

>other-trans = token *("/" token)

Yes. Basically, any number of tokens separated by a "/"

Thanks,
Rishi.

>Multimedia Technologies, Ericsson Research EAB/TVA/A

Rishi Mathew
Software Development Engineer
Helix Development Support Group
RealNetworks, Inc.
[email-masked]
206.892.6126
http://www.helixcommunity.org
http://www.realnetworks.com/products/support/devsupport.html