Subject: RE: [MMUSIC] SDP description for HTTP/RTSP streams

From: "Thomas Gal" <[email-masked]>
Date: Tue, 23 Nov 2004 11:27:25 -0800

Well there's descriptive language in the RTSP document itself. There's
an open source implementation at vovida.org you may use as reference.
Here's a link to the class information
http://www.vovida.org/document/rtsp/rtspstack/RtspSdp.html.

-Tom 

> -----Original Message-----
> From: Nicholas Humfrey [mailto:[email-masked]] 
> Sent: Tuesday, November 23, 2004 10:28 AM
> To: [email-masked]
> Subject: [MMUSIC] SDP description for HTTP/RTSP streams
> 
> 
> Hi,
> 
> 
> I have been trawling the web to see if there is an official 
> way to describe a RTSP/HTTP (URI) stream using SDP.
> 
> I have seen some SDP descriptions that put 'http' into the 
> transport in m=, the server in c=, and the path as an attribute.
> 
> 
> Has there been any Internet draft to standardize this ?
> 
> 
> I have mixed feelings about it - half of me thinks it is 'wrong' and 
> there are better ways of describing these types of (evil ;-) 
> shoutcast/icecast streams as URIs (M3U, PLS).
> 
> But the other half of me thinks it would be nice to be able to 
> describe all types of media streams using SDP and announce them over 
> SAP. And store them in a common format in directories of streams.
> 
> 
> 
> nick.
> 
> 
> 
> PS. Advertisement for my two perl modules:
> 
> http://search.cpan.org/~njh/Net-SAP/
> http://search.cpan.org/~njh/Net-SDP/
> 
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mmusic
> 

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Ross Finlayson <[email-masked]>
Date: Tue, 23 Nov 2004 13:32:42 -0800

>Well there's descriptive language in the RTSP document itself.

I don't think so.  The RTSP specification notes that a SDP description for 
a stream *could* be received using a HTTP "GET", instead of using a RTSP 
"DESCRIBE".  But that's not what Nicholas Humfrey was asking about.  I 
believe he was asking how to describe a HTTP (as opposed to RTP) media 
stream within SDP.  I.e., his question really didn't have anything to do 
with RTSP.

         Ross.

---

From: Nicholas J Humfrey <[email-masked]>
Date: Wed, 24 Nov 2004 03:25:19 +0000

Yes Ross is right. Sorry I didn't make it clear what I meant before. 
Here is an example of a URI to a Icecast stream:

http://152.78.104.83:8000/surge-live-high-mp3

And here is a proposed SDP description of that URI:

v=0
o=njh 3310243893 3310243893 IN IN4 hwickabab.ecs.soton.ac.uk
s=SURGE Live!
i=Southampton University's Radio from Glen Eyre
t=0 0
a=type:broadcast
m=audio 8000 http mpeg
c=IN IP4 152.78.104.83
a=http-path:/surge-live-high-mp3

This is modeled on a SDP description I saw generated by 
VLC/miniSAPserver - I don't think it is based on any Internet Draft.

By combining the 'audio' and the 'mpeg' in the m= line, you get the 
MIME type of the HTTP stream...

nick.

On 23 Nov 2004, at 21:32, Ross Finlayson wrote:

> I don't think so.  The RTSP specification notes that a SDP description 
> for a stream *could* be received using a HTTP "GET", instead of using 
> a RTSP "DESCRIBE".  But that's not what Nicholas Humfrey was asking 
> about.  I believe he was asking how to describe a HTTP (as opposed to 
> RTP) media stream within SDP.  I.e., his question really didn't have 
> anything to do with RTSP.
>
>         Ross.
>
>
>

---

From: Colin Perkins <[email-masked]>
Date: Mon, 29 Nov 2004 16:29:11 +0000

Nick,

> VLC/miniSAPserver - I don't think it is based on any Internet Draft.

Looks reasonable, although I don't think it's documented anywhere. If 
there's a future option of running HTTP over something other than TCP, 
then it might make sense to use "m=audio 8000 TCP/HTTP mpeg" to align 
with the comedia spec (draft-ietf-mmusic-sdp-comedia-09.txt).

Would you be willing to write up a draft documenting this?

Colin