Subject: [MMUSIC] SDP for alternative encodings

From: Aaron Colwell <[email-masked]>
Date: Tue, 1 Mar 2005 10:04:21 -0800

I have a few questions about how to represent alternative encodings with SDP.

How do the following 2 SDPs differ in meaning?

m=audio 49230 RTP/AVP 96 97 98
a=rtpmap:96 L8/8000
a=rtpmap:97 L16/8000
a=rtpmap:98 L16/11025/2

m=audio 49230 RTP/AVP 96
a=rtpmap:96 L8/8000
m=audio 49230 RTP/AVP 97
a=rtpmap:97 L16/8000
m=audio 49230 RTP/AVP 98
a=rtpmap:98 L16/11025/2

If I understand the SDP spec it seems to me that this indicates that payload
types 96, 97, and 98 will all be transmitted to port 49230 and represent the
same stream. What am I missing?

The SDP Internet Draft seems to indicate that alternate streams are signalled 
by m= lines using the same port. The RTSP spec says that if the server doesn't
care about what ports are used then it should just specify 0. The SDP draft 
also mandates that m= lines with the same port have "compatible media (e.g.  
both audio or both video)". This seems to imply that the server has to specify
ports if it wants to serve an A/V stream. Is that the intention or is 0 a 
special case? If 0 is a special case then how are you supposed to specify
alternate streams when the server doesn't care about the ports used?

Aaron

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: [email-masked]
Date: Wed, 2 Mar 2005 08:22:16 +1100

Aaron,
        My understanding is that if these were SDP for a request then - 
your first example is saying I would like an audio media session and I 
support any one(1)of the following three codecs for it. Your second example is requesting 
three(3) audio media sessions, each using the codec grouped with the m= 
line.

Regards - Wayne D.

Aaron asked:
*********************************************************

I have a few questions about how to represent alternative encodings with 
SDP.

m=audio 49230 RTP/AVP 96
a=rtpmap:96 L8/8000
m=audio 49230 RTP/AVP 97
a=rtpmap:97 L16/8000
m=audio 49230 RTP/AVP 98
a=rtpmap:98 L16/11025/2

If I understand the SDP spec it seems to me that this indicates that 
payload
types 96, 97, and 98 will all be transmitted to port 49230 and represent 
the
same stream. What am I missing?

The SDP Internet Draft seems to indicate that alternate streams are 
signalled 
by m= lines using the same port. The RTSP spec says that if the server 
doesn't
care about what ports are used then it should just specify 0. The SDP 
draft 
also mandates that m= lines with the same port have "compatible media 
(e.g. 
both audio or both video)". This seems to imply that the server has to 
specify
ports if it wants to serve an A/V stream. Is that the intention or is 0 a 
special case? If 0 is a special case then how are you supposed to specify
alternate streams when the server doesn't care about the ports used?

Aaron

******************************************************************************
 - NOTICE FROM DIMENSION DATA AUSTRALIA
This message is confidential, and may contain proprietary or legally privileged information.  If you have received this email in error, please notify the sender and delete it immediately.

Internet communications are not secure. You should scan this message and any attachments for viruses.  Under no circumstances do we accept liability for any loss or damage which may result from your receipt of this message or any attachments.
******************************************************************************