Subject: Re: [MMUSIC] 2326bis(RTSP) need text for even # of server_port

From: Magnus Westerlund <[email-masked]>
Date: Fri, 01 Jul 2005 14:36:51 +0200

Hi,

I was digging back in inbox and found this email.

Jae-Hwan Kim wrote:
> 
> Unlike RFC2326, this part seems to require a RTP source port matching
> with server_port. But this is not my question and this part has no
> notion regarding 'even number of server_port for receiving a packet'.
> 
> So I think a text like the following could be added at the end of this
> part.
> ---------
> o The even number of server_port to receive a media data is undefined in
> RTSP. 
>           The client SHOULD NOT send a packet to this port. 
> ---------
> 

To clarify, is what you desire to have added in the draft regarding 
source ports that they may use both even and odd port numbers? Or is it 
something else?

Thanks

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: "Amir Wolf" <[email-masked]>
Date: Wed, 6 Jul 2005 17:10:41 +0300

Hi,
Sending RTP packets from client to server are already defined in draft-ietf-mmusic-rtsp-nat-03.txt, indeed to overcome NAT problems, so I guess that it is allowed when not in Play mode.

Amir

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of Magnus Westerlund
> Sent: Wednesday, July 06, 2005 12:53 PM
> To: Jae-Hwan Kim
> Cc: [email-masked]
> Subject: Re: [MMUSIC] 2326bis(RTSP) need text for even # of 
> server_port
> 
> 
> Okay,
> 
> I think what we need to define is that any RTP traffic from 
> the client 
> to the server shall be sent to the even port or the 
> explicitly given RTP 
> port in the case of using the src_addr header.
> 
> The other question is if it is allowed to send RTP packets to the 
> server. My initial comment is that this is dependent on the mode. In 
> PLAY mode it could be disallowed. However I don't know how people 
> consider using this port as the target for opening pinholes 
> in firewalls 
> and can thus receive traffic. I think the other participants 
> can comment 
> on this.
> 
> Cheers
> 
> Magnus
> 
> Jae-Hwan Kim wrote:
> > Hi Magnus,
> > This is about an undefined action.
> > 
> > In both RFC2326 and 2326bis, there is no text for the 
> possibility if the
> > client sends some data to even # of server_port, while it 
> sends RTCP to
> > odd # of server_port.
> > 
> > I heard negative information to proscribe an undefined 
> action is better
> > than having no information. 
> > 
> 
> 
> -- 
> 
> Magnus Westerlund
>