Subject: RE: [MMUSIC] 2326bis(RTSP) need text for even # of server_port

From: "Jae-Hwan Kim" <[email-masked]>
Date: Wed, 6 Jul 2005 18:45:53 +0900

Hi Magnus,
This is about an undefined action.

In both RFC2326 and 2326bis, there is no text for the possibility if the
client sends some data to even # of server_port, while it sends RTCP to
odd # of server_port.

I heard negative information to proscribe an undefined action is better
than having no information. 

Best Regards,
Jae-Hwan

> -----Original Message-----
> From: Magnus Westerlund [mailto:[email-masked]]
> Sent: Friday, July 01, 2005 9:37 PM
> To: Jae-Hwan Kim
> Cc: [email-masked]
> Subject: Re: [MMUSIC] 2326bis(RTSP) need text for even # of
server_port
> 
> Hi,
> 
> I was digging back in inbox and found this email.
> 
> Jae-Hwan Kim wrote:
> >
> > Unlike RFC2326, this part seems to require a RTP source port
matching
> > with server_port. But this is not my question and this part has no
> > notion regarding 'even number of server_port for receiving a
packet'.
> >
> > So I think a text like the following could be added at the end of
this
> > part.
> > ---------
> > o The even number of server_port to receive a media data is
undefined in
> > RTSP.
> >           The client SHOULD NOT send a packet to this port.
> > ---------
> >
> 
> To clarify, is what you desire to have added in the draft regarding
> source ports that they may use both even and odd port numbers? Or is
it
> something else?
> 
> Thanks
> 
> Magnus Westerlund
> 
> Multimedia Technologies, Ericsson Research EAB/TVA/A
> ----------------------------------------------------------------------
> Ericsson AB                | Phone +46 8 4048287
> Torshamsgatan 23           | Fax   +46 8 7575550
> S-164 80 Stockholm, Sweden | mailto: [email-masked]

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 06 Jul 2005 11:53:02 +0200

Okay,

I think what we need to define is that any RTP traffic from the client 
to the server shall be sent to the even port or the explicitly given RTP 
port in the case of using the src_addr header.

The other question is if it is allowed to send RTP packets to the 
server. My initial comment is that this is dependent on the mode. In 
PLAY mode it could be disallowed. However I don't know how people 
consider using this port as the target for opening pinholes in firewalls 
and can thus receive traffic. I think the other participants can comment 
on this.

Cheers

Magnus

-- 

Magnus Westerlund

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 11 Jul 2005 15:49:29 +0200

Hi,

I have know added text that specifies to which ports the client shall 
send its RTP/UDP packets if it sends any.

For src_addr and dest_addr parameters:

\item The RTP/UDP packets from the client to the
server {\SHALL} be sent to the address and port given by the first
address and port pair of the "src\_addr" parameter.

\item RTP and RTCP Packets {\SHOULD} be sent from the
corresponding receiver port, i.e. RTCP packets from server should
be sent from the "src\_addr" parameters second address port pair.

For client_port

\item RTP/UDP packets from the client to the server {\SHALL} be
sent to the address specified in the "source" parameter and first
even port number given in server\_port range.

\item The client {\SHOULD} send its RTP/UDP packets from the
address specified in "destination" parameter and from the first even
port number specified in client\_port" parameter.

Cheers

Magnus Westerlund