Subject: [MMUSIC] MMUSIC stage and studio requirements I-D ...

From: lazzaro <[email-masked]>
Date: Thu, 7 Jul 2005 13:01:48 -0700

Hi everyone,

         I just sent an new individual I-D submission
off to Internet-Drafts, that is targeted to MMUSIC:

----

Requirements for a Stage and Studio Multimedia Framework
  <draft-lazzaro-mmusic-stage-studio-requirements-00.txt>

                                 Abstract

Is the IETF multimedia stack appropriate for use in the digital
audio equipment found in recording studios and concert halls?
To help answer this question, this memo lists the requirements
for a session management framework for stage and studio
devices.

Download URL for an advance copy:

http://www.cs.berkeley.edu/~lazzaro/sa/pubs/txt/current-sands.txt

----

Some background may be helpful.  RTP MIDI has many
potential applications.  Many are WAN-oriented, and SIP
and RTSP as is will work well for these.  The RTP MIDI
I-D includes interoperability advice for those apps.

The application described in the above abstract --
networking together professional audio equipment in
recording studios and concert stages -- is a "networking
in the small" problem (the network spans the rooms of
a recording studio or concert venue) and has unique
requirements.

MMUSIC may be the right place to design a framework
for session management for this application.

Or, maybe not -- maybe a new custom protocol done by
an audio-centric standards body is more appropriate,
free from our legacy-compatibility constraints.

Or, maybe there is room for both types of protocols,
as the potential devices span from the very simple
(powered by 8-bit micros) to very complex (expensive
multiprocessor implementations of mixing consoles).

I decided the best way to start the discussion on this
topic was to write a list of requirements for the domain
as seen by the authors.  Thus this I-D.  Even if the work of
doing the framework is not appropriate for MMUSIC,
MMUSIC may be the right place to host the discussion
of the requirements for the application.  If the WG agrees,
then elevating this I-D to WG item would be the way to
express this agreement.

I won't be in Paris, but if the chairs wish to hold a
discussion there, I'd be happy to make up slides to
guide their presentation.

Finally, AVT'ers should note this is an MMUSIC
I-D -- I CC'd this initial posting to both lists, but
discussion should occur on MMUSIC.

---
John Lazzaro
http://www.cs.berkeley.edu/~lazzaro
lazzaro [at] cs [dot] berkeley [dot] edu
---

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: "Shigeru Aoki" <[email-masked]>
Date: Fri, 8 Jul 2005 11:46:31 +0900

Hello Lazzaro,

Have you checked the AES (Audio Engineering Society) standard before your 
submission?
The AES is the international organization of standardizing the studio or stage 
(generally referred to as "professional") audio. As far as I read your draft, 
you'd better take a look at the Internet Audio Delivery System WG in the AES.

All the best,

Shigeru Aoki
Senior Technologist,
The Japan FM Network

---

From: lazzaro <[email-masked]>
Date: Thu, 7 Jul 2005 20:50:31 -0700

On Jul 7, 2005, at 7:46 PM, Shigeru Aoki wrote:
> Have you checked the AES (Audio Engineering Society) standard  
> before your submission?
> The AES is the international organization of standardizing the  
> studio or stage (generally referred to as "professional") audio. As  
> far as I read your draft, you'd better take a look at the Internet  
> Audio Delivery System WG in the AES.

Yes I did check.  Here is the meeting report for the
Internet Audio Delivery System WG at the
San Francisco AES meeting last fall:

http://www.aes.org/standards/b_reports/b_meeting-reports/aes117- 
sc-02-14-report.cfm

The meeting report doesn't seem to describe a
group whose ongoing work is a close match for
a project to do a session management framework
for IETF protocols.  Also, the report says the
WG has no new projects and no new business
apart from AES-X074, and is slated to be
folded into another group soon.  Their charter
is written in an open-ended way, indeed it
it would cover most of AVT's audio work.  But
in practice the group doesn't seem to be doing
that sort of Internet standards work.

---
John Lazzaro

---

From: "Shigeru Aoki" <[email-masked]>
Date: Fri, 8 Jul 2005 19:48:01 +0900

First of all, You should not include your matter into the AES-X074 since it has 
different intention from yours. Your requirements draft should be proposed to the 
WG for the discussion in the WG. if you would like to work for professional audio, 
you'd better propose to the AES too.

By the way, The WG has been moved to SC-02-14 from SC-06-04 already. The new 
report of the meeting which was held in this May will be posted soon.

Shig.