Subject: RE: [MMUSIC] 2326bis(RTSP) need text for even # of server_port

From: "Jae-Hwan Kim" <[email-masked]>
Date: Tue, 12 Jul 2005 04:30:17 +0900

Hi Magnus,

Thank you for your text. It looks good.
But can we add a text as followings?
"In PLAY mode, sending RTP packets from client to server is not defined
in this specification. However, it may be possible with a RTSP
extension."

Because the behavior, sending RTP packet from client to server, seems
not defined, IMO, the new specification should give some comment to a
reader. Because I found a similar example as well. ANNOUNCE can be
possible but 2326bis text describes that it requires a RTSP extension.

Best Regards,
Jae-Hwan

> -----Original Message-----
> From: Magnus Westerlund [mailto:[email-masked]]
> Sent: Monday, July 11, 2005 10:49 PM
> To: Jae-Hwan Kim
> Cc: [email-masked]
> Subject: Re: [MMUSIC] 2326bis(RTSP) need text for even # of
server_port
> 
> Hi,
> 
> I have know added text that specifies to which ports the client shall
> send its RTP/UDP packets if it sends any.
> 
> For src_addr and dest_addr parameters:
> 
> \item The RTP/UDP packets from the client to the
> server {\SHALL} be sent to the address and port given by the first
> address and port pair of the "src\_addr" parameter.
> 
> \item RTP and RTCP Packets {\SHOULD} be sent from the
> corresponding receiver port, i.e. RTCP packets from server should
> be sent from the "src\_addr" parameters second address port pair.
> 
> For client_port
> 
> \item RTP/UDP packets from the client to the server {\SHALL} be
> sent to the address specified in the "source" parameter and first
> even port number given in server\_port range.
> 
> \item The client {\SHOULD} send its RTP/UDP packets from the
> address specified in "destination" parameter and from the first even
> port number specified in client\_port" parameter.
> 
> Cheers
> 
> Magnus Westerlund
> 
> Multimedia Technologies, Ericsson Research EAB/TVA/A
> ----------------------------------------------------------------------
> Ericsson AB                | Phone +46 8 4048287
> Torshamsgatan 23           | Fax   +46 8 7575550
> S-164 80 Stockholm, Sweden | mailto: [email-masked]

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 12 Jul 2005 10:14:58 +0200

Hi,

I think your suggestion is reasonable. I will add the following to the 
RTP/AVP/UDP section:

In RTSP PLAY mode, the transmission of RTP packets from client to
server is unspecified. The behavior in regards to such RTP packets
{\MAY} be defined in future.

Cheers

Magnus

-- 

Magnus Westerlund